Language:
switch to room list switch to menu My folders
Go to page: 1 [2] 3 4 5 6 ... Last
[#] Fri Jun 30 2023 14:48:56 EDT from LadySerenaKitty

[Reply] [ReplyQuoted] [Headers] [Print]

Okay so I have a different issue.  I resolved by rebuilding the database, but now I has another issue.

I am receiving mails, but in webcit they are completely blank and in my mail clients, my inbox is empty.  I currently have over 200 messages in there.  I ran /usr/local/ctdlsupport/bin/db_verify and this is the result:

db_verify: BDB0522 Page 0: metadata page corrupted
db_verify: BDB0523 Page 0: could not check metadata page
db_verify: log.0000000001: BDB0090 DB_VERIFY_BAD: Database verification failed
BDB5105 Verification of log.0000000001 failed.

How do I fix these issues?



[#] Fri Jun 30 2023 15:42:14 EDT from LadySerenaKitty

[Reply] [ReplyQuoted] [Headers] [Print]

Ah, you know what ... NEVERMIND.  Restored original database from backup and started citserver with port 25 firewalled, somehow that made it not crashy.

Fri Jun 30 2023 14:48:56 EDT from LadySerenaKitty

Okay so I have a different issue.  I resolved by rebuilding the database, but now I has another issue.

I am receiving mails, but in webcit they are completely blank and in my mail clients, my inbox is empty.  I currently have over 200 messages in there.  I ran /usr/local/ctdlsupport/bin/db_verify and this is the result:

db_verify: BDB0522 Page 0: metadata page corrupted
db_verify: BDB0523 Page 0: could not check metadata page
db_verify: log.0000000001: BDB0090 DB_VERIFY_BAD: Database verification failed
BDB5105 Verification of log.0000000001 failed.

How do I fix these issues?



 



[#] Sun Jul 02 2023 12:03:53 EDT from IGnatius T Foobar

[Reply] [ReplyQuoted] [Headers] [Print]

So ... is it still crashing when port 25 is open?

[#] Sun Jul 02 2023 12:43:49 EDT from LadySerenaKitty

[Reply] [ReplyQuoted] [Headers] [Print]

After setting auto-purge to forget all messages over 100 days old, my message count dropped immensely and I re-opened port 25.  No issues since, it's running smoothly.

Sun Jul 02 2023 12:03:53 EDT from IGnatius T Foobar
So ... is it still crashing when port 25 is open?

 



[#] Sun Jul 02 2023 16:19:29 EDT from p.agsten

Subject: Re: Citadel stopped working after Ubuntu release upgrade

[Reply] [ReplyQuoted] [Headers] [Print]

Eventually resolved it by using Easy Install. Apparently the Citadel version in the distro (917-4) has an issue. Installing 972 through Easy Install made averything work again.

Mon Apr 03 2023 12:37:10 EDT from IGnatius T Foobar Subject: Re: Citadel stopped working after Ubuntu release upgrade

You might try deleting all those old sysvinit scripts. Citadel has been using systemd natively for some time now.

It could be that it's getting started up wrong.

And if that doesn't fix it, you might also try ditching the Easy Install distribution entirely and just running the Docker container.

 



[#] Sun Jul 02 2023 16:28:12 EDT from p.agsten

Subject: Strange rooms (folders) in IMAP cannot be deleted

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

today I noticed 5 strange folders in my IMAP client with naming like 64a15d9d.0004.0000000007.foldertest1688296861342. Sometimes there is even subfolders like /foldertest in there as well. When I try to delete from IMAP client, Citadel server returns error 'NO ... no such room, or access denied'.

When accessing the account though Webcit I see the same folder as room 9999999999.64a15d9d.0003.0000000007.foldertest1688296861342\foldertest. Again, Cannot edit or delete it, Error 'Higher access is required to access this function'

Is there any way to get rid of these folders?`

Any help is much appreciated.



[#] Sun Jul 02 2023 18:25:12 EDT from IGnatius T Foobar

Subject: Re: Citadel stopped working after Ubuntu release upgrade

[Reply] [ReplyQuoted] [Headers] [Print]

Eventually resolved it by using Easy Install. Apparently the Citadel version

in the distro (917-4) has an issue. Installing 972 through Easy Install
made
averything work again.

Ooooh, sorry to hear you got bit by that issue. There is a very old version of Citadel in the debian repository (and therefore in the ubuntu repository) and it is more or less unmaintained. I thought it had been removed, actually.

Happy to hear that the upgrade to a current version went cleanly for you.

[#] Sun Jul 02 2023 18:27:31 EDT from IGnatius T Foobar

Subject: Re: Strange rooms (folders) in IMAP cannot be deleted

[Reply] [ReplyQuoted] [Headers] [Print]

When accessing the account though Webcit I see the same folder as room

9999999999.64a15d9d.0003.0000000007.foldertest1688296861342\foldertest.


When a folder (or the room object representing that folder) is deleted, it does not get deleted from disk immediately. Instead, it is placed into an invalid namespace (9999999999) and gets deleted the next time the auto-purger runs. This is typically overnight in your time zone.

If it doesn't go away by itself, maybe someone tried to rename it back into a valid namespace?

[#] Tue Jul 04 2023 12:25:33 EDT from cattalk22

Subject: citadel github

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

bulding Citadel on Docker fails because git.citadel.org refused the connection at the git clone command:

Cloning into 'citadel'...
fatal: unable to connect to git.citadel.org:
git.citadel.org[0: 72.0.224.90]: errno=Connection refused
git.citadel.org[1: 2606:8800:21:12::4800:e05a]: errno=Cannot assign requested address

Browsing to http://git.citadel.org/ shows that a user and password is needed.

The documentation on https://www.citadel.org/docker.html links to https://code.citadel.org/ which also needs an account (that I can't register because all of my mail addresses aren't allowed).

Is this on purpose? If yes, how to build Citadel via Dockerfile?



[#] Tue Jul 04 2023 12:52:50 EDT from cattalk22

Subject: Thunderbird sync with Citadel not working

[Reply] [ReplyQuoted] [Headers] [Print]

Hello again,

another issue that I currently encounter. Thunderbird doesn't sync anymore with Citadel server even tho settings are correct (nothing has changed).
When I sync with the phone all works well. I compared the logs entries on Citadel server when syncing with phone and with PC and on phone there is a lot going on in the log while on PC it's really just only this:

citserver[7]: 118 noop
citserver[7]: ---- Looking up [NOOP] -----
citserver[7]: Found.
citserver[7]: IMAP command completed in 0.876 seconds
citserver[7]: 119 UID fetch 727286984:* (FLAGS)
citserver[7]: ---- Looking up [UID] -----
citserver[7]: ---- Looking up [UID] -----
citserver[7]: Found.
citserver[7]: IMAP command completed in 0.1413 seconds
citserver[7]: 120 UID fetch 727286380:727286983 (UID RFC822.SIZE FLAGS BODY.PEEK[HEADER.FIELDS (From To Cc Bcc Subject Date Message-ID Priority X-Priority References Newsgroups In-Reply-To Content-Type Reply-To)])
citserver[7]: ---- Looking up [UID] -----
citserver[7]: ---- Looking up [UID] -----
citserver[7]: Found.
citserver[7]: IMAP command completed in 0.1070 seconds

Does anybody know what could cause this?

 



[#] Tue Jul 04 2023 13:46:04 EDT from cattalk22

Subject: Re: Thunderbird sync with Citadel not working

[Reply] [ReplyQuoted] [Headers] [Print]

Update:

I just installed another mail client and it syncs the mail exactly to the same point as Thunderbird (2023-06-15) but everything newer isn't there although I see it on the phone and also on Citadel Web.

Then I installed Thunderbird on my Notebook and it also syncs only up to this point. Strange.



[#] Tue Jul 04 2023 14:05:00 EDT from cattalk22

Subject: Re: Thunderbird sync with Citadel not working

[Reply] [ReplyQuoted] [Headers] [Print]

Update 2:

Now I got something useful. In the previous post I said that I can see the mails in Citadel Web but I actually didn't try to open the mails.
So I did this now and the Web GUI shows just "ERROR".
The log:

webcit[10]: GET /msg/727286537 HTTP/1.1
citserver[8]: [mail(3)] MSG4 727286537
citserver[8]: msgbase: CtdlOutputMsg(msgnum=727286537, mode=2, section=<>)
citserver[8]: msgbase: security check fail; message 727286537 is not in 0000000003.Mail
webcit[10]: HTTP: 200 [0.001184] GET /msg/727286537

This only applies to mails after the date that Thunderbird syncs.

What is this "security check" that fails?



[#] Tue Jul 04 2023 14:34:56 EDT from Arron

Subject: Administrators can see user passwords?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

Recently started using Citadel and i've noticed that admins can see user passwords... why? Is there an out of the box solution to disable this?

 

Thanks,

Arron



[#] Wed Jul 05 2023 17:36:47 EDT from IGnatius T Foobar

Subject: Re: citadel github

[Reply] [ReplyQuoted] [Headers] [Print]

bulding Citadel on Docker fails because git.citadel.org refused the
connection at the git clone command:

Cloning into 'citadel'...
fatal: unable to connect to git.citadel.org:
git.citadel.org[0: 72.0.224.90]: errno=Connection refused
git.citadel.org[1: 2606:8800:21:12::4800:e05a]: errno=Cannot assign
requested address

Browsing to http://git.citadel.org/ shows that a user and password is
needed.

The documentation on https://www.citadel.org/docker.html links to
https://code.citadel.org/ which also needs an account (that I can't
register because all of my mail addresses aren't allowed).

Is this on purpose? If yes, how to build Citadel via Dockerfile?

We did recently change the location of the repository. https://code.citadel.org is our private GitLab instance and I have just gone ahead and made the landing page go to the 'Explore' screen instead of the login screen, so you should be able to browse it now. You can also create an account using the email address cattalk22@uncensored.citadel.org if you want to; this would allow you to submit merge requests and the like if you felt inclined. We restrict logins to @citadel.org and @uncensored.citadel.org to keep random idiots on the outside from creating accounts.

Now, where was it that you saw a reference to the old git repository address?
I am looking through things and don't see it.

Also ... is there a reason you are attempting to build the container yourself?
You can just pull it from Docker Hub already built and ready to run. That's kind of the point.

[#] Wed Jul 05 2023 17:38:15 EDT from IGnatius T Foobar

Subject: Re: Thunderbird sync with Citadel not working

[Reply] [ReplyQuoted] [Headers] [Print]

citserver[8]: msgbase: security check fail; message 727286537 is not

Have you really put over 727 million messages through your Citadel system since installing it?

If not, I think your disk might be corrupted.

[#] Wed Jul 05 2023 17:39:38 EDT from IGnatius T Foobar

Subject: Re: Administrators can see user passwords?

[Reply] [ReplyQuoted] [Headers] [Print]

Recently started using Citadel and i've noticed that admins can see
user passwords... why? Is there an out of the box solution to disable
this?

Passwords are not encrypted on disk for local accounts. If you use an external authenticator such as an LDAP directory you can use whatever encryption that service provides.

[#] Wed Jul 05 2023 21:10:51 EDT from Arron

Subject: Re: Administrators can see user passwords?

[Reply] [ReplyQuoted] [Headers] [Print]

It's not a case of checking on disk,

If a user with access level 6 (admin) goes to edit a user using webcit, the password of that user is visible to the admin.



[#] Thu Jul 06 2023 13:53:33 EDT from chernobyl

Subject: EasyInstall aborting with Updated/Upgrading Rasbian OS

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I have been able to run Citadel for a few years with few issues on my Raspberry PI's here at work. 

I went to attempt to install Citadel using EasyInstall (as done multiple times without issue) on a new Raspberry PI I have that has run "apt-get update" and "apt-get upgrade". 

For some reason, when running EasyInstall on this new PI, i get the following undefined reference error:

 

/usr/bin/ld: /usr/local/ctdlsupport/lib/libdb.a(mut_pthread.o): undefined reference to symbol 'pthread_rwlockattr_init@@GLIBC_2.4'

//lib/arm-linux-gnueabihf/libpthread.so.0: error adding symbols: DSO missing from command line

collect2: error: ld returned 1 exit status

Makefile:41: recipe for target 'ctdl3264' failed

make: *** [ctdl3264] Error 1

 Citadel Easy Install is aborting. 

 The last few lines above this message may indicate what went wrong. 

 Linux Debian 9.13( 4.19.66-v7+ armv7l) 

 
 
Is this due to Citadel having compile issues with the reported version of Debian?
What can I try to work around this? 
I have tried the docker install but that did not work either. 
 
Thanks in advance for any help provided!


[#] Fri Jul 07 2023 17:32:07 EDT from IGnatius T Foobar

Subject: Re: EasyInstall aborting with Updated/Upgrading Rasbian OS

[Reply] [ReplyQuoted] [Headers] [Print]

I have tried the docker install but that did not work either. 

Can you explain what happened when you tried to run the Docker version?

That is the recommended easiest way to run Citadel.

[#] Fri Jul 07 2023 18:28:52 EDT from chernobyl

Subject: Re: EasyInstall aborting with Updated/Upgrading Rasbian OS

[Reply] [ReplyQuoted] [Headers] [Print]

Sure. I had to spend a little time figuring out that the version of Docker I have supports slightly different syntax and arguments. 

Looks like it may have something to do with what's being talked about over here: https://github.com/docker/compose/issues/8756

 

/usr/local $ sudo docker run -d --restart=on-failure --net=host --volume=/usr/local/citadel:/citadel-data --name=citadel citadeldotorg/citadel

Unable to find image 'citadeldotorg/citadel:latest' locally

Pulling repository docker.io/citadeldotorg/citadel

Error: Status 410 trying to pull repository citadeldotorg/citadel: "<html>\r\n<head><title>410 Gone</title></head>\r\n<body>\r\n<center><h1>410 Gone</h1></center>\r\n<hr><center>openresty</center>\r\n</body>\r\n</html>\r\n"

I'm getting a 410 Gone when trying to access the specified image. I tried to follow the instructions at the following web page: https://www.citadel.org/docker.html

Let me know if I may have overlooked something. It tends to happen..lol

 


Go to page: 1 [2] 3 4 5 6 ... Last