Language:
switch to room list switch to menu My folders
Go to page: First ... 27 28 29 30 [31] 32 33 34 35 ... Last
[#] Thu Feb 25 2021 14:13:30 EST from Gaston

Subject: Re: Errors when running setup

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Feb 24 2021 11:51:11 EST from Gaston Subject: Re: Errors when running setup

 

Sun Feb 21 2021 10:18:13 EST from Gaston Subject: Errors when running setup

Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by Citadel Server.
This means, Citadel won't be the service provider for a specific service you configured it to.

If you don't want Citadel to provide these services, turn them off in WebCit via: "Admin->System Preferences->Network".

The failed ports and sockets are: extensions: TCP port 0.0.0.0:504: (citadel-TCP) ;extensions: TCP port 0.0.0.0:143: (IMAP) ;extensions: TCP port 0.0.0.0:993: (IMAPS) ;extensions: TCP port 0.0.0.0:119: (NNTP) ;extensions: TCP port 0.0.0.0:563:
(NNTPS) ;extensions: TCP port 0.0.0.0:110: (POP3) ;extensions: TCP port 0.0.0.0:995: (POP3S) ;extensions: TCP port 0.0.0.0:25: (SMTP-MTA) ;extensions: TCP port 0.0.0.0:465: (SMTPs-MTA) ;extensions: TCP port 0.0.0.0:587: (SMTP-MSA)

If you want Citadel to provide you with that functionality, check the output of "netstat -lnp" on Linux, or "netstat -na" on BSD and disable the program that binds these ports.


To make both ways actualy take place restart the citserver with "sendcommand down"

The errors returned by the system were:
failed; failed; failed; failed; failed; failed; failed; failed; failed; failed

You can recheck the above if you follow this faq item:
http://www.citadel.org/doku.php?id=faq:mastering_your_os:net#netstat



 Can anyone help me with this? Happens every time I restart Citadel server in Webcit!



 



[#] Fri Feb 26 2021 09:02:01 EST from Nurb432

Subject: "not Found" errors

[Reply] [ReplyQuoted] [Headers] [Print]

Not so much a question just an fyi, been seeing that a LOT today on the forums. 

Like every other refresh. 



[#] Fri Feb 26 2021 09:22:06 EST from ParanoidDelusions

Subject: Re: "not Found" errors

[Reply] [ReplyQuoted] [Headers] [Print]

I got a security error one today, too. 

 

Fri Feb 26 2021 09:02:01 EST from Nurb432 Subject: "not Found" errors

Not so much a question just an fyi, been seeing that a LOT today on the forums. 

Like every other refresh. 



 



[#] Sat Feb 27 2021 05:16:19 EST from markus

Subject: Re: Sender address added to recipient address

[Reply] [ReplyQuoted] [Headers] [Print]

Did you fix some of my other points that I have mentioned in

#] Thu Jan 28 2021 18:34:21 EST from markus

too? Or in other words: Where can I read about what was fixed or changed in the actual software?

Thanks

Markus

 

Sun Feb 21 2021 15:28:04 EST from IGnatius T Foobar Subject: Re: Sender address added to recipient address
recipient: user@mydomain.com, user@gmail.com

 

why does citadel add sender address to recipient address ?

This is a new bug that has been discovered and fixed. Please download Citadel Server again (using Easy Install again if that's how you originally installed it) and you will receive the fix.

 



[#] Sun Feb 28 2021 21:20:11 EST from lgwapnitsky

Subject: New install fails immediately

[Reply] [ReplyQuoted] [Headers] [Print]

Just installed Citadel on Ubuntu 20.04 from the repo. No configs have been changed, but, when accessing the web interface, I receive a 503 error that redirects me to a non-existent page in the Citadel docs.

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.
Read More...

Advice is welcome.

Thank you,

Larry



[#] Fri Mar 05 2021 03:49:01 EST from tabbi

Subject: citadel with nginx

[Reply] [ReplyQuoted] [Headers] [Print]

How can I use citadel with nginx as a webservice (not with webcit)

 



[#] Sat Mar 06 2021 13:15:11 EST from IGnatius T Foobar

Subject: Re: citadel with nginx

[Reply] [ReplyQuoted] [Headers] [Print]

Run WebCit on another port and configure nginx to proxy to it.

[#] Sun Mar 07 2021 05:22:17 EST from tabbi

Subject: Re: citadel with nginx

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sat Mar 06 2021 13:15:11 EST from IGnatius T Foobar Subject: Re: citadel with nginx
Run WebCit on another port and configure nginx to proxy to it.

Its a nice idea, I try it :-)

Regards tabbi



[#] Sun Mar 07 2021 21:22:31 EST from noahhallows

Subject: DKIM on Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Hello

I am setting up a email server using Citadel and I need to use DKIM to stop emails going to the recipients SPAM folder.

Can some one help.



[#] Sun Mar 07 2021 23:31:59 EST from IGnatius T Foobar

Subject: Re: DKIM on Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Citadel does not support DKIM directly. You will need to send your outbound mail through some other agent to add the DKIM signature. Fortunately you can do this using the "smart host" directive in Citadel to send mail to a local mailer.

[#] Mon Mar 08 2021 05:52:40 EST from infomatics

Subject: closed ports

[Reply] [ReplyQuoted] [Headers] [Print]

Running citadel on debian 9 with no other apps.

firewall is disabled and all iptable entries removed with default allow on all

citadel setup with standard ports and webcit running with 8080 and 8443

8080 and 8443 work and are open ie can configure and add users

ports 25,123,465,587,993 are all closed when testing with  tcptraceroute

can someone please offer some guidance

rgds Ian



[#] Wed Mar 10 2021 09:19:20 EST from citadeluser

Subject: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Sending emails is not reliable. Small text emails usually work. But you can't rely on it. Emails with attachments (pictures, etc.) "disappear" without error messages, they do not arrive.

I received such log entries from email servers on the recipient side:


"collect: premature EOM: input/output error"






[#] Wed Mar 10 2021 13:09:46 EST from NevadaRob

Subject: Re: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

I have the same issue on Raspbian.  Mail working nice on port 8443.  I can receive attachments but get an error when trying to attach and send a small file.  

This support installation of citadel can add attachments fine.

I must have a permission setting wrong - but where?



citadel-logo.gif (image/gif, 3042 bytes) [ View | Download ]
[#] Wed Mar 10 2021 14:21:27 EST from ParanoidDelusions

Subject: Re: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Look at your usr/local/citadel/files directory on RPi, Raspbian OS.

 My guess is even as root or with su or sudo you can't access this folder. You'll need to CHOWN it. 


Wed Mar 10 2021 13:09:46 EST from NevadaRob Subject: Re: collect: premature EOM: input/output error

I have the same issue on Raspbian.  Mail working nice on port 8443.  I can receive attachments but get an error when trying to attach and send a small file.  

This support installation of citadel can add attachments fine.

I must have a permission setting wrong - but where?



 



citadel-logo.gif (image/gif, 3042 bytes) [ View | Download ]
[#] Wed Mar 10 2021 19:37:29 EST from NevadaRob

Subject: Re: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Right you are!

for anyone else with this issue

cd /usr/local/citadel

sudo chmod -R 775 test

sudo chown -R citadel:citadel test

Thanks



[#] Thu Mar 11 2021 02:33:53 EST from sharezone

Subject: errore installation citadel on raspberry pi4

[Reply] [ReplyQuoted] [Headers] [Print]

i try to install citadel on raspberry pi4 with command 

wget http://easyinstall.citadel.org/install | sudo bash

 

but i receview error 

 

config.guess timestamp = 2006-07-02

 

uname -m = aarch64

uname -r = 4.19.0-13-arm64

uname -s = Linux

uname -v = #1 SMP Debian 4.19.160-2 (2020-11-28)

 

/usr/bin/uname -p = unknown

/bin/uname -X     =

 

hostinfo               =

/bin/universe          =

/usr/bin/arch -k       =

/bin/arch              = aarch64

/usr/bin/oslevel       =

/usr/convex/getsysinfo =

 

UNAME_MACHINE = aarch64

UNAME_RELEASE = 4.19.0-13-arm64

UNAME_SYSTEM  = Linux

UNAME_VERSION = #1 SMP Debian 4.19.160-2 (2020-11-28)

configure: error: cannot guess build type; you must specify one

 Citadel Easy Install is aborting.

 The last few lines above this message may indicate what went wrong.

 Linux Debian 10.8( 4.19.0-13-arm64 aarch64)

 

can help me

 


[#] Fri Mar 12 2021 12:08:14 EST from citadeluser

Subject: Re: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Log on the recipient side  after Citadel-SMTP email with text only:

sendmail[1840]: 12CGlZ0C001739: to=<xxx@yyy.aa>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31051, dsn=2.0.0, stat=Sent

 

Log on the recipient side after Citadel-SMTP Email with attachments:

sendmail[1923]: 12CGqgmh001823: collect: premature EOM: unexpected close





Note:

Note: with "easyinstall" there was a warning "Variable b64 defined but not used" (or something like that)

Does this variable have something to do with Base64 for binary attechments?

Does this mean that SMTP does not work with binary attechments?

 



[#] Fri Mar 12 2021 12:43:05 EST from citadeluser

Subject: Re: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Sending email with binary attachments is not possible internally either. Emails are sent - but without attachments.



[#] Fri Mar 12 2021 17:21:49 EST from citadeluser

Subject: Re: collect: premature EOM: input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

vcard_edit.c:424:6: warning: variable 'is_b64' set but not used [-Wunused-but-set-variable]
  424 |  int is_b64 = 0;

 

And many more warnings



[#] Fri Mar 12 2021 19:57:08 EST from markus

Subject: Please renew config.guess/config.sub in libcitadel-easyinstall.tar.gz

[Reply] [ReplyQuoted] [Headers] [Print]

Dear developers,

I have checked the latest editions (9th of March 2021) of

- citadel-easyinstall.tar.gz,

- webcit-easyinstall.tar.gz and

- libcitadel-easyinstall.tar.gz

As I can see, you have renewed config.guess and config.sub in the first two mentioned archives, but not in the last.

Would you please do it?

Thanks,

Markus



Go to page: First ... 27 28 29 30 [31] 32 33 34 35 ... Last