Language:
switch to room list switch to menu My folders
Go to page: First ... 5 6 7 8 [9] 10 11 12 13 ... Last
[#] Mon Jul 06 2020 15:32:41 EDT from IGnatius T Foobar

Subject: Re: Correct place to set e-mail address aliases for users via webit?

[Reply] [ReplyQuoted] [Headers] [Print]

My previous answer was not exactly correct. Sorry about that. These

screens are a bit confusing and we will find a way to fix that.

For those of you still interested -- there is a new version of WebCit available (just run Easy Install again and you'll get the new version) which removes the "e-mail addresses" inputs in places where it has no effect, such as the "edit your contact information" and "edit address book entry" screens. Email address input boxes will continue to appear when you are editing the contacts in your *own* address book.

[#] Mon Jul 06 2020 15:35:21 EDT from IGnatius T Foobar

Subject: Re: Changing the address of webcitadel

[Reply] [ReplyQuoted] [Headers] [Print]

Is it possible to change the log in address for the citadel web log
in page? During my install I seem to have set it up as the main page
of the website / ipaddress

At the present time this is not possible. A future version is being built that will operate this way by default, but it is quite some time away.

As a workaround, you can do one of the following two things:

1. Run the Citadel site on another port
2. Run the Citadel site on another port internally, and then configure your web server to proxy to it when it detects the name of the site (for example mail.example.com instead of www.example.com).

[#] Tue Jul 07 2020 04:51:18 EDT from Marius

Subject: Upgrade to the newest version?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi

I easy-installed a Citadel Standalone Mailserver three years ago. It's still working finde but maybe - for security or feature reasons - I should go for the newest code?

How do I patch the Citadel Server to the todays version of the Code? Can I check my version somewhere? (I am a simple User, not a coder :) )

 

regards,

Marius



[#] Tue Jul 07 2020 05:28:34 EDT from Marius

Subject: Re: Upgrade to the newest version?

[Reply] [ReplyQuoted] [Headers] [Print]

I have found my version: 911

Tue Jul 07 2020 04:51:18 EDT from Marius @ Uncensored Subject: Upgrade to the newest version?

Hi

I easy-installed a Citadel Standalone Mailserver three years ago. It's still working finde but maybe - for security or feature reasons - I should go for the newest code?

How do I patch the Citadel Server to the todays version of the Code? Can I check my version somewhere? (I am a simple User, not a coder :) )

 

regards,

Marius



 



[#] Tue Jul 07 2020 09:24:29 EDT from IGnatius T Foobar

Subject: Re: Upgrade to the newest version?

[Reply] [ReplyQuoted] [Headers] [Print]

I easy-installed a Citadel Standalone Mailserver three years ago.
It's still working finde but maybe - for security or feature reasons
- I should go for the newest code?

It's up to you, but if you want the latest version it's easy to upgrade:

1. Shut down Citadel and TAKE A FULL BACKUP

2. Run the Easy Install script again.

That's all there is to it. The script will detect your existing installation and upgrade it.

[#] Tue Jul 07 2020 15:45:19 EDT from lgc

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



[#] Tue Jul 07 2020 15:59:23 EDT from warbaby

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

You might try to turn  on Bash's trace feature, maybe you can see the problem. 

a) Download easyinstall locally..

wget -O easyinstall.sh http://easyinstall.citadel.org/install

b) chmod +x  easyinstall.sh

c) edit top line to

#!/bin/bash -x

then

./easyinstall.sh

or use

bash -x ./easyinstall.sh

to see what it is looking for when it dies..

 

 

 

 

Tue Jul 07 2020 03:45:19 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



 



[#] Tue Jul 07 2020 17:17:31 EDT from lgc

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



[#] Tue Jul 07 2020 17:36:57 EDT from lgc

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

Gave that a shot (on a new, fresh install)

Same error, but the installer runs just as verbose as it normally does in that phase, I now get the following:

 

       Error 

Setup failed to restart Citadel server.  Please restart it manually.

Press return to continue...

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''
Citadel Easy Install is aborting.
+ show_alert The last few lines above this message may indicate what went wrong.
+ echo '' The last few lines above this message may indicate what went wrong. ''
The last few lines above this message may indicate what went wrong.
+ show_alert Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)'
+ echo '' Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)' ''
Linux Debian 10.4( 4.19.0-9-amd64 x86_64)
+ cd /root
+ rm -fr /tmp/citadel-build.406
+ exit 1

 

Anything else I can check?

Tue Jul 07 2020 15:59:23 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

You might try to turn  on Bash's trace feature, maybe you can see the problem. 

a) Download easyinstall locally..

wget -O easyinstall.sh http://easyinstall.citadel.org/install

b) chmod +x  easyinstall.sh

c) edit top line to

#!/bin/bash -x

then

./easyinstall.sh

or use

bash -x ./easyinstall.sh

to see what it is looking for when it dies..

 

 

 

 

Tue Jul 07 2020 03:45:19 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



 



 



[#] Tue Jul 07 2020 19:14:23 EDT from warbaby

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

I've got a Debian 10 box here, I'm taking a look.

Tue Jul 07 2020 05:36:57 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Gave that a shot (on a new, fresh install)

Same error, but the installer runs just as verbose as it normally does in that phase, I now get the following:

 

       Error 

Setup failed to restart Citadel server.  Please restart it manually.

Press return to continue...

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''
Citadel Easy Install is aborting.
+ show_alert The last few lines above this message may indicate what went wrong.
+ echo '' The last few lines above this message may indicate what went wrong. ''
The last few lines above this message may indicate what went wrong.
+ show_alert Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)'
+ echo '' Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)' ''
Linux Debian 10.4( 4.19.0-9-amd64 x86_64)
+ cd /root
+ rm -fr /tmp/citadel-build.406
+ exit 1

 

Anything else I can check?

Tue Jul 07 2020 15:59:23 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

You might try to turn  on Bash's trace feature, maybe you can see the problem. 

a) Download easyinstall locally..

wget -O easyinstall.sh http://easyinstall.citadel.org/install

b) chmod +x  easyinstall.sh

c) edit top line to

#!/bin/bash -x

then

./easyinstall.sh

or use

bash -x ./easyinstall.sh

to see what it is looking for when it dies..

 

 

 

 

Tue Jul 07 2020 03:45:19 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



 



 



 



[#] Wed Jul 08 2020 05:40:48 EDT from warbaby

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

root@box:~# uname -a
Linux box.local.lan 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

I can confirm..

   2. External LDAP - RFC 2307 compliant directory

Pukes right here, on Deb 10 Buster.

###

Please enter the name of the Citadel user account that should be granted administrative privileges once created. If using internal authentication this user account will be created if it does not exist. For external authentication this user account has to exist.
This is currently set to:
admin
Enter new value or press return to leave unchanged:

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''

###

I did no other setup though.. probably should have.

See:

http://www.citadel.org/ldap_deprecated.html

and

http://www.citadel.org/msadsso.html




Tue Jul 07 2020 05:36:57 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Gave that a shot (on a new, fresh install)

Same error, but the installer runs just as verbose as it normally does in that phase, I now get the following:

 

       Error 

Setup failed to restart Citadel server.  Please restart it manually.

Press return to continue...

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''
Citadel Easy Install is aborting.
+ show_alert The last few lines above this message may indicate what went wrong.
+ echo '' The last few lines above this message may indicate what went wrong. ''
The last few lines above this message may indicate what went wrong.
+ show_alert Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)'
+ echo '' Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)' ''
Linux Debian 10.4( 4.19.0-9-amd64 x86_64)
+ cd /root
+ rm -fr /tmp/citadel-build.406
+ exit 1

 

Anything else I can check?

Tue Jul 07 2020 15:59:23 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

You might try to turn  on Bash's trace feature, maybe you can see the problem. 

a) Download easyinstall locally..

wget -O easyinstall.sh http://easyinstall.citadel.org/install

b) chmod +x  easyinstall.sh

c) edit top line to

#!/bin/bash -x

then

./easyinstall.sh

or use

bash -x ./easyinstall.sh

to see what it is looking for when it dies..

 

 

 

 

Tue Jul 07 2020 03:45:19 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



 



 



 



[#] Wed Jul 08 2020 19:50:28 EDT from abuchman

Subject: email routing

[Reply] [ReplyQuoted] [Headers] [Print]

 

Stupid question probably but do I need to set an MX record to receive mail? (sorry im new to this but totally over Microsoft)

 


[#] Wed Jul 08 2020 21:08:37 EDT from warbaby

Subject: Re: email routing

[Reply] [ReplyQuoted] [Headers] [Print]

Yes, you do need MX records to receive email.

You have some kind of interface with your host/registrar to add/edit DNS records, correct?

It probably has form fields for DNS Records.. so, you add one A record for your mail server..

Type [A]  Name [mail]  IP [ip address]  TTL [2 Min] # Use a short Time To Live when testing, and don't use any cache if using cloudflare..use the [DNS ONLY] option..

Then you add the MX record..

Type [MX]  Domain [example.com] Mail Server [mail.example.com]  TTL [2 min]  Priority [5]  # It's no big deal what you put here if you only have one mail server..

After you've done that, go to somewhere like..

https://mxtoolbox.com/

and check your records..  if there is anything wrong, it should let you know.. 

When that is done, you might want to crank up the TTLs a bit.  But not too long, in case you still need to change things.. an hour or so... You don't want to wait 24 hours to fix a typo.

There are also DMARC and SPF records to set up or your outbound mail will be going into spam folders, but having the MX record will allow you to receive email without any problems..

There are many resources for this information, easily found.. 

You're entering a man's world running a mail server on the internet.  Read up, take notes, make diagrams..

You'll have to pay your dues (so to speak), to gain many important skills.

Wed Jul 08 2020 07:50:28 PM EDT from abuchman @ Uncensored Subject: email routing
 

Stupid question probably but do I need to set an MX record to receive mail? (sorry im new to this but totally over Microsoft)

 


 



[#] Thu Jul 09 2020 09:30:50 EDT from abuchman

Subject: Re: email routing

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Jul 08 2020 21:08:37 EDT from warbaby @ Uncensored Subject: Re: email routing

Yes, you do need MX records to receive email.

You have some kind of interface with your host/registrar to add/edit DNS records, correct?

It probably has form fields for DNS Records.. so, you add one A record for your mail server..

Type [A]  Name [mail]  IP [ip address]  TTL [2 Min] # Use a short Time To Live when testing, and don't use any cache if using cloudflare..use the [DNS ONLY] option..

Then you add the MX record..

Type [MX]  Domain [example.com] Mail Server [mail.example.com]  TTL [2 min]  Priority [5]  # It's no big deal what you put here if you only have one mail server..

After you've done that, go to somewhere like..

https://mxtoolbox.com/

and check your records..  if there is anything wrong, it should let you know.. 

When that is done, you might want to crank up the TTLs a bit.  But not too long, in case you still need to change things.. an hour or so... You don't want to wait 24 hours to fix a typo.

There are also DMARC and SPF records to set up or your outbound mail will be going into spam folders, but having the MX record will allow you to receive email without any problems..

There are many resources for this information, easily found.. 

You're entering a man's world running a mail server on the internet.  Read up, take notes, make diagrams..

You'll have to pay your dues (so to speak), to gain many important skills.

Wed Jul 08 2020 07:50:28 PM EDT from abuchman @ Uncensored Subject: email routing
 

Stupid question probably but do I need to set an MX record to receive mail? (sorry im new to this but totally over Microsoft)

 


 



Thank you so much!!! ill get to it!

 


[#] Thu Jul 09 2020 10:31:02 EDT from Marius

Subject: Re: Upgrade to the newest version?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Jul 07 2020 09:24:29 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Upgrade to the newest version?
I easy-installed a Citadel Standalone Mailserver three years ago.
It's still working finde but maybe - for security or feature reasons
- I should go for the newest code?

It's up to you, but if you want the latest version it's easy to upgrade:

1. Shut down Citadel and TAKE A FULL BACKUP

2. Run the Easy Install script again.

That's all there is to it. The script will detect your existing installation and upgrade it.

Thank you, everything worked fine! The script made it...



[#] Thu Jul 09 2020 11:18:57 EDT from lgc

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

Did some more testing - attempted to install the package that comes with Debian 10 (citadel-suite) and when doing the setup, and choosing the LDAP settings, the install completes, but the application segfaults continually:

uname -a
Linux cit1 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

sudo journalctl -xe
Jul 09 08:06:19 cit1 kernel: show_signal_msg: 310 callbacks suppressed
Jul 09 08:06:19 cit1 kernel: citserver[11787]: segfault at 10000014c ip 00007fee
Jul 09 08:06:19 cit1 kernel: Code: a5 4d 85 e4 74 bc 4c 39 f0 74 a0 31 c0 48 8d
Jul 09 08:06:19 cit1 kernel: citserver[11788]: segfault at 10000014c ip 00007fee
Jul 09 08:06:19 cit1 kernel: Code: a5 4d 85 e4 74 bc 4c 39 f0 74 a0 31 c0 48 8d

Attempting to http or https to the web interface indicates a 503 error.

 

Wed Jul 08 2020 05:40:48 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

root@box:~# uname -a
Linux box.local.lan 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

I can confirm..

   2. External LDAP - RFC 2307 compliant directory

Pukes right here, on Deb 10 Buster.

###

Please enter the name of the Citadel user account that should be granted administrative privileges once created. If using internal authentication this user account will be created if it does not exist. For external authentication this user account has to exist.
This is currently set to:
admin
Enter new value or press return to leave unchanged:

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''

###

I did no other setup though.. probably should have.

See:

http://www.citadel.org/ldap_deprecated.html

and

http://www.citadel.org/msadsso.html




Tue Jul 07 2020 05:36:57 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Gave that a shot (on a new, fresh install)

Same error, but the installer runs just as verbose as it normally does in that phase, I now get the following:

 

       Error 

Setup failed to restart Citadel server.  Please restart it manually.

Press return to continue...

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''
Citadel Easy Install is aborting.
+ show_alert The last few lines above this message may indicate what went wrong.
+ echo '' The last few lines above this message may indicate what went wrong. ''
The last few lines above this message may indicate what went wrong.
+ show_alert Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)'
+ echo '' Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)' ''
Linux Debian 10.4( 4.19.0-9-amd64 x86_64)
+ cd /root
+ rm -fr /tmp/citadel-build.406
+ exit 1

 

Anything else I can check?

Tue Jul 07 2020 15:59:23 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

You might try to turn  on Bash's trace feature, maybe you can see the problem. 

a) Download easyinstall locally..

wget -O easyinstall.sh http://easyinstall.citadel.org/install

b) chmod +x  easyinstall.sh

c) edit top line to

#!/bin/bash -x

then

./easyinstall.sh

or use

bash -x ./easyinstall.sh

to see what it is looking for when it dies..

 

 

 

 

Tue Jul 07 2020 03:45:19 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



 



 



 



 



[#] Thu Jul 09 2020 12:22:16 EDT from warbaby

Subject: Re: Citserver with LDAP authentication does not start

[Reply] [ReplyQuoted] [Headers] [Print]

Haven't messed with citadel/LDAP in a few years, but.. here are my thoughts:

a) Debian packages are old.

b) Stick with easyinstall.

c) Socialism has failed every time it's been tried.

d) IIRC citadel assumes a working LDAP server for authentication.

e) IIRC install with internal auth, create admin account, THEN rerun easyinstall after LDAP service is setup and tested, then choose the LDAP option.

 


Thu Jul 09 2020 11:18:57 AM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Did some more testing - attempted to install the package that comes with Debian 10 (citadel-suite) and when doing the setup, and choosing the LDAP settings, the install completes, but the application segfaults continually:

uname -a
Linux cit1 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

sudo journalctl -xe
Jul 09 08:06:19 cit1 kernel: show_signal_msg: 310 callbacks suppressed
Jul 09 08:06:19 cit1 kernel: citserver[11787]: segfault at 10000014c ip 00007fee
Jul 09 08:06:19 cit1 kernel: Code: a5 4d 85 e4 74 bc 4c 39 f0 74 a0 31 c0 48 8d
Jul 09 08:06:19 cit1 kernel: citserver[11788]: segfault at 10000014c ip 00007fee
Jul 09 08:06:19 cit1 kernel: Code: a5 4d 85 e4 74 bc 4c 39 f0 74 a0 31 c0 48 8d

Attempting to http or https to the web interface indicates a 503 error.

 

Wed Jul 08 2020 05:40:48 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

root@box:~# uname -a
Linux box.local.lan 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2+deb10u1 (2020-06-07) x86_64 GNU/Linux

I can confirm..

   2. External LDAP - RFC 2307 compliant directory

Pukes right here, on Deb 10 Buster.

###

Please enter the name of the Citadel user account that should be granted administrative privileges once created. If using internal authentication this user account will be created if it does not exist. For external authentication this user account has to exist.
This is currently set to:
admin
Enter new value or press return to leave unchanged:

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''

###

I did no other setup though.. probably should have.

See:

http://www.citadel.org/ldap_deprecated.html

and

http://www.citadel.org/msadsso.html




Tue Jul 07 2020 05:36:57 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Gave that a shot (on a new, fresh install)

Same error, but the installer runs just as verbose as it normally does in that phase, I now get the following:

 

       Error 

Setup failed to restart Citadel server.  Please restart it manually.

Press return to continue...

+ die
+ show_alert Citadel Easy Install is aborting.
+ echo '' Citadel Easy Install is aborting. ''
Citadel Easy Install is aborting.
+ show_alert The last few lines above this message may indicate what went wrong.
+ echo '' The last few lines above this message may indicate what went wrong. ''
The last few lines above this message may indicate what went wrong.
+ show_alert Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)'
+ echo '' Linux Debian '10.4(' 4.19.0-9-amd64 'x86_64)' ''
Linux Debian 10.4( 4.19.0-9-amd64 x86_64)
+ cd /root
+ rm -fr /tmp/citadel-build.406
+ exit 1

 

Anything else I can check?

Tue Jul 07 2020 15:59:23 EDT from warbaby @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

You might try to turn  on Bash's trace feature, maybe you can see the problem. 

a) Download easyinstall locally..

wget -O easyinstall.sh http://easyinstall.citadel.org/install

b) chmod +x  easyinstall.sh

c) edit top line to

#!/bin/bash -x

then

./easyinstall.sh

or use

bash -x ./easyinstall.sh

to see what it is looking for when it dies..

 

 

 

 

Tue Jul 07 2020 03:45:19 PM EDT from lgc @ Uncensored Subject: Re: Citserver with LDAP authentication does not start

Having the same issue on my system:

1. Fresh install of Debian 10.4, up-to-date
2. Running the easyinstall from wget -q -O - http://easyinstall.citadel.org/install | bash
3. Only option change is to choose #2 for an LDAP server, with my known-working settings

I get the same error in my events - "Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support."

Verified that the packages for ldap (installed with allowing the prerequisites to be installed)

ii  libldap-2.4-2:amd64           2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP libraries
ii  libldap-common                2.4.47+dfsg-3+deb10u2        all          OpenLDAP common files for libraries
ii  libldap2-dev:amd64            2.4.47+dfsg-3+deb10u2        amd64        OpenLDAP development libraries



 



 



 



 



 



[#] Sat Jul 11 2020 17:33:59 EDT from BenM

Subject: Re: Correct place to set e-mail address aliases for users via webit?

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for that. It sounds like I may have been entering the e-mail addresses in the wrong place for 10 years.

 

Mon Jul 06 2020 15:32:41 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Correct place to set e-mail address aliases for users via webit?
My previous answer was not exactly correct. Sorry about that. These

screens are a bit confusing and we will find a way to fix that.

For those of you still interested -- there is a new version of WebCit available (just run Easy Install again and you'll get the new version) which removes the "e-mail addresses" inputs in places where it has no effect, such as the "edit your contact information" and "edit address book entry" screens. Email address input boxes will continue to appear when you are editing the contacts in your *own* address book.

 



[#] Sun Jul 12 2020 09:49:09 EDT from IGnatius T Foobar

Subject: Re: Correct place to set e-mail address aliases for users via webit?

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for that. It sounds like I may have been entering the e-mail addresses

in the wrong place for 10 years.

Well, certainly not for 10 years. Until recently, we set each user's email addresses from their vCards. It's only within the last year or so that we've made it a setting that only an administrator can change.

[#] Sun Jul 12 2020 16:56:38 EDT from IGnatius T Foobar

Subject: Re: Support for custom Sieve scripts to be discontinued in the nextrelease

[Reply] [ReplyQuoted] [Headers] [Print]

I use to write sieve scripts (with some issues), but I can bite the

bullet. If as you said: The option "Filter it according to rules
selected below" in "Advanced | View/edit server-side mail filters" for

each user, will still work.

Yes, that's going to be the only option now. Legacy WebCit has been hacked to make that screen display all the time.


Any user who has that option selected in an existing installation will have their rules preserved across the new version.

Go to page: First ... 5 6 7 8 [9] 10 11 12 13 ... Last