Language:
switch to room list switch to menu My folders
Go to page: First ... 9 10 11 12 [13] 14 15 16 17 ... Last
[#] Sun May 17 2020 13:38:13 EDT from Imspyguy @ Uncensored

Subject: Outlook connector or similar

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

Do you still support the outlook connector?  Is there something similar that I could use besides the imap to go with Calendar, notes, tasks on a similar client?

 

I like the app, and it runs very well on a pi4.  Any input is appreciated.

 

thanks

 

JB 



[#] Sun May 17 2020 14:01:38 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Outlook connector or similar

[Reply] [ReplyQuoted] [Headers] [Print]

Do you still support the outlook connector?  Is there something
similar that I could use besides the imap to go with Calendar, notes,
tasks on a similar client?

Unfortunately the company that made the Outlook connector went out of business.

[#] Sun May 17 2020 20:43:04 EDT from gll @ Uncensored

Subject: Re: Searching this room

[Reply] [ReplyQuoted] [Headers] [Print]

Oh great, thanks!



[#] Sun May 17 2020 20:49:04 EDT from gll @ Uncensored

Subject: Re: Searching this room

[Reply] [ReplyQuoted] [Headers] [Print]

Lol, that doesn't work either.  The search box appears, but it appears to be disabled.  Can't get the cursor into it.

Sun May 17 2020 11:40:03 EDT from FrostyBison @ Uncensored Subject: Re: Searching this room

Change the view of this room to Mail Folder (using the "View as:" drop down in the upper right corner of the page) to reveal a search box.



 



[#] Mon May 18 2020 18:16:42 EDT from FrostyBison @ Uncensored

Subject: Re: Searching this room

[Reply] [ReplyQuoted] [Headers] [Print]

You're right!

I'd not actually tried the search box before suggesting it to you.

 



[#] Mon May 25 2020 15:57:56 EDT from nristen @ Uncensored

Subject: Re: Searching this room

[Reply] [ReplyQuoted] [Headers] [Print]

Yeah, the search bar does not work for me either.

Mon May 18 2020 06:16:42 PM EDT from FrostyBison @ Uncensored Subject: Re: Searching this room

You're right!

I'd not actually tried the search box before suggesting it to you.

 



 



[#] Wed May 27 2020 10:05:25 EDT from amaliuk @ Uncensored

Subject: How to use Citadel with Thunderbird?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello!

 

How to use calendar, contacts and task in Thunderbird?

SyncKolab is inconpatible with Thunderbird



[#] Fri May 29 2020 07:51:12 EDT from kianwalters05 @ Uncensored

Subject: Citadel Not Working

[Reply] [ReplyQuoted] [Headers] [Print]

Hi, I recently installed citadel and it all worked, I could access it on the web and there were no errors, but i went to logon this morning and it says the page took too long to respond. I tried restarting the service but that didnt work. I dont know what to do. 



[#] Fri May 29 2020 11:52:27 EDT from amaliuk @ Uncensored

Subject: Re: Citadel Not Working

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri May 29 2020 07:51:12 EDT from kianwalters05 @ Uncensored Subject: Citadel Not Working

Hi, I recently installed citadel and it all worked, I could access it on the web and there were no errors, but i went to logon this morning and it says the page took too long to respond. I tried restarting the service but that didnt work. I dont know what to do. 



            see in logs.

           less /var/log/syslog | grep webcit

 



[#] Wed Jun 03 2020 01:59:02 EDT from warbaby @ Uncensored

Subject: Easy Install update blew out my room aliases..

[Reply] [ReplyQuoted] [Headers] [Print]

My install was pretty old, not sure the version. It appears mail.aliases is no longer parsed. 

I have added/removed rooms, and added test rooms, but " Alternative public email addresses pointing to this room" has no effect.

I keep getting back, "invalid recipient' when I try to send. Same message through smtp, or webcit.

I even tried checking through the api, but didn't see a way to get or set any alias fields.

Anybody have anything to try?



[#] Thu Jun 04 2020 11:05:43 EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> to warbaby <warbaby@uncensored.citadel.org>,Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Easy Install update blew out my room aliases..

[Reply] [ReplyQuoted] [Headers] [Print]

The same is happening on my server, perhaps because I have many users.

Using this command updates the directory:
sendcommand IGAB

And for easy recall, I made a small script with its description.

do_sendcommandIGAB.sh
#!/bin/bash
#200 em Citadel server ADMIN CONNECTION ready.
#IGAB
#200 Directory has been rebuilt.
#sendcommand: processing ended.

sendcommand IGAB


On 6/2/20 11:59 PM, warbaby wrote:
My install was pretty old, not sure the version. It appears mail.aliases
is no longer parsed.

I have added/removed rooms, and added test rooms, but " Alternative
public email addresses pointing to this room" has no effect.

I keep getting back, "invalid recipient' when I try to send. Same
message through smtp, or webcit.

I even tried checking through the api, but didn't see a way to get or
set any alias fields.

Anybody have anything to try?

[#] Thu Jun 04 2020 11:40:53 EDT from warbaby @ Uncensored

Subject: Re: Easy Install update blew out my room aliases..

[Reply] [ReplyQuoted] [Headers] [Print]

I have 2 users on this system..

I issued IGAB with ./sendcommand .. but first...

root@mail:/usr/local/citadel# ./sendcommand echo "FOO"
sendcommand: started (pid=19140) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
echo FOO
200 FOO
sendcommand: processing ended.

Which works.. however ..

root@mail:/usr/local/citadel# ./sendcommand IGAB
sendcommand: started (pid=19079) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
IGAB
530 Unrecognized or unsupported command.
sendcommand: processing ended.

Does not. Also did not work on another clean installation I setup for testing.. "Whats going on?"

Brain not fully awake yet.. perhaps I am doing something wrong.  

  Thanks for you response!



[#] Thu Jun 04 2020 13:49:12 EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> to Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Easy Install update blew out my room aliases..

[Reply] [ReplyQuoted] [Headers] [Print]

There is a thread on:

2/10/20, 5:20 PM from MAS3
Mail aliases limited

Maybe there is some clue (although it seems to be with a different version).


On 6/4/20 9:40 AM, warbaby wrote:
I have 2 users on this system..

I issued IGAB with ./sendcommand .. but first...

root@mail:/usr/local/citadel# ./sendcommand echo "FOO"
sendcommand: started (pid=19140) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
echo FOO
200 FOO
sendcommand: processing ended.

Which works.. however ..

root@mail:/usr/local/citadel# ./sendcommand IGAB
sendcommand: started (pid=19079) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
IGAB
530 Unrecognized or unsupported command.
sendcommand: processing ended.

Does not. Also did not work on another clean installation I setup for
testing.. "Whats going on?"

Brain not fully awake yet.. perhaps I am doing something wrong.

  Thanks for you response!

[#] Thu Jun 04 2020 17:48:54 EDT from gll @ Uncensored

Subject: webcit

[Reply] [ReplyQuoted] [Headers] [Print]

Why is webcit not recognized by UFW, even apt upgrade say's "K01webcit' missing LSB tags and overrides", same without the K01?

When enable, UFW blocks access to the web portal, even though all the necessary ports and protocols are allowed.



[#] Thu Jun 04 2020 20:01:36 EDT from gll @ Uncensored

Subject: Re: How to use Citadel with Thunderbird?

[Reply] [ReplyQuoted] [Headers] [Print]

I've been using it with Thunderbird for years.  no special setup, are you still having problems?

Wed May 27 2020 10:05:25 EDT from amaliuk @ Uncensored Subject: How to use Citadel with Thunderbird?

Hello!

 

How to use calendar, contacts and task in Thunderbird?

SyncKolab is inconpatible with Thunderbird



 



[#] Fri Jun 05 2020 10:40:35 EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> to warbaby <warbaby@uncensored.citadel.org>,Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Easy Install update blew out my room aliases..

[Reply] [ReplyQuoted] [Headers] [Print]

My mistake, I did not read "room aliases" correctly, I read it as "mail
aliases"; my brain is intoxicated with so many chemicals vs. CV19 at work.


On 6/4/20 9:40 AM, warbaby wrote:
I have 2 users on this system..

I issued IGAB with ./sendcommand .. but first...

root@mail:/usr/local/citadel# ./sendcommand echo "FOO"
sendcommand: started (pid=19140) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
echo FOO
200 FOO
sendcommand: processing ended.

Which works.. however ..

root@mail:/usr/local/citadel# ./sendcommand IGAB
sendcommand: started (pid=19079) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
IGAB
530 Unrecognized or unsupported command.
sendcommand: processing ended.

Does not. Also did not work on another clean installation I setup for
testing.. "Whats going on?"

Brain not fully awake yet.. perhaps I am doing something wrong.

  Thanks for you response!

[#] Fri Jun 05 2020 14:18:06 EDT from warbaby @ Uncensored

Subject: Re: Easy Install update blew out my room aliases..

[Reply] [ReplyQuoted] [Headers] [Print]

No worries.  For the moment, I am just accepting the issue as is, taking care not to lunge at anything, since it is an older, and fairly important mail database.  

Deliverable is not affected, since they are only readonly rooms (lists), that nobody posts to except me, so I can still send to them as "room_foo" .

The only thing lost at the moment is "Pretty Room Names" .. So, my solution for today, is "have some humility," and "cope".

But I did setup a dev environment, pulled all the code, and have been digging around in it.

It would be good to have a room setup here for this kind of dev-hacking. 

Sometimes the sheer volume of posts to "Citadel Support" makes these little conversations hard to find and follow.. 

 

Fri Jun 05 2020 10:40:35 AM EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> Subject: Re: Easy Install update blew out my room aliases..
My mistake, I did not read "room aliases" correctly, I read it as "mail
aliases"; my brain is intoxicated with so many chemicals vs. CV19 at work.


On 6/4/20 9:40 AM, warbaby wrote:
I have 2 users on this system..

I issued IGAB with ./sendcommand .. but first...

root@mail:/usr/local/citadel# ./sendcommand echo "FOO"
sendcommand: started (pid=19140) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
echo FOO
200 FOO
sendcommand: processing ended.

Which works.. however ..

root@mail:/usr/local/citadel# ./sendcommand IGAB
sendcommand: started (pid=19079) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
IGAB
530 Unrecognized or unsupported command.
sendcommand: processing ended.

Does not. Also did not work on another clean installation I setup for
testing.. "Whats going on?"

Brain not fully awake yet.. perhaps I am doing something wrong.

  Thanks for you response!

 



[#] Fri Jun 05 2020 14:55:38 EDT from warbaby @ Uncensored

Subject: Alternate procedure to set "email aliases" for a user

[Reply] [ReplyQuoted] [Headers] [Print]

If anyone is still having trouble setting email aliases

try ..  (likely in /usr/local/citadel  for easy install)

./sendcommand AGEA username

to GET/DISPLAY  the alias

then..and please read the full procedure before you do it.. some of the SET commands are expecting multi-line input, so the connection stays open until you terminate it with ^D.

./sendcommand ASEA username
# now paste a clean list of email addresses from your clipboard.
# now send a ^D
^D

then

./sendcommand AGEA username
# Read them out again to see what you have.

There does seem to be some validation going on.  I found a typo in one address caused it to be omitted from the list.

This method does not initialize the new aliases in any active session, so be sure to...

Logoff & log back on..

Also, "Primary Internet e-mail address" still seems to be chosen somewhat at random.  It's not always from the top or bottom of the list.



[#] Sat Jun 06 2020 14:59:59 EDT from gll @ Uncensored

Subject: webcit

[Reply] [ReplyQuoted] [Headers] [Print]

Has anyone reviewed webit code,  is it possible there is a build-in backdoor through webcit?



[#] Tue Jun 09 2020 11:00:00 EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> to gll <gll@uncensored.citadel.org>,Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: webcit

[Reply] [ReplyQuoted] [Headers] [Print]

Several months ago, a person here reported a security flaw, where with a
simple url pointing to your internet exposed citadel server with webcit,
nginx (and I suppose Apache too) could list ALL usernames, allowing an
attack hammering for getting SMTP / POP access.

I was able to check it on my server. Unfortunately I couldn't copy the
mail and I lost the details in this ocean of messages.

I do not remember if I managed to "block" this url, but I suppose that
the damage was already done, from time to time I see in my logs many
attempts with usernames of my citadel using dummy keys.

Maybe Art knows more about this.


On 6/6/20 12:59 PM, gll wrote:
Has anyone reviewed webit code,  is it possible there is a build-in
backdoor through webcit?

Go to page: First ... 9 10 11 12 [13] 14 15 16 17 ... Last