Language:
switch to room list switch to menu My folders
Go to page: First ... 4 5 6 7 [8] 9 10 11 12 ... Last
[#] Sat Feb 15 2020 21:13:29 EST from MAS3 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hmm, i'm sorry.

I rebooted and all aliases that were entered when the user was created, re-appeared.
Still when i add an alias to the 20 aliases that user already has, (i think) the last one in the list is dropped from the list.
The "Primary Internet e-mail address" (only visible form the user's Vcard) changes to some entry from the old list.

Another user already has 21 aliases, but adding aliases there does the exact same thing.

Rebooting the system seems to undo changes from the list, but not the changed Primary e-mail address.

I'll create another user, with some 50 aliases just to see if that will work upon creation.
But it'll take me some time to do that and test it.

 



[#] Sat Feb 15 2020 21:58:03 EST from MAS3 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

So i started to do this right away.

Made a test user and copied the alias test1@mydomain.com 50 times (or thought i did).

Then i started to edit the number so that i would end up with aliases test1 to test 50.
But when i was at the number 10, i couldn't add characters anymore.
That field seems limited to 512 characters, and thus limiting the number of aliases after all.
In this test case, it limits the number of aliases to 24.
And they seem to work for this new test user, sent and received an external mail to test23@mydomain.com.

Both users i tried to add aliases to, should have space to add at least 1 alias to the list of 512 characters, but still there's trouble in getting that done.
So there must be something else that's going wrong, and i'm assuming it's me doing something wrong here.

 

 



[#] Mon Feb 17 2020 16:09:29 EST from pdccnet @ Uncensored

Subject: Re: Easy Install can't create directories

[Reply] [ReplyQuoted] [Headers] [Print]

Sorry I never got back on this.

I was able to successfully install after following your instructions. Thanks so much for explaining it so well.

 



[#] Mon Feb 17 2020 17:13:15 EST from pdccnet @ Uncensored

Subject: Citadel server will not load

[Reply] [ReplyQuoted] [Headers] [Print]

I think I've totally screwed up my Citadel server.

I tried to run through the ./setup again to add LDAP information because I was not seeing it in WebCit.

After running through, making the changes and allowing setup to restart the Citadel server, it just hung. I waited over 10 minutes but nothing was happening. I could not access the server via WebCit. The command prompt was running the row of asterisks and had about 5 "." left to replace.

I did a ctrl-c and tried rebooting the server.

Citadel did not load (not a huge surprise).

I tried to just re-run the installer but that errored out.

I tried to uninstall Citadel by doing apt-get remove citadel-server

It claimed to work.

I then tried to reinstall using the Easy Installer. It ran up to a point and then reported this:

       Error 

 

Setup could not connect to a running Citadel server.: No such file or directory /usr/local/citadel/citadel-admin.socket

 

 

Press return to continue...

 Citadel Easy Install is aborting. 

 The last few lines above this message may indicate what went wrong. 

 Linux Debian stretch/sid( 4.4.0-173-generic x86_64) 

I'm not quite sure what to do at this point. I googled the "could not connect..." message but, from what I could tell, no one else who reported this problem got it resolved either (not to mention, most were more than a year old and a lot of the suggestions were for getting a newer version. I'm running a brand new version).

 



[#] Wed Feb 19 2020 13:50:34 EST from Gunnar @ Uncensored

Subject: Easyinstall, setup failed on Raspberry 4B, Raspbian Buster

[Reply] [ReplyQuoted] [Headers] [Print]

Hello, my name is Gunnar. I am located in the south of Lower Saxony, Germany.

I want to migrate my old MS-Active Directory and MS Exchange to Samba and Citadel.
I already set up one Raspberry 4B running Raspbian Buster with Samba AD-DC with rfc2307 support.
This seems to work fine. I was able to join this new domain with a Windows-PC and to log on.

On another Raspberry 4B with Raspbian Buster I like to install Citadel.
For the use of integrated authentication from the Windows-PCs (SSO) I choose
"2. External LDAP - RFC 2307 POSIX schema"
During the install
Unfortunately the setup inside the easyinstall-script fails with:

Error
Setup failed to restart Citadel Server. Please restart it manually.
Press return to continue...
 Citadel Easy Install is aborting.
 the last few lines above this message may indicate what went wrong.
 Linux Debian 10.3( 4.19.97-v7l+ armv71)

When I try to run the citserver manually with the x9 option, I get:

citserver[26082]: *** Citadel server engine ***
citserver[26082]:
citserver[26082]: Version 928 (build 796090168) ***
citserver[26082]: Copyright (C) 1987-2019 by the Citadel development team.
citserver[26082]:
citserver[26082]: This program is open source software: you can redistribute it and/or
citserver[26082]: modify it under the terms of the GNU General Public License, version 3.
citserver[26082]:
citserver[26082]: This program is distributed in the hope that it will be useful,
citserver[26082]: but WITHOUT ANY WARRANTY; without even the implied warranty of
citserver[26082]: MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
citserver[26082]: GNU General Public License for more details.
citserver[26082]:
citserver[26082]: libcitadel(unnumbered)
citserver[26082]:
citserver[26082]: Checking directory access
citserver[26082]: Opening databases
citserver[26082]: *** Citadel server engine ***
citserver[26082]: citserver[26082]: db: mounting databases
citserver[26082]: Version 928 (build 796090168) ***
citserver[26082]: Copyright (C) 1987-2019 by the Citadel development team.
citserver[26082]:
citserver[26082]: citserver[26082]: Initializing configuration system
citserver[26082]: Your system is configured for LDAP authentication,
citserver[26082]: but you are running a server built without OpenLDAP support.


I am not sure if this is related to the Bustter issue in August 2019, or if it is related to this issue:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=943531
Or, I am just doing silly things.

I appreciate any suggestion.

Some information I have attached:
setup_strace_1.out    strace output from running 'strace setup' withhin the easyinstall-script.
setup_strace_2.out    strace output from running 'strace setup' manually.
citserver_strace.out    strace output from running 'strace citserver' manually.
apt_list.out                 'apt list --installed' output.
dpkg--list.out              'dpkg --list' output.
ldd_citserver.out         'ldd citserver' output.
ldd_setup.out             'ldd setup' output.
model.out                   'cat /sys/firmware/devicetree/base/model' output.
os-release.out            'cat /etc/os-release' output.
uname-a.out              'uname -a' output.


Thank you very much.
Best Regards,
Gunnar



ldd_citserver.out (application/octet-stream, 4673 bytes) [ View | Download ]
uname-a.out (application/octet-stream, 115 bytes) [ View | Download ]
ldd_setup.out (application/octet-stream, 1901 bytes) [ View | Download ]
apt_list.out (application/octet-stream, 41621 bytes) [ View | Download ]
os-release.out (application/octet-stream, 411 bytes) [ View | Download ]
setup_strace_2.out (application/octet-stream, 538506 bytes) [ View | Download ]
dpkg--list.out (application/octet-stream, 93423 bytes) [ View | Download ]
model.out (application/octet-stream, 46 bytes) [ View | Download ]
setup_strace_1.out (application/octet-stream, 212245 bytes) [ View | Download ]
citserver_strace.out (application/octet-stream, 176674 bytes) [ View | Download ]
[#] Fri Feb 21 2020 03:19:01 EST from johnm @ Uncensored

Subject: rpi4 and setting Citadel admin priviledges from command line

[Reply] [ReplyQuoted] [Headers] [Print]

Anyone know how to create or edit an existing administrator account from the command line in a raspberry pi?

 

I am trying to login with what I thought was admin account to no avail.

 

So now I am searching how to create another admin acocunt for citadel.

 

Thank you!



[#] Fri Feb 28 2020 23:13:53 EST from Freejack @ Uncensored

Subject: Created room to be shared with users, permissions do not carry thru...

[Reply] [ReplyQuoted] [Headers] [Print]

Created a Floor and room for users to share emails for accounts receivables. Have it set to allow users to be able to delete and when checking permissions, they have everything except delete. The only user with delete is the roomaide.  The room is set public and all users allowed to post can delete. So at the moment the other users can not delete them.

 

There are sub rooms and folders and they all have the same permissions and no way to delete except the roomaide s able too.

 

Anyone have any idea?



[#] Sat Feb 29 2020 15:37:10 EST from neobrave @ Uncensored

Subject: DKIM

[Reply] [ReplyQuoted] [Headers] [Print]

Hi everyone,

For about a month I am playing around with Citadel trying to setup fast and reliable mail server. Was even changing provider that agrees to make a PTR record for me, to make it googlesafe).

Meanwhile I am straggling with configuration of DKIM on Citadel. Although it looks quite simple to me to add the public key to the header of the outgoing mail. The only instruction I found in documentation is to use postfix or provider's smtp relay and DKIMproxy as smarthost. This solution looks like a workaround in my current setup, I also think that the article dated 2008 might be not super actual, as nowadays without DKIM it is useless to have a SMTP server. I believe it is possible to set it up somewhere, but I just didn't find where. If anyone can give me a hint on this matter will be very much appreciated.

 

 

 

 

 



[#] Sat Feb 29 2020 19:15:17 EST from kahless01 @ Uncensored

Subject: Restart Now: Services do not restart

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Guys!

I’ve been trying out Citadel on Debian Buster and seems like a great piece of software, however, I have one little issue and I was hoping if someone could help out.

During the ‘Restart Now‘ cycle via the web, the IMAP, SMTP and other related services do not come back online. And I receive the following error via the terminal.

 citserver[465]: extensions: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by Citadel Server.#012 This means, Citadel won't be the service provider for a specific service you configured it to.#012#012If you don't want Citadel to provide these services, turn them off in WebCit via: "Admin->System Preferences->Network".#012#012The failed ports and sockets are: extensions: TCP port *:504: (citadel-TCP) ;extensions: TCP port *:993: (IMAPS) ;extensions: TCP port *:465: (SMTPs-MTA) #012#012If you want Citadel to provide you with that functionality, check the output of "netstat -lnp" on Linux, or "netstat -na" on BSD and disable the program that binds these ports.#012#012#012To make both ways actualy take place restart the citserver with "sendcommand down"#012#012The errors returned by the system were:#012failed; failed; failed#012#012You can recheck the above if you follow this faq item:#012http://www.citadel.org/doku.php?id=faq:mastering_your_os:net#netstat

Broadcast message from systemd-journald@nyc-us-mail01 (Sun 2020-03-01 00:04:51 UTC):

citserver[465]: extensions: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by Citadel Server.

 This means, Citadel won't be the service provider for a specific service you configured it to.

If you don't want Citadel to provide these services, turn them off in WebCit via: "Admin->System Preferences->Network".

The failed ports and sockets are: extensions: TCP port *:504: (citadel-TCP) ;extensions: TCP port *:993: (IMAPS) ;extensions: TCP port *:465: (SMTPs-MTA) 

If you want Citadel to provide you with that functionality, check the output of "netstat -lnp" on Linux, or "netstat -na" on BSD and disable the program that binds these ports.

To make both ways actualy take place restart the citserver with "sendcommand down"

The errors returned by the system were:

failed; failed; failed

You can recheck the above if you follow this faq item:

http://www.citadel.org/doku.php?id=faq:mastering_your_os:net#netstat

Message from syslogd@nyc-us-mail01 at Mar  1 00:04:51 ...

 citserver[465]: extensions: Startup Problems

Broadcast message from systemd-journald@nyc-us-mail01 (Sun 2020-03-01 00:04:51 UTC):

citserver[465]: extensions: Startup Problems

root@nyc-us-mail01:~# 


It’s noteworthy that during boot the required services start fine, it’s only just after reboot.

Thanks.
 
Kind Regards
 
James
 


[#] Sat Feb 29 2020 21:47:03 EST from kahless01 @ Uncensored

Subject: Re: Restart Now: Services do not restart

[Reply] [ReplyQuoted] [Headers] [Print]

Resolved. Solution is as follows:

$ sudo setcap CAP_NET_BIND_SERVICE=+eip /usr/local/citadel/citserver

Thanks.



[#] Mon Mar 02 2020 13:16:51 EST from "Jeremy Morton" <gamept@game-point.net> to room_citadel_support@citadel.org

Subject: How can I unsubscribe?

[Reply] [ReplyQuoted] [Headers] [Print]

I tried unsubscribing from this list, and I'm still getting e-mails
from it. Could an admin please unsubscribe me? Thanks.

--
Best regards,
Jeremy Morton (Jez)

[#] Tue Mar 03 2020 17:26:55 EST from "s3cr3to" <s3cr3to@uncensored.citadel.org> to Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: How can I unsubscribe?

[Reply] [ReplyQuoted] [Headers] [Print]

You need to do it yourself, go to:

https://uncensored.citadel.org/listsub

And write **the email address that you used** to subscribe.

Regards

On 3/2/20 11:16 AM, Jeremy Morton wrote:

I tried unsubscribing from this list, and I'm still getting e-mails from
it.  Could an admin please unsubscribe me?  Thanks.

[#] Sat Mar 07 2020 08:12:22 EST from neobrave @ Uncensored

Subject: DKIM on Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Hi everyone,

 

 

Here me again quering the community regarding the functionality of DKIM on Citadel. It looks quite simple to me to add the public key to the header of the outgoing mail, however I didn't find any config for is as well as workaround such as outgoing mail filter that allowing scripting.

The only instruction I found in documentation is to use postfix/sendmail or provider's smtp relay and DKIMproxy as smarthost. This however looks very outdated, and I am frankly cannot believe, that DKIM is not supported out of the box, as that it almost a guarantee that all sent emails will land in the recipient spam folder. How do you deal with this situation? Since upon install citmail start to be used instead of the sendmail as standard mta, it is reasonable to assume that there should be similar functionality in regards with DKIM, however I had not much success while looking for the documentation.

Any help on this matter will be very much appreciated.

 

 

 

 

 

 



[#] Sat Mar 07 2020 08:45:24 EST from "Jeremy Morton" <gamept@game-point.net> to room_citadel_support@citadel.org

Subject: Please unsub me

[Reply] [ReplyQuoted] [Headers] [Print]

PLEASE UNSUB ME FROM THIS LIST!!!!

Your unsub form on the website doesnt work so an admin will have to do
it. My email is gamept@game-point.net

Hey, if I start spamming the list you'll have to ban me, right? If
you don't remove me I'm gonna start fucking spamming, fuckers!!!

Yours truly,
- Piss off

[#] Sat Mar 07 2020 10:00:07 EST from LoanShark @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]


Somebody wants a few magazine subscriptions...

[#] Sat Mar 07 2020 13:23:26 EST from neobrave @ Uncensored

Subject: STARTTLS

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all,

When I am EHLO the Citadel's 25th port it does not advertise STARTTLS. What is shown when I am doing the same on 587. Other good mail services though advertising STARTTLS also on port 25.

Does anyone has an idea what could be wrong?

 



[#] Sat Mar 07 2020 15:35:22 EST from rleddy @ Uncensored

Subject: nodejs interface to citadel server

[Reply] [ReplyQuoted] [Headers] [Print]

 

 

https://github.com/copious-world/node-citadel

 

This is not yet tests. So, I have a slightly older version (a week or two) doing some work on my tiny website.

The current check-in is still full of bugs (as if it was C and was not yet compiled.) But, I thought you might like to know that it is mostly there.

Do you guys know much about ifps?

 



[#] Sat Mar 07 2020 16:22:31 EST from "me" <me@scifidan.com> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Please unsub me

[Reply] [ReplyQuoted] [Headers] [Print]

Dude, swallow a chill pill and take a deep breath.


On 3/7/20 5:45 AM, Jeremy Morton wrote:


PLEASE UNSUB ME FROM THIS LIST!!!!

Your unsub form on the website doesnt work so an admin will have to do
it.  My email is gamept@game-point.net

Hey, if I start spamming the list you'll have to ban me, right? If you
don't remove me I'm gonna start fucking spamming, fuckers!!!

Yours truly,
- Piss off

[#] Sun Mar 08 2020 10:27:19 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Please unsub me

[Reply] [ReplyQuoted] [Headers] [Print]

2020-03-07 08:45 from Jeremy Morton <gamept@game-point.net> to room_citadel_support@citadel.org

Subject: Please unsub me

PLEASE UNSUB ME FROM THIS LIST!!!!

Your unsub form on the website doesnt work so an admin will have to do

it. My email is gamept@game-point.net

Hey, if I start spamming the list you'll have to ban me, right? If
you don't remove me I'm gonna start fucking spamming, fuckers!!!

Yours truly,
- Piss off


Hello Jeremy Morton, whose email address gamept@game-point.net is now exposed to actual spammers through your posting it.

You may regret having done that.

[#] Mon Mar 09 2020 13:09:29 EDT from IncorrectPassword @ Uncensored

Subject: Not seeing new messages in webcit

[Reply] [ReplyQuoted] [Headers] [Print]

A couple weeks ago, new mail stopped showing up in my webmail. However it is syncing to all devices. I checked my pop settings and it is set to leave messages on the server (and firing up a laptop that had not been on in a while, it got all the new messages as well). Any ideas? I tired restarting the webcit service as well as the whole of the server running citadel.



Go to page: First ... 4 5 6 7 [8] 9 10 11 12 ... Last