Language:
switch to room list switch to menu My folders
Go to page: First ... 5 6 7 8 [9] 10 11 12 13 ... Last
[#] Fri Sep 20 2019 11:16:55 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Unable to install using Easy Install- libical error

[Reply] [ReplyQuoted] [Headers] [Print]

I am unable to install Citadel using the Easy Install Script.

It gives this error and terminates-

configure: error: libical/ical.h was not found and is required. 
More info: http://www.citadel.org/doku.php/installation:start

To provide an answer we would need to know what Linux distribution and version you are running.

[#] Fri Sep 20 2019 11:17:48 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: help with install on raspberry pi

[Reply] [ReplyQuoted] [Headers] [Print]

and I get the error saying it can create folder in the /usr/local
directory.

Easy Install needs to be run as root.

[#] Fri Sep 20 2019 11:18:35 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: help with install on raspberry pi

[Reply] [ReplyQuoted] [Headers] [Print]

I had tried the

dpkg-reconfigure command

and there is no difference

The packages are known to be problematic on the latest Debian. They made some weird change. Use the Easy Install distribution.

[#] Fri Sep 20 2019 11:19:58 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Delivery Status Notification (Failure) Anyone?

[Reply] [ReplyQuoted] [Headers] [Print]

rejection messages for a single rejected sent email.  In fact
sometime I get a series (100s) of rejection notices time-stamped
exactly one minute apart.  Is this normal?

That's not normal. If you could post one of the rejection notices (with as much of the header intact as possible) we might be able to figure it out.

Citadel's outgoing mail code is actually libcurl these days, so it would be surprising to find a bug in it. Maybe it's a configuration issue.

[#] Fri Sep 20 2019 11:21:17 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: where are the old posts on citadel support?

[Reply] [ReplyQuoted] [Headers] [Print]

I look for old posts in this Room. The oldest posts are from September
2018.
Do you have an archiv?

We used to send it to mail-archive.org but we were getting abusive spam from the people at Zimbra so we had to stop it. Sorry.

[#] Fri Sep 20 2019 15:50:35 EDT from GLABA @ Uncensored

Subject: Re: Your connection to citadel server is broken...

[Reply] [ReplyQuoted] [Headers] [Print]

i could try it, i yust install the default package



[#] Fri Sep 20 2019 15:53:35 EDT from gll @ Uncensored

Subject: Re: Delivery Status Notification (Failure) Anyone?

[Reply] [ReplyQuoted] [Headers] [Print]

This is the best I could copy, from message source.

It says "X-Mailer: Citadel 917" because it's the only notice I saved, but I'm getting the same results after the update to Citadel 927.

I've  sent another email to an address that rejects.  I'll post that when the rejection notices start coming in.

I there a better way to look at the email in raw for more info? 

===============================

From - Mon Jul 15 18:27:13 2019

X-Account-Key: account15

X-UIDL: 561803

X-Mozilla-Status: 0005

X-Mozilla-Status2: 00000000

X-Mozilla-Keys:                                                                                 

Return-Path: Citadel

Date: Mon, 15 Jul 2019 17:07:21 -0700

Subject: Delivery Status Notification (Failure)

Message-ID: <5D2D1539-0008928B@MY_DOMAIN_NAME.ca>

From: "Citadel" <citadel@MY_DOMAIN_NAME.ca>

Content-type: multipart/mixed; boundary="=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e"

MIME-Version: 1.0

X-Mailer: Citadel 917

 

This is a multipart message in MIME format.

 

--=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e

Content-type: text/plain

 

A message you sent could not be delivered to some or all of its recipients

due to prolonged unavailability of its destination(s).

Giving up on the following addresses:

 

John.Doe@pwgsc-tpsgc.gc.ca: 421 (Domain service not available, closing transmission channel)

--=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e

Content-type: message/rfc822

Content-Transfer-Encoding: 7bit

Content-Disposition: inline

 

Return-Path: gord@MY_DOMAIN_NAME.ca

Date: Tue, 09 Jul 2019 14:09:07 -0700

To: Jan Doe <Jan.Doe@bgis.com>

CC: John Doe <John.Doe@pwgsc-tpsgc.gc.ca>

Subject: Re: Security Breach

Message-ID: <5D250273-00088324@MY_DOMAIN_NAME.ca>

From: "gord" <gord@MY_DOMAIN_NAME.ca>

MIME-Version: 1.0

X-Mailer: WebCit 917

Content-type: multipart/alternative; boundary="Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002"

 

This is a multipart message in MIME format.

 

--Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002

Content-type: text/plain; charset=utf-8

Content-Transfer-Encoding: quoted-printable

 

Hi, <<<<<<<<<<<<<    BODY DELETED   >>>>>>>>>>>>>

 

 

--Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002

Content-type: text/html; charset=utf-8

Content-Transfer-Encoding: quoted-printable

 

<html><body>

Hi <<<<<<<<<<<<<    BODY DELETED   >>>>>>>>>>>>> autre moyen.)</p>=0A<=

</body></html>

 

--Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002--

--=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e--

 



[#] Sun Sep 22 2019 07:34:47 EDT from xylo @ Uncensored

Subject: Hello Citadelia's

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for the interesting software , just a quick question [of no particular importance] does jabber "server to server" work? is it a thing ? or a future thing maybe?

new site is https://www.rhun.co.nz.

My first experience with spamassassin [traumatised] - its an aggressive little bugger isnt it? and i was wondering why email wasnt working? well after actually configuring spamassasin correctly or at least my version email works a treat.

apologies if this isnt the correct place for this



[#] Mon Sep 23 2019 10:53:02 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Hello Citadelia's

[Reply] [ReplyQuoted] [Headers] [Print]

My first experience with spamassassin [traumatised] - its an
aggressive little bugger isnt it? and i was wondering why email wasnt
working? well after actually configuring spamassasin correctly or at
least my version email works a treat.

Spam filtering can be tricky to get just right. I find that a combination of some good RBL's plus SpamAssassin tuned to reject mail that contains links to sites that are on an RBL works pretty well. Lately I've also had to reject mail from vanity domains such as *.rocks, *.ninja, *.monster, etc. In practice, 100% of the mail from these domains is spam.

[#] Mon Sep 23 2019 15:07:21 EDT from xylo @ Uncensored

Subject: Re: Hello Citadelia's

[Reply] [ReplyQuoted] [Headers] [Print]

yes , I couldnt update my old mail server as it was debian 5 or 6? anyway old, lots of spam, and other nefarious emails so I shutdown and went to .... citadel. I found your protocol command page to tinker with . Ill read a bit more about spamassassin as well.

Anyway thanks again.

 



[#] Mon Sep 23 2019 15:12:00 EDT from xylo @ Uncensored

Subject: Re: Hello Citadelia's

[Reply] [ReplyQuoted] [Headers] [Print]

sorry me again, I read pimylifes install page - that was how i got onto citadel - anyway his Idea of setting spamassassin to "2" was a little aggressive I thought - all emails i tested it with were 2.4? about.. its probably about tuning i expect -- the RBL list is the correct format - rbl.megarbl.net or with http before?



[#] Tue Sep 24 2019 13:16:45 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Hello Citadelia's

[Reply] [ReplyQuoted] [Headers] [Print]

The RBL's we use here are: bl.spamcop.net, b.barracudacentral.org, cbl.abuseat.org, zen.spamhaus.org

The default spam threshold level for SpamAssassin is 5, so setting it to 2 does sound *very* aggressive. However, I don't claim to be an expert on that topic; you're probably better off asking in the SpamAssassin project's own forums.

There are also third party spam filtering services that will work very well, but if you're running Citadel you have probably already taken a position that you don't want some other organization reading your mail before you get it.

[#] Tue Sep 24 2019 13:19:36 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Hello Citadelia's

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for the interesting software , just a quick question [of no
particular importance] does jabber "server to server" work? is it a
thing ? or a future thing maybe?

The stubs are in place for XMPP S2S to be written in the future, but right now we don't have it.

Discouraging this, of course, was the fact that all the major services didn't support S2S, and eventually dropped support for XMPP completely, because they don't want you venturing outside of their little walled gardens.

[#] Wed Sep 25 2019 07:15:17 EDT from alex007 @ Uncensored

Subject: Re: where are the old posts on citadel support?

[Reply] [ReplyQuoted] [Headers] [Print]

thanks for the info! Please leave all messages if possible. It's a huge knowledge repository.

Fri Sep 20 2019 11:21:17 EDT from IGnatius T Foobar @ Uncensored Subject: Re: where are the old posts on citadel support?
I look for old posts in this Room. The oldest posts are from September
2018.
Do you have an archiv?

We used to send it to mail-archive.org but we were getting abusive spam from the people at Zimbra so we had to stop it. Sorry.

 



[#] Wed Sep 25 2019 07:26:15 EDT from alex007 @ Uncensored

Subject: Re: maximum number of Mails displayed wit webcit in a room

[Reply] [ReplyQuoted] [Headers] [Print]

my english is bad.

So my question again:

Is it true that webcit only can display a certain number of messages?

In one room there are exactly 7005 messages that I can see in webcit, but there are more messages, newer messages I can't see.

Thunderbird my mail client shows me all messages, but even Thunderbird tells me, the number of messages is "7005+"

Is that a magic numer : 7005?

Fri Sep 20 2019 04:31:19 EDT from alex007 @ Uncensored Subject: maximum number of Mails displayed wit webcit in a room

is it possible, that webcit only can display a certain number of messages?

In one room there are exactly 7005 messages that I can see in webcit, but there are more messages, newer messages I can't see.

Thunderbird my mail client shows me all messages, but even Thunderbird tells me, the number of messages is "7005+"

Is that a magic numer : 7005?

 

Any Ideas



thanx for your input!



[#] Thu Sep 26 2019 14:56:54 EDT from gll @ Uncensored

Subject: Re: Delivery Status Notification (Failure) Anyone?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi, just received 1340 rejection notices again on another rejected email.  Seems it keeps trying to send it for over a week and when it does it tries once every minute and sends out the rejection notice.

Fri Sep 20 2019 15:53:35 EDT from gll @ Uncensored
 

Subject: Re: Delivery Status Notification (Failure) Anyone?

This is the best I could copy, from message source.

It says "X-Mailer: Citadel 917" because it's the only notice I saved, but I'm getting the same results after the update to Citadel 927.

I've  sent another email to an address that rejects.  I'll post that when the rejection notices start coming in.

I there a better way to look at the email in raw for more info? 

===============================

From - Mon Jul 15 18:27:13 2019

X-Account-Key: account15

X-UIDL: 561803

X-Mozilla-Status: 0005

X-Mozilla-Status2: 00000000

X-Mozilla-Keys:                                                                                 

Return-Path: Citadel

Date: Mon, 15 Jul 2019 17:07:21 -0700

Subject: Delivery Status Notification (Failure)

Message-ID: <5D2D1539-0008928B@MY_DOMAIN_NAME.ca>

From: "Citadel" <citadel@MY_DOMAIN_NAME.ca>

Content-type: multipart/mixed; boundary="=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e"

MIME-Version: 1.0

X-Mailer: Citadel 917

 

This is a multipart message in MIME format.

 

--=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e

Content-type: text/plain

 

A message you sent could not be delivered to some or all of its recipients

due to prolonged unavailability of its destination(s).

Giving up on the following addresses:

 

John.Doe@pwgsc-tpsgc.gc.ca: 421 (Domain service not available, closing transmission channel)

--=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e

Content-type: message/rfc822

Content-Transfer-Encoding: 7bit

Content-Disposition: inline

 

Return-Path: gord@MY_DOMAIN_NAME.ca

Date: Tue, 09 Jul 2019 14:09:07 -0700

To: Jan Doe <Jan.Doe@bgis.com>

CC: John Doe <John.Doe@pwgsc-tpsgc.gc.ca>

Subject: Re: Security Breach

Message-ID: <5D250273-00088324@MY_DOMAIN_NAME.ca>

From: "gord" <gord@MY_DOMAIN_NAME.ca>

MIME-Version: 1.0

X-Mailer: WebCit 917

Content-type: multipart/alternative; boundary="Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002"

 

This is a multipart message in MIME format.

 

--Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002

Content-type: text/plain; charset=utf-8

Content-Transfer-Encoding: quoted-printable

 

Hi, <<<<<<<<<<<<<    BODY DELETED   >>>>>>>>>>>>>

 

 

--Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002

Content-type: text/html; charset=utf-8

Content-Transfer-Encoding: quoted-printable

 

<html><body>

Hi <<<<<<<<<<<<<    BODY DELETED   >>>>>>>>>>>>> autre moyen.)</p>=0A<=

</body></html>

 

--Citadel--Multipart--MY_DOMAIN_NAME.ca--0324--0002--

--=_Citadel_Multipart_MY_DOMAIN_NAME.ca_5438061e--

 



 



[#] Fri Sep 27 2019 01:28:39 EDT from giovanni @ Uncensored

Subject: webcit not responding

[Reply] [ReplyQuoted] [Headers] [Print]

Hi There, 

 

I have installed Citadel on a CentOS machine.

All component have been installed without any error.

I can see all ports listening correctly:

# netstat -anltup |grep LIST

tcp        0      0 0.0.0.0:119             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:504             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:2020            0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      1499/citserver

tcp        0      0 0.0.0.0:2000            0.0.0.0:*               LISTEN      1124/webcit

 

 

But when I try to connect to webcit from a browser ( http://myserver:2000 ) I receive a 'connection reset error'

And if I try from the same machine I see the same result

 

# wget localhost:2000

--2019-09-27 01:19:06--  http://localhost:2000/

Resolving localhost (localhost)... ::1, 127.0.0.1

Connecting to localhost (localhost)|::1|:2000... failed: Connection refused.

Connecting to localhost (localhost)|127.0.0.1|:2000... connected.

HTTP request sent, awaiting response... Read error (Connection reset by peer) in headers.

Retrying.

 

--2019-09-27 01:19:08--  (try: 2)  http://localhost:2000/

Connecting to localhost (localhost)|127.0.0.1|:2000... connected.

HTTP request sent, awaiting response... Read error (Connection reset by peer) in headers.

Retrying.

 
 
I looked for logs but I couldn't find much.
How can I troubleshoot this further?
 
Cheers, Giovanni
 


[#] Tue Oct 01 2019 15:50:00 EDT from giovanni @ Uncensored

Subject: Re: webcit not responding

[Reply] [ReplyQuoted] [Headers] [Print]

Eventually I found a work-around removing SSL (I don't need security so it works for me):

 

/etc/systemd/system/webcit-http.service

FROM

ExecStart=/usr/local/webcit/webcit -s  -i0.0.0.0 -p2000 uds /usr/local/citadel

TO

ExecStart=/usr/local/webcit/webcit -i0.0.0.0 -p2000 -x9 -t/usr/logwebcit uds /usr/local/citadel



[#] Fri Oct 04 2019 08:16:22 EDT from mk @ Uncensored

Subject: Can't login!

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all,

 

I installed Citadel on a Rasbian setup and i cannot get pass the initial login page!!! I followed this guide:

 

https://pimylifeup.com/raspberry-pi-email-server/

 

It recognises my username/password but after clicking on login...nothing happens!Any idea; 

 

Ι`m using webcit (ports 931 and 8443) as a webserver!!!

ty

Manolis



[#] Sat Oct 05 2019 06:33:06 EDT from Skaterunner @ Uncensored

Subject: Email attachments

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all,

Email attachments are still corrupted! 

Citadel installed on a raspberry pi 4. I use it on a standalone network for personal use. Email attachments are corrupted just going from one account to another without leaving the closed network. By corrupted I mean they can’t be read by the original program. I tried text files and libre doc files. This issue must have been addressed but I can’t find any info about remedies. Suggestions welcomed.

Sincerly Skaterunner




Go to page: First ... 5 6 7 8 [9] 10 11 12 13 ... Last