Language:
switch to room list switch to menu My folders
Go to page: First ... 4 5 6 7 [8] 9 10 11 12 ... Last
[#] Sat May 04 2019 17:32:46 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

So... 

reinstalled the library and it told me I had to include the path if something was linking to the library: 

If you ever happen to want to link against installed libraries

in a given directory, LIBDIR, you must either use libtool, and

specify the full pathname of the library, or use the `-LLIBDIR'

flag during linking and do at least one of the following:

----------------------------------------------------------------------

root@tsbbs:/home/pi/Downloads/libcitadel# cd /usr/local/lib

root@tsbbs:/usr/local/lib# citadel

citadel: error while loading shared libraries: libcitadel.so.4: cannot open shared object file: No such file or directory

root@tsbbs:/usr/local/lib# ls

libcitadel.a   libcitadel.solibcitadel.so.4.0.925  pypy2.7  python3.5

libcitadel.la  libcitadel.so.4pkgconfig       python2.7



Yup it is there... so I figured out how to add the path:


root@tsbbs:/usr/local/lib# echo "/usr/local/lib" > /etc/ld.so.conf.d/local.conf

root@tsbbs:/usr/local/lib# ldconfig

root@tsbbs:/usr/local/lib# citadel

commands: cannot open citadel.rc: No such file or directory

Seems citadel.rc ISN'T there... 

So I do a find on it, and it is in /Home/Downloads/textclient/citadel.rc 

So I go there and execute citadel... and it runs the citadel text client! 

So I type in the username and password... 

And I'm back to it not recognizing the password for the account. 

tsbbs:~/Downloads/textclient $ citadel
Attaching to server...
[localhost:504]
Citadel 925             
Citadel Server
(null)
 pause    next    stop
 ctrl-s  ctrl-o  ctrl-c
 
Cannot open '/usr/local/citadel/messages//hello': No such file or directory
 
Enter your name: ParanoidDelusions
Please enter your password: ********
<< wrong password >>
Enter your name:  

Which is what I was getting when I was installing it from the distro repo package. 

I don't see anything in citadel.rc that clearly would impact user authentication. 





[#] Sat May 04 2019 17:35:57 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Although, with it manually compiled and installed this way - it seems that I can still log in using the webclient - which wasn't working right when I had installed the text client from the repo. It seems like something in citadel.rc is breaking authentication... I'm suspecting if I moved it out of the home directory and rebooted, it might break the webclient too... 

 



[#] Sat May 04 2019 17:38:52 EDT from ParanoidDelusions @ Uncensored

Subject: Well... nevermind...

[Reply] [ReplyQuoted] [Headers] [Print]

Nevermind. I've got myself so worked up I was using the wrong password. It works. Woohoo me! 
Pretty good for a Windows admin stumbling around like an idiot in the dark trying things randomly until something worked. If anybody is hiring Linux admins... I'm available cheap. 

 



[#] Mon May 06 2019 23:17:00 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

So, now that I've got everything up and running, one of my first callers noticed that in the Online Users page - it exposes the FROM host IP address. 

Can this be turned off? It seems like a security risk for users. 

 



[#] Tue May 07 2019 00:33:22 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

It looks like individuals users can suppress being shown in the Caller log in the Telnet client with .Enter Configuration. 

Is this what I am looking for, and is there a similar option in the Web Client I can't find? 



[#] Tue May 07 2019 13:57:36 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

So... I see here that there are image attachments and when I select "View" them, the image opens up in my browser. 

If I upload an attachment to my Citadel - I see it in the post... if I view it, I get a black screen with a small white rectangle in the center. If I download it and try to open it, I get an error that the file cannot be opened. 

 



[#] Fri May 10 2019 14:28:28 EDT from Udo @ Uncensored

Subject: Citadel installation on Raspberry PI 3B

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

over the last few days i tried to get Citadel working on a Raspy 3b. Unfortunatly without any luck.

I used the latest debian image with the apt-get citadel-suite command.

After the installation I end up with two issues. In the log the following error is shown:

c_default_cal_zone, which I'm able to fix.

I get the login screen, but I'm never able to actually login. Admin and password is fine.

I'm following the guide from here:  https://pimylifeup.com/raspberry-pi-email-server/.

As mentioned in the guide i created the directory /etc/citadel/netconfigs

but after executing  /usr/lib/citadel-server/setup the folder is gone.

 

I even ended up trying to install it with the "Easy Install" but it turned out to

me that it isn't  easy at all. I needed to install a lot of missing dependencies.

After the setup was finished i couldn't call the login page.

 

Any help would be highly appriciated.

 

Thanks

Udo

 



[#] Fri May 10 2019 17:03:20 EDT from Udo @ Uncensored

Subject: Re: Citadel installation on Raspberry PI 3B

[Reply] [ReplyQuoted] [Headers] [Print]

Ok I just checked again,

 

the directory "/etc/citadel/netconfigs/" is missing. Creating and changing ownership to citadel doesn't help. 

It get's deleted if i try to login, restart the server or run the citadel setup again.

 

Kind regards

Udo



[#] Fri May 10 2019 18:08:19 EDT from Udo @ Uncensored

Subject: Re: Citadel installation on Raspberry PI 3B

[Reply] [ReplyQuoted] [Headers] [Print]

another test - > setting up the folder upfront of the installation of citadel does help with deletion issue

but still the folder is somehow recognized but not used (empty):

"..citserver[1351]: Cannot create /etc/citadel/netconfigs/7: Is a directory"

Login istn't possible.

 

Kind regards

Udo

 

 

Fri May 10 2019 17:03:20 EDT from Udo @ Uncensored Subject: Re: Citadel installation on Raspberry PI 3B

Ok I just checked again,

 

the directory "/etc/citadel/netconfigs/" is missing. Creating and changing ownership to citadel doesn't help. 

It get's deleted if i try to login, restart the server or run the citadel setup again.

 

Kind regards

Udo



 



[#] Fri May 10 2019 19:27:07 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I really recommend using the easy install at citadel.org, then compiling your own version of the text client if you want a traditional text Citadel experience to be available. I had to install it several times and get the feel for what was going on before I started to get it right... and the .deb packages, at least for Raspbian - had some issues.


I can't offer more help right now - but I am by no means talented at Linux and I have it up and running at secure.wallofhate.com for https, wallofhate

for http and telnet.wallofhate.com for telnet sessions. If I can do it, you can.

[#] Fri May 10 2019 19:28:10 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I might have more time to sit down and give some details of my experience and what I did to get it running, tomorrow.

[#] Fri May 10 2019 19:31:21 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Ig - I can see that it would be a benefit to my citadel to be part of your node network, which would generate extra content - always a value add... but I'd like to keep my domain not become a "citadel.org" BBS. Is that possible?


[#] Sun May 12 2019 08:36:05 EDT from Paul28 @ Uncensored

Subject: Install Citadel on Raspberry Pi 3 B+ using Easy Install

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I did the installation of Citadel using Easy Install on a Raspberry Pi 3 B+.

Apache webserver, Mysql,PHPMyadmin and Owncloud also were configured.

I get following errorcode wich is not known yet at the Citadel website :

 

checking for libical/ical.h... no

configure: error: libical/ical.h was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start

 Citadel Easy Install is aborting. 

 The last few lines above this message may indicate what went wrong. 

 Linux Debian 9.9( 4.14.98-v7+ armv7l) 


A sollution anyone ? Thanks !

Kind regards

Paul

 


[#] Sun May 12 2019 11:25:06 EDT from "Robert J. Clay" <rjclay@gmail.com> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

On Sun, May 12, 2019 at 8:30 AM Citadel Support
<room_Citadel_Support@citadel.org> wrote:



I get following errorcode wich is not known yet at the Citadel website :

checking for libical/ical.h... no

configure: error: libical/ical.h was not found and is required. More info:
http://www.citadel.org/doku.php/installation:start

It looks to me like you don't have the 'libical-dev' package is
installed on the system...




--
Robert J. Clay
rjclay@gmail.com

[#] Sun May 12 2019 11:42:05 EDT from "Robert J. Clay" <rjclay@gmail.com> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Re: [Citadel Support] Website issue?

[Reply] [ReplyQuoted] [Headers] [Print]

On Sun, May 12, 2019 at 8:30 AM Citadel Support
<room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: Paul28 <paul28@uncensored.citadel.org>
Subject: Install Citadel on Raspberry Pi 3 B+ using Easy Install

checking for libical/ical.h... no
. More info: http://www.citadel.org/doku.php/installation:start

Note also that I get the following error attempting to that URL:
This topic does not exist yet

Also, attempting to do a search on either 'Documentation' or
'FAQ / Knowledge Base' results only on the following error:

502 Bad Gateway

Attempting to access the links on either of those pages work with issue...


--
Robert J. Clay
rjclay@gmail.com

[#] Sun May 12 2019 11:44:25 EDT from "Robert J. Clay" <rjclay@gmail.com> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

On Sun, May 12, 2019 at 8:30 AM Citadel Support
<room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: Paul28 <paul28@uncensored.citadel.org>
Subject: Install Citadel on Raspberry Pi 3 B+ using Easy Install

I'm also wondering why, if that subject was what the post actualy
had, why that did subject did not make it into the email that made it
to me.



--
Robert J. Clay
rjclay@gmail.com

[#] Mon May 13 2019 07:57:13 EDT from spubbler @ Uncensored

Subject: When I try to log in I just get "please wait"

[Reply] [ReplyQuoted] [Headers] [Print]

Having set up Citadel using the rapsberry pi guide, when I try to log into the browser interface I just get a seemingly endless "please wait" message

What am I doing wrong?

 



[#] Mon May 13 2019 10:54:55 EDT from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

So, now that I've got everything up and running, one of my first
callers noticed that in the Online Users page - it exposes the FROM
host IP address. 

Can this be turned off? It seems like a security risk for users. 

In the text client, we have an option called "stealth mode" that lets you hide from the wholist completely. That's not the same thing, but it's related.

VERY recently, we had the ability to change your room and host name in the wholist to any arbitrary values. It ended up getting used for people to put silly little quips in those fields. That's sort of why it's been removed -- I'm planning on putting in an option for users to simply enter a status message to place next to their names instead of the room/host combination.
But you kind of caught that small space in between.

[#] Mon May 13 2019 10:55:48 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel installation on Raspberry PI 3B

[Reply] [ReplyQuoted] [Headers] [Print]

the directory "/etc/citadel/netconfigs/" is missing. Creating and
changing ownership to citadel doesn't help. 

Sounds like you might be using an old version? The netconfigs/ directory no longer exists; we've moved all of that stuff directly into the database.

[#] Mon May 13 2019 10:57:15 EDT from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I might have more time to sit down and give some details of my
experience and what I did to get it running, tomorrow.

Cool. We have to redo some of the documentation, as it's getting a bit dated.


Go to page: First ... 4 5 6 7 [8] 9 10 11 12 ... Last