Language:
switch to room list switch to menu My folders
Go to page: First ... 26 27 28 29 [30] 31 32 33 34 35
[#] Mon May 31 2021 02:52:36 EDT from smashbot64

Subject: Re: Citadel in Docker (prototype repo URL?)

[Reply] [ReplyQuoted] [Headers] [Print]

revisited... sourceforge was too complicated? just insult to injury. citadel is a blessing of source code within superb architecture. surely I am not the only one implementing message search and forgot password routines. 

Mon May 31 2021 02:48:31 EDT from smashbot64 Subject: Re: Citadel in Docker (prototype repo URL?)

github was too costly? lol... the source is out there, someone just has to volunteer to maintain

Sun May 23 2021 14:11:13 EDT from IGnatius T Foobar Subject: Re: Citadel in Docker (prototype repo URL?)

some (long) time ago I expressed my interest in trying out Citadel within a Docker container and someone here pointed me to some repository where some sort of "prototype" was available. Now, I have lost that particular link and am now asking if anyone here can (once more) provide it to me?

We ended up going in a different direction.  Instead of Docker, we built an AppImage, which just had its first beta release a couple of days ago.

AppImage, as you may know, packages an entire complex application and all of its dependencies into a single executable file that runs on many different Linux versions.  It turns out we had to change a lot of things that were based on outdated assumptions to make this happen.  For example, we ended support for the LFHS-style build and now require everything in a single directory.  These changes ought to make it a lot easier to put Citadel and its dependencies into a container, but as previously noted, we are not currently working on that.

Go ahead and try the AppImage if it can satisfy your requirements.



 



 



[#] Mon May 31 2021 14:52:01 EDT from IGnatius T Foobar

Subject: Re: Citadel in Docker (prototype repo URL?)

[Reply] [ReplyQuoted] [Headers] [Print]

Search should be pretty easy because there is already a full text indexer built into the message store.

As for the public repositories ... Citadel pre-dates them all, so we've always managed it ourselves.  Our public "forge" is at https://code.citadel.org/

 



[#] Wed Jun 02 2021 03:45:26 EDT from jmb100770

Subject: Re: 500 No such user on AUTH LOGIN

[Reply] [ReplyQuoted] [Headers] [Print]

I encountered this same authentication problem with version 931 built via easy-install.  I think the problem is with citadel/modules/smtp/serv_smtp.c where smtp_get_user(5) is called in smtp_command_loop.  From this context, the offset parameter 5 should be replaced by zero (0).  I modified the easy-install script to work with a patched copy of the tarball and the resulting build seems to work correctly.

 



[#] Wed Jun 02 2021 13:24:18 EDT from cyberlaw

Subject: IP Based Relaying thru Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

I've had to abandon my HMAIL server (Windows XP PRO issues activating)

I have installed a Debian system with Citadel. I am looking to do some relaying of email from specific IP addresses from old devices that cannot handle auth.

Is it possible thru Citadel and can it be done via the web manager? Or will it have to be done via CLI?



[#] Thu Jun 03 2021 09:12:08 EDT from IGnatius T Foobar

Subject: Re: 500 No such user on AUTH LOGIN

[Reply] [ReplyQuoted] [Headers] [Print]

in smtp_command_loop.  From this context, the offset parameter 5
should be replaced by zero (0).  I modified the easy-install script

Thanks for the tip! We will check that out and patch the mainline source.

[#] Sat Jun 05 2021 09:47:54 EDT from compdecon

Subject: Modem Support

[Reply] [ReplyQuoted] [Headers] [Print]

Planning on standing up a Citadel at our makerspace

How much support is still in the current version for dialup modems?

CDL



[#] Sat Jun 05 2021 10:22:21 EDT from compdecon

Subject: Modem Support

[Reply] [ReplyQuoted] [Headers] [Print]

Planning on standing up a Citadel at our makerspace

How much support is still in the current version for dialup modems?

CDL



[#] Sat Jun 05 2021 11:12:36 EDT from IGnatius T Foobar

Subject: Re: Modem Support

[Reply] [ReplyQuoted] [Headers] [Print]

How much support is still in the current version for dialup modems?

You're in luck -- Citadel still works great on dialup.

To make it work, there's not much you have to do with Citadel -- what you really want is to hook up your modem or modem pool to the underlying Linux host. There are tutorials all over the Internet for that. You'll probably end up using a program called "mgetty" which became quite dominant in that space in the final years before broadband Internet replaced dialup in most homes.

Then you just set up an account on your host, for example, one called "bbs" or "citadel" whose shell is /usr/local/citadel/citadel (the text mode client) and put a message in your system's login banner telling users to type that account name to get in.

[#] Sat Jun 05 2021 11:42:45 EDT from Nurb432

Subject: Re: AppImage releases of Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Sure, ill try both :)

Sat Jun 05 2021 11:07:16 AM EDT from IGnatius T Foobar Subject: Re: AppImage releases of Citadel
You should be able to run the 32 bit image on a 64 bit board. In fact, I would love it if you could try that.

 



[#] Sat Jun 05 2021 13:44:25 EDT from Nurb432

Subject: Re: AppImage releases of Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

On the BPI M3 ->  ./citadel-1622326264-armv7l.appimage: error while loading shared libraries: libz.so: cannot open shared object file: No such file or directory

I'm sure i can fix that, just thought id put that out here before i do. Would have thought that woudl be in the image and not needing to add it myself to the system? 32bit Armbian/Bullseye, updated to current just before i tried.
 
On 64bit Jetson, i get a command not found. Strange, its set to be executable so it should at least try to run. Unless its something IN the appimage its trying to run and its a useless/bogus error.  Jetsons run a hacked up version of Ubuntu, but i have a couple of 64bit machine running Armbian/Bullseye ill try tonight.


[#] Sat Jun 05 2021 13:46:43 EDT from Nurb432

Subject: Re: AppImage releases of Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Sorry, exact error on the Jetson ->  bash: ./citadel-1622326264-armv7l.appimage: No such file or directory

 
and should this be over in the support room instead? i guess this is getting a bit OT for announcements now. Sorry.


[#] Sat Jun 05 2021 15:28:30 EDT from Nurb432

Subject: New App Images

[Reply] [ReplyQuoted] [Headers] [Print]

Figured its better than over here than in announcements.. 

Findings so far. ( all ARM )

  • In general 32bit images apparently wont run on 64bit Armbian or Ubuntu.  Just as a test i grabbed cura 32 bit for RPI and get the same inaccurate message "No such file or directory" i got with 32bit citadel on 64bit board.
  • 32bit image on 32bit Armbian gives me the same error regardless of cura or citadel:   AppImage: error while loading shared libraries: libz.so: cannot open shared object file: No such file or directory
  • I also tried 64 bit cura on 64bit Armbian, and got the same libZ message as i got on 32/32. So that also must be a Appimage thing. I woudl have expected those libraries to come from inside the image.  I do have libz installed, so i must research.   Once i sort that i suspect matching image to architecture will work.
  • I wonder if this is all due to the builds being built "for" RPI and mine being another OS.  Part of research to be done.


[#] Sat Jun 05 2021 15:53:11 EDT from IGnatius T Foobar

Subject: Re: 500 No such user on AUTH LOGIN

[Reply] [ReplyQuoted] [Headers] [Print]

I encountered this same authentication problem with version 931 built
via easy-install.  I think the problem is with
citadel/modules/smtp/serv_smtp.c where smtp_get_user(5) is called

Thanks again for submitting this fix. It has been tested and the mainline code has been patched.

Easy Install is updated, other distribution methods will follow shortly.

[#] Sat Jun 05 2021 16:25:47 EDT from Zandercraft

Subject: "didn't find Template [login] 5 5" and favicon.ico Not Found.

[Reply] [ReplyQuoted] [Headers] [Print]

Hey guys! I was successfully able to install Citadel a few days ago using the Easy Install process, as outlined in the documentation/installation instructions. It was quite an easy install and worked perfectly. I later deleted the three folders as mentioned in the docs since I wanted to test out some other software. I inevitably came to the conclusion the Citadel would be the best for me to use... I installed it again using the same process, but now I get the following error: "didn't find Template [login] 5 5". The Javascript console also shows that favicon.ico is "net::ERR_EMPTY_RESPONSE". I have tried re-installing about 3 times and it happens each time. I have tried reboots and  it still does not work. I am using a Raspberry Pi 2 Model B+ with Raspberry Pi OS 32-bit Lite. Thanks in advance!



[#] Sat Jun 05 2021 17:48:18 EDT from Nurb432

[Reply] [ReplyQuoted] [Headers] [Print]

Installing zlib1g-dev fixes the lib error when platform matches appimage. odd you have to do that on the host, shouldn't that all be packaged in the image? 



[#] Mon Jun 07 2021 16:07:16 EDT from Nurb432

[Reply] [ReplyQuoted] [Headers] [Print]

Just a warning i have NOT looked into this more yet. It starts, crashes and then repeats tying indefinitely.  I had this same issue with Armbian bullseye on the 32bit BPI but i figured i should put it back to buster and try it again.

This was running from a direct root login via ssh, not sudo/shell. Command line included.  

______________________

 

root@bananapim3:~# ./citadel-1622326264-armv7l.appimage run

ctdlvisor: Welcome to the Citadel System, brought to you using AppImage.

ctdlvisor: LD_LIBRARY_PATH = /tmp/.mount_citadegxy60w/usr/lib

ctdlvisor:            PATH = /tmp/.mount_citadegxy60w/usr/bin

ctdlvisor:          APPDIR = /tmp/.mount_citadegxy60w

ctdlvisor:  data directory = /usr/local/citadel

ctdlvisor:       HTTP port = 80

ctdlvisor:      HTTPS port = 443

ctdlvisor: citserver running on pid=2355

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/citadel/citserver with data directory /usr/local/citadel

ctdlvisor: webcit (HTTP) running on pid=2356

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/webcit/webcit

ctdlvisor: webcit (HTTPS) running on pid=2357

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/webcit/webcit

ctdlvisor: pid=2355 exited, status=139, exitcode=0

ctdlvisor: citserver crashed on signal 11

ctdlvisor: citserver running on pid=2358

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/citadel/citserver with data directory /usr/local/citadel

ctdlvisor: pid=2358 exited, status=139, exitcode=0

ctdlvisor: citserver crashed on signal 11

 

 

after killing it witha control-c:

 

 

^Cctdlvisor: caught signal 2

ctdlvisor: waiting for all child process to exit...

ctdlvisor: 2367 (Citadel Server) ended, status=139

ctdlvisor: waiting for all child process to exit...

ctdlvisor: 2356 (WebCit HTTP) ended, status=15

ctdlvisor: waiting for all child process to exit...

ctdlvisor: 2357 (WebCit HTTPS) ended, status=15

ctdlvisor: waiting for all child process to exit...

ctdlvisor: exit code 0

 
 


[#] Mon Jun 07 2021 21:06:51 EDT from Nurb432

[Reply] [ReplyQuoted] [Headers] [Print]

It must be me. somehow. I forgot i had an old PI 2 in a drawer ( was for BeePI emulator but sort of lost interest and dismissed it out of my head ). 

Current Raspbian 'lite'.. SSH over, sudo to a shell. Create the data folder.  Grab the rile via wget. Change permissions..... 'run'.. It didnt need the extra stuff the BPI needed. But same results, except it eventually died on its own ( perhaps i didnt wait long enough on the BPI ).   It dont like me.    *pout*



[#] Tue Jun 08 2021 15:30:40 EDT from tactyl

Subject: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

Como puedo instalar se servidos. gracias



[#] Tue Jun 08 2021 16:50:24 EDT from IGnatius T Foobar

Subject: Re: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

This is an English language forum.

[#] Tue Jun 08 2021 20:47:24 EDT from ParanoidDelusions

Subject: Re: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

Te quieren usar el "Easy Install" o "AppImage" y por cual OS? Es muy facil, actualamente. Disafortunademente, mi espanol es muy terible - pero yo atemptar ayudar con la asistiencia de Google Translate.  

Tue Jun 08 2021 15:30:40 EDT from tactyl Subject: problemas

Como puedo instalar se servidos. gracias



 



Go to page: First ... 26 27 28 29 [30] 31 32 33 34 35