Language:
switch to room list switch to menu My folders
Go to page: First ... 18 19 20 21 [22] 23 24 25 26 ... Last
[#] Mon Aug 03 2020 16:07:14 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Access to other users mail

[Reply] [ReplyQuoted] [Headers] [Print]

If you know the actual name of the room (such as "8644012017.Mail") you can use the private room commands to invite another user to it, but there's no way to prevent the owner of the room from seeing that someone else has access to the room.

[#] Tue Aug 04 2020 17:30:15 EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> to Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Access to other users mail

[Reply] [ReplyQuoted] [Headers] [Print]

You may be able to do this by using IMAP on your computer to connect to
that user account. Just configure it not to download the emails, not to
mark them as read and not to delete anything on the server. (Thunderbird)

Try a new account, fill it with emails and try this method in
thunderbird. You will see that the user's email client does not perceive
this action.(I think)

I do this to organize the mailbox of a user who receives hundreds of
emails a week. The user uses POP (but I already checked with another
user who uses IMAP) to download his mail; and so he doesn't have to
re-download the thousands of emails in case he needs to reinstall his
computer.

Then, when I see that the emails have already been "read/downloaded" by
the user; I simply move the old ones to the archive folder.

Translated with www.DeepL.com/Translator (free version)


On 8/3/20 2:07 PM, IGnatius T Foobar wrote:
If you know the actual name of the room (such as "8644012017.Mail") you can
use the private room commands to invite another user to it, but there's no
way to prevent the owner of the room from seeing that someone else has access
to the room.

[#] Thu Aug 13 2020 07:25:58 EDT from BenM @ Uncensored

Subject: Re: housekeeping: WARNING: housekeeping loop has not run for 2467 minutes.

[Reply] [ReplyQuoted] [Headers] [Print]

Presumably related to the housekeeping loop issue, there seems to be a general problem with my Citadel system where idle sessions are not cleared up and just stay alive indefinitely. This is causing the CPU usage to max out and eventually bring down the entire box (not just citserver).

I noticed that the 'Maximum concurrent sessions' setting was unlimited (as far as I know it has always been set to 0), so I changed it to 20. However, Citadel soon hits 20 sessions and stops accepting SMTP mail or allowing IMAP logons or webcit logins until restarted manually.

syslog contains 'context: scheduled 20 idle sessions for termination'

The box it is running on is:
Operating system: Debian Linux 10 (32 bit)
Processor: Intel(R) Atom(TM) CPU D525 @ 1.80GHz, 4 cores
RAM: 2GB RAM

Is anyone else facing this issue or am I just lucky?



[#] Thu Aug 20 2020 06:02:21 EDT from alex007 @ Uncensored

Subject: Re: Corrupted attachments

[Reply] [ReplyQuoted] [Headers] [Print]

The problem still exists, I have  with a new installation of citadel 929 on
raspberrypi 3 with a fresh raspbian - based on debian buster.

I could sponsor a new raspberrypi to citadel.org to test it.

Fri May 08 2020 11:10:25 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Corrupted attachments
I have a really old Pi and will see what I can do to test. It might not work at all, but who knows. What is the size of the attachment you tried to send?

 



[#] Thu Aug 20 2020 11:56:44 EDT from josel @ Uncensored

Subject: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

I have Citadel installed on two networks sandboxed (no internet) and also on a network with internet. For some reason Citadel takes too long to load on the sandboxed network but no problems on the network with internet access. What could be the cause?



[#] Thu Aug 20 2020 12:41:45 EDT from warbaby @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

DNS resolution most likely, If you have no DNS service at all, a lot of services are going to be painfully slow to respond.

Try adding some local dns entries in /etc/hosts or router, or whatever is pretending to be your dns.. (that will fix slow ssh logins also.

192.168.0.5 mail mail.local.lan muh.mailserver.lan  citadel  # whatever

 

Thu Aug 20 2020 11:56:44 AM EDT from josel @ Uncensored Subject: Citadel on standalone network

I have Citadel installed on two networks sandboxed (no internet) and also on a network with internet. For some reason Citadel takes too long to load on the sandboxed network but no problems on the network with internet access. What could be the cause?



 



[#] Thu Aug 20 2020 13:00:40 EDT from josel @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

Forgot to mention that each network does have it's own DNS server.



[#] Thu Aug 20 2020 13:13:08 EDT from josel @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

When doing an nslookup by domain or IP I get an immediate response, same with curl or did commands. The latency is when I use the browser to get to Citadel mail.



[#] Thu Aug 20 2020 14:23:05 EDT from warbaby @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

Is the browser on the citadel box, or a different one?   Is there any delay connected locally or remotely with the text client? Try both.

Either case, I'd have a terminal open with top or htop, maybe another with tail -f syslog .. then hit webcit iwith the browser and watch what happens.   Get as much info together as you can.. Isolate the problem to a realm. 

Modern browsers do weird things. also, "extensions" like "ghostery" and "adblock" and "https everywhere" .  Slow to me says "resolution timeout" ..  not citserver.  which is always "really fast".

I notice I can't even hit a local server with a browser anymore until I literally type in "HTTP:\\mylocal.server", the full url, with scheme, at least ONE TIME.  Because most browsers want to assume it's public site, try to decide if i's a query, try to do a prefectch. ask you if you want to order from amazoom, send passwords to grooogle, or any other of the things that they like to do, so try it with something like lynx and see if you get the same result.  

That's how I would proceed.  Then compare your findings to your public box. It shouldn't be too hard to isolate.  Also, "right click" "inspect element"  "Network" and "reload" Check the actual request thats going out, and see whats its doing in the waterfall..

Might not be citadel at all. If it turns out to be that, I'd take a close look at your disk media.  That is, if dns does not turn out to be the issue after all.  I'd still make sure there are some entries in hosts on the server box EVEN IF YOU DON'T THINK YOU NEED THEM.

 A lot of things depend on that even with fake names and spoofed dns servers.  The key to understanding will be found by "ssh".  if it's slow to get to by ssh, you need a hosts entry for your loopback interface to "server.name" on the server box.

Thu Aug 20 2020 01:13:08 PM EDT from josel @ Uncensored Subject: Re: Citadel on standalone network

When doing an nslookup by domain or IP I get an immediate response, same with curl or did commands. The latency is when I use the browser to get to Citadel mail.



 



[#] Thu Aug 20 2020 15:52:05 EDT from josel @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

Browser is on a different box. I have also done what you suggested regarding right click and inspect. What I've seen is that it takes long long some .gif files.



[#] Thu Aug 20 2020 15:53:11 EDT from josel @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

Sorry, I meant that it takes long loading .gif files.



[#] Thu Aug 20 2020 22:28:40 EDT from warbaby @ Uncensored

Subject: Re: Citadel on standalone network

[Reply] [ReplyQuoted] [Headers] [Print]

AHA!  I KNEW is was those bloody gifs! .. hahaha, thanks man for the gut laugh of the day...

Those tiny little image files should not be causing you any problems..  What is top showing when you hit the page? Are you tailing syslog? 

ssh mail.server [log in]

sudo su

tail -f /var/log/syslog

 

then..

ssh mail.server [log in]

top

 

THEN load the page.

:)

Thu Aug 20 2020 03:52:05 PM EDT from josel @ Uncensored Subject: Re: Citadel on standalone network

Browser is on a different box. I have also done what you suggested regarding right click and inspect. What I've seen is that it takes long long some .gif files.



 



[#] Mon Aug 24 2020 10:22:18 EDT from phaake37 @ Uncensored

Subject: Re: Corrupted attachments

[Reply] [ReplyQuoted] [Headers] [Print]

All,

 

Did this ever get resolved?  I just tried this on my Citadel Server (Raspberry PI 3B+) and my text file produced:

 

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
123ÿó@Ð

 

the Original:

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
1234

So it appears to be something with appending to the file or? 

 

Any ideas?

Thanks!

 

 

Sat May 09 2020 23:13:54 EDT from warbaby @ Uncensored Subject: Re: Corrupted attachments

You might try a few more text uploads with various strings and see if there is any consistency with the char length.  

You might try creating some new files with a text editor and see how they look after a reboot.

I predict it is going to be failing Chink SD card writes, rather than a problem with Citadel. 

Or at least, replacing the Chink SD card would be my first approach, since that's a more widely known problem. 

Who knows all the various ways they fail? It might not be a total failure, just not writing properly.

Sometimes you can edit and save a file, it looks okay if you cat it out, but shows garbage after rebooting.

 

Sat May 09 2020 06:58:25 PM EDT from MAS3 @ Uncensored Subject: Re: Corrupted attachments

Thanks for the suggestion.

I created a small file, containing this text:

 

This is a text file created by the standard windows text editor.
It is not a large file, but i'm sure it will be corrupted once it's sent.

So let's see what will happen to it.

 

And this was what was received in the attachment (i'm not sure it will show exactly as i received due to the corruption)
Hmm seems there's more to it, as the font size has changed after copy / paste, and indentation was added:

 

This is a text file created by the standard windowsüÑ•áЁ•‘¥Ñ½È¸4)%Ё¥Ì¹½Ð„±…ɝ”™¥±”°‰ÕЁ¤´ÍÕÉ—ò—Bv–ÆÂ&R6÷''WFVBöæ6R—Bw26VçBàРХ6òÆWBw2?ÙYHÚ]Ú[\[ˆÈ]ƒBþ¾



 



 



[#] Tue Aug 25 2020 09:21:21 EDT from alex007 @ Uncensored

Subject: Re: Corrupted attachments

[Reply] [ReplyQuoted] [Headers] [Print]

it has something to do with character encoding I think.

My editor gedit says, that the original file I sent ist UTF-8 encoded, the file I downloaded with webcit is ISO 8859-15 encoded. See the files attached.

Does this only occur for German installations ?

 

Mon Aug 24 2020 10:22:18 EDT from phaake37 @ Uncensored Subject: Re: Corrupted attachments

All,

 

Did this ever get resolved?  I just tried this on my Citadel Server (Raspberry PI 3B+) and my text file produced:

 

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
123ÿó@Ð

 

the Original:

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
1234

So it appears to be something with appending to the file or? 

 

Any ideas?

Thanks!

 

 

Sat May 09 2020 23:13:54 EDT from warbaby @ Uncensored Subject: Re: Corrupted attachments

You might try a few more text uploads with various strings and see if there is any consistency with the char length.  

You might try creating some new files with a text editor and see how they look after a reboot.

I predict it is going to be failing Chink SD card writes, rather than a problem with Citadel. 

Or at least, replacing the Chink SD card would be my first approach, since that's a more widely known problem. 

Who knows all the various ways they fail? It might not be a total failure, just not writing properly.

Sometimes you can edit and save a file, it looks okay if you cat it out, but shows garbage after rebooting.

 

Sat May 09 2020 06:58:25 PM EDT from MAS3 @ Uncensored Subject: Re: Corrupted attachments

Thanks for the suggestion.

I created a small file, containing this text:

 

This is a text file created by the standard windows text editor.
It is not a large file, but i'm sure it will be corrupted once it's sent.

So let's see what will happen to it.

 

And this was what was received in the attachment (i'm not sure it will show exactly as i received due to the corruption)
Hmm seems there's more to it, as the font size has changed after copy / paste, and indentation was added:

 

This is a text file created by the standard windowsüÑ•áЁ•‘¥Ñ½È¸4)%Ё¥Ì¹½Ð„±…ɝ”™¥±”°‰ÕЁ¤´ÍÕÉ—ò—Bv–ÆÂ&R6÷''WFVBöæ6R—Bw26VçBàРХ6òÆWBw2?ÙYHÚ]Ú[\[ˆÈ]ƒBþ¾



 



 



 



blub2.txt (text/plain, 95 bytes) [View| Download]
blub2webcit.txt (text/plain, 99 bytes) [View| Download]
[#] Wed Sep 02 2020 10:00:03 EDT from vogelap @ Uncensored

Subject: Trying to install on Ubuntu VM in Windows 10

[Reply] [ReplyQuoted] [Headers] [Print]

I am trying to install Citadel using EasyInstall on a Ubuntu VM on Windows 10.

Here's what I am receiving... Can anyone provide any suggestions?

 

MyServer:~$ sudo -s

root@MyServer:/home/andrew# curl http://easyinstall.citadel.org/install | bash

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

100   185  100   185    0     0    642      0 --:--:-- --:--:-- --:--:--   642

bash: line 1: html: No such file or directory

bash: line 2: syntax error near unexpected token `<'

'ash: line 2: `<head><title>301 Moved Permanently</title></head>

 


[#] Wed Sep 02 2020 10:08:18 EDT from warbaby @ Uncensored

Subject: Re: Trying to install on Ubuntu VM in Windows 10

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Andrew! 

If you look closely you can see clearly you got html back instead of a script.

Try:

wget http://easyinstall.citadel.org/install --output-document=easy-install.sh

or use the capital O switch

wget http://easyinstall.citadel.org/install --O easy-install.sh

then you can

chmod +x easy-install.sh

./easy-install.sh

 

Wed Sep 02 2020 10:00:03 AM EDT from vogelap @ Uncensored Subject: Trying to install on Ubuntu VM in Windows 10

I am trying to install Citadel using EasyInstall on a Ubuntu VM on Windows 10.

Here's what I am receiving... Can anyone provide any suggestions?

 

MyServer:~$ sudo -s

root@MyServer:/home/andrew# curl http://easyinstall.citadel.org/install | bash

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

100   185  100   185    0     0    642      0 --:--:-- --:--:-- --:--:--   642

bash: line 1: html: No such file or directory

bash: line 2: syntax error near unexpected token `<'

'ash: line 2: `<head><title>301 Moved Permanently</title></head>

 


 



[#] Wed Sep 02 2020 10:11:00 EDT from warbaby @ Uncensored

Subject: Re: Trying to install on Ubuntu VM in Windows 10

[Reply] [ReplyQuoted] [Headers] [Print]

Woops, that should only be one - on the dash O example. 

wget ... -O easy-install.sh

Wed Sep 02 2020 10:08:18 AM EDT from warbaby @ Uncensored Subject: Re: Trying to install on Ubuntu VM in Windows 10

Hi Andrew! 

If you look closely you can see clearly you got html back instead of a script.

Try:

wget http://easyinstall.citadel.org/install --output-document=easy-install.sh

or use the capital O switch

wget http://easyinstall.citadel.org/install --O easy-install.sh

then you can

chmod +x easy-install.sh

./easy-install.sh

 

Wed Sep 02 2020 10:00:03 AM EDT from vogelap @ Uncensored Subject: Trying to install on Ubuntu VM in Windows 10

I am trying to install Citadel using EasyInstall on a Ubuntu VM on Windows 10.

Here's what I am receiving... Can anyone provide any suggestions?

 

MyServer:~$ sudo -s

root@MyServer:/home/andrew# curl http://easyinstall.citadel.org/install | bash

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                 Dload  Upload   Total   Spent    Left  Speed

100   185  100   185    0     0    642      0 --:--:-- --:--:-- --:--:--   642

bash: line 1: html: No such file or directory

bash: line 2: syntax error near unexpected token `<'

'ash: line 2: `<head><title>301 Moved Permanently</title></head>

 


 



 



[#] Sat Sep 05 2020 17:06:38 EDT from LinuxBoy @ Uncensored

Subject: Add Sender's Email Address to Address Book, Mailing List or Database

[Reply] [ReplyQuoted] [Headers] [Print]

How would I automatically (or in a scripted or other way) automatically add/collect all sender's email addresses from the email header and then add it to the Address Book, Mailing List, or database file?

Thank you for your support.



[#] Sun Sep 06 2020 01:24:33 EDT from brianwl @ Uncensored

Subject: Database corruption

[Reply] [ReplyQuoted] [Headers] [Print]

Hello, I've been happily using Citadel for my family's mail server for years, and have not had but a very few problems, and every time simply restoring from a backup has cured it.

This time, however, whatever happened seems to have persisted through most of my backups while the server kept running, so almost all my backups are corrupted.

I _do_ have a good backup from mid-August, but I'd much rather not have to export all my family member's IMAP client data (or likely lose all that email)

 

Here are the errors generated after restoring the last 5 days worth of citadel/data:

 

root@mail:~# cat /var/log/mail.err | cut -d':' -f4- | sort | uniq -c | sort -n
   4929  DB: BDB2506 file cdb.00 has LSN 14765/1303875, past end of log at 1/28
   4970  DB: BDB2506 file cdb.00 has LSN 14795/4275094, past end of log at 1/28
   9053  DB: BDB2506 file cdb.00 has LSN 14826/1401646, past end of log at 1/28
   9520  DB: BDB2506 file cdb.00 has LSN 14889/4245711, past end of log at 1/28
  12086  DB: BDB2506 file cdb.00 has LSN 14856/9334939, past end of log at 1/28

As you can see from the uniq -c, it simply spams that single message in my mail.err log until I shut down the service.

I can't access citserver in any way that I know of while its running...

Are there any tools to save newer versions of my backups, or is it hopeless?

Thanks!

 

    -Brian



[#] Mon Sep 07 2020 18:11:49 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Database corruption

[Reply] [ReplyQuoted] [Headers] [Print]


It isn't common for a Citadel database to simply go bad like that, unless you ran out of disk space, or somehow got two Citadel servers running at the same time (but the software tries to prevent that).

With the server shut down, you can attempt the following repairs:

1. Use "db_recover -c" as per the Berkeley DB supplied directions, to attempt to clean the database files.

2. If that doesn't work, the "database_cleanup.sh" script will often succeed where db_recover fails. Be sure you have plenty of free disk space because this is basically a dump-and-load of your db.

Go to page: First ... 18 19 20 21 [22] 23 24 25 26 ... Last