Language:
switch to room list switch to menu My folders
Go to page: First ... 13 14 15 16 [17] 18 19 20 21 ... Last
[#] Sun Jun 14 2020 18:49:27 EDT from warbaby @ Uncensored

Subject: Re: - sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

That  ç on 344 is the redhat install line

                yum groupinstall "Development Tools" </dev/tty || die

Too many arguments on 356 ..

ti's is the beginning of the debian stuff..

   apt-get install \

You should print out ${DIST} at around 340, and probably EXIT; and see what value you have.  It should just be "SUSE," since we only want to run a package installer. Version and distribution slugs are superfluous at this point. 

 


Sun Jun 14 2020 06:34:16 PM EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

I fixed the OS detection:

 This is a NEW Citadel installation.
 Installation will now begin.
 Do you want Easy Install to attempt to install your OS dependencies? Y
./install: Zeile 344: ç
./install: Zeile 356: [: Zu viele Argumente.
 Easy Install does not yet know how to do this on your operating system.
 Citadel Easy Install is aborting.
 The last few lines above this message may indicate what went wrong.
 Linux NAME="openSUSE Leap" NAME="openSUSE Leap" VERSION="15.1" ID="opensuse-leap" ID_LIKE="suse opensuse" VERSION_ID="15.1" PRETTY_NAME="openSUSE Leap 15.1" ANSI_COLOR="0;32" CPE_NAME="cpe:/o:opensuse:leap:15.1" BUG_REPORT_URL="https://bugs.opensuse.org" HOME_URL="https://www.opensuse.org/" ( 4.12.14-lp151.28.52-default x86_64)

 [: Zu viele Argumente. -> means too many arguments

Sun Jun 14 2020 18:13:32 EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

okay, it looks like libsieve2 wasn#t installed via Yast or zypper. Only libksieve was there, I uninstalled it, but according to easyinstall, sieve2.h is still there

I'm using bash but I'm logged in via ssh now..

I can't find the logfile in /tmp, only the build folder:

/tmp/citadel-build.1147

it is deleted when easyinstall aborts

 

Sun Jun 14 2020 17:22:18 EDT from warbaby @ Uncensored Subject: Re: - sieve2_license error

Okay, FIRST, uninstall your distribution's libsieve2 again.

Recall, easy install is logged to  '/tmp/citadel-install-log.txt'

You should be getting the exact same thing everybody else does if you answer NO there.

This is as complex as it is .

DOWNLOAD_SITE=http://easyinstall.citadel.org
# Original source code packages.
DB_SOURCE=db-6.2.32.NC.tar.gz
LIBICAL_SOURCE=libical-3.0.3.tar.gz
LIBSIEVE_SOURCE=libsieve-2.2.7-ctdl2.tar.gz

So, instead of reading the script from standard input, just download the script..

wget http://easyinstall.citadel.org/install

now, run it from the command line ./install  # you might want to open it up, and read it, so you can see what is going on. 

have another terminal open

tail -f /tmp/citadel-install-log.txt

watch and see what is going on..

It has to be something simple.  A path, an environment variable, some issue about your shell?  What shell you using?  Bash?

 

Sun Jun 14 2020 05:05:10 PM EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

Well, I understood you recommended to let easyinstall install libsieve2

If I say no I get the quoted "sieve2_license error"

Before I installed libsieve2 via Yast I got a sieve not present error

 

Sun Jun 14 2020 16:58:17 EDT from warbaby @ Uncensored Subject: Re: - sieve2_license error

What happens if you answer N, right here?

  Do you want Easy Install to attempt to install your OS dependencies?

 

Sun Jun 14 2020 04:52:16 PM EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

Yes, I did install libsieve via Yast because Easyinstall won't install the dependencies for me:

 Do you want Easy Install to attempt to install your OS dependencies? Y
sh: Zeile 341: [: ==: Einstelliger (unärer) Operator erwartet.
sh: Zeile 353: [: ==: Einstelliger (unärer) Operator erwartet.
 Easy Install does not yet know how to do this on your operating system.
 Citadel Easy Install is aborting.
 The last few lines above this message may indicate what went wrong.
 Linux 4.12.14-lp151.28.52-default( 4.12.14-lp151.28.52-default x86_64)

 

 

Sat Jun 13 2020 22:28:19 EDT from warbaby @ Uncensored Subject: Re: - sieve2_license error

Did you already have libsieve2 installed from a dev package?  If so, you might need to uninstall it with Yast, or whatever, then run easy install again..

From the tarball..  "This is NOT the real libSieve!  If you are really and truly working with libSieve then you want to go to http://libsieve.sourceforge.net and get the upstream sources.  libsieve-2.2.7-ctdl2 is a temporary fork of libsieve-2.2.7 that has had all of the lex and yacc stuff removed with a chainsaw so that it may be included with the "Easy Install" distribution of the Citadel system without requiring users to have lex (flex) and yacc (bison) installed. ...

 

Sat Jun 13 2020 05:34:44 PM EDT from bgerum2 @ Uncensored Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

Hi, I was using citadel on Opensuse sytems for several years, but I got into trouble two years ago when I upgraded from 42.3 I think.

I'm actually trying to set up a citadel server on Opensuse 15.1, too. Via easyinstall. I have no problems with berkeley db, I have the following packages installed:

db48-utils

libdb-4_8

libdb-4_8-devel

libgda-5_0-bdb

 

But I have a problem with sieve:

checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
 Citadel Easy Install is aborting.

 



 



 



 



 



 



 



 



 



[#] Sun Jun 14 2020 18:56:01 EDT from warbaby @ Uncensored

Subject: Re: - sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

bash portability issue?  Here's what I'm using.. Debian 10 default.

me@ftp:~$ bash --version
bash --version
GNU bash, version 4.4.12(1)-release (x86_64-pc-linux-gnu)

Sun Jun 14 2020 06:34:16 PM EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

I fixed the OS detection:

 This is a NEW Citadel installation.
 Installation will now begin.
 Do you want Easy Install to attempt to install your OS dependencies? Y
./install: Zeile 344: ç
./install: Zeile 356: [: Zu viele Argumente.
 Easy Install does not yet know how to do this on your operating system.
 Citadel Easy Install is aborting.
 The last few lines above this message may indicate what went wrong.
 Linux NAME="openSUSE Leap" NAME="openSUSE Leap" VERSION="15.1" ID="opensuse-leap" ID_LIKE="suse opensuse" VERSION_ID="15.1" PRETTY_NAME="openSUSE Leap 15.1" ANSI_COLOR="0;32" CPE_NAME="cpe:/o:opensuse:leap:15.1" BUG_REPORT_URL="https://bugs.opensuse.org" HOME_URL="https://www.opensuse.org/" ( 4.12.14-lp151.28.52-default x86_64)

 [: Zu viele Argumente. -> means too many arguments

Sun Jun 14 2020 18:13:32 EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

okay, it looks like libsieve2 wasn#t installed via Yast or zypper. Only libksieve was there, I uninstalled it, but according to easyinstall, sieve2.h is still there

I'm using bash but I'm logged in via ssh now..

I can't find the logfile in /tmp, only the build folder:

/tmp/citadel-build.1147

it is deleted when easyinstall aborts

 

Sun Jun 14 2020 17:22:18 EDT from warbaby @ Uncensored Subject: Re: - sieve2_license error

Okay, FIRST, uninstall your distribution's libsieve2 again.

Recall, easy install is logged to  '/tmp/citadel-install-log.txt'

You should be getting the exact same thing everybody else does if you answer NO there.

This is as complex as it is .

DOWNLOAD_SITE=http://easyinstall.citadel.org
# Original source code packages.
DB_SOURCE=db-6.2.32.NC.tar.gz
LIBICAL_SOURCE=libical-3.0.3.tar.gz
LIBSIEVE_SOURCE=libsieve-2.2.7-ctdl2.tar.gz

So, instead of reading the script from standard input, just download the script..

wget http://easyinstall.citadel.org/install

now, run it from the command line ./install  # you might want to open it up, and read it, so you can see what is going on. 

have another terminal open

tail -f /tmp/citadel-install-log.txt

watch and see what is going on..

It has to be something simple.  A path, an environment variable, some issue about your shell?  What shell you using?  Bash?

 

Sun Jun 14 2020 05:05:10 PM EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

Well, I understood you recommended to let easyinstall install libsieve2

If I say no I get the quoted "sieve2_license error"

Before I installed libsieve2 via Yast I got a sieve not present error

 

Sun Jun 14 2020 16:58:17 EDT from warbaby @ Uncensored Subject: Re: - sieve2_license error

What happens if you answer N, right here?

  Do you want Easy Install to attempt to install your OS dependencies?

 

Sun Jun 14 2020 04:52:16 PM EDT from bgerum2 @ Uncensored Subject: Re: - sieve2_license error

Yes, I did install libsieve via Yast because Easyinstall won't install the dependencies for me:

 Do you want Easy Install to attempt to install your OS dependencies? Y
sh: Zeile 341: [: ==: Einstelliger (unärer) Operator erwartet.
sh: Zeile 353: [: ==: Einstelliger (unärer) Operator erwartet.
 Easy Install does not yet know how to do this on your operating system.
 Citadel Easy Install is aborting.
 The last few lines above this message may indicate what went wrong.
 Linux 4.12.14-lp151.28.52-default( 4.12.14-lp151.28.52-default x86_64)

 

 

Sat Jun 13 2020 22:28:19 EDT from warbaby @ Uncensored Subject: Re: - sieve2_license error

Did you already have libsieve2 installed from a dev package?  If so, you might need to uninstall it with Yast, or whatever, then run easy install again..

From the tarball..  "This is NOT the real libSieve!  If you are really and truly working with libSieve then you want to go to http://libsieve.sourceforge.net and get the upstream sources.  libsieve-2.2.7-ctdl2 is a temporary fork of libsieve-2.2.7 that has had all of the lex and yacc stuff removed with a chainsaw so that it may be included with the "Easy Install" distribution of the Citadel system without requiring users to have lex (flex) and yacc (bison) installed. ...

 

Sat Jun 13 2020 05:34:44 PM EDT from bgerum2 @ Uncensored Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

Hi, I was using citadel on Opensuse sytems for several years, but I got into trouble two years ago when I upgraded from 42.3 I think.

I'm actually trying to set up a citadel server on Opensuse 15.1, too. Via easyinstall. I have no problems with berkeley db, I have the following packages installed:

db48-utils

libdb-4_8

libdb-4_8-devel

libgda-5_0-bdb

 

But I have a problem with sieve:

checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
 Citadel Easy Install is aborting.

 



 



 



 



 



 



 



 



 



[#] Sun Jun 14 2020 19:06:21 EDT from warbaby @ Uncensored

Subject: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

I'm seeing some evidence of differences in the bash implementation in openSuse..  

DEBIAN WORKS, kek.. you could install deb 10 buster in just a few minutes....

but, if you're really settled on SUSE, figuring out what the differences in how that bash flavor views the world is probably a good first step.

I run this script quite often, and never see an error from it.



[#] Sun Jun 14 2020 19:10:27 EDT from bgerum2 @ Uncensored

Subject: Re: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

Ok this would be the fix:

elif [ ${DIST} == "openSUSE Leap" ]
    then
        show_info You are on a OpenSuse-like system.
        zypper in -t pattern devel_basis </dev/tty || die
        zypper in \
            zlib-devel \
            openldap-devel \
            openssl-devel \
            libcurl-devel \
            libical-devel \
            expat-devel \
            </dev/tty || die

but I still get a "too many arguments" error for the eilf line, no matter if I put the Redhat, Debian, openSUSE Leap in " quotes or ' quotes

 

Sun Jun 14 2020 19:06:21 EDT from warbaby @ Uncensored Subject: sieve2_license error

I'm seeing some evidence of differences in the bash implementation in openSuse..  

DEBIAN WORKS, kek.. you could install deb 10 buster in just a few minutes....

but, if you're really settled on SUSE, figuring out what the differences in how that bash flavor views the world is probably a good first step.

I run this script quite often, and never see an error from it.



 



[#] Sun Jun 14 2020 19:12:11 EDT from bgerum2 @ Uncensored

Subject: Re: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

 bash --version

GNU bash, Version 4.4.23(1)-release (x86_64-suse-linux-gnu)
Copyright (C) 2016 Free Software Foundation, Inc.
Lizenz GPLv3+: GNU GPL Version 3 oder jünger <http://gnu.org/licenses/gpl.html>

 

Sun Jun 14 2020 19:10:27 EDT from bgerum2 @ Uncensored Subject: Re: sieve2_license error

Ok this would be the fix:

elif [ ${DIST} == "openSUSE Leap" ]
    then
        show_info You are on a OpenSuse-like system.
        zypper in -t pattern devel_basis </dev/tty || die
        zypper in \
            zlib-devel \
            openldap-devel \
            openssl-devel \
            libcurl-devel \
            libical-devel \
            expat-devel \
            </dev/tty || die

but I still get a "too many arguments" error for the eilf line, no matter if I put the Redhat, Debian, openSUSE Leap in " quotes or ' quotes

 

Sun Jun 14 2020 19:06:21 EDT from warbaby @ Uncensored Subject: sieve2_license error

I'm seeing some evidence of differences in the bash implementation in openSuse..  

DEBIAN WORKS, kek.. you could install deb 10 buster in just a few minutes....

but, if you're really settled on SUSE, figuring out what the differences in how that bash flavor views the world is probably a good first step.

I run this script quite often, and never see an error from it.



 



 



[#] Mon Jun 15 2020 07:40:58 EDT from warbaby @ Uncensored

Subject: Re: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

try turning on trace when you run the script..

./easyinstall -x

 

Sun Jun 14 2020 07:12:11 PM EDT from bgerum2 @ Uncensored Subject: Re: sieve2_license error

 bash --version

GNU bash, Version 4.4.23(1)-release (x86_64-suse-linux-gnu)
Copyright (C) 2016 Free Software Foundation, Inc.
Lizenz GPLv3+: GNU GPL Version 3 oder jünger <http://gnu.org/licenses/gpl.html>

 

Sun Jun 14 2020 19:10:27 EDT from bgerum2 @ Uncensored Subject: Re: sieve2_license error

Ok this would be the fix:

elif [ ${DIST} == "openSUSE Leap" ]
    then
        show_info You are on a OpenSuse-like system.
        zypper in -t pattern devel_basis </dev/tty || die
        zypper in \
            zlib-devel \
            openldap-devel \
            openssl-devel \
            libcurl-devel \
            libical-devel \
            expat-devel \
            </dev/tty || die

but I still get a "too many arguments" error for the eilf line, no matter if I put the Redhat, Debian, openSUSE Leap in " quotes or ' quotes

 

Sun Jun 14 2020 19:06:21 EDT from warbaby @ Uncensored Subject: sieve2_license error

I'm seeing some evidence of differences in the bash implementation in openSuse..  

DEBIAN WORKS, kek.. you could install deb 10 buster in just a few minutes....

but, if you're really settled on SUSE, figuring out what the differences in how that bash flavor views the world is probably a good first step.

I run this script quite often, and never see an error from it.



 



 



 



[#] Mon Jun 15 2020 07:45:45 EDT from warbaby @ Uncensored

Subject: Re: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

that last command I sent won't work, unless you invoke the interpreter first..

so, just add the -x to the shebang line

#!/bin/bash -x

Sun Jun 14 2020 07:12:11 PM EDT from bgerum2 @ Uncensored Subject: Re: sieve2_license error

 bash --version

GNU bash, Version 4.4.23(1)-release (x86_64-suse-linux-gnu)
Copyright (C) 2016 Free Software Foundation, Inc.
Lizenz GPLv3+: GNU GPL Version 3 oder jünger <http://gnu.org/licenses/gpl.html>

 

Sun Jun 14 2020 19:10:27 EDT from bgerum2 @ Uncensored Subject: Re: sieve2_license error

Ok this would be the fix:

elif [ ${DIST} == "openSUSE Leap" ]
    then
        show_info You are on a OpenSuse-like system.
        zypper in -t pattern devel_basis </dev/tty || die
        zypper in \
            zlib-devel \
            openldap-devel \
            openssl-devel \
            libcurl-devel \
            libical-devel \
            expat-devel \
            </dev/tty || die

but I still get a "too many arguments" error for the eilf line, no matter if I put the Redhat, Debian, openSUSE Leap in " quotes or ' quotes

 

Sun Jun 14 2020 19:06:21 EDT from warbaby @ Uncensored Subject: sieve2_license error

I'm seeing some evidence of differences in the bash implementation in openSuse..  

DEBIAN WORKS, kek.. you could install deb 10 buster in just a few minutes....

but, if you're really settled on SUSE, figuring out what the differences in how that bash flavor views the world is probably a good first step.

I run this script quite often, and never see an error from it.



 



 



 



[#] Mon Jun 15 2020 09:51:28 EDT from easy now @ Uncensored

Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

bgerum2  please note that you did not have to hijack my space and kill my request for help. For a person who has been using citadel for a couple of years you should by now know that you don't do that. In the future, if you have something to say about my request for help, say it directly to me or just ask help for your own problem not playing dirty and pinching off on others. Please learn to respect forum rules and good ethics.  



[#] Mon Jun 15 2020 10:03:05 EDT from easy now @ Uncensored

Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

bgerum2,

Please note that you did not have to hijack my question and kill my request for help. If you have a contribution to my question then say what you have to help but you did not have to do it in a sneaky and unethical way. In the future please start you own request for help the proper way.

 

Sat Jun 13 2020 17:34:44 EDT from bgerum2 @ Uncensored Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

Hi, I was using citadel on Opensuse sytems for several years, but I got into trouble two years ago when I upgraded from 42.3 I think.

I'm actually trying to set up a citadel server on Opensuse 15.1, too. Via easyinstall. I have no problems with berkeley db, I have the following packages installed:

db48-utils

libdb-4_8

libdb-4_8-devel

libgda-5_0-bdb

 

But I have a problem with sieve:

checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
 Citadel Easy Install is aborting.

 



 



[#] Mon Jun 15 2020 10:07:41 EDT from easy now @ Uncensored

Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

Sat Jun 13 2020 17:34:44 EDT from bgerum2 @ Uncensored Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

Hi, I was using citadel on Opensuse sytems for several years, but I got into trouble two years ago when I upgraded from 42.3 I think.

I'm actually trying to set up a citadel server on Opensuse 15.1, too. Via easyinstall. I have no problems with berkeley db, I have the following packages installed:

db48-utils

libdb-4_8

libdb-4_8-devel

libgda-5_0-bdb

 

But I have a problem with sieve:

checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
 Citadel Easy Install is aborting.

 



 



[#] Mon Jun 15 2020 10:51:45 EDT from easy now @ Uncensored

Subject: Re: BerkeleyDB lib error while installing with Easy Install

[Reply] [ReplyQuoted] [Headers] [Print]

Hello Guys,

My question quoted here below was hijacked by bgerum2 earlier on.

I could gather from warbaby's comments above (if I understand it correctly) that there is no current working package developed for Opensuse 15.1_Leap.

Does this mean that Citadel/EasyInstall has dropped support for Opensuse?

If not, could you please advise on how to deal with my issue.

Thank you.

 

Sat Jun 13 2020 08:19:12 EDT from easy now @ Uncensored Subject: BerkeleyDB lib error while installing with Easy Install

Hello All,

Easy Install throws an error while checking dependencies, like "Cannot locate a suitable Berkelydb library. Use --with-db=PATH to where it is installed" 

I then tried various ways to install with the given  --with-db various way but none worked. I thought the problem could be somehow different from what is given in the error since I believe (unless I've misunderstood the install process) Easy Install should download and install Berkeleydb itself. 

Suppose I need to install Berekeleydb and library myself, how do I use the --with-db=PATH with install command?
And, if Easy Install should download and install them, please advise me on how to deal with this error.

Server OS: Opensuse 15.1 Leap
Installed Java version: 8
Installed required and recommended libraries myself via yast
Command used: curl http://easyinstall.citadel.org/install | sh

Many thanks in advance.



 



[#] Mon Jun 15 2020 10:56:51 EDT from CitadelNewbee @ Uncensored

Subject: smart host login

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

how can I enter the login AUTH parameters for a smart hostin the form.

thank you



[#] Mon Jun 15 2020 11:34:47 EDT from warbaby @ Uncensored

Subject: Re: BerkeleyDB lib error while installing with Easy Install

[Reply] [ReplyQuoted] [Headers] [Print]

I was talking strictly about easyinstall, the package retrieval for SUSE was left for another day.. I am not aware of packages for SUSE.. but that doesn't mean they don't exist.

try this..

wget http://easyinstall.citadel.org/install -O easyinstall.sh

chmod+x easyinstall.sh

edit the top line to

#!/bin/bash -x

run it and see what is happening..

You might be benefited by the other conversation also.

Perpetuating that hijacking was probably my fault.. I did edit the subject line when I replied, but yes it should have been a new thread.. My apology for that.

But..   You might both be having the same issue, (seems like a string/path thing..) and  can benefit by working together to complete that section of easy install.

 

Mon Jun 15 2020 10:51:45 AM EDT from easy now @ Uncensored Subject: Re: BerkeleyDB lib error while installing with Easy Install

Hello Guys,

My question quoted here below was hijacked by bgerum2 earlier on.

I could gather from warbaby's comments above (if I understand it correctly) that there is no current working package developed for Opensuse 15.1_Leap.

Does this mean that Citadel/EasyInstall has dropped support for Opensuse?

If not, could you please advise on how to deal with my issue.

Thank you.

 

Sat Jun 13 2020 08:19:12 EDT from easy now @ Uncensored Subject: BerkeleyDB lib error while installing with Easy Install

Hello All,

Easy Install throws an error while checking dependencies, like "Cannot locate a suitable Berkelydb library. Use --with-db=PATH to where it is installed" 

I then tried various ways to install with the given  --with-db various way but none worked. I thought the problem could be somehow different from what is given in the error since I believe (unless I've misunderstood the install process) Easy Install should download and install Berkeleydb itself. 

Suppose I need to install Berekeleydb and library myself, how do I use the --with-db=PATH with install command?
And, if Easy Install should download and install them, please advise me on how to deal with this error.

Server OS: Opensuse 15.1 Leap
Installed Java version: 8
Installed required and recommended libraries myself via yast
Command used: curl http://easyinstall.citadel.org/install | sh

Many thanks in advance.



 



 



[#] Mon Jun 15 2020 11:38:16 EDT from warbaby @ Uncensored

Subject: Re: smart host login

[Reply] [ReplyQuoted] [Headers] [Print]

 

If your relay server is running on a port other than the standard SMTP port 25, you can also specify the port number using “host:port” syntax; i.e. “relay99.myisp.com:2525”

Furthermore, if your relay server requires authentication, you can specify it using username:password@host or username:password@host:port syntax; i.e. “jsmith:pass123@relay99.myisp.com:25”

http://www.citadel.org/doku.php?id=documentation:system_administration_manual&s[]=smart&s[]=host

 

Mon Jun 15 2020 10:56:51 AM EDT from CitadelNewbee @ Uncensored Subject: smart host login

Hi,

how can I enter the login AUTH parameters for a smart hostin the form.

thank you



 



[#] Mon Jun 15 2020 12:59:36 EDT from warbaby @ Uncensored

Subject: An Open Suse Leap 42.1 Package..

[Reply] [ReplyQuoted] [Headers] [Print]

[#] Mon Jun 15 2020 15:30:44 EDT from p.agsten @ Uncensored

Subject: SMTP session logs

[Reply] [ReplyQuoted] [Headers] [Print]

Hi All,

I just migrated to Citadel from hMailserver. So far I am satisfied. However, I cannot find the SMTP logs which detail issues with mail delivery. I have a couple of mail of one of my users bounce with 554 (Transaction failed). Normally, I would expect to find more detail from the recieving serverin some sort of mail.err or smtp log but this does not seem to exist. Also checked Citadel documentation but did not find anything.

Can someone pleae point me to the right place to look into.

Thanks,

Pit



[#] Mon Jun 15 2020 15:41:31 EDT from bgerum2 @ Uncensored

Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

Hi easy now, sorry, I just wanted to help you, I think both problems are connected so I edited the subject. But I probably should have started a new thread.

 

Mon Jun 15 2020 10:03:05 EDT from easy now @ Uncensored Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

bgerum2,

Please note that you did not have to hijack my question and kill my request for help. If you have a contribution to my question then say what you have to help but you did not have to do it in a sneaky and unethical way. In the future please start you own request for help the proper way.

 

Sat Jun 13 2020 17:34:44 EDT from bgerum2 @ Uncensored Subject: Re: BerkeleyDB lib error ...-- sieve2_license error

Hi, I was using citadel on Opensuse sytems for several years, but I got into trouble two years ago when I upgraded from 42.3 I think.

I'm actually trying to set up a citadel server on Opensuse 15.1, too. Via easyinstall. I have no problems with berkeley db, I have the following packages installed:

db48-utils

libdb-4_8

libdb-4_8-devel

libgda-5_0-bdb

 

But I have a problem with sieve:

checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
 Citadel Easy Install is aborting.

 



 



 



[#] Mon Jun 15 2020 15:53:23 EDT from bgerum2 @ Uncensored

Subject: Re: An Open Suse Leap 42.1 Package..

[Reply] [ReplyQuoted] [Headers] [Print]

Yes, that's what I used until two years ago, but it is not updated anymore. Leap switched Version numbering after 42.3 to 15.0, now we're at 15.1

The latest citadel version in this repo is 8.24,  quite outdated

There was also another repo, by stefjakobs, but it's not online anymore.

 

Mon Jun 15 2020 12:59:36 EDT from warbaby @ Uncensored Subject: An Open Suse Leap 42.1 Package..

 



[#] Mon Jun 15 2020 16:13:25 EDT from bgerum2 @ Uncensored

Subject: Re: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

ok, I found the shell problem:

the DISt variable has to be in quotes, like this:

elif [ "${DIST}" == "openSUSE Leap" ]

 

 

Sun Jun 14 2020 18:05:29 EDT from warbaby @ Uncensored Subject: Re: sieve2_license error

By "add the section for Open Susie," I meant, to the installer portion, because the var should be already set.

Sun Jun 14 2020 06:03:21 PM EDT from warbaby @ Uncensored Subject: sieve2_license error

Okay, I translated from Zee Deutch! 

sh: Line 341: [: ==: unary operator expected.
sh: line 353: [: ==: unary operator expected.

this is a shell flavor thing.  You might try double quotes around those strings. but the script does appear to be working.

Also, there is no direct package installation support YET, for Open Susie in easy install.  [You could create this patch as you are troubleshooting your install..]

341:        if [ ${DIST} == 'RedHat' ]

353:        elif [ ${DIST} == 'Debian' ]

367:  else
                show_alert 'Easy Install does not yet know how to do this on your operating system.'
                die

um.. you can see in the block beginning at 197

elif [ "${OS}" = "Linux" ] ; then
        KERNEL=`uname -r`
        if [ -f /etc/redhat-release ] ; then
                DIST='RedHat'
                PSEUDONAME=`cat /etc/redhat-release | sed s/.*\(// | sed s/\)//`
                REV=`cat /etc/redhat-release | sed s/.*release\ // | sed s/\ .*//`
        elif [ -f /etc/SUSE-release ] ; then
                DIST=`cat /etc/SUSE-release | tr "\n" ' '| sed s/VERSION.*//`
                REV=`cat /etc/SUSE-release | tr "\n" ' ' | sed s/.*=\ //`
        elif [ -f /etc/mandrake-release ] ; then
                DIST='Mandrake'
                PSEUDONAME=`cat /etc/mandrake-release | sed s/.*\(// | sed s/\)//`
                REV=`cat /etc/mandrake-release | sed s/.*release\ // | sed s/\ .*//`
        elif [ -f /etc/debian_version ] ; then
                DIST='Debian'
                REV=`cat /etc/debian_version`

Could add a section for Open Susie.. etc..

But, it should not be difficult to get the script to bypass one check on something that is already there..

It would be best if you can find out why/where.. could be related to that unary operator issue..

Perhaps, double quotes or something are needed...

if you are getting past line 442,

442        ./configure --prefix=$SUPPORT || die

then you might take a look in

/tmp/citadel-build.2704/libsieve-2.2.7/src




 



 



[#] Mon Jun 15 2020 16:26:08 EDT from warbaby @ Uncensored

Subject: Re: sieve2_license error

[Reply] [ReplyQuoted] [Headers] [Print]

Okay, I made that change and ran a lint check, it doesn't seem to affect anything else.

I'm going to encourage both you guys to complete the rest of the section, starting at at 367..

elif [ "${DIST}" == "openSUSE Leap" ]

then

## whatever all you need to do to get your packages installed..

 

### down to..

else
      show_alert 'Easy Install does not yet know how to do this on your operating system.'
      die
   fi

## Test this thoroughly! .

Then, make a single post for "Easy Install Update for openSUSE Leap"

.. this would really be helping others out!

 

 

Mon Jun 15 2020 04:13:25 PM EDT from bgerum2 @ Uncensored Subject: Re: sieve2_license error

ok, I found the shell problem:

the DISt variable has to be in quotes, like this:

elif [ "${DIST}" == "openSUSE Leap" ]

 

 

Sun Jun 14 2020 18:05:29 EDT from warbaby @ Uncensored Subject: Re: sieve2_license error

By "add the section for Open Susie," I meant, to the installer portion, because the var should be already set.

Sun Jun 14 2020 06:03:21 PM EDT from warbaby @ Uncensored Subject: sieve2_license error

Okay, I translated from Zee Deutch! 

sh: Line 341: [: ==: unary operator expected.
sh: line 353: [: ==: unary operator expected.

this is a shell flavor thing.  You might try double quotes around those strings. but the script does appear to be working.

Also, there is no direct package installation support YET, for Open Susie in easy install.  [You could create this patch as you are troubleshooting your install..]

341:        if [ ${DIST} == 'RedHat' ]

353:        elif [ ${DIST} == 'Debian' ]

367:  else
                show_alert 'Easy Install does not yet know how to do this on your operating system.'
                die

um.. you can see in the block beginning at 197

elif [ "${OS}" = "Linux" ] ; then
        KERNEL=`uname -r`
        if [ -f /etc/redhat-release ] ; then
                DIST='RedHat'
                PSEUDONAME=`cat /etc/redhat-release | sed s/.*\(// | sed s/\)//`
                REV=`cat /etc/redhat-release | sed s/.*release\ // | sed s/\ .*//`
        elif [ -f /etc/SUSE-release ] ; then
                DIST=`cat /etc/SUSE-release | tr "\n" ' '| sed s/VERSION.*//`
                REV=`cat /etc/SUSE-release | tr "\n" ' ' | sed s/.*=\ //`
        elif [ -f /etc/mandrake-release ] ; then
                DIST='Mandrake'
                PSEUDONAME=`cat /etc/mandrake-release | sed s/.*\(// | sed s/\)//`
                REV=`cat /etc/mandrake-release | sed s/.*release\ // | sed s/\ .*//`
        elif [ -f /etc/debian_version ] ; then
                DIST='Debian'
                REV=`cat /etc/debian_version`

Could add a section for Open Susie.. etc..

But, it should not be difficult to get the script to bypass one check on something that is already there..

It would be best if you can find out why/where.. could be related to that unary operator issue..

Perhaps, double quotes or something are needed...

if you are getting past line 442,

442        ./configure --prefix=$SUPPORT || die

then you might take a look in

/tmp/citadel-build.2704/libsieve-2.2.7/src




 



 



 



Go to page: First ... 13 14 15 16 [17] 18 19 20 21 ... Last