Language:
switch to room list switch to menu My folders
Go to page: First ... 15 16 17 18 [19] 20 21 22 23
[#] Mon Jan 20 2020 14:31:44 EST from bmentink @ Uncensored

Subject: Re: Incorrect character set in received mail on some sites only

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Jan 20 2020 11:11:01 AM EST from IGnatius T Foobar @ Uncensored Subject: Re: Incorrect character set in received mail on some sites only
How do I switch between text/html in WebCit?

If a message is in plain text, WebCit receives it from Citadel Server in plain text and renders it in a plain form (using <pre> tags or whatever).
Is your sender giving you messages that have the content-type header set incorrectly? Can you post a partial example?

Hi,

It seems the offending email has the content type as:

MIME-Version: 1.0
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: quoted-printable

That was from the header info.

 

Here is an example of the text I get what I get ..

椼杭眠摩桴∽∱栠楥桧㵴ㄢ•污㵴∢猠捲∽瑨灴㩳⼯牴摡浥⹥浴摣⹮潣渮⽺浩条獥ㄯ楰數⹬楧㽦敧㵮〲〲㄰〲㸢琼扡敬挠汥獬慰楣杮∽∰挠汥灬摡楤杮∽∰眠摩桴∽〷∰戠捧汯牯∽桷瑩≥愠楬湧∽散瑮牥•瑳汹㵥戢牯敤⵲敬瑦›瀱⁸䌣䍃䍃⁃潳楬㭤戠牯敤⵲楲桧㩴ㄠ硰⌠䍃䍃䍃猠汯摩※潢摲牥琭灯›瀱⁸䌣䍃䍃⁃潳楬㭤㸢਍†††琼㹲਍††††琼⁤敨杩瑨∽〲•潣獬慰㵮㐢㸢渦獢㭰⼼摴ാ ††㰠琯㹲਍†††琼㹲਍††††琼⁤楷瑤㵨㈢∰㰾琯㹤਍††††琼㹤

Cheers,

 



[#] Tue Jan 21 2020 10:47:20 EST from pdccnet @ Uncensored

Subject: Easy Install can't create directories

[Reply] [ReplyQuoted] [Headers] [Print]

 

First, I'm running Linux Mint 18 Cinnamon 64-bit.

I've run the prerequisites for Debian & Ubuntu systems (I believe that would be correct for Mint)

I then ran the command for Easy Install:

     sudo curl http://easyinstall.citadel.org/install | bash

But every time I get this message:

      Easy Install is unable to create subdirectories in /usr/local. 

      Did you forget to run the install command as the root user? 

      Please become root (with a command like "su" or "sudo -s") and 

      try again. 

I've checked the permissions on the directory:

     $ ls -ld /usr/local

     drwxr-xr-x 10 root root 4096 Jun 28  2016 /usr/local

Not really seeing anything wrong there.

 

Any ideas or suggestions on how to get this done (short of actually logging in as "root")?

 



[#] Tue Jan 21 2020 13:28:48 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Easy Install can't create directories

[Reply] [ReplyQuoted] [Headers] [Print]

I then ran the command for Easy Install:

     sudo curl http://easyinstall.citadel.org/install | bash

When you enter the command that way, sudo runs the curl command as root, then passes the results through a non-sudo bash. In other words, the privilege elevation ends at the pipe symbol.

Please run one of the suggested commands ("su" or "sudo -s") so that you can run the *entire* command pipeline privileged.

[#] Tue Jan 21 2020 14:47:54 EST from pdccnet @ Uncensored

Subject: Re: Easy Install can't create directories

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Jan 21 2020 13:28:48 EST from IGnatius T Foobar @ Uncensored Subject: Re: Easy Install can't create directories
I then ran the command for Easy Install:

     sudo curl http://easyinstall.citadel.org/install | bash

When you enter the command that way, sudo runs the curl command as root, then passes the results through a non-sudo bash. In other words, the privilege elevation ends at the pipe symbol.

Please run one of the suggested commands ("su" or "sudo -s") so that you can run the *entire* command pipeline privileged.

makes sense about the privilege ending at the pipe. But here's what happens when I try your suggestions:

1. first using "sudo -s"

     sudo -s curl http://easyinstall.citadel.org/install | bash

       % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current

                                      Dload  Upload   Total   Spent    Left  Speed

       0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0mkdir: cannot create directory '/usr/local/ctdltest.30924': Permission denied

      Easy Install is unable to create subdirectories in /usr/local. 

      Did you forget to run the install command as the root user? 

      Please become root (with a command like "su" or "sudo -s") and 

      try again. 

      70 26718   70 18896    0     0  76168      0 --:--:-- --:--:-- --:--:-- 76502

     curl: (23) Failed writing body (224 != 2736)

 

2. next using "su":

     su root curl http://easyinstall.citadel.org/install | bash

     Password: 

     /usr/bin/curl: /usr/bin/curl: cannot execute binary file

 



[#] Tue Jan 21 2020 15:51:48 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Easy Install can't create directories

[Reply] [ReplyQuoted] [Headers] [Print]


No, please do it this way:

Just type "sudo -s" by itself. Nothing else.
Your prompt will change from "$" to "#" indicating you are running with root privileges.

Then do "curl http://easyinstall.citadel.org/install | bash"

After the installation has completed, you may exit the root shell to return to normal privilege level.

[#] Wed Jan 22 2020 03:13:06 EST from haryanto @ Uncensored

Subject: SSL Accept Fail

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

 

my name is haryanto i'm from indonesia, my machine using citadel mail server but i got problem.

I success to send and receive via webmail Citadel Server, but when I sync via Outlook or Thunderbird, Citadel Server has log


citserver[19043]: crypto: SSL_accept failed: retval=0, errval=1, err=error:00000001:lib(0):func(0):reason(1)
Jan 22 12:43:57 mail citserver[19043]: crypto: SSL_accept failed: retval=0, errval=1, err=error:00000001:lib(0):func(0):reason(1)
Jan 22 12:43:57 mail citserver[19043]: citserver[19043]: client disconnected: ending session.
Jan 22 12:43:57 mail citserver[19043]: citserver[19043]: context: [ 24]SRV[IMAP] Session ended.
Jan 22 12:43:57 mail citserver[19043]: client disconnected: ending session.
Jan 22 12:43:57 mail citserver[19043]: context: [ 24]SRV[IMAP] Session ended.
Jan 22 12:44:01 mail citserver[19043]: citserver[19043]: context: session (IMAP) started from  (36.71.17.173) uid=-1
Jan 22 12:44:01 mail citserver[19043]: context: session (IMAP) started from  (36.71.17.173) uid=-1
Jan 22 12:44:02 mail citserver[19043]: citserver[19043]: crypto: SSL_accept failed: retval=0, errval=1, err=error:00000001:lib(0):func(0):reason(1)


i check my hostname dan hosts is same

i try remove keys from citadel folder and restart and still not solve problem


please help and thank you for attention



[#] Thu Jan 23 2020 09:45:47 EST from pdccnet @ Uncensored

Subject: Re: Easy Install can't create directories

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Jan 21 2020 15:51:48 EST from IGnatius T Foobar @ Uncensored Subject: Re: Easy Install can't create directories

No, please do it this way:

Just type "sudo -s" by itself. Nothing else.
Your prompt will change from "$" to "#" indicating you are running with root privileges.

Then do "curl http://easyinstall.citadel.org/install | bash"

After the installation has completed, you may exit the root shell to return to normal privilege level.

Thanks for the help! That worked. I'm still new to Linux and not familiar with the nuances of the sudo switches (I only have ever used "sudo"). Thanks again for the clarification!



[#] Thu Jan 23 2020 19:34:32 EST from bmentink @ Uncensored

Subject: Re: Incorrect character set in received mail on some sites only

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Jan 20 2020 02:31:44 PM EST from bmentink @ Uncensored Subject: Re: Incorrect character set in received mail on some sites only

 

Mon Jan 20 2020 11:11:01 AM EST from IGnatius T Foobar @ Uncensored Subject: Re: Incorrect character set in received mail on some sites only
How do I switch between text/html in WebCit?

If a message is in plain text, WebCit receives it from Citadel Server in plain text and renders it in a plain form (using <pre> tags or whatever).
Is your sender giving you messages that have the content-type header set incorrectly? Can you post a partial example?

Hi,

It seems the offending email has the content type as:

MIME-Version: 1.0
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: quoted-printable

That was from the header info.

 

Here is an example of the text I get what I get ..

椼杭眠摩桴∽∱栠楥桧㵴ㄢ•污㵴∢猠捲∽瑨灴㩳⼯牴摡浥⹥浴摣⹮潣渮⽺浩条獥ㄯ楰數⹬楧㽦敧㵮〲〲㄰〲㸢琼扡敬挠汥獬慰楣杮∽∰挠汥灬摡楤杮∽∰眠摩桴∽〷∰戠捧汯牯∽桷瑩≥愠楬湧∽散瑮牥•瑳汹㵥戢牯敤⵲敬瑦›瀱⁸䌣䍃䍃⁃潳楬㭤戠牯敤⵲楲桧㩴ㄠ硰⌠䍃䍃䍃猠汯摩※潢摲牥琭灯›瀱⁸䌣䍃䍃⁃潳楬㭤㸢਍†††琼㹲਍††††琼⁤敨杩瑨∽〲•潣獬慰㵮㐢㸢渦獢㭰⼼摴ാ ††㰠琯㹲਍†††琼㹲਍††††琼⁤楷瑤㵨㈢∰㰾琯㹤਍††††琼㹤

Cheers,

 

So, lacking an answer on this, I have installed BlueMail on linux, and use that exclusively as my email client, it works great and render's mail correctly ..
Cheers,


 



[#] Mon Feb 10 2020 11:39:02 EST from Falco @ Uncensored

Subject: Webcit - File Uploads Corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

When uploading files to a room, the contents get scrambled. I set up citadel with the installation script on a raspberry pi 4 running ubuntu 19 x64 aarch64 although for the installer to work I had to add "--build aarach64-unknown-linux-gnu" to the .configure calls.

For testing purposes I uploaded a ascii text test file. The first 20 characters or so made it okay, and then it became garbage. I had a scour through the support room (by the way this is a most horrible way to handle issues, please use github or something) and apparently this has been an issue for at least half a year now.

Also I read that setting a room as file directory would fix it. I did so and it did not help at all. Also I didn't find any documentation as to what that actually does. A tooltip would be nice for those options that explain them in a bit more detail. I got an error after entering a name saying:
" "/usr/local/citadel/files///FD_Public" appears in the file directory for room "FileDump" but is not a regular file. Directories, named pipes, sockets, etc. are not usable in Citadel room directories. "

I don't know what to make of that. There was no file or directory there. Do I have to manually create them? I created a directory in that place and didn't get any more such messages. After uploading files to the room, that directory didn't have them, nor did I get any errors. The file download worked, but the file was still corrupted.

 

I would appreciate it if this issue was fixed so I can upload files. I would also appreciate a bit more help being built into the web interface itself.



[#] Mon Feb 10 2020 11:54:31 EST from Falco @ Uncensored

Subject: Re: Webcit - File Uploads Corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

It seems uploads work on here, but I'm not sure why, or why it doesn't work for me.
Either way here are the two files in comparison.

hexdump -C text.txt
00000000  54 68 69 73 20 69 73 20  61 20 54 65 78 74 20 2d  |This is a Text -|
00000010  20 4c 69 6e 65 20 31 0a  54 68 69 73 20 69 73 20  | Line 1.This is |
00000020  61 6e 6f 74 68 65 72 20  54 65 78 74 20 2d 20 4c  |another Text - L|
00000030  69 6e 65 20 32 0a 54 68  69 73 20 69 73 20 61 20  |ine 2.This is a |
00000040  74 68 69 72 64 20 54 65  78 74 20 2d 20 4c 69 6e  |third Text - Lin|
00000050  65 20 33 0a 54 68 69 73  20 69 73 20 6e 6f 74 20  |e 3.This is not |
00000060  61 20 54 65 78 74 20 2d  20 4c 69 6e 65 20 34 0a  |a Text - Line 4.|
00000070  54 68 69 73 20 69 73 20  61 20 54 65 78 74 20 61  |This is a Text a|
00000080  67 61 69 6e 20 2d 20 4c  69 6e 65 20 35 0a        |gain - Line 5.|
0000008e
hexdump -C text_corrupt.txt
00000000  54 68 69 73 20 69 73 20  61 20 54 65 78 74 20 2d  |This is a Text -|
00000010  20 4c 69 6e 65 20 31 0a  54 68 69 73 20 69 73 20  | Line 1.This is |
00000020  61 6e 6f 74 68 65 72 20  54 65 78 74 20 2d 20 4c  |another Text - L|
00000030  69 6e 65 fc 80 c8 29 51  a1 a5 cc 81 a5 cc 81 84  |ine...)Q........|
00000040  81 d1 a1 a5 c9 90 81 51  95 e1 d0 80 b4 81 31 a5  |.......Q......1.|
00000050  b9 94 80 cc 29 51 a1 a5  cc 81 a5 cc 81 b9 bd d0  |....)Q..........|
00000060  81 84 81 51 95 e1 d3 f2  02 d2 04 c6 96 e6 52 03  |...Q..........R.|
00000070  40 a5 46 86 97 32 06 97  32 06 12 05 46 57 87 42  |@.F..2..2...FW.B|
00000080  06 16 76 16 96 e2 02 d2  04 c6 96 e6 52 03 50 bf  |..v.........R.P.|
00000090  83 ef bf                                          |...|



text_corrupt.txt (text/plain, 200 bytes) [View| Download]
text.txt (text/plain, 196 bytes) [View| Download]
[#] Mon Feb 10 2020 19:20:12 EST from MAS3 @ Uncensored

Subject: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi.

I'm running Citadel 925 with WebCit 917 on a Raspi 3B.

I've been trying to add aliases to a user, but there seems to be a limit even though there shouldn't be one.
Whenever i add an alias, the default address for that user is reset to some seemingly random one from the list, the original is gone, and the new alias isn't added to the list.
Is there a limit (of 20 or 21) after all ?
It doesn't matter whether the admin or the user itself is trying to do that, and neither whether the users' vcard, or it's configuration is changed (by the admin).

In my spam fighting attempts, i'm used to add another alias for any site requiring an e-mail address to register for example.
Whenever spam starts pouring in on that address, it'll be time to dump that one, and the site it is coupled to along with it.
Has been working great for years and years with my setup before Citadel, and i'd like to have that back.

What am i missing, did i forget to set some other option ?
The users already in the list seem to work fine, but the list is much smaller than it used to be now.





[#] Tue Feb 11 2020 16:30:25 EST from schaap23 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Feb 10 2020 19:20:12 EST from MAS3 @ Uncensored Subject: Mail aliases limited ?

Hi.

I'm running Citadel 925 with WebCit 917 on a Raspi 3B.

I've been trying to add aliases to a user, but there seems to be a limit even though there shouldn't be one.
Whenever i add an alias, the default address for that user is reset to some seemingly random one from the list, the original is gone, and the new alias isn't added to the list.
Is there a limit (of 20 or 21) after all ?
It doesn't matter whether the admin or the user itself is trying to do that, and neither whether the users' vcard, or it's configuration is changed (by the admin).

In my spam fighting attempts, i'm used to add another alias for any site requiring an e-mail address to register for example.
Whenever spam starts pouring in on that address, it'll be time to dump that one, and the site it is coupled to along with it.
Has been working great for years and years with my setup before Citadel, and i'd like to have that back.

What am i missing, did i forget to set some other option ?
The users already in the list seem to work fine, but the list is much smaller than it used to be now.





This functionality has never worked properly for me. I use the mail.aliases file as an alternative. The location for easyinstall is: /usr/local/citadel/network/mail.aliases

each line consists of

alias email address, destination email address.

e.g. 

nospam@domain.com, MyRealEmailAddress@domain.com

 

Email for nospam@domain.com is forwarded to the email box of MyRealEmailAddress@domain.com.

Using the mail.aliases file has always worked fine for me. 



[#] Tue Feb 11 2020 20:02:15 EST from MAS3 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Thank you for the reply.

Excuse my ignorance, it's all new to me.

/usr/local/citadel/network/mail.aliases does not exist.
Am i at an incorrect location for my install. or do i have to create it (and how would i do that) ?

Are there other possible locations to look for this file ?

 



[#] Thu Feb 13 2020 20:37:08 EST from Bob Randale @ Uncensored

Subject: Citadel 68k Networking

[Reply] [ReplyQuoted] [Headers] [Print]

Hello!

I used to run a Citadel BBS on my first (and then second) Amiga computer(s) in the early '90s.

I just got an Amiga A2000 up and running, installed the software, and have it ready to roll.

My first question is, can I get a network feed to and from today's Citadel(s)?

My alternative method (instead of dial-up) is using an emulator on my Windoze PC, on which I also have the software running.

The Amiga  A2000 is connected to a separate phone line, just like it was 30 years ago, and the Windows emulator is "Amiga Forever".

Thank you for any suggestion(s), even if it's to "uninstall".  :)



[#] Fri Feb 14 2020 09:47:32 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel 68k Networking

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Bob! I think I remember you from the old days. Welcome!

Unfortunately the support for the old-style CitaNet/C86Net networking is long gone. If you wanted to do something like that, you'd have to write a pretty big translation layer. The modern Citadel system supports RSS, which you could use to budge some sort of bidirectional feed, but you'd need to write scripts to handle the transport and also translate the data format.

[#] Fri Feb 14 2020 09:48:35 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Webcit - File Uploads Corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Falco: thanks for posting the corrupted version of the upload. We'll have a look at it
!

[#] Sat Feb 15 2020 11:49:06 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

/usr/local/citadel/network/mail.aliases does not exist.
Am i at an incorrect location for my install. or do i have to create
it (and how would i do that) ?

mail.aliases was removed from Citadel about a year ago. If you still have that file it isn't going to do anything.

To create an alias for a user in the current version of Citadel, simply edit the user and add as many Internet email addresses to that user as you'd like to have. The aliases may be in *any* domain that is valid for your system.
Remember, you *do* have to include the domain name.

[#] Sat Feb 15 2020 19:26:12 EST from MAS3 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Thank you.

The problem is as described e few posts above the one where i told i can't find this file:

Adding aliases (e.g alias1@mydomain.com, alias2@mydomain.com and so on), doesn't work as i expected.
If i do this for an existing user, the addition will not be added to the list, other aliases seem to disappear from the list, and the primary e-mail address for that user is reset to a seemingly random one from the list of aliases.

I checked just now to be sure to get the "primary e-mail address" part right, and saw that now all aliases for all users seem to be gone.



[#] Sat Feb 15 2020 21:13:29 EST from MAS3 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hmm, i'm sorry.

I rebooted and all aliases that were entered when the user was created, re-appeared.
Still when i add an alias to the 20 aliases that user already has, (i think) the last one in the list is dropped from the list.
The "Primary Internet e-mail address" (only visible form the user's Vcard) changes to some entry from the old list.

Another user already has 21 aliases, but adding aliases there does the exact same thing.

Rebooting the system seems to undo changes from the list, but not the changed Primary e-mail address.

I'll create another user, with some 50 aliases just to see if that will work upon creation.
But it'll take me some time to do that and test it.

 



[#] Sat Feb 15 2020 21:58:03 EST from MAS3 @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

So i started to do this right away.

Made a test user and copied the alias test1@mydomain.com 50 times (or thought i did).

Then i started to edit the number so that i would end up with aliases test1 to test 50.
But when i was at the number 10, i couldn't add characters anymore.
That field seems limited to 512 characters, and thus limiting the number of aliases after all.
In this test case, it limits the number of aliases to 24.
And they seem to work for this new test user, sent and received an external mail to test23@mydomain.com.

Both users i tried to add aliases to, should have space to add at least 1 alias to the list of 512 characters, but still there's trouble in getting that done.
So there must be something else that's going wrong, and i'm assuming it's me doing something wrong here.

 

 



Go to page: First ... 15 16 17 18 [19] 20 21 22 23