Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last
[#] Tue Jan 07 2020 21:49:15 EST from IGnatius T Foobar @ Uncensored

Subject: Re: WebCit : http-auth - SSO

[Reply] [ReplyQuoted] [Headers] [Print]

This method could be the simplest to implement SSO for
webcit/citadel.

Does your identity provider support OpenID? Citadel has OpenID support built in.

[#] Tue Jan 07 2020 21:51:42 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Where is the documentation on how to run a Wiki?

[Reply] [ReplyQuoted] [Headers] [Print]

User Documentation seems to be a bit thin ... a search of the "Documentation"

page and the "FAQ" shows nothing on how to run a Wiki, yet the specifications

state that Citadel can be used as a wiki .

Create a room with the "wiki" view.

By default, you will be placed on the start page. Click "Edit this page" to begin creating the start page.

In the editor, you can create two types of links:
1. If the link is a full URL, it will take the user to that external site.
2. If the link is the name of another page, it will create a link to that page.

Creating a link to a page that does not exist, will behave similarly to the start page: you'll get a blank page and you can click "Edit this page" to create it.

It's extremely simple to use ... and you don't even need to use Wiki markup!

[#] Tue Jan 07 2020 21:54:03 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Hello! Is the NNTP interface of current Citadel releases broken? I am

having trouble getting Pan to deal with a test Citadel instance of

Yes. The NNTP interface is incomplete. We started developing it during a collaboration project with another developer, and development was halted when we discovered that he just wanted to use it to expand the reach of an anti-semitic hate site.

Someday we might finish it.

[#] Tue Jan 07 2020 21:56:11 EST from bmentink @ Uncensored

Subject: Re: Where is the documentation on how to run a Wiki?

[Reply] [ReplyQuoted] [Headers] [Print]

Many Thanks :)

Tue Jan 07 2020 09:51:42 PM EST from IGnatius T Foobar @ Uncensored Subject: Re: Where is the documentation on how to run a Wiki?
User Documentation seems to be a bit thin ... a search of the "Documentation"

page and the "FAQ" shows nothing on how to run a Wiki, yet the specifications

state that Citadel can be used as a wiki .

Create a room with the "wiki" view.

By default, you will be placed on the start page. Click "Edit this page" to begin creating the start page.

In the editor, you can create two types of links:
1. If the link is a full URL, it will take the user to that external site.
2. If the link is the name of another page, it will create a link to that page.

Creating a link to a page that does not exist, will behave similarly to the start page: you'll get a blank page and you can click "Edit this page" to create it.

It's extremely simple to use ... and you don't even need to use Wiki markup!

 



[#] Tue Jan 07 2020 21:56:59 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Sending email to gmail accounts, goto SPAM folder by default

[Reply] [ReplyQuoted] [Headers] [Print]

Is there any reason gmail is seeing mail from citadel as SPAM?

Mail from Citadel in general, or mail from your specific Citadel site?

* Make sure you're not on any blacklists
* Make sure your forward DNS, reverse DNS, and Citadel FQDN all agree with each other

See also: [ http://wwwdev.citadel.org/i_want_to_be_a_whitehead.html ]

[#] Tue Jan 07 2020 22:00:49 EST from bmentink @ Uncensored

Subject: Re: Sending email to gmail accounts, goto SPAM folder by default

[Reply] [ReplyQuoted] [Headers] [Print]

As I mentioned in an update to my post:

 

Ahhh, I think I see the problem.  The "From:" address field was bmentink@citadel which is the node name, gmail obviously thew it's hands up at that.

I have to go into the SMTP settings and set the option:

Only change the From: header if the address is not valid for the user

That has fixed the "From:" header to my domain name ..

 

Tue Jan 07 2020 09:56:59 PM EST from IGnatius T Foobar @ Uncensored Subject: Re: Sending email to gmail accounts, goto SPAM folder by default
Is there any reason gmail is seeing mail from citadel as SPAM?

Mail from Citadel in general, or mail from your specific Citadel site?

* Make sure you're not on any blacklists
* Make sure your forward DNS, reverse DNS, and Citadel FQDN all agree with each other

See also: [ http://wwwdev.citadel.org/i_want_to_be_a_whitehead.html ]

 



[#] Wed Jan 08 2020 13:44:00 EST from darknetuser @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Yes. The NNTP interface is incomplete. We started developing it
during a collaboration project with another developer, and development

was halted when we discovered that he just wanted to use it to expand

the reach of an anti-semitic hate site.

Someday we might finish it.

Thanks for the response.

It sounds a bit unfortunate. I really love NNTP. Anyway, I wonder how you can use a Citadel node with NNTP to extend the reach of a website.

[#] Wed Jan 08 2020 15:21:54 EST from General Fault @ Uncensored

Subject: Citadel Easy Install Script issue SCROLLING

[Reply] [ReplyQuoted] [Headers] [Print]

Hello!

I'm installing Citadel using the EasyInstall script with Curl.

I have tried it on:

Ubuntu 16

Ubuntu 18

Centos 7

Centos 8

Everything installs and compiles fine, however when I get to the end where it asks for the Citidal <Server Port Number> It scrolls wildly in the terminal. The same result on ALL those tried OS's.

I have even tried via local connections and terminals on those machines with the same result. 

Is there a problem with the script?

-GF



[#] Wed Jan 08 2020 15:26:24 EST from General Fault @ Uncensored

Subject: Re: Citadel Easy Install Script issue SCROLLING

[Reply] [ReplyQuoted] [Headers] [Print]

I can also report the same result when using wget.



[#] Wed Jan 08 2020 16:34:29 EST from bmentink @ Uncensored

Subject: Re: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?



 



[#] Wed Jan 08 2020 16:36:46 EST from bmentink @ Uncensored

Subject: How do I get push emails to work

[Reply] [ReplyQuoted] [Headers] [Print]

The how-to says to get the Funambol sync server sync module from here: http://bionicmessage.net/node/3

But that link is broken, has that project been abandoned?



[#] Wed Jan 08 2020 16:36:16 EST from "me" <me@scifidan.com> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

I have no idea man. I wonder, how are you handling your calendar? Is it on the web portal for citadel or is it via a dav connection on your device?

On 1/8/20 1:34 PM, bmentink wrote:

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?



 



[#] Wed Jan 08 2020 16:45:04 EST from bmentink @ Uncensored

Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

I am using the web portal .. adding an event at say 2pm on a particular day, then goto day view and the event shows at 11am ... weird ..

Wed Jan 08 2020 04:36:16 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

I have no idea man. I wonder, how are you handling your calendar? Is it on the web portal for citadel or is it via a dav connection on your device?

On 1/8/20 1:34 PM, bmentink wrote:

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?


 



 



[#] Wed Jan 08 2020 16:46:36 EST from "me" <me@scifidan.com> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm ..itshows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

GOing by your description it sounds alot like a timezone issue. Are you using alternate dns servers on your browser config?



On 1/8/20 1:45 PM, bmentink wrote:

I am using the web portal .. adding an event at say 2pm on a particular day, then goto day view and the event shows at 11am ... weird ..

Wed Jan 08 2020 04:36:16 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

I have no idea man. I wonder, how are you handling your calendar? Is it on the web portal for citadel or is it via a dav connection on your device?

On 1/8/20 1:34 PM, bmentink wrote:

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?


 



 



[#] Wed Jan 08 2020 16:53:31 EST from "me" <me@scifidan.com> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] (no subject)

[Reply] [ReplyQuoted] [Headers] [Print]

Yes. The NNTP interface is incomplete. We started developing it
during a collaboration project with another developer, and development

was halted when we discovered that he just wanted to use it to expand

the reach of an anti-semitic hate site.

Someday we might finish it.

Thanks for the response.

It sounds a bit unfortunate. I really love NNTP. Anyway, I wonder how you
can use a Citadel node with NNTP to extend the reach of a website.


I was curious about the same thing because I, too, am an avid newsgroup
user and would be interested in using NNTP features. How does NNTP
extend a website's reach, just curious

[#] Wed Jan 08 2020 18:01:03 EST from bmentink @ Uncensored

Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm ..itshows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

No, all my machines VM's etc go through the same DNS server ..

Wed Jan 08 2020 04:46:36 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm ..itshows in "Day View" at 11am

GOing by your description it sounds alot like a timezone issue. Are you using alternate dns servers on your browser config?

 

 

On 1/8/20 1:45 PM, bmentink wrote:

I am using the web portal .. adding an event at say 2pm on a particular day, then goto day view and the event shows at 11am ... weird ..

Wed Jan 08 2020 04:36:16 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

I have no idea man. I wonder, how are you handling your calendar? Is it on the web portal for citadel or is it via a dav connection on your device?

On 1/8/20 1:34 PM, bmentink wrote:

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?

 


 



 



[#] Thu Jan 09 2020 01:21:42 EST from "me" <me@scifidan.com> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm..itshows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

What happens if you set the server to GMT?

On 1/8/20 3:01 PM, bmentink wrote:

No, all my machines VM's etc go through the same DNS server ..

Wed Jan 08 2020 04:46:36 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm ..itshows in "Day View" at 11am

GOing by your description it sounds alot like a timezone issue. Are you using alternate dns servers on your browser config?

 

 

On 1/8/20 1:45 PM, bmentink wrote:

I am using the web portal .. adding an event at say 2pm on a particular day, then goto day view and the event shows at 11am ... weird ..

Wed Jan 08 2020 04:36:16 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

I have no idea man. I wonder, how are you handling your calendar? Is it on the web portal for citadel or is it via a dav connection on your device?

On 1/8/20 1:34 PM, bmentink wrote:

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?

 


 



 



[#] Thu Jan 09 2020 10:48:40 EST from General Fault @ Uncensored

Subject: Re: Citadel Easy Install Script issue SCROLLING

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Jan 08 2020 15:26:24 EST from General Fault @ Uncensored Subject: Re: Citadel Easy Install Script issue SCROLLING

I can also report the same result when using wget.



Is there a secret handshake to get a reply? :)

 

We have now tried this on two more machines. CentOS 7 and a different Ubuntu 18/TLS with the same result.



[#] Thu Jan 09 2020 12:54:49 EST from darknetuser @ Uncensored

Subject: Re: Citadel Easy Install Script issue SCROLLING

[Reply] [ReplyQuoted] [Headers] [Print]


Is there a secret handshake to get a reply? :)

 

We have now tried this on two more machines. CentOS 7 and a different

Ubuntu 18/TLS with the same result.


It looks like there is an isue with piping.

When I download the script and execute it without using the pipe, it works.


curl -LO http://easyinstall.citadel.org/install
chmod +x install
bash ./install

(or something like that)

If you try to use piping as described by the official docummentation, the script goes mad.

[#] Thu Jan 09 2020 15:16:52 EST from bmentink @ Uncensored

Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm..itshows in "Day View" at 11am

[Reply] [ReplyQuoted] [Headers] [Print]

.. and why would I do that? It seems that would be very confusing for sent messages .. surly it should be NZDT for my location .. (I am in New Zealand )

Thu Jan 09 2020 01:21:42 AM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm..itshows in "Day View" at 11am

What happens if you set the server to GMT?

On 1/8/20 3:01 PM, bmentink wrote:

No, all my machines VM's etc go through the same DNS server ..

Wed Jan 08 2020 04:46:36 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm ..itshows in "Day View" at 11am

GOing by your description it sounds alot like a timezone issue. Are you using alternate dns servers on your browser config?

 

 

On 1/8/20 1:45 PM, bmentink wrote:

I am using the web portal .. adding an event at say 2pm on a particular day, then goto day view and the event shows at 11am ... weird ..

Wed Jan 08 2020 04:36:16 PM EST from "me" <me@scifidan.com> Subject: Re: [Citadel Support] Re: Bug? - I set a calender event at 2pm .. itshows in "Day View" at 11am

I have no idea man. I wonder, how are you handling your calendar? Is it on the web portal for citadel or is it via a dav connection on your device?

On 1/8/20 1:34 PM, bmentink wrote:

Anyone? I have checked that the timezone on the server is correct ..

Tue Jan 07 2020 09:16:57 PM EST from bmentink @ Uncensored Subject: Bug? - I set a calender event at 2pm .. it shows in "Day View" at 11am

Is this a bug, or maybe a Timezone thing .. how do I check?

 

 


 



 



Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last