Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 4 5 [6] 7 8 9 10 ... Last
[#] Thu Jan 10 2019 05:13:54 EST from CrazyEddy @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Port 25 is critical to SMTP. It's one of the few protocols that won't work on
any other port. If you can't receive on it, you'll have to use fetchmail or
something to receive from another server.

[#] Mon Jan 14 2019 12:24:39 EST from notjames @ Uncensored

Subject: Apt Repository Status

[Reply] [ReplyQuoted] [Headers] [Print]

Greetings,

Are the repositories located at http://debian.citadel.org still active? I can't ping them at the moment. If they are defunct, http://www.citadel.org/doku.php?id=installation:debian should be updated or removed to reflect that. Thanks!



[#] Tue Jan 15 2019 16:01:18 EST from jdredd @ Uncensored

Subject: Citadel on RPI and Smart Host / Relay

[Reply] [ReplyQuoted] [Headers] [Print]

Greetings!

I am working on an RPI 3B+ running Raspbian.

I have Citadel installed and sorta working.

I can send email to my new Citadel server and it comes in, checking via POP.

My ISP are jerks and block the SMTP usages out, so I use MailGun to be my SMTP relay. 

If I setup my email client ( say thunderbird ) to point to MailGun's SMTP server (smtp.mailgun.com) I can fire out emails just fine.

If I setup my email client to my new server, emails will never go out via SMTP.

"someone@somewhere.com: 550 (550 5.7.1 Relaying denied 221 See you later. Yours truly, Mailgun )"

It has to be the smart hosts entry I made but I can't seem to get it right?

I've tried these as the entry

smtp://myusername@myserver.com:mypassword@smtp.mailgun.org:587

myusername@myserver.com:mypassword@smtp.mailgun.org:587

 

Right now its set to 

smtp.mailgun.org:587

Which I know is wrong, but doing so gets me the above error message currently, while the others I will get something else that happens, and no emails go out.

 

 



[#] Wed Jan 16 2019 22:05:28 EST from rat @ Uncensored

Subject: Re: Citadel Installation Fails

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Nov 23 2018 15:51:07 EST from Leon @ Uncensored Subject: Citadel Installation Fails

Hello,

today I tried to install Citadel on my Raspberry Pi with the Easyinstall Method.

After an hour this failure cames:

Citadel Easy Install is aborting.

The last few lines above this message may indicate what went wrong.

Linux Debian 9.4 (4.14.79+ armv61)

What can I do now?



 

Missing package. libical-dev.

 

However, if you're installing on a RPi with Raspbian, your missing package issues don't end there. Despite the easyinstall script saying it would install dependencies for you, it doesn't install all of them. So the script will error out several times depending on which packages are missing.

 

I had to install all of the following to complete install:

 

sudo apt install apache2 db4.8-util javascript-common libjs-prototype libjs-scriptaculous libmarkdown2 libsieve2-1 tinymce libdb-dev build-essential curl g++ gettext shared-mime-info libssl-dev zlib1g-dev libical-dev libldb-dev libldap2-dev expat libexpat1-dev libcurl4-openssl-dev

 

Then you can rerun the easyinstall script.

 

 



[#] Sat Jan 19 2019 00:24:04 EST from paperthings @ Uncensored

Subject: Email issues

[Reply] [ReplyQuoted] [Headers] [Print]

Whenever I try to send an email, it does not send, and same thing for recieve. I have all of the settings correct and a proper DNS. Please Help.



[#] Sat Jan 19 2019 07:55:00 EST from ThinkPad User @ Uncensored

Subject: Citadel Server logon loop

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

I'm having an issue with Citadel server, I've just set it up like how this tutorial said:

https://pimylifeup.com/raspberry-pi-email-server/

The system used was a Raspberry Pi Zero W running Raspbain Lite

The admin account does exist but no matter what with no error, it just loops back to the logon screen

 



[#] Sat Jan 19 2019 11:10:04 EST from ThinkPad User @ Uncensored

Subject: Citadel Server logon loop

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

I'm having an issue with Citadel server, I've just set it up like how this tutorial said:

https://pimylifeup.com/raspberry-pi-email-server/

The system used was a Raspberry Pi Zero W running Raspbain Lite

The admin account does exist but no matter what with no error, it just loops back to the logon screen or just hangs on Please wait



[#] Sat Jan 19 2019 15:08:03 EST from dagreekbmw @ Uncensored

Subject: Re: Citadel on RPI and Smart Host / Relay

[Reply] [ReplyQuoted] [Headers] [Print]

did you end up having a problem that it keeps looping "Please Wait..." 



[#] Sat Jan 19 2019 15:09:26 EST from dagreekbmw @ Uncensored

Subject: Re: Citadel Server logon loop

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sat Jan 19 2019 11:10:04 EST from ThinkPad User @ Uncensored Subject: Citadel Server logon loop

Hi,

 

I'm having an issue with Citadel server, I've just set it up like how this tutorial said:

https://pimylifeup.com/raspberry-pi-email-server/

The system used was a Raspberry Pi Zero W running Raspbain Lite

The admin account does exist but no matter what with no error, it just loops back to the logon screen or just hangs on Please wait



I am having the same problem. Does anyone know how to fix this? I am able to get to Citadel from another computer but when i login it just keeps looping "Please Wait..."



[#] Sat Jan 19 2019 17:12:58 EST from ThinkPad User @ Uncensored

Subject: Citadel Server logon loop

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

I'm having an issue with Citadel server, I've just set it up like how this tutorial said:

https://pimylifeup.com/raspberry-pi-email-server/

The system used was a Raspberry Pi Zero W running Raspbain Lite

The admin account does exist but no matter what with no error, it just loops back to the logon screen or just hangs on Please wait



[#] Sun Jan 20 2019 07:39:25 EST from Hardy @ Uncensored

Subject: Login loop

[Reply] [ReplyQuoted] [Headers] [Print]

Hi there,

 

I'm new in this forum. I've installed Citadel on my Raspi today and I'm having the same troble with the log-in loop.

I tried to logon to my Citadel via commandline.

pi@raspberrypi:/etc $ sudo sendcommand "USER pi"
sendcommand: started (pid=3310) connecting to Citadel server at /var/run/citadel/citadel-admin.socket
200 raspberrypi Citadel server ADMIN CONNECTION ready.
USER pi
300 Password required for pi
sendcommand: processing ended.
pi@raspberrypi:/etc $

 

pi@raspberrypi:/etc $ sudo sendcommand "PASS"
sendcommand: started (pid=3318) connecting to Citadel server at /var/run/citadel/citadel-admin.socket
200 raspberrypi Citadel server ADMIN CONNECTION ready.
PASS
542 You must send a name with USER first.
sendcommand: processing ended.
pi@raspberrypi:/etc $

Does anybody know, how to write user and password in one line ? 

regards

Hardy

 

 

 



[#] Tue Jan 22 2019 16:55:32 EST from Windows10User @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Having the same issue with a Pi2 and Pi3



[#] Wed Jan 23 2019 04:14:35 EST from rat @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I guess nobody wants to read my posts about making sure all the proper packages are installed before running the easy installer script...



[#] Wed Jan 23 2019 08:12:40 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I guess nobody wants to read my posts about making sure all the proper

packages are installed before running the easy installer script...

Some do, but some will never ... you can lead a horse to water but sometimes only a pressure washer will do.

[#] Thu Jan 24 2019 08:40:41 EST from kaza @ Uncensored

Subject: How do I customize the login screen ?

[Reply] [ReplyQuoted] [Headers] [Print]

I wan to remove option with google openid login as also button for new user registration



[#] Thu Jan 24 2019 08:47:27 EST from rat @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Jan 23 2019 08:12:40 EST from IGnatius T Foobar @ Uncensored
Some do, but some will never ... you can lead a horse to water but sometimes only a pressure washer will do. 

For what it's worth, I'll repeat myself for the benefit of others.

I did a reinstall on my RPi recently, from scratch and a new Raspbian image flashed to USB.

sudo apt install apache2 db4.8-util javascript-common libjs-prototype libjs-scriptaculous libmarkdown2 libsieve2-1 tinymce libdb-dev build-essential curl g++ gettext shared-mime-info libssl-dev zlib1g-dev libical-dev libldb-dev libldap2-dev expat libexpat1-dev libcurl4-openssl-dev

was all of the packages I needed for the easy installer script to complete.



[#] Fri Jan 25 2019 18:21:25 EST from IGnatius T Foobar @ Uncensored

Subject: Re: How do I customize the login screen ?

[Reply] [ReplyQuoted] [Headers] [Print]

I wan to remove option with google openid login as also button for
new user registration

Disable self-service user registration in the system options screen.

[#] Fri Jan 25 2019 18:21:52 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

was all of the packages I needed for the easy installer script to complete.


Thanks for the writeup. That is helpful.

[#] Sun Jan 27 2019 04:44:11 EST from jsdckr @ Uncensored

Subject: Message search function

[Reply] [ReplyQuoted] [Headers] [Print]

Greetings Is there any way to search for a text string either via webcit (ideally) or via the console client? 

I see that there is an indexing function built in - but I can't see how to access it.

Many thanks for your help, Jamie



[#] Mon Jan 28 2019 05:04:43 EST from jsdckr @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

...PS - Just for clarification, for our intended citadel use, we need users to be able to search for a text string in title or content of all rooms.... Possible? Very much hope so; I first used Cit/ux extensively back in 1989 and would very much love to make good use of it again for a new application. Thanks again, Jamie

Go to page: 1 2 3 4 5 [6] 7 8 9 10 ... Last