Language:
switch to room list switch to menu My folders
Go to page: First ... 17 18 19 20 [21] 22 23 24 25 ... Last
[#] Sat Feb 03 2018 19:25:07 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Smart Host Auth

[Reply] [ReplyQuoted] [Headers] [Print]

This section in Citadel's documentation called Configuring Relaying show that the URL syntax should look like this

[smtp[s]://][username:password@]host[:port]

But the problem is Citadel takes what is listed after the @ symbol and makes a DNS query based off of that. This works until the user name also has an @ symbol in it. So when I configure this:
smtp://ME@DOMAIN.com:abc123@asp-submit.reflexion.net:2525
it tries to make a DNS request for "DOMAIN.com:abc123@asp-submit.reflexion.net".

Yes, my testing does reproduce that same effect.

When you specify a Smart Host for outbound delivery of all mail, Citadel passes that string along to libcurl as the CURLOPT_URL for SMTP delivery.  (Citadel uses libcurl for all protocol handling.)  So unfortunately it's not something we are able to change in Citadel to make it properly handle a username with an @ character in it.  (Seems very silly, doesn't it?  I can't believe we're the first ones to have this problem.)

You indicated that you're not a programmer but you are willing to help in developing a solution.  Would it be possible for you to post this problem on the libcurl mailing list or support channels, and see what their experts have to say about it?  In that context, Citadel is not really relevant except that it is "an application using libcurl for SMTP delivery" and the smtp://ME@DOMAIN.com:abc123@asp-submit.reflexion.net:2525 is the CURLOPT_URL being used by the program.



[#] Sat Feb 03 2018 19:28:25 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Big fan... Big, frustrated, adoring fan

[Reply] [ReplyQuoted] [Headers] [Print]

I have just recently tried installing, and running, citadel. I love it! The idea, the execution, the fight! I've been playing for a few days, and getting errors like c_port_number and c_ctdluid bugs. When I attempt repair using recommended fixes, more errors appear. If 32-bit Ubuntu 16.04 is my root issue, I'm happy to change vector/host. I'm trying to avoid compiling from [my own poorly modified] source code. 

Thanks for the kind words! For some reason, we do keep having a nagging problem with the port number setting, but the good news is that you should be able to just set those values in your system configuration and they will stay set.

Ubuntu repos are a bit behind the cutting edge, because first the packager for Debian has to do an update, then it goes through the whole Debian testing process, and then it flows from Debian over to Ubuntu. Sometimes that can take time (even months). For a new installation you might want to try out the Easy Install method instead.



[#] Sat Feb 03 2018 19:40:44 EST from wylekyote @ Uncensored

Subject: Server down with libev: ev_io_start called with corrupted watcher

[Reply] [ReplyQuoted] [Headers] [Print]

Starting it up it goes through the mail queue then aborts with a core dump

 

citserver[3945]: No external notifiers configured on system/user

citserver[3945]: -- db checkpoint --

citserver: ev.c:3846: ev_io_start: Assertion `("libev: ev_io_start called with corrupted watcher", ((WL)w)->next != (WL)w)' failed.

Aborted (core dumped)

 

 

 

Version info as follows -- off the debian repos 

 

 

citserver[3945]:  

citserver[3945]:  

citserver[3945]: *** Citadel server engine v8.24 (build 5644ab7) ***

citserver[3945]: Copyright (C) 1987-2014 by the Citadel development team.

citserver[3945]: This program is distributed under the terms of the GNU General Public License.

citserver[3945]:  

citserver[3945]: Called as: citserver

citserver[3945]: libcitadel(unnumbered)

citserver[3945]: Loading citadel.config

citserver[3945]: Acquiring control record

citserver[3945]: master_startup() started

citserver[3945]: Opening databases

citserver[3945]: bdb(): open_databases() starting

citserver[3945]: Compiled db: Berkeley DB 4.7.25: (March 22, 2017)

citserver[3945]:   Linked db: Berkeley DB 4.7.25: (March 22, 2017)

citserver[3945]: Calculated dbversion: 4007025

citserver[3945]:   Previous dbversion: 4007025

citserver[3945]: Linked zlib: 1.2.3

citserver[3945]: bdb(): Setting up DB environment

citserver[3945]: dbenv->open(dbenv, /var/lib/citadel/data/, 5461, 0)

citserver[3945]: DB: Finding last valid log LSN: file: 302198 offset 2277753

citserver[3945]: DB: Recovery starting from [302198][2273555]

citserver[3945]: DB: Recovery complete at Sun Feb  4 00:36:53 2018

citserver[3945]: DB: Maximum transaction ID 80000023 Recovery checkpoint [302198][2278832]

citserver[3945]: Starting up DB

 
 
please help 


[#] Sun Feb 04 2018 02:57:05 EST from bitpilot @ Uncensored

Subject: I'm enjoying this BBS Groupware app quite a bit

[Reply] [ReplyQuoted] [Headers] [Print]

Went missing the rain-forest or all the BBS years. I'm really enjoying your app you folks built, need a rusty coder? Installed this thing with the easy installers and she goes real good. No show-stoppers I can see right.

I'm going to use it for several years during my kids secondary education so would like to contribute to it in some ways.

If there's any pointers on clam-daemon and other resource sucking behemoths for AV I'd be mighty grateful. I'm running off a first gen raspberry pi and whilst that rockets with your app - the Clam AV stuff tends to rip it a new one, especially in terms of nuking all the memory. I dunno, maybe auto security updates is enough right?

 

 



[#] Sun Feb 04 2018 03:05:14 EST from bitpilot @ Uncensored

Subject: Re: I'm enjoying this BBS Groupware app quite a bit

[Reply] [ReplyQuoted] [Headers] [Print]

Might aswell go for the double jeopardy while I'm here :) Are their any scripts floating around for backing it up incase I nuke it? Highly likely given my affinity with random button pressing to see what gives.



[#] Sun Feb 04 2018 03:41:12 EST from bitpilot @ Uncensored

Subject: Giving webcit awesome process durability

[Reply] [ReplyQuoted] [Headers] [Print]

Hi folks, here's a little trick I use to keep Webcit process running even when it falls over with segmentation fault. That way Webcit and Citadel just keep on working - pretty handy if you have a bunch of folks using it.

cd ~

mkdir script

cd script

nano survive-webcit.sh

chmod +x survive-webcit.sh

 

... copy/paste this code here ...

#!/bin/sh

service=webcit

case  "$(pidof $service | wc -w)" in

0) echo "$service is not running!!!"

nohup '/usr/local/webcit/webcit' &

;;

1) echo "$service is  running!!!"

;;

*) echo "multiple instances running"

;;

esac

... snip here ...
 
 
Then..
Ctrl-O to save, Save As survive-webcit.sh
Ctrl-X to get the hell out of there back to terminal
Now your back in terminal right so fire up crontab as whatever that user is running webcit.
Probably just your normal user unless you did the Easy Install as SU or a Sudoer.
 
type the command terminal... crontab -e
 
add this cronjob... */1  *  *   *   *    /usr/bin/nohup /bin/sh /home/pi/script/survive-webcit.sh &
 
That's all..
 
Now some folks may not have nohup installed so if you need it, sudo yum install nohup or sudo apt-get install nohup
That's for Rehat or Debian/Ubuntu based distro's respectively.
 
Too easy huh?
 
 


[#] Sun Feb 04 2018 16:22:10 EST from bgerum @ Uncensored

Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Jan 29 2018 18:34:53 EST from bgerum @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog

 

Mon Jan 29 2018 13:35:33 EST from IGnatius T Foobar @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog
thanks for the reply. Unfortunately it seems the last version supplied by
the
homueller SuSE repo which is linked in the citadel.org doku ist 824.


Is there another rpm source?

I'm not aware of another RPM source. You could switch to Easy Install, which works on all distributions, but you'll have to move your data files to another directory first.

I used the Easy Install a long time ago, but the RPM version ist much more integrated in the OpenSuSE environment, not only directory-wise but also regarding startscripts, updating etc.

Do you think you could give Mr. homueller a hint there are new citadel versions out there? 



Ok, I found another OpenSuSE rpm source:

https://download.opensuse.org/repositories/home:/stefjakobs:/citadel-testing

it does provide citadel-9.01-13.19.x86_64, I installed it although it is compiled for the tumbleweed version of OpenSuSE, not leap which is what i use.

however, my database upgrade problem still remains:

citserver[14575]: Checking directory access
citserver[14575]: Opening databases
citserver[14575]: bdb(): open_databases() starting
citserver[14575]: Compiled db: Berkeley DB 4.8.30: (March 31, 2016)
citserver[14575]:   Linked db: Berkeley DB 4.8.30: (October 21, 2013)
citserver[14575]: Calculated dbversion: 4008030
citserver[14575]:   Previous dbversion: 4008030
citserver[14575]: Linked zlib: 1.2.8
citserver[14575]: bdb(): Setting up DB environment
citserver[14575]: dbenv->open(dbenv, /var/lib/citadel/data/, 10899, 0)
citserver[14575]: DB: Finding last valid log LSN: file: 6494 offset 9355549
citserver[14575]: DB: Recovery starting from [6494][9355421]
citserver[14575]: DB: Recovery complete at Sun Feb  4 22:10:24 2018
citserver[14575]: DB: Maximum transaction ID 80000024 Recovery checkpoint [6494][9355549]
citserver[14575]: Starting up DB
citserver[14575]: Checking floor reference counts
citserver[14575]: bdb(): cursor still in progress on cdb 04: can't begin transaction during r/o cursor
citserver[14575]: citserver is stopping in order to prevent data loss. uid=0 gid=0 euid=0 egid=0


 



[#] Sun Feb 04 2018 16:42:59 EST from travisr @ Uncensored

Subject: Re: Smart Host Auth

[Reply] [ReplyQuoted] [Headers] [Print]

 

Yes, my testing does reproduce that same effect.

When you specify a Smart Host for outbound delivery of all mail, Citadel passes that string along to libcurl as the CURLOPT_URL for SMTP delivery.  (Citadel uses libcurl for all protocol handling.)  So unfortunately it's not something we are able to change in Citadel to make it properly handle a username with an @ character in it.  (Seems very silly, doesn't it?  I can't believe we're the first ones to have this problem.)

You indicated that you're not a programmer but you are willing to help in developing a solution.  Would it be possible for you to post this problem on the libcurl mailing list or support channels, and see what their experts have to say about it?  In that context, Citadel is not really relevant except that it is "an application using libcurl for SMTP delivery" and the smtp://ME@DOMAIN.com:abc123@asp-submit.reflexion.net:2525 is the CURLOPT_URL being used by the program.

I have a post over at libcurl under the users section. If I get a resolution or something to get me in the right direction, I'll try and post back here with an update.



[#] Wed Feb 07 2018 05:54:31 EST from ematos @ Uncensored

Subject: Forward an email to a PHP script

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I'm a Citadel novice. I want to forward an email sent to an room to be processed by a PHP script. The PHP script will need to have access to the data from message (or at least, the message source text, when I can use a library to extract the info). I have read the FAQ

"How do I automatically forward all mail to a remote email address somewhere?"

but it is not exactly what I need. Is it possible to do what I need in Citadel?

Thanks for attention,

Ely

 



[#] Wed Feb 07 2018 14:49:35 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Forward an email to a PHP script

[Reply] [ReplyQuoted] [Headers] [Print]

I'm a Citadel novice. I want to forward an email sent to an room to
be processed by a PHP script. The PHP script will need to have access
to the data from message (or at least, the message source text, when
I can use a library to extract the info). I have read the FAQ

There are a couple of ways to do this.

One would be to make the room a mailing list, and put the script's email address in as a list subscriber.

The other way would be for your script to scrape the room's contents using either IMAP or by reading its RSS feed.

[#] Thu Feb 08 2018 22:14:42 EST from travisr @ Uncensored

Subject: Re: Smart Host Auth

[Reply] [ReplyQuoted] [Headers] [Print]

 

I have a post over at libcurl under the users section. If I get a resolution or something to get me in the right direction, I'll try and post back here with an update.

I posted at libcurl and this is what they said:

curl does not support '@' as part of the username when put in the URL. You
need to URL-encode it first, which then makes it %40. Like this:  smtp://ME%40DOMAIN.com:abc123@asp-submit.reflexion.net:2525

I tried that and it seemed to help. It is now requesting the correct domain in the DNS query, but I still get a Login Denied.
I keep going around and around on this and I'm to the point where I'm changing every little option to see if I can get it to work but I cant. Is there something here that someone sees?

I have email currently working with Exchange 2013.
It is setup for Smart Host authentication > > Offer basic authentication only after starting TLS:
Username = ME@DOMAIN.com
Password = [Password]


When I view the send connector logs for Exchange 2013, I get this:
220 asp.reflexion.net mail-cs-01 ESMTP,
EHLO HomeSVR.[MyLastName].home,  (I DONT KNOW WHY IT'S SENDING THIS, OR WHY IT WORKS) (HomeSVR is the name of the server, [mylastname].home is how I setup my home Active Directory that I don't use anymore)
250-asp.reflexion.net mail-cs-01,
250-STARTTLS,
250-PIPELINING,
250-8BITMIME,
250 SIZE 52428800,
STARTTLS,
220 ready for tls,
Sending certificate
CN=HomeSVR,Certificate subject
CN=HomeSVR,Certificate issuer name
[ID],Certificate serial number (this is a free, but now expired cert I think came from StartSSL, Never changed it out. I think StartSSL closed down)
[ID],Certificate thumbprint
HomeSVR;HomeSVR.[MyLastName].home,Certificate alternate names
Received certificate
[ID],Certificate thumbprint
Valid,Chain validation status
SmartHost certificate
"CN=*.reflexion.net, OU=Domain Control Validated - RapidSSL(R), OU=See www.rapidssl.com/resources/cps (c)14, OU=GT53011388",Certificate subject
"CN=RapidSSL SHA256 CA - G3, O=GeoTrust Inc., C=US",Certificate issuer name
00C407,Certificate serial number
5D80FA258B460F01B353A4DDFC6D29A0AECBB9E8,Certificate thumbprint
*.reflexion.net;reflexion.net,Certificate alternate names
EHLO HomeSVR.[MyLastName].home,
250-asp.reflexion.net mail-cs-01,
250-PIPELINING,
250-8BITMIME,
250-AUTH LOGIN PLAIN,
250 SIZE 52428800,
AUTH LOGIN,
334 <authentication information>,
<Binary Data>,
334 <authentication information>,
<Binary Data>,
"235 ok, go ahead (#2.0.0)",
,sending message with RecordId 116037131436042 and InternetMessageId <e90d20b4eda942ca8f089b58d900ef19@HomeSVR.[MyLastName].home>
MAIL FROM:<ME@DOMAIN.com> SIZE=5053,
RCPT TO:<ME@gmail.com>,
250 ok,
250 ok,
DATA,
354 go ahead,
250 ok 1518135203 qp 13102,
QUIT,
221 asp.reflexion.net mail-cs-01,
,Local

So there is a log of a working connection.


Here is what I get when I try to send mail via Citadel

citserver[21126]: smtpclient: 604 attempting delivery now
citserver[21126]: smtpclient: smtp_attempt_delivery(603, ME@gmail.com)
citserver[21126]: smtpclient: trying smtp://ME%40DOMAIN.com:abc123@asp-submit.reflexion.net:2525/DOMAIN.com
citserver[21126]: smtpclient: libcurl returned 67 (Login denied) , SMTP response 250
citserver[21126]: smtpclient: recp: <ME@gmail.com> , result: 250 (Requested mail action completed and OK)
citserver[21126]: smtpclient: submission age: 0d0h0m2s
citserver[21126]: smtpclient: num_success=1 , num_fail=0 , num_delayed=0
citserver[21126]: smtpclient: 604 deleting
citserver[21126]: smtpclient: end queue run


I'm thinking the whole TLS/STARTTLS thing is an issue or not setup right, but i'm just not sure what I'm missing or what I'm not translating right from Exchange to Citadel.



[#] Fri Feb 09 2018 16:07:12 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Smart Host Auth

[Reply] [ReplyQuoted] [Headers] [Print]


My guess is that your mail relaying provider does not allow logins over an unencrypted connection. Now if they offer SMTPS over a different port number, you could just go smtps:// instead of smtp:// but barring that...

Citadel Server has an undocumented configuration setting that will tell the SMTP client to attempt the STARTTLS command if the remote server supports it. Do this:

cd /usr/local/citadel
./sendcommand 'conf putval|c_smtpclient_try_starttls|1'

That's great news to hear that libcurl accepts %40 as a URL-escaped version of @.

[#] Sat Feb 10 2018 13:58:20 EST from travisr @ Uncensored

Subject: Re: Smart Host Auth

[Reply] [ReplyQuoted] [Headers] [Print]

I opened a terminal and did the commands to stop citadel and then start it again with -x9 logging, then used another terminal to run the command "./sendcommand 'conf putval|c_smtpclient_try_starttls|1'"
It came back with:

sendcommand: started (pid=18681) connecting to Citadel server at /usr/local/citadel/citadel-admin.socket
200 mail Citadel server ADMIN CONNECTION ready.
conf putval|c_smtpclient_try_starttls|1
200 setting 'c_smtpclient_try_starttls' to '1'
sendcommand: processing ended.

So it looked like it accepted the command. I then tried to send an email, but it failed with the login denied reason again but I didn't see anything in the logs about STARTTLS. Will I see anything for this in the logs showing this change?



[#] Tue Feb 13 2018 05:28:59 EST from smb3something @ Uncensored

Subject: Citadel not running after restart

[Reply] [ReplyQuoted] [Headers] [Print]

I was getting this error after installing / restarting a couple days ago on a new host but apparantly not. 



[#] Tue Feb 13 2018 05:34:13 EST from smb3something @ Uncensored

Subject: Re: Citadel not running after restart

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Feb 13 2018 05:28:59 EST from smb3something @ Uncensored Subject: Citadel not running after restart

I was getting this error after installing / restarting a couple days ago on a new host but apparantly not. 



Apologies, accidentally posted before I was done constructing the message. I'm getting the following when I start the service - citserver[4204]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I'm not sure where this config is made or how to set it back. Webcit won't talk to citadel either.  I had this issue a few times on Ubuntu 16.04 - ultimately I reinstalled on 14.04 and upgraded to 16.04.

It seems like the service isn't listening on a port (netstat would seem to confirm) but I haven't found in what config file this port is set.  Any ideas are appreciated.



[#] Tue Feb 13 2018 08:44:10 EST from smb3something @ Uncensored

Subject: Re: Citadel not running after restart

[Reply] [ReplyQuoted] [Headers] [Print]

I went back a bunch of pages and found someone who mentioned unning /usr/lib/citadel-server/setup and changing the port back to 504 solves the issue (it did for me as well).  I found references to this being a long standing bug where making changes under the admin user causes this. I also noted that the Deb/Ubuntu packages aren't always quite up to date (and this is how I installed).  I tried installing/updating from the easy installer script but it looks like I'm missing a dependency for open LDAP headers:

     configure: error: OpenLDAP development headers were not found and are required.  More info: http://www.citadel.org/doku.php/installation:start
     Operating system: Linux Debian stretch/sid ( 4.14.14-x86_64-linode94 x86_64)

Can anyone offer any pointers for this?

 



[#] Tue Feb 13 2018 13:11:10 EST from username @ Uncensored

Subject: configuration setting c_defualt_calzone is empty but must not

[Reply] [ReplyQuoted] [Headers] [Print]

I just started using Citadel, and I got this error 

 

Broadcast message from systemd-journald@RASPBERRYPINAME (Tue 2018-02-13 18:10:35 UTC):

 

citserver[879]: configuration setting c_default_cal_zone is empty, but must not - check your config!

 

How do I fix it? Thanks

 



[#] Tue Feb 13 2018 19:09:43 EST from far9T @ Uncensored

Subject: Receiving 550 Bounceback For (Almost) Every Recipient

[Reply] [ReplyQuoted] [Headers] [Print]

For reference, here's an example of what I send: https://pastebin.com/EjmmpuUH

I then get this message in my inbox: https://pastebin.com/iw6j104b

For my setup, I'm running the Citadel server on a VPS. I'm using a registrar, so all email from `example.com` should be forwarded to `examplehost.vps-hosting-domain.com`

Using my personal email, I can send and receive email just fine. However, for most of my recipients, I get this 550 error. Sometimes I'll receive the bounceback error as late as a week after I sent the original message!

And the email address of my recipients I know to be correct. I can send it to the same recipients from my personal email.

The examples show an email sent from a client with PGP signing, but I get the issue if I send it from webcit, too, with signing off.

Anything I can check? Thanks.



[#] Wed Feb 14 2018 11:31:14 EST from far9T @ Uncensored

Subject: Re: Receiving 550 Bounceback For (Almost) Every Recipient

[Reply] [ReplyQuoted] [Headers] [Print]

Some additional information.

Here is the citadel syslog entry for one of the failed attempts:

<TIMESTAMP> hostname citserver[1649]: smtpclient: trying smtp://aspmx.l.google.com/example.com
<TIMESTAMP> hostname citserver[1649]: smtpclient: libcurl returned 56 (Failure when receiving data from the peer) , SMTP response 550
<TIMESTAMP> hostname citserver[1649]: smtpclient: recp: <recipient@otherexample.com> , result: 550 (Requested action not taken: mailbox unavailable or relaying denied)
<TIMESTAMP> hostname citserver[1649]: smtpclient: submission age: 0d0h0m50s
<TIMESTAMP> hostname citserver[1649]: smtpclient: num_success=0 , num_fail=2 , num_delayed=0

So I found a pattern. Any mail server that uses Google's (spam checker?) doesn't like email form my host.



[#] Thu Feb 15 2018 19:56:29 EST from bobdoe @ Uncensored

Subject: Uploaded files

[Reply] [ReplyQuoted] [Headers] [Print]

So finally installed latest Citadel 917 using easy install.

I created a test room with file directory enabled. It seems to work, but noticed something strange: upload and download rights can be enabled even if leaving visible folder disabled. What's the point of this? If not visible files cannot be uploaded or downloaded at all in the room! Unless in command line mode instead of webcit?



Go to page: First ... 17 18 19 20 [21] 22 23 24 25 ... Last