Language:
switch to room list switch to menu My folders
Go to page: First ... 8 9 10 11 [12] 13 14 15 16 ... Last
[#] Thu Mar 30 2017 12:11:10 EDT from graylion @ Uncensored

Subject: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



[#] Thu Mar 30 2017 12:29:04 EDT from bennabiy @ Uncensored

Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

For LDAP authentication to work, you need to have libldap2-dev installed on a debian or ubuntu system (not sure package on others)...

 

That needs to be installed before you run the easy install scripts. 

Thu Mar 30 2017 07:03:06 AM EDT from graylion @ Uncensored Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

sorted - it did not like LDAP as authentication :(



 



[#] Thu Mar 30 2017 12:31:07 EDT from bennabiy @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

This is a known issue (although not entirely known WHY it happens ) but to fix it with an easy install:

sudo ~citadel/setup

will rerun through the setup of citserver and one of the entries is the port.

Thu Mar 30 2017 12:11:10 PM EDT from graylion @ Uncensored Subject: c_port_number

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



 



[#] Thu Mar 30 2017 23:22:33 EDT from kc5tja @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I've been kicking around the idea of setting up a Citadel instance for myself and my friends to use (Twitter just makes more and more and more stupid ideas reality, pushing me and my group that much closer to wanting our own local forum). The last time I set up a Citadel instance on a cloud server, it ended up forwarding spam every which way, and I had to shut it down.
Any one have a collection of howto's or other resources on how to secure a Citadel instance? (Point of reference; package in Ubuntu is 9.01; I know it's not the latest, but it's the easiest for me to configure for hopefully obvious reasons.)

Thanks.

[#] Fri Mar 31 2017 04:29:03 EDT from graylion @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks, that worked



[#] Fri Mar 31 2017 06:31:45 EDT from graylion @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Mar 30 2017 12:31:07 EDT from bennabiy @ Uncensored Subject: Re: c_port_number

This is a known issue (although not entirely known WHY it happens ) but to fix it with an easy install:

sudo ~citadel/setup

will rerun through the setup of citserver and one of the entries is the port.

Thu Mar 30 2017 12:11:10 PM EDT from graylion @ Uncensored Subject: c_port_number

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



 



Thanks! That alone was not sufficient though, ~citadel/setup still hangs on restart.

 

--2017-03-30 03:46:35--  http://easyinstall.citadel.org/citadel-init-scripts.tar
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10240 (10K) [application/x-tar]
Saving to: 'citadel-init-scripts.tar'

     0K ..........                                            100% 44.5K=0.2s

2017-03-30 03:46:35 (44.5 KB/s) - 'citadel-init-scripts.tar' saved [10240/10240]



[#] Fri Mar 31 2017 10:07:52 EDT from graylion @ Uncensored

Subject: LDAP issues

[Reply] [ReplyQuoted] [Headers] [Print]


Hi - further to the above, I still have issues with LDAP after installing libldap2-dev (Ubuntu 16.04.2)

1) easy install:

Reconfiguring Citadel server

Restarting Citadel server to apply changes
**************************************************************************....

and in another terminal:

root@mail  Fri Mar 31 14:58:21  /tmp
#tail -f citadel-install-log.txt


root@mail  Fri Mar 31 15:00:38  /tmp
#

after selecting option 2 and giving the base DN. I also had a TCPdump running and there are no packets on port 389

2) if I go into the WebUI and try to enter a directory server, click save and go back to the Directory page it remains empty and the port 0

Clearly something is missing. Help?

Thanks!



[#] Fri Mar 31 2017 10:54:03 EDT from graylion @ Uncensored

Subject: MySQL on the same box

[Reply] [ReplyQuoted] [Headers] [Print]

Setting up mysql-server-5.7 (5.7.17-0ubuntu0.16.04.1) ...
Renaming removed key_buffer and myisam-recover options (if present)
insserv: warning: script 'K15webcit' missing LSB tags and overrides
insserv: warning: script 'webcit' missing LSB tags and overrides
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service webcit and rc.local if started
insserv:  loop involving service rc.local at depth 11
insserv:  loop involving service webcit at depth 1
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package mysql-server-5.7 (--configure):

now, presumably if I installed from reporitories this would work, but the version in the repo has been built without LDAP support :(

Help?



[#] Fri Mar 31 2017 11:07:04 EDT from graylion @ Uncensored

Subject: Re: MySQL on the same box

[Reply] [ReplyQuoted] [Headers] [Print]

sorted. LSB comments missing - added



[#] Sat Apr 01 2017 18:41:20 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

whenever I try to telnet to anything it just says "trying (ip address)" forever.



[#] Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



[#] Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



[#] Mon Apr 03 2017 03:39:48 EDT from graylion @ Uncensored

Subject: Re: LDAP issues

[Reply] [ReplyQuoted] [Headers] [Print]

Hi guys - anybody?

Fri Mar 31 2017 10:07:52 EDT from graylion @ Uncensored Subject: LDAP issues


Hi - further to the above, I still have issues with LDAP after installing libldap2-dev (Ubuntu 16.04.2)

1) easy install:

Reconfiguring Citadel server

Restarting Citadel server to apply changes
**************************************************************************....

and in another terminal:

root@mail  Fri Mar 31 14:58:21  /tmp
#tail -f citadel-install-log.txt


root@mail  Fri Mar 31 15:00:38  /tmp
#

after selecting option 2 and giving the base DN. I also had a TCPdump running and there are no packets on port 389

2) if I go into the WebUI and try to enter a directory server, click save and go back to the Directory page it remains empty and the port 0

Clearly something is missing. Help?

Thanks!



 



[#] Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



[#] Mon Apr 03 2017 09:15:43 EDT from vnaster @ Uncensored

Subject: Configuring Citadel as Microsoft Exchange Public folders alternative

[Reply] [ReplyQuoted] [Headers] [Print]

Is it possible to configure Citadel as a Microsoft Exchange Public folders alternative and make it connect to an existing pop3 server?

We are thinking to use this system for collaboration/management/storage/ of our emails on a LAN

Wouldn't like to fully replace our current email provider as it seems a rather Herculean task.

Thank you,

Evangelos



[#] Wed Apr 05 2017 12:18:31 EDT from heini @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Empty message



[#] Wed Apr 05 2017 12:45:13 EDT from heini @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Empty message



[#] Wed Apr 05 2017 13:44:46 EDT from "Dirk Heinrichs" <dirk.heinrichs@altum.de> to room_citadel_support@uncensored.citadel.org

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

On 28.03.2017 19:11, heini wrote:

Tue Mar 28 2017 11:41:18 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

Did you install the dependencies and follow the directions for debian?

Yes, I did.


Tried easyinstall again and found out that compiling libcitadel requires package zlib1g-dev, which isn't listed as dependency. But...

 I currently have about 5 citadel installs all happily running on debian (from wheezy to Jessie) all using LDAP.

 This is a Stretch system, ...


... which leads to another compilation problem later, in the citadel package. The problem here is that Stretch already ships OpenSSL 1.1, which introduces API incompatible changes. So, in order to compile Citadel on Stretch, it has to be adapted to OpenSSL 1.1 first.

Bye...

    Dirk

-- 
Dirk Heinrichs <dirk.heinrichs@altum.de>
GPG Public Key: D01B367761B0F7CE6E6D81AAD5A2E54246986015
Sichere Internetkommunikation: http://www.retroshare.org
Privacy Handbuch: https://www.privacy-handbuch.de


[#] Wed Apr 05 2017 17:05:40 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



[#] Thu Apr 06 2017 03:10:10 EDT from graylion @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

Your ISP is lying :)

Wed Apr 05 2017 17:05:40 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



 



Go to page: First ... 8 9 10 11 [12] 13 14 15 16 ... Last