Language:
switch to room list switch to menu My folders
Go to page: First ... 10 11 12 13 [14] 15 16 17 18 ... Last
[#] Mon Nov 16 2020 12:23:40 EST from platonov

Subject: Re: MIGR export/import for database recovery/upgrades/selective mods

[Reply] [ReplyQuoted] [Headers] [Print]

Its a pleasure to hear such a valuation.

I'll follow up on this in some detail in the Citadel Documentation room.

Sun Nov 15 2020 17:37:25 EST from omatnet @ Uncensored Subject: Re: MIGR export/import for database recovery/upgrades/selective mods

Wow, that you so much! This is a great resource and should be on the Citadel website...! I can't believe I've been using Citadel for 8 years now, researching for info and learning to tweak it, and this is the first time I see such a good and comprehensive reference for using the 'sendcommand'

Thank you so much!!!

Sat Nov 14 2020 15:58:11 EST from platonov @ Uncensored Subject: Re: MIGR export/import for database recovery/upgrades/selective mods

Well, I can offer you a couple of key Citadel documents (see attachments here).

They are based on protocol and system_administration_manual. But they have been redone to include the extensive TOC and all sorts of formatting has been changed to make it all look the way I like to see things. Just unzip it and make sure css/main.css is present for the styles to work they way it was intended.

Protocol is actually that "good and detailed 'sendcommand' commands+parameters documentation".

So...

Sat Nov 14 2020 13:31:01 EST from omatnet @ Uncensored Subject: Re: MIGR export/import for database recovery/upgrades/selective mods

Those are very good points. I was never able to find a detailed description of the 'sendcommand' and the commands + parameters it can received (other than the 1-page on the Citadel.org website). If there is some detailed documentation for the 'sendcommand' it could be a good start.

Can anyone direct me/us to a good and detailed 'sendcommand' commands+parameters documentation? 

Sat Nov 14 2020 08:16:30 EST from platonov @ Uncensored Subject: MIGR export/import for database recovery/upgrades/selective mods

I'd like to understand the "MIGR export/import" commands a lil bit deeper than a skin-deep level.
It seems to me that MIGR is a pretty flexible and powerful mechanism
for doing things like database repair and/or modification on either the entire database
or its sections: config, user, room, floor, message.

It seems that it also could be used for restoring just database sections or
even a selected few variables, parameters and so on.

For example if there is a database corruption you may loose
your config parameters, in which case you could simply edit
the last good XML created by MIGR export and copy the config
section to a separate XML file which you could then import and thus
recover your system parameters.

Yes, things get tricky when you start dealing with users,
rooms, floors or messages and if you change some things by editing
the XML file, you may create conflicts or loose the entire sections
of the database if you, for example, change the room number without
changing other related things so it is all remains consistent.

But if you are aware of what you are doing and understand the
consequences then MIGR export/import become a pretty powerful
and flexible tool for taking care of some database damages
and/or reconfiguring some things en-masse, which could be done
in minutes if not seconds, instead of wasting hours by doing it
by hand via either webcit or textclient.

Could someone clarify some of these points and explain why it
is a "no-no" deal to do the database upgrades via MIGR export/import
or why it is not a good idea to rely on this mechanism for restoring
the selected sections?



 



 



cit_docs_01.zip (application/zip, 180583 bytes) [ View | Download ]
[#] Tue Nov 17 2020 15:12:45 EST from platonov

Subject: email accounts and aliases

[Reply] [ReplyQuoted] [Headers] [Print]

I am trying to setup some email aliases for main account so that the email sent to these alias accounts would also all be copied to one account.

In the article:
How do I create two public email addresses with same recipient but in different domains?
it says:

..."Internet e-mail aliases" will contain all other email addresses for the user. These addresses may be in any domain that is valid for your site.

The issues I have:

1. Some of my accounts can not be entered  as "Internet e-mail aliases". When you enter them and push "Save changes" and then do "Edit configuration" again to verify the data, the fields are blank.

Or, if you enter several comma separated email addresses into aliases field, it removes most of them. But it consistently allows postmaster@my-domain.

And some of the accounts can not be entered even as "Primary Internet e-mail address" and some worked yesterday, but today you can't enter them as aliases any more.

2. What happens in terms of mail delivery to alias addresses? Does mail get copied to all of them or only to the primary account which has all these aliases?

 



[#] Tue Nov 17 2020 17:02:24 EST from jtbreazeoutlook.com

Subject: E-Mail Attachemnts

[Reply] [ReplyQuoted] [Headers] [Print]

Good day,

I recently set up a Raspberry Pi server running citadel for my local volunteer fire department, switching them over from GoDaddy. This process took me 3 days, and I thought I had everything set, but today I learned that they can't download and open any attachments, or view any attachments sent to them. Any and all attachments say they are corrupted. This has been tested on multiple devices, OS's, and browsers. I looked in the advanced settings and couldn't find anything about attachments. I have removed the spam filter and antivirus, thinking that maybe when they got scanned they became corrupted, but that didn't help. 

What's the fix here? Anything I can do?



[#] Tue Nov 17 2020 17:08:51 EST from jtbreazeoutlook.com

Subject: Re: E-Mail Attachemnts

[Reply] [ReplyQuoted] [Headers] [Print]

And I just tested that attachments can leave the server, and be ok, but anything coming in gets corrupted. 



[#] Tue Nov 17 2020 17:54:13 EST from jtbreazeoutlook.com

Subject: Re: Corrupted attachments

[Reply] [ReplyQuoted] [Headers] [Print]

I'm encountering this issue now too. Sorry for adding an extra post with the same exact issue, it took me a while to figure out how to search this thread. I'm using a Pi 4, brand new, new SD card, and new install it Citadel, used the easy install. Everything else is working great, and email attachments leave the server OK, but coming in is when they get corrupted. I did that text file thing to view, and I got similar results. When it left, it was 115 bytes, and when it arrived it was 162 bytes. 

File contents when sent: The quick brown fox jumps over the lazy dog. Now is the time for all good men to come to the aid of their country.

File contents when arrived: The quick brown fox jumps over the lazy dog. Now is the tÿö–ÖRf÷"ÆÂvööBÖVâFò6öÖRFòF†R–BöbF†V—"6÷VçG'’ïÿ

Ÿÿ

So, what can we do about this? I've got some users that need their PDF files pronto, and I need a fix asap.
Tue Aug 25 2020 09:21:21 EDT from alex007 @ Uncensored Subject: Re: Corrupted attachments

it has something to do with character encoding I think.

My editor gedit says, that the original file I sent ist UTF-8 encoded, the file I downloaded with webcit is ISO 8859-15 encoded. See the files attached.

Does this only occur for German installations ?

 

Mon Aug 24 2020 10:22:18 EDT from phaake37 @ Uncensored Subject: Re: Corrupted attachments

All,

 

Did this ever get resolved?  I just tried this on my Citadel Server (Raspberry PI 3B+) and my text file produced:

 

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
123ÿó@Ð

 

the Original:

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
1234

So it appears to be something with appending to the file or? 

 

Any ideas?

Thanks!

 

 

Sat May 09 2020 23:13:54 EDT from warbaby @ Uncensored Subject: Re: Corrupted attachments

You might try a few more text uploads with various strings and see if there is any consistency with the char length.  

You might try creating some new files with a text editor and see how they look after a reboot.

I predict it is going to be failing Chink SD card writes, rather than a problem with Citadel. 

Or at least, replacing the Chink SD card would be my first approach, since that's a more widely known problem. 

Who knows all the various ways they fail? It might not be a total failure, just not writing properly.

Sometimes you can edit and save a file, it looks okay if you cat it out, but shows garbage after rebooting.

 

Sat May 09 2020 06:58:25 PM EDT from MAS3 @ Uncensored Subject: Re: Corrupted attachments

Thanks for the suggestion.

I created a small file, containing this text:

 

This is a text file created by the standard windows text editor.
It is not a large file, but i'm sure it will be corrupted once it's sent.

So let's see what will happen to it.

 

And this was what was received in the attachment (i'm not sure it will show exactly as i received due to the corruption)
Hmm seems there's more to it, as the font size has changed after copy / paste, and indentation was added:

 

This is a text file created by the standard windowsüÑ•áЁ•‘¥Ñ½È¸4)%Ё¥Ì¹½Ð„±…ɝ”™¥±”°‰ÕЁ¤´ÍÕÉ—ò—Bv–ÆÂ&R6÷''WFVBöæ6R—Bw26VçBàРХ6òÆWBw2?ÙYHÚ]Ú[\[ˆÈ]ƒBþ¾



 



 



 



(, 0 bytes) [View| Download]
(, 0 bytes) [View| Download]

 



blub2webcit.txt (text/plain, 99 bytes) [View| Download]
blub2.txt (text/plain, 95 bytes) [View| Download]
[#] Tue Nov 17 2020 22:45:20 EST from redw

Subject: Where are the keys stored

[Reply] [ReplyQuoted] [Headers] [Print]

hi- silly question

referring to: https://www.citadel.org/how_to_install_a_certificate_signed_by_a_recognized_certificate_authority.html

 

Where is the Keys/ directory?

 

thanks,

red



[#] Wed Nov 18 2020 12:04:48 EST from platonov

Subject: Re: email accounts and aliases

[Reply] [ReplyQuoted] [Headers] [Print]

The issue of not being able to add aliases to some account has been resolved.

This issue has been resolved.
In order for Administration -> Add, change, delete user accounts -> User name to be able to add aliases, the "Primary Internet e-mail address" on those aliases should be left blank. If it is filled with some address, that address can not be added as alias, since it IS specified.

Tue Nov 17 2020 15:12:45 EST from platonov @ Uncensored Subject: email accounts and aliases

I am trying to setup some email aliases for main account so that the email sent to these alias accounts would also all be copied to one account.

In the article:
How do I create two public email addresses with same recipient but in different domains?
it says:

..."Internet e-mail aliases" will contain all other email addresses for the user. These addresses may be in any domain that is valid for your site.

The issues I have:

1. Some of my accounts can not be entered  as "Internet e-mail aliases". When you enter them and push "Save changes" and then do "Edit configuration" again to verify the data, the fields are blank.

Or, if you enter several comma separated email addresses into aliases field, it removes most of them. But it consistently allows postmaster@my-domain.

And some of the accounts can not be entered even as "Primary Internet e-mail address" and some worked yesterday, but today you can't enter them as aliases any more.

2. What happens in terms of mail delivery to alias addresses? Does mail get copied to all of them or only to the primary account which has all these aliases?

 



 



[#] Wed Nov 18 2020 19:01:29 EST from hamiltra

Subject: Corrupted Images As Email Attachments

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Support,

I’m running Citadel version 929, Webcit 926 and server 929 on Raspbian. When i use the web portal to initiate an email with a 465KB image file attached, the image shows blank when clicking the View link in the email from the we portal. A forwarded email outside of Citadel is fine.  Is the web portal corrupting the image on retrieval from the backend?  Please advise.

-roger



[#] Wed Nov 18 2020 21:19:12 EST from ParanoidDelusions

Subject: Re: Corrupted Images As Email Attachments

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Nov 18 2020 19:01:29 EST from hamiltra @ Uncensored Subject: Corrupted Images As Email Attachments

Hi Support,

I’m running Citadel version 929, Webcit 926 and server 929 on Raspbian. When i use the web portal to initiate an email with a 465KB image file attached, the image shows blank when clicking the View link in the email from the we portal. A forwarded email outside of Citadel is fine.  Is the web portal corrupting the image on retrieval from the backend?  Please advise.

-roger



This may be related. I'm running Citadel 925, 925, 925 on a Rasbian base. I can copy and paste an image into a message and that works fine. But if I upload it as a file, it doesn't display - just a blank square. 

Like this:

 

which opens to this, if you click "view", and is corrupt, if you download it: 



[#] Wed Nov 18 2020 21:20:24 EST from ParanoidDelusions

Subject: Re: Corrupted Images As Email Attachments

[Reply] [ReplyQuoted] [Headers] [Print]

Leading me to wonder if this is something unique to Raspbian - I had thought maybe it was a permissions issue - but maybe it has something to do with some support library that isn't installed? 



[#] Thu Nov 19 2020 01:12:35 EST from onazari

Subject: citadel failed to start after easy installation

[Reply] [ReplyQuoted] [Headers] [Print]

Hi, I Installed citadel by easy installation script but finally it get to failed to start.

I have nginx webserver , jitsu server , matrix synapse on this vps

Systemctl status result:

● citadel.service - Citadel Server                                  Loaded: loaded (/etc/systemd/system/citadel.service; enabled; vendor preset: enabled)                                         Active: active (running) since Thu 2020-11-19 00:23:38 EST; 46min ago                                                       Main PID: 201575 (citserver)                                      Tasks: 3 (limit: 2281)
     Memory: 3.9M
     CGroup: /system.slice/citadel.service                                  └─201575 /usr/local/citadel/citserver             Nov 19 00:23:38 ubuntu citserver[201575]: tcpserver: bind: Address already in use                                             Nov 19 00:23:38 ubuntu citserver[201575]: extensions: TCP port *:5222: (XMPP) FAILED.                                         Nov 19 00:23:38 ubuntu citserver[201575]: extensions: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by Citadel Server.                                                                   This means, Citadel won't be the service provider for a specific service you configured it to.                                                                                              If you don't want Citadel to provide these services, turn them off in WebCit via: "Admin->System Preferences->Network".                                                                      The failed ports and sockets are: extensions: TCP port *:5222: (XMPP)                                                         If you want Citadel to provide you with that functionality, check the output of "netstat -lnp" on Linux, or "netstat -na" on BSD and disable the program that binds these ports.

 

Please help me to fix it.

Tanks.



[#] Thu Nov 19 2020 05:54:18 EST from hamiltra

Subject: Re: Corrupted Images As Email Attachments

[Reply] [ReplyQuoted] [Headers] [Print]

This is exactly what I've been getting as an output. Now, I can't login from my regular browser Brave. I've cleared caches and cookies without login success.  what is showing when I attempt to login is an empty page of 'Not Found'.  Using a different browser, I can view the login page just fine, though.



[#] Thu Nov 19 2020 11:11:37 EST from ParanoidDelusions

Subject: Re: Corrupted Images As Email Attachments

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Nov 19 2020 05:54:18 EST from hamiltra @ Uncensored Subject: Re: Corrupted Images As Email Attachments

This is exactly what I've been getting as an output. Now, I can't login from my regular browser Brave. I've cleared caches and cookies without login success.  what is showing when I attempt to login is an empty page of 'Not Found'.  Using a different browser, I can view the login page just fine, though.



So, being that this isn't happening on other distros and hardware platforms - I'm wondering if it is something unique to Raspbian on a Pi? 



[#] Thu Nov 19 2020 11:34:26 EST from warbaby

Subject: HOW TO: Quickly make a build directory and compile citadel & webcit

[Reply] [ReplyQuoted] [Headers] [Print]

This is an experimental addition to easyinstall (diff from current attached) which adds the option to -k or -keep (retain) sources.

With it, you can run easyinstall (assuming a development environment here, so don't mess around with your working mail server.. )

Again, this is not official, and not (yet) fully tested.  Use it at your own risk!

[Having said that, there's not much going on here. It's just a switch to output all the files to /usr/src instead of /tmp, and then.. don't delete them.]

AFTER your dev installation (using easyinstall-with-keep-source.sh) you can...

cd /usr/src/citadel-build-xxxxx
# edit some files
make upgrade
make install
# DON'T run make clean.. so you will still be "configured".. 

That's about it.

This has been tested and works on my box, but if you see the need for any corrections or updates, please submit them back to me.

Thanks,

-Warbaby



easyinstall-with-keep-source.sh (application/x-shellscript, 37046 bytes) [ View | Download ]
easyinstall.sh.dist (application/octet-stream, 36149 bytes) [ View | Download ]
easyinstall-with-keep-source.diff (text/x-patch, 1114 bytes) [ View | Download ]
[#] Thu Nov 19 2020 11:44:22 EST from warbaby

Subject: Testing an image upload (lookin at you fineloader.js) ...

[Reply] [ReplyQuoted] [Headers] [Print]

Okay, I've got my dev tools open, looking at the network request..

Attaching SomethingCrazy.jpg ..

Let's see what's going on.

Request

-----------------------------358352476817467187212240267008
Content-Disposition: form-data; name="qquuid"

c152de69-e873-4e8d-857f-3de415ea9861
-----------------------------358352476817467187212240267008
Content-Disposition: form-data; name="qqfilename"

SomethingCrazy.jpg
-----------------------------358352476817467187212240267008
Content-Disposition: form-data; name="qqtotalfilesize"

94651
-----------------------------358352476817467187212240267008
Content-Disposition: form-data; name="qqfile"; filename="SomethingCrazy.jpg"
Content-Type: image/jpeg

ÿØÿà

Okay, tiny mce won't let me post the whole thing.. But I'm looking it over. I'm guessing fineloader.js may hold the answers to the file attachment situation.



SomethingCrazy.jpg (image/jpeg, 128061 bytes) [ View | Download ]
[#] Thu Nov 19 2020 11:53:07 EST from warbaby

Subject: Re: citadel failed to start after easy installation

[Reply] [ReplyQuoted] [Headers] [Print]

prosody/jitsi is tying up those ports, but always be sure to check the output of "netstat -lnp" as it says in the error message.

The answer was literally printed right on the screen in front of you.

netstat -lnp # See what is running on which ports.

If you're already running prosody or jitsi-meet, you can change the configuration option to turn Citadel's internal XMPP server OFF, by setting it's ports to -1 in

Webcit.. Administration -> Site Configuration -> Settings

Set the values for both of these to -1

XMPP (Jabber) client to server port (-1 to disable)

XMPP (Jabber) server to server port (-1 to disable)

Either that, or

a) Uninstall prosody

or

b) Run Citadel XMPP on an alternate port.

 

Thu Nov 19 2020 01:12:35 AM EST from onazari @ Uncensored Subject: citadel failed to start after easy installation

Hi, I Installed citadel by easy installation script but finally it get to failed to start.

I have nginx webserver , jitsu server , matrix synapse on this vps

Systemctl status result:

● citadel.service - Citadel Server                                  Loaded: loaded (/etc/systemd/system/citadel.service; enabled; vendor preset: enabled)                                         Active: active (running) since Thu 2020-11-19 00:23:38 EST; 46min ago                                                       Main PID: 201575 (citserver)                                      Tasks: 3 (limit: 2281)
     Memory: 3.9M
     CGroup: /system.slice/citadel.service                                  └─201575 /usr/local/citadel/citserver             Nov 19 00:23:38 ubuntu citserver[201575]: tcpserver: bind: Address already in use                                             Nov 19 00:23:38 ubuntu citserver[201575]: extensions: TCP port *:5222: (XMPP) FAILED.                                         Nov 19 00:23:38 ubuntu citserver[201575]: extensions: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by Citadel Server.                                                                   This means, Citadel won't be the service provider for a specific service you configured it to.                                                                                              If you don't want Citadel to provide these services, turn them off in WebCit via: "Admin->System Preferences->Network".                                                                      The failed ports and sockets are: extensions: TCP port *:5222: (XMPP)                                                         If you want Citadel to provide you with that functionality, check the output of "netstat -lnp" on Linux, or "netstat -na" on BSD and disable the program that binds these ports.

 

Please help me to fix it.

Tanks.



 



[#] Thu Nov 19 2020 12:03:44 EST from warbaby

Subject: Thoughts about Raspberry PI uploads/attachments..

[Reply] [ReplyQuoted] [Headers] [Print]

Somebody with a raspberry pi is going to have to do this... [as I don't have one handy..]

Do a fresh easyinstall with easyinstall-with-keep-source.sh ( a few messages ago).

in addition to considering fineloader.js

dig into

/usr/src/citadel-build.xxxxx/webcit/paramhandling.c

and have a look at

upload_handler() on 534 ..

read & examine..

.. my quick and dirty is to change the log levels all to "error," and add whatever more log lines to log the living daylights out of it.. "make upgrade" "make install" and then tail syslog..

This should reveal pretty quickly where the train is leaving the tracks.. Or, at least, where it isn't..

Good Luck!



[#] Thu Nov 19 2020 13:48:21 EST from s3cr3to to Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Question: Which one of the following distros is recommended toinstall Citadel? Debian, Ubuntu

[Reply] [ReplyQuoted] [Headers] [Print]

Question: Which one of the following distros is recommended to install
Citadel? Debian, Ubuntu

I need to install a newer version to support modern TLS; we know that
Ubuntu is based on Debian and contributes to Debian. But, I thought that
being in the distro that the developers use, maybe I will be able to
avoid future problems.

My current citadel servers are in Debian, and I haven't had any
problems; except for bugs and things that the version installed with the
.deb package no longer supports

Thanks in advance.

Regards

[#] Thu Nov 19 2020 19:07:42 EST from ParanoidDelusions

Subject: Re: Thoughts about Raspberry PI uploads/attachments..

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Nov 19 2020 12:03:44 EST from warbaby @ Uncensored Subject: Thoughts about Raspberry PI uploads/attachments..

Somebody with a raspberry pi is going to have to do this... [as I don't have one handy..]

Do a fresh easyinstall with easyinstall-with-keep-source.sh ( a few messages ago).

in addition to considering fineloader.js

dig into

/usr/src/citadel-build.xxxxx/webcit/paramhandling.c

and have a look at

upload_handler() on 534 ..

read & examine..

.. my quick and dirty is to change the log levels all to "error," and add whatever more log lines to log the living daylights out of it.. "make upgrade" "make install" and then tail syslog..

This should reveal pretty quickly where the train is leaving the tracks.. Or, at least, where it isn't..

Good Luck!



I've got a spare pi and a 5 pack of 32gb SD cards on their way. I'll take one and give this a shot. I'm not a Linux expert. I may have noob questions. 




[#] Thu Nov 19 2020 20:56:30 EST from jtbreazeoutlook.com

Subject: Re: Corrupted attachments

[Reply] [ReplyQuoted] [Headers] [Print]

I think I have the issue narrowed down to a locale issue. I have now have the server running on a completely different Pi with a different OS (switched from Raspbian to Ubuntu Mate) and used sendcommand to migrate the server, and after re-installing the server again on the new pi through easyinstall, AND reset the local of Ubuntu, which took about 2 days. Since this didn't fix my issue, I dove into the locale files on webcit, which are NOT where they say they should be in the documentation, I only have en_GB, no en_US files, so, no webcit.mo file to be found, so I can't match the locale of webcit to the locale of my server that it stores files on. Could this be the issue? Is there even a en_US webcit.mo file I could find somewhere? The documentation seems to refer to that being a thing.

Tue Nov 17 2020 05:54:13 PM EST from jtbreazeoutlook.com @ Uncensored Subject: Re: Corrupted attachments

I'm encountering this issue now too. Sorry for adding an extra post with the same exact issue, it took me a while to figure out how to search this thread. I'm using a Pi 4, brand new, new SD card, and new install it Citadel, used the easy install. Everything else is working great, and email attachments leave the server OK, but coming in is when they get corrupted. I did that text file thing to view, and I got similar results. When it left, it was 115 bytes, and when it arrived it was 162 bytes. 

File contents when sent: The quick brown fox jumps over the lazy dog. Now is the time for all good men to come to the aid of their country.

File contents when arrived: The quick brown fox jumps over the lazy dog. Now is the tÿö–ÖRf÷"ÆÂvööBÖVâFò6öÖRFòF†R–BöbF†V—"6÷VçG'’ïÿ

Ÿÿ

So, what can we do about this? I've got some users that need their PDF files pronto, and I need a fix asap.
Tue Aug 25 2020 09:21:21 EDT from alex007 @ Uncensored Subject: Re: Corrupted attachments

it has something to do with character encoding I think.

My editor gedit says, that the original file I sent ist UTF-8 encoded, the file I downloaded with webcit is ISO 8859-15 encoded. See the files attached.

Does this only occur for German installations ?

 

Mon Aug 24 2020 10:22:18 EDT from phaake37 @ Uncensored Subject: Re: Corrupted attachments

All,

 

Did this ever get resolved?  I just tried this on my Citadel Server (Raspberry PI 3B+) and my text file produced:

 

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
123ÿó@Ð

 

the Original:

TEXT
TEXT
TEXT
TEXT
TEXT
1234
1234
1234
1234
1234

So it appears to be something with appending to the file or? 

 

Any ideas?

Thanks!

 

 

Sat May 09 2020 23:13:54 EDT from warbaby @ Uncensored Subject: Re: Corrupted attachments

You might try a few more text uploads with various strings and see if there is any consistency with the char length.  

You might try creating some new files with a text editor and see how they look after a reboot.

I predict it is going to be failing Chink SD card writes, rather than a problem with Citadel. 

Or at least, replacing the Chink SD card would be my first approach, since that's a more widely known problem. 

Who knows all the various ways they fail? It might not be a total failure, just not writing properly.

Sometimes you can edit and save a file, it looks okay if you cat it out, but shows garbage after rebooting.

 

Sat May 09 2020 06:58:25 PM EDT from MAS3 @ Uncensored Subject: Re: Corrupted attachments

Thanks for the suggestion.

I created a small file, containing this text:

 

This is a text file created by the standard windows text editor.
It is not a large file, but i'm sure it will be corrupted once it's sent.

So let's see what will happen to it.

 

And this was what was received in the attachment (i'm not sure it will show exactly as i received due to the corruption)
Hmm seems there's more to it, as the font size has changed after copy / paste, and indentation was added:

 

This is a text file created by the standard windowsüÑ•áЁ•‘¥Ñ½È¸4)%Ё¥Ì¹½Ð„±…ɝ”™¥±”°‰ÕЁ¤´ÍÕÉ—ò—Bv–ÆÂ&R6÷''WFVBöæ6R—Bw26VçBàРХ6òÆWBw2?ÙYHÚ]Ú[\[ˆÈ]ƒBþ¾



 



 



 



(, 0 bytes) [View| Download]
(, 0 bytes) [View| Download]

 



(, 0 bytes) [View| Download]
(, 0 bytes) [View| Download]

 



blub2.txt (text/plain, 95 bytes) [View| Download]
blub2webcit.txt (text/plain, 99 bytes) [View| Download]
Go to page: First ... 10 11 12 13 [14] 15 16 17 18 ... Last