Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 [4] 5 6 7 8 ... Last
[#] Sun Jul 12 2020 09:49:09 EDT from IGnatius T Foobar

Subject: Re: Correct place to set e-mail address aliases for users via webit?

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for that. It sounds like I may have been entering the e-mail addresses

in the wrong place for 10 years.

Well, certainly not for 10 years. Until recently, we set each user's email addresses from their vCards. It's only within the last year or so that we've made it a setting that only an administrator can change.

[#] Sun Jul 12 2020 16:56:38 EDT from IGnatius T Foobar

Subject: Re: Support for custom Sieve scripts to be discontinued in the nextrelease

[Reply] [ReplyQuoted] [Headers] [Print]

I use to write sieve scripts (with some issues), but I can bite the

bullet. If as you said: The option "Filter it according to rules
selected below" in "Advanced | View/edit server-side mail filters" for

each user, will still work.

Yes, that's going to be the only option now. Legacy WebCit has been hacked to make that screen display all the time.


Any user who has that option selected in an existing installation will have their rules preserved across the new version.

[#] Sun Jul 12 2020 18:29:16 EDT from jxgreen5

Subject: Weird issue

[Reply] [ReplyQuoted] [Headers] [Print]

I randomly had trouble accessing the web portal one day, so I decided to SSH into my VPS. Whenever I tried to reinstall Citadel I got the following "Setup could not connect to a running Citadel server.: Connection refused /usr/local/citadel/citadel-admin.socket". And whenever I tried to start the server manually, I kept getting an error looking like this: 
citserver[771]: db: cdb_fetch(4): BDB0075 DB_PAGE_NOTFOUND: Requested page not found

 

Broadcast message from systemd-journald@vps.mydomain.net (Sun 2020-07-12 18:12:15 EDT):

 

citserver[771]: db: cdb_fetch(4): BDB0075 DB_PAGE_NOTFOUND: Requested page not found

 

 

Message from syslogd@vps at Jul 12 18:12:15 ...

 citserver[771]: db: cdb_fetch(4): BDB0075 DB_PAGE_NOTFOUND: Requested page not found

Can I get some assistance please? I'm not the most experienced with the Linux CMD as a whole.

 


[#] Sun Jul 12 2020 19:36:43 EDT from warbaby

Subject: Re: Weird issue

[Reply] [ReplyQuoted] [Headers] [Print]

 

That's a Berkeley database error. Try the db cleanup/repair procedure. 

FIRST, MAKE A BACKUP

Database repair

Although Citadel's data store is quite reliable, database corruption can occur in rare instances. External factors such as an operating system crash or an unexpected loss of power might leave the database in an unknown state. A utility is provided which may be able to repair your database if this occurs. If you find that your Citadel server is not running, and reading the logs shows that it is crashing because of an inability to validate a database, follow these steps:

Stop the Citadel service with a command like ”/etc/init.d/citadel stop” # will vary with package or easyinstall..

Make a backup of your data. Either write it out to tape or copy it to another directory, or a tarball.

“cd” to your Citadel directory and type ”./database_cleanup.sh”

Let the cleanup script run. Do not interrupt this process for any reason.

Restart the Citadel service with a command like ”/etc/init.d/citadel start”

If this procedure does not work, you must restore from your most recent backup.

http://www.citadel.org/doku.php?id=documentation:system_administration_manual

See also Importing/Exporting your Citadel database, same page.

Sun Jul 12 2020 06:29:16 PM EDT from jxgreen5 @ Uncensored Subject: Weird issue

I randomly had trouble accessing the web portal one day, so I decided to SSH into my VPS. Whenever I tried to reinstall Citadel I got the following "Setup could not connect to a running Citadel server.: Connection refused /usr/local/citadel/citadel-admin.socket". And whenever I tried to start the server manually, I kept getting an error looking like this: 
citserver[771]: db: cdb_fetch(4): BDB0075 DB_PAGE_NOTFOUND: Requested page not found

 

Broadcast message from systemd-journald@vps.mydomain.net (Sun 2020-07-12 18:12:15 EDT):

 

citserver[771]: db: cdb_fetch(4): BDB0075 DB_PAGE_NOTFOUND: Requested page not found

 

 

Message from syslogd@vps at Jul 12 18:12:15 ...

 citserver[771]: db: cdb_fetch(4): BDB0075 DB_PAGE_NOTFOUND: Requested page not found

Can I get some assistance please? I'm not the most experienced with the Linux CMD as a whole.

 


 



[#] Wed Jul 15 2020 13:16:57 EDT from david

Subject: Unable to receive messages on my newly setup citadel email server

[Reply] [ReplyQuoted] [Headers] [Print]

I am quite new here so I apologies in advance, but I would like some help troubleshooting why I am unable to receive emails.

I am able to send emails without problems but when I  reply I get the following response:
The recipient server did not accept our requests to connect. [thelipners.com : timed out]

 

My setup is a raspberry pi, I have a home internet connection and have opened ports  80 25 587 and 465 and set up a dynamic DNS which seems to be working.

 

Any tips or pointers in the right direction would be great,

Thanks



[#] Thu Jul 16 2020 06:36:40 EDT from abuchman

Subject: Forwarding mail

[Reply] [ReplyQuoted] [Headers] [Print]

First let me say thank you for all your help Mail is now flowing in and out and is no longer being marked as spam! Now I want to forward email from my email to my Gmail. I have seen how to forward ALL mail from the server-side rules but I just want to forward mine, not the entire server. can someone help me out, please?



[#] Thu Jul 16 2020 06:49:52 EDT from abuchman

Subject: Re: Unable to receive messages on my newly setup citadel email server

[Reply] [ReplyQuoted] [Headers] [Print]

 

 

Wed Jul 15 2020 13:16:57 EDT from david @ Uncensored Subject: Unable to receive messages on my newly setup citadel email server

I am quite new here so I apologies in advance, but I would like some help troubleshooting why I am unable to receive emails.

I am able to send emails without problems but when I  reply I get the following response:
The recipient server did not accept our requests to connect. [thelipners.com : timed out]

 

My setup is a raspberry pi, I have a home internet connection and have opened ports  80 25 587 and 465 and set up a dynamic DNS which seems to be working.

 

Any tips or pointers in the right direction would be great,

Thanks



David, have you set up an MX record in your DNS? You will actually need a few things for mail to flow correctly. (thanks to all on this forum that helped me understand this. You will need an A record that points to an IP address or a CNAME that points to the dynamic provider. then an MX record that points to the name of your domain. You will need an SPF record to show the internet where your mail should be coming from usually something like "v=spf1 MX +all" works but im not `100% sure how that works with dynamic addresses (This will be a TXT record.) to keep your email from going to spam a DKIM and dmarc entry helps a lot. I hope this helps

 


[#] Thu Jul 16 2020 12:01:49 EDT from s3cr3to to abuchman <abuchman@uncensored.citadel.org>,Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Forwarding mail

[Reply] [ReplyQuoted] [Headers] [Print]

I use some options here:
1) Using Gmail/web to connect an get my mail from the account in Citadel.

2) Use the Gmail app in android and with IMAP connect to your citadel,
is slow but can be done. Or use K9 app some time ago.

3) Create a filter in webcit log in your mail account, go to Advanced -
View/edit server-side mail filters.

Select the drop down list on "When new mail arrives:" -> "Filter it
according to rules selected below"
[Add rule:]
If "All" - "Forward to" - [your@gmail.com] - "Keep" - "Continue" (if you
need more rules) or "Stop" if is the last rule.

Filters is the best optio BUT from time to time the filter don't process
all the mails (sad)

I manage to create some sieve filters, but this option will dissapear
soon. Seems to me that sieve was more faster but very hard to write and
work.

Example of sieve that works like a charm for me (edited and small example)
require "fileinto";
require "reject";
require "envelope";

#UPS NAS
if header :contains ["From"]
[
"mynas@freenas.local"
] {
redirect "mygmail@gmail.com";
#redirect "myacc@mycitadel.com"; #DANGER-AUTO-SPAM
keep;
stop;
}
...

NOTE: I write the filter for an user in my work, but for some reason,
Gmail was rejecting the forwarded mail, this happens since 2019. I don't
have the reject message, but surprise they are working again!
SMTPC:IO[]CC[]S[][] Delivery successful. Time[0.971091s] Recipient
<coworker> @ <gmail.com> (coworker) Status message: 2.0.0 OK 00046
t132si05oig.91 - gsmtp


On 7/16/20 4:36 AM, abuchman wrote:
First let me say thank you for all your help Mail is now flowing in and
out and is no longer being marked as spam! Now I want to forward email
from my email to my Gmail. I have seen how to forward ALL mail from the
server-side rules but I just want to forward mine, not the entire
server. can someone help me out, please?

[#] Thu Jul 16 2020 12:32:06 EDT from abuchman

Subject: Re: Forwarding mail

[Reply] [ReplyQuoted] [Headers] [Print]

 

So i have rainloops to get mail and it works great (someone suggested it) My issue i want to forward each email to a different address so my lazy ass partners dont have to login to the webmail or configure gmail. can i use serverside rules to process that? like if email abuchman@lfgnexus.com forward to andrew@gmail.com?

 


[#] Thu Jul 16 2020 13:38:37 EDT from s3cr3to to abuchman <abuchman@uncensored.citadel.org>,Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Forwarding mail

[Reply] [ReplyQuoted] [Headers] [Print]

Seems doable to me, just go for option 3 "filter" in.
- Advanced
- View/edit server-side email filters
-- When new mail arrives: filter it according to rules selected below

If [from] [is]
abuchman@lfgnexus.com
[Forward to]
andrew@gmail.com
and then [Keep] or [Stop]

This is from my old citadel, don't know if the new versions have a new
way to create filters.

As I tell before, gmail was marking errors still at the beginning of
this year and to my surprise today I see that it worked again.

And from time to time, sometimes the filter doesn't process some emails.
It's sporadic, but annoying, I guess because of the server load. That's
why I decided to use IMAP from my cell phone, just to be sure when I
need to get an important email.

Regards


On 7/16/20 10:32 AM, abuchman wrote:
So i have rainloops to get mail and it works great (someone suggested
it) My issue i want to forward each email to a different address so my
lazy ass partners dont have to login to the webmail or configure gmail.
can i use serverside rules to process that? like if email
abuchman@lfgnexus.com forward to andrew@gmail.com?

[#] Thu Jul 16 2020 13:40:33 EDT from s3cr3to to abuchman <abuchman@uncensored.citadel.org>,Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Forwarding mail

[Reply] [ReplyQuoted] [Headers] [Print]

serverside rules?

Sorry if not what you asked (creating a filter)

On 7/16/20 11:38 AM, s3cr3to wrote:

Seems doable to me, just go for option 3 "filter" in.
- Advanced
- View/edit server-side email filters
-- When new mail arrives: filter it according to rules selected below

If [from] [is]
abuchman@lfgnexus.com
[Forward to]
andrew@gmail.com
and then [Keep] or [Stop]

This is from my old citadel, don't know if the new versions have a new
way to create filters.

As I tell before, gmail was marking errors still at the beginning of
this year and to my surprise today I see that it worked again.

And from time to time, sometimes the filter doesn't process some emails.
It's sporadic, but annoying, I guess because of the server load. That's
why I decided to use IMAP from my cell phone, just to be sure when I
need to get an important email.

Regards


On 7/16/20 10:32 AM, abuchman wrote:
So i have rainloops to get mail and it works great (someone suggested
it) My issue i want to forward each email to a different address so my
lazy ass partners dont have to login to the webmail or configure
gmail. can i use serverside rules to process that? like if email
abuchman@lfgnexus.com forward to andrew@gmail.com?

[#] Sat Jul 18 2020 11:44:44 EDT from BenM

Subject: housekeeping: WARNING: housekeeping loop has not run for 2467 minutes.

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I am getting entries like the ones below in syslog:

Jul 18 12:17:24 server citserver[1597]: housekeeping: WARNING: housekeeping loop has not run for 2467 minutes.  Is something stuck?
Jul 18 12:17:25 server citserver[1597]: citserver[1597]: housekeeping: WARNING: housekeeping loop has not run for 2467 minutes.  Is something stuck
It seems to be related to having full text indexing enabled. I am also seeing very high CPU usage, it starts low but then quickly climbs higher and higher the longer the system is up until it is maxed out, although, this is true even with full text indexing disabled. I am running Debian 10 and Citadel 929.  The Citadel database is about 6 GB.
Any ideas?
Thanks,
Ben


[#] Sat Jul 18 2020 15:32:07 EDT from IGnatius T Foobar

Subject: Re: Forwarding mail

[Reply] [ReplyQuoted] [Headers] [Print]

This is from my old citadel, don't know if the new versions have a new

way to create filters.

If you are creating rules using the rules editor in WebCit, this is still the preferred way to go. It will also be the only way to go in the next version of Citadel, so anyone who has custom Sieve scripts will need to convert their scripts over to rules before the next upgrade.

[#] Tue Jul 21 2020 14:57:54 EDT from gll

Subject: Delivery Status Notification (Failure)

[Reply] [ReplyQuoted] [Headers] [Print]

This is crazy!  Every time a sent email gets rejected, undeliverable, Citadel sends "Delivery Status Notification (Failure)" notices at one per minute.  Last time this happened we got 1500 notices.  Anyone else experience that and is there a solution?



[#] Tue Jul 21 2020 18:39:56 EDT from nristen

Subject: Task not showing up on the Summary Page

[Reply] [ReplyQuoted] [Headers] [Print]

I recently upgraded to 929 using EasyInstall on a CentOS VPS.

 

I don't know if this was happening before or not.

 

I created a task for the current day, but it does not show up on the Summary page.  I also tried creating a task without any date associated with it and again it does not show up on the Summary page.  Any ideas what this could be?

 

Thank you



[#] Tue Jul 21 2020 18:42:15 EDT from nristen

Subject: Re: Task not showing up on the Summary Page

[Reply] [ReplyQuoted] [Headers] [Print]

 I just tested this on Uncensored as well with the same results

Tue Jul 21 2020 06:39:56 PM EDT from nristen @ Uncensored Subject: Task not showing up on the Summary Page

I recently upgraded to 929 using EasyInstall on a CentOS VPS.

 

I don't know if this was happening before or not.

 

I created a task for the current day, but it does not show up on the Summary page.  I also tried creating a task without any date associated with it and again it does not show up on the Summary page.  Any ideas what this could be?

 

Thank you



 



[#] Fri Jul 24 2020 12:33:14 EDT from leon1912

Subject: 503: Service unavailable

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

today I setup an Apache webserver on my Pi.

After this I installed Citadel.

When I try to access Citadel from my web browser, I got the 503 message:

What can I do or what did I have done wrong?

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.

 

What can I do or what did I have done wrong?

Thank you



[#] Mon Jul 27 2020 10:40:03 EDT from asdf

Subject: Err: 421 when sending emails

[Reply] [ReplyQuoted] [Headers] [Print]

I have a fresh install of Citadel on a rpi 4, and every time I try to send an email, I get the error:

A message you sent has not been delivered to some or all of its recipients.
Citadel will continue attempting delivery for five days.
The following addresses were undeliverable:

asdfsafas@afasdfsafsadfsadf.asdf: 421()



[#] Wed Jul 29 2020 14:12:01 EDT from david

Subject: Overwritten citadel index page

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I have just been installing PHP7 for a project on my raspberry pi (owncloud) and have overwritten the index file so that when I enter my domain url, instead of loading up the webcit log in page, I get Apache2 Debian Default Pag.

Is there any way to get the  webcit /var/www/html/index.html page back?



[#] Thu Jul 30 2020 09:04:17 EDT from bananaOp

Subject: user deleted from web interface

[Reply] [ReplyQuoted] [Headers] [Print]

HEllo!

I am configuring a citadel server, everything seems to work for the most part, but when I deleted a user from the web interface, and then wanted to recreate it, it complains that user already exists, although I don't see it in the user list anymore. I tried restarting everything, same. Is there a way to refresh/force this properly? (command line ?) Thank you!

 

B



Go to page: 1 2 3 [4] 5 6 7 8 ... Last