Language:
switch to room list switch to menu My folders
Go to page: First ... 7 8 9 10 [11] 12 13 14 15 ... Last
[#] Sun Jan 14 2024 07:21:23 EST from Nurb432

Subject: Re: bug found in citadel mail server

[Reply] [ReplyQuoted] [Headers] [Print]

lol

 



[#] Sun Jan 14 2024 07:34:02 EST from admin1234

Subject: Re: bug found in citadel mail server

[Reply] [ReplyQuoted] [Headers] [Print]

Hi what are you meaning?you wrote lol 

Who are you and why write this things?



[#] Sun Jan 14 2024 08:00:28 EST from p.agsten

Subject: Re: Citadel Server crashes

[Reply] [ReplyQuoted] [Headers] [Print]

First of all many thanks for the support - as always very quick and to the point.

1. Upgrade to Citadel Server v993 or later. We literally spent all of last summer improving the database layer, and it is now much more robust, even in the face of server crashes or other problems.

Done that and Citadel and DB are now version 996. Let's see whether we see again any DB issues. Had to restore DB from backup twice in the last two years.

2. You might have instructions in your outbound SMTP queue to deliver that message but the message itself doesn't exist. If you want to, you can go to the hidden room "__CitadelSMTPSpoolout__" and your queue will be in there.
If you find delivery instructions that reference that message, just delete them.

My understanding is only Aide can enter that room, right? I can get there two ways:
1. Go via Administration -> View the outbound SMTP queue
2. Go via Advanced -> Go to a 'hidden' room
Both ways no messages are shown:

Is there a way to remove the message number via command line client?

BTW, is there a documentation on error and return codes somewhere? I noticed that 'systemctl stop citadel' does not exit clean but with retun code 15. Not sure what this means.

Regards,

P.

 

 

Thu Jan 11 2024 15:13:25 EST from IGnatius T Foobar Subject: Re: Citadel Server crashes
1. What could have caused the database corruption and is there a tool that

can be used to check and restore database integrity without data loss?

2. What is causing the errors related to message #97535 and how can I fix

this?

1. Upgrade to Citadel Server v993 or later. We literally spent all of last summer improving the database layer, and it is now much more robust, even in the face of server crashes or other problems.

2. You might have instructions in your outbound SMTP queue to deliver that message but the message itself doesn't exist. If you want to, you can go to the hidden room "__CitadelSMTPSpoolout__" and your queue will be in there.
If you find delivery instructions that reference that message, just delete them.

 



[#] Sun Jan 14 2024 08:03:51 EST from admin1234

Subject: Re: bug found in citadel mail server

[Reply] [ReplyQuoted] [Headers] [Print]

Hi what are you meaning?you wrote lol 

Who are you and why write this things?



[#] Sun Jan 14 2024 16:35:42 EST from p.agsten

Subject: TLS configuration

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

After the upgrade I am playing around with the server a bit to harden and improve reputation. I noticed that TLS does not seem to be advertized. Tested with the local server:

~$ telnet localhost 25
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 [my host] ESMTP Citadel server ready.
EHLO [some alias]
250-Hello [some alias] (localhost [127.0.0.1])
250-HELP
250-SIZE 10485760
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

The server has certificates installed and uses those when connecting via IMAP. There are also a lot of TLS messages in syslog. But in the response above I miss repsonse line 250-STARTTLS indicating TLS support for the MTA. STARTTLS command is accepted (220) though so in theory would work but as it's not advertized might not be used when remote server is waiting for that capability response.

Am I missing something?

Kind regards,

P.

 



[#] Mon Jan 15 2024 13:01:56 EST from IGnatius T Foobar

Subject: Re: bug found in citadel mail server

[Reply] [ReplyQuoted] [Headers] [Print]

Hello dear admin and support I hope you are in good mood today actually I found a important bug in citadel mail server and it could endanger sensitive data in local and global citadels I never ill-use that bug and it's information as you now no pain no gain I decided to inform you that report by email but can I expect prize ?(I am bug hunter and receive prize in trust wallet) your helping and cooperation can encourage me to trying find more bugs we can make better internet environment by the way I don't want too much money after observing and confirmation you can evaluate my request

We do not negotiate with extortionists.  If you believe you have found a bug in the software please post it here or private mail to me if you feel it is sensitive information.

 



[#] Mon Jan 15 2024 13:06:16 EST from IGnatius T Foobar

Subject: Re: Citadel Server crashes

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a way to remove the message number via command line client?

That might actually be a better option.  Once logged in to the command line client, type ".Goto __CtdlSMTPSpoolout__"

Then hit "F" to read-Forward

You'll see two types of messages there.  Half ought to be "delivery instructions" and the other half should be the messages themselves.  If you find one without the other it is a stray message and you can hit "D" to delete it.

 

BTW, is there a documentation on error and return codes somewhere? I noticed that 'systemctl stop citadel' does not exit clean but with retun code 15. Not sure what this means.

That's a different story.  But there's a way to find out.  Stop the Citadel server with systemctl, then start it in the foreground with:

cd /usr/local/citadel

./citserver -x9

Run it for a little while, then stop it with ctrl-c or by shutting it down from the user interface.  Then post the last screenful of log messages here, so we can see why you got that exit code.



[#] Mon Jan 15 2024 13:09:34 EST from IGnatius T Foobar

Subject: Re: TLS configuration

[Reply] [ReplyQuoted] [Headers] [Print]

After the upgrade I am playing around with the server a bit to harden and improve reputation. I noticed that TLS does not seem to be advertized. Tested with the local server:

The server has certificates installed and uses those when connecting via IMAP. There are also a lot of TLS messages in syslog. But in the response above I miss repsonse line 250-STARTTLS indicating TLS support for the MTA. STARTTLS command is accepted (220) though so in theory would work but as it's not advertized might not be used when remote server is waiting for that capability response.

Am I missing something?

You're not missing anything; that is the normal behavior.

The reason we do not advertise STARTTLS is because too many sites start up with a self-signed certificate, and we've found that those sites will not receive mail from many popular sources if STARTTLS is advertised but the certificate is invalid from the sender's perspective.

If this is something you need, we could add an undocumented server configuration item to switch it on manually.  Would that help?



[#] Thu Jan 18 2024 00:19:03 EST from MarisaG

Subject: Citadel hosting?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello! I provide Citadel hosting starting at $7 and would like to know if I can get it listed it here. My website is at https://citadelhosting.retro-os.live/. If any questions I'm listening at fstltna@yahoo.com :)



[#] Fri Jan 19 2024 01:23:22 EST from p.agsten

Subject: Re: Citadel Server crashes

[Reply] [ReplyQuoted] [Headers] [Print]

cd /usr/local/citadel

./citserver -x9

Run it for a little while, then stop it with ctrl-c or by shutting it down from the user interface.  Then post the last screenful of log messages here, so we can see why you got that exit code.

 

citserver[251519]: Additional memory allocated since startup: 0 bytes
citserver[251519]: listdeliver: delivery interval not yet reached; last run was 2m2s ago
citserver[251519]: smtpclient: start full queue run , last_queue_job_processed=0 , last_queue_job_submitted=0
citserver[251519]: smtpclient: 0 messages to be processed
citserver[251519]: smtpclient: end full queue run , last_queue_job_processed=0 , last_queue_job_submitted=0
citserver[251519]: rssclient: polling interval not yet reached; last run was 2m2s ago
citserver[251519]: bdb: -- checkpoint --
citserver[251519]: Additional memory allocated since startup: 0 bytes
^Ccitserver[251519]: sysdep: caught signal 2
citserver[251519]: citserver: closing databases
citserver[251519]: bdb: performing final checkpoint
citserver[251519]: bdb: flushing the database logs
citserver[251519]: bdb: closing databases
citserver[251519]: bdb: closing database 00
citserver[251519]: bdb: closing database 01
citserver[251519]: bdb: closing database 02
citserver[251519]: bdb: closing database 03
citserver[251519]: bdb: closing database 04
citserver[251519]: bdb: closing database 05
citserver[251519]: bdb: closing database 06
citserver[251519]: bdb: closing database 07
citserver[251519]: bdb: closing database 08
citserver[251519]: bdb: closing database 09
citserver[251519]: bdb: closing database 0a
citserver[251519]: bdb: closing database 0b
citserver[251519]: bdb: closing database 0c
citserver[251519]: bdb: closing database 0d
citserver[251519]: bdb: closing environment
citserver[251519]: bdb: shutdown completed
citserver[251519]: citserver: Exiting with status 2
citserver[251519]: main: removing lockfile

Looks like this is creatign a different result than when run under systemd.

That might actually be a better option.  Once logged in to the command line client, type ".Goto __CtdlSMTPSpoolout__"

Then hit "F" to read-Forward

 

Indeed I found there two message that were more than a year old and deleted them. This greatly reduced the amount of noise in the log. But I still have msgbase errors for two messages. One comes up around every half an hour, the other has longer cycles.

Jan 18 20:38:41 [host] citserver[251656]: citserver[251656]: msgbase: message #93647 was not found
Jan 18 20:38:41 [host] citserver[251656]: msgbase: message #93647 was not found
Jan 18 20:38:41 [host] citserver[251656]: citserver[251656]: msgbase: message #93647 was not found
Jan 18 20:38:41 [host] citserver[251656]: citserver[251656]: msgbase: message #93647 was not found
Jan 18 20:38:41 [host] citserver[251656]: citserver[251656]: msgbase: error; invalid preloaded message for output
Jan 18 20:38:41 [host] citserver[251656]: msgbase: message #93647 was not found
Jan 18 20:38:41 [host] citserver[251656]: msgbase: message #93647 was not found
Jan 18 20:38:41 [host] citserver[251656]: msgbase: error; invalid preloaded message for output

Is there a way from the command line to identify a specific message number?

KR,

P.

 



[#] Fri Jan 19 2024 01:27:23 EST from p.agsten

Subject: Re: TLS configuration

[Reply] [ReplyQuoted] [Headers] [Print]

If this is something you need, we could add an undocumented server configuration item to switch it on manually.  Would that help?

That would be great. I mainly use Citadel as mail and collaboration platform and this would be greatly improve reputation interacting with other public MTAs. Not mega urgent though probably something for a next release.

Many thanks for considering!

P.

 



[#] Fri Jan 19 2024 18:42:29 EST from IGnatius T Foobar

Subject: Re: Citadel hosting?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello! I provide Citadel hosting starting at $7 and would like to
know if I can get it listed it here. My website is at
https://citadelhosting.retro-os.live/. If any questions I'm listening
at fstltna@yahoo.com :)

Pleased to do so. In the "Download" page, a fourth option has been added which links to a new page of Citadel hosting services. Yours is now listed on that page. Please let me know if you want it to read any differently.
Also, if your organization ever elects to discontinue the service, please also get in touch.

Thanks for providing such a useful service to the community!

[#] Sat Jan 20 2024 11:03:04 EST from IGnatius T Foobar

Subject: Re: TLS configuration

[Reply] [ReplyQuoted] [Headers] [Print]

That would be great. I mainly use Citadel as mail and collaboration platform

and this would be greatly improve reputation interacting with other public

MTAs. Not mega urgent though probably something for a next release.

On it! Server option completed already (it was just a couple extra lines of code) so we just need to go through the user interfaces adding that switch in. Look for it in the next release.

[#] Sat Jan 20 2024 16:30:33 EST from bjornw

Subject: citadel installation

[Reply] [ReplyQuoted] [Headers] [Print]

Hi There!

 

I was just recommended citadel as a mail server.

I have ubuntu-22.04 and I follow the instructions to configure/compile and setup citadel.

 

After providing all input the setup program says it is restarting services, but the setup program never completes.

If I manually start citadel, I can connect on mail port and talk to the service.

If I run setup again, it takes me through the few questions about admin and passwords and then it tries to restart but never finishes.

 

Any help is appreciated.

PS: I would expect the configuration files to be under /usr/local/citadel or /etc/citadel, but I cannot find any...

 



[#] Sat Jan 20 2024 19:41:51 EST from bjornw

Subject: Re: citadel installation

[Reply] [ReplyQuoted] [Headers] [Print]

Found out I need to enable the web interface :-)



[#] Sun Jan 21 2024 21:01:35 EST from IGnatius T Foobar

Subject: Re: citadel installation

[Reply] [ReplyQuoted] [Headers] [Print]

I have ubuntu-22.04 and I follow the instructions to
configure/compile and setup citadel.

Hopefully you are using the docker container, or the easy install build, and not the woefully obsolete packages that are in the ubuntu repository?

[#] Mon Jan 22 2024 07:13:31 EST from Nurb432

Subject: Re: citadel installation

[Reply] [ReplyQuoted] [Headers] [Print]

Debian repositories is at 916..  Ouch.



[#] Thu Jan 25 2024 15:27:28 EST from CarlosEVC63

Subject: How to redirect http to https for Webcit

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Guys,

I am new at this forum.

I have just installed a brand new Citadel server, and it is running like a charm.

OS is Ubuntu 22.04.

I would appreciate if someone would tell me how the web server of Webcit can be configured to redirect all the http requests to https requests automatically.

I am running Webcit without any proxy in between. No Apache or Nginx installed, just bared Citadel.

 

Carlos

 

 



[#] Sat Jan 27 2024 13:56:06 EST from s3cr3to to undisclosed-recipients: ;

Subject: Re: How to redirect http to https for Webcit

[Reply] [ReplyQuoted] [Headers] [Print]

My personal solution:

A LXC on Proxmox running  "Nginx Proxy Manager" (NPM)
I installed it using this script: https://tteck.github.io/Proxmox/

Later, I plan to install it in a VM with Docker to learn more about Docker.
If you are using Citadel in Docker, I guess you will have no problem to
create another container for NPM.

On 1/25/24 13:27, CarlosEVC63 wrote:

Hi Guys,

I am new at this forum.

I have just installed a brand new Citadel server, and it is running
like a charm.

OS is Ubuntu 22.04.

I would appreciate if someone would tell me how the web server of
Webcit can be configured to redirect all the http requests to https
requests automatically.

I am running Webcit without any proxy in between. No Apache or Nginx
installed, just bared Citadel.

Carlos

[#] Sat Jan 27 2024 14:42:52 EST from Nurb432

Subject: Re: How to redirect http to https for Webcit

[Reply] [ReplyQuoted] [Headers] [Print]

For what its worth, that is how i run everything at home that has an incoming connection so i can get SSL.  Works well, not a lot of setup overhead. Pretty bullet proof.

Only difference is i use full VMs.  

Sat Jan 27 2024 13:56:06 EST from s3cr3to Subject: Re: How to redirect http to https for Webcit
My personal solution:

A LXC on Proxmox running  "Nginx Proxy Manager" (NPM)



Go to page: First ... 7 8 9 10 [11] 12 13 14 15 ... Last