Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 [4] 5 6 7 8 ... Last
[#] Thu Sep 21 2023 14:16:42 EDT from javier.putterman

Subject: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Only just started using Citadel. It was working perfectly fine until I recently rebooted the instance it was running on. 

Now it starts, runs for 10 seconds, and then systemctl status returns this:

citadel.service - Citadel Server

   Loaded: loaded (/etc/systemd/system/citadel.service; enabled; vendor preset: disabled)

   Active: failed (Result: signal) since Thu 2023-09-21 13:46:34 EDT; 5s ago

  Process: 25129 ExecStart=/usr/local/citadel/citserver (code=killed, signal=SEGV)

 Main PID: 25129 (code=killed, signal=SEGV)

 

systemd[1]: citadel.service: Main process exited, code=killed, status=11/SEGV

systemd[1]: citadel.service: Failed with result 'signal'.

systemd[1]: citadel.service: Service RestartSec=100ms expired, scheduling restart.

systemd[1]: citadel.service: Scheduled restart job, restart counter is at 5.

systemd[1]: Stopped Citadel Server.

systemd[1]: citadel.service: Start request repeated too quickly.

systemd[1]: citadel.service: Failed with result 'signal'.

systemd[1]: Failed to start Citadel Server.

journalctl -xe returned this:

citserver[25125]: extensions: TCP port *:465: (SMTPs-MTA) registered.

citserver[25125]: extensions: TCP port *:587: (SMTP-MSA) registered.

citserver[25125]: extensions: unix domain socket 'lmtp.socket': registered.

citserver[25125]: extensions: unix domain socket 'lmtp-unfiltered.socket': registered.

citserver[25125]: citserver[25125]: Existing database version on disk is 992

citserver[25125]: Existing database version on disk is 992

citserver[25125]: citserver[25125]: extensions: service DICT_TCP has been manually disabled, skipping

citserver[25125]: extensions: service DICT_TCP has been manually disabled, skipping

citserver[25125]: citserver[25125]: extensions: TCP port *:5222: (XMPP) registered.

citserver[25125]: extensions: TCP port *:5222: (XMPP) registered.

citserver[25125]: citserver[25125]: main: changing uid to 1003

citserver[25125]: main: changing uid to 1003

kernel: citserver[25126]: segfault at 10 ip 00007f88216d8d40 sp 00007f8819b1bb98 error 4 in libcitadel.so.4.0.992[7f88216be000+21000]

kernel: Code: 08 83 ef 01 eb a5 0f 1f 40 00 c3 66 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 40 00 48 63 f6 48 0f af 77 08 48 8b 07 48 01 f0 c3 90 <8b> 47 10 c3 66 66 2e 0f 1f 84 00 00 00 00 00 90 48 89 f1 48 8b 57

systemd[1]: citadel.service: Main process exited, code=killed, status=11/SEGV

systemd[1]: citadel.service: Failed with result 'signal'.

I'm new to Citadel, know some Linux and basic coding, but otherswise am stumped here. Not sure what to do, because I'm not entirely sure what's going on. It mentions a "segfault," which sounds like some sort of illegal memory issue. Maybe it's a permissions based issue, but I haven't knowingly changed any on that box. Just rebooted, and that was it.

Any guidance would be greatly appreciated as I'm stuck.

Cheers,

JP

 

 

 


[#] Fri Sep 22 2023 15:50:56 EDT from nnitrus

Subject: Re: installing on AmazonLinux (or any ARM, really)

[Reply] [ReplyQuoted] [Headers] [Print]

I get a similar error on Ubuntu:

  This is a NEW Citadel installation. 

 Installation will now begin. 

find: '/usr/local/ctdlsupport': No such file or directory

find: '/usr/local/ctdlsupport': No such file or directory

find: '/usr/local/ctdlsupport': No such file or directory

find: '/usr/local/ctdlsupport': No such file or directory

 Do you want Easy Install to attempt to install your OS dependencies? Y

sh: 319: [: Debian: unexpected operator

sh: 332: [: Debian: unexpected operator

 



[#] Fri Sep 22 2023 16:19:58 EDT from Nurb432

Subject: Re: installing on AmazonLinux (or any ARM, really)

[Reply] [ReplyQuoted] [Headers] [Print]

Docker supports ARM.

 

( cant believe im suggesting docker.. )



[#] Fri Sep 22 2023 20:50:03 EDT from Nurb432

Subject: Re: installing on AmazonLinux (or any ARM, really)

[Reply] [ReplyQuoted] [Headers] [Print]

i guess i should have added, that 'real' ARM hardware does work.  One of mine is being used to test builds with..

Not knowing AWS, but i wonder if their stuff is 'different' than the rest somehow. 

Fri Sep 22 2023 16:19:58 EDT from Nurb432 Subject: Re: installing on AmazonLinux (or any ARM, really)

Docker supports ARM.

 

( cant believe im suggesting docker.. )



 



[#] Sat Sep 23 2023 00:12:38 EDT from IGnatius T Foobar

Subject: Re: installing on AmazonLinux (or any ARM, really)

[Reply] [ReplyQuoted] [Headers] [Print]

I get a similar error on Ubuntu:

All right, I've gone ahead and updated the OS detection logic in Easy Install and tried it on both Amazon Linux and Ubuntu, both on ARM. Both detect the OS correctly.

That having been said, you really might want to have a look at the Docker version of Citadel; it's the same software but it's much easier to get running.

[#] Sat Sep 23 2023 07:02:11 EDT from p.agsten

Subject: Citadel Server stopped sending mails out

[Reply] [ReplyQuoted] [Headers] [Print]

Dear All,

couple of days back server stopped sending mails. Notices because of an error message coming back with SMTP code 412. Receiving is fine, no issues.

In the logs I keep seeing this message:

Sep 23 12:56:17 citserver[5959]: citserver[5959]: msgbase: message #97535 was not found
Sep 23 12:56:17 citserver[5959]: citserver[5959]: smtpclient: 97535 does not exist
Sep 23 12:56:17 citserver[5959]: msgbase: message #97535 was not found
Sep 23 12:56:17 citserver[5959]: smtpclient: 97535 does not exist

Thought maybe database had issues so restored a backup from before last time message was sent successfully. But this did not change anything. No mail goes out and the error also reappears. I therefore guess it is unrelated.

When I login as admin in Webcit and go to outbound SMTP queue it is showing:

As there are mails pending that have not been delivered, I would have expected to see them here.

Any ideas would be much welcome.

Thanks,

P.

         


[#] Sat Sep 23 2023 13:23:21 EDT from javier.putterman

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Tried re-running the Easy Install, but that crapped out too after it started up.

I guess I can try just blowing it all away and start from scratch, but I'd rather not.

Definitely bombs out at the segfault mentioned above. 

 



[#] Sat Sep 23 2023 14:01:41 EDT from IGnatius T Foobar

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Tried re-running the Easy Install, but that crapped out too after it
started up.

Ok, one more time.

You should definitely wipe out /usr/local/ctdlsupport, /usr/local/citadel, and /usr/local/webcit before continuing.

I made some tweaks to Easy Install and tested it on a brand new RHEL installation.
It worked for me.

[#] Sat Sep 23 2023 14:06:48 EDT from javier.putterman

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Yep. Doing that right now. Thank you.

 



[#] Sat Sep 23 2023 14:29:43 EDT from javier.putterman

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

I got through the Easy Install after deleting those folders and cleaning everything up, seemed to install just fine, but...

Then it crashed as I was re-creating an email account through the web interface. I saved the changes, and then it lost connection.

Checked systemctl status citadel on the server, and it looks like the same exact segfault issue again.

It's strange because it was working perfectly fine for over a week, and I was starting to create a few accounts, and then this happened. Actually, now that I'm thinking about it, I think this started when I changed something from the web interface the first time.

FWIW I'm running: Red Hat Enterprise Linux release 8.8 (Ootpa).

It's frustrating because I was really starting to dig Citadel, and then this. 

Everything else on that server is running fine. Didn't do a yum update until AFTER the first time this happened. 

Weird.

Thanks for looking into it, thought. Much appreciated.

Cheers,

-JP

 

 

 



[#] Sat Sep 23 2023 15:10:08 EDT from javier.putterman

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Sir,

Here's what I've been able to figure out, so far, not that I entirely understand it:

When I write data to the server using the web app via HTTP (8080), it's fine, but...

If I do the same thing via HTTPS (8443) it crashes and the server poops the bed with the same segfault error until I blow it all away and start over.

Something happens when I write to the server from 8443. It's the only variable I changed that lead it to crash. And it was working for a while just using 8080, so...

Will do it again to confirm.

I hope this helps. 

Cheers,

-JP

 



[#] Sat Sep 23 2023 19:53:24 EDT from IGnatius T Foobar

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Can I ask why you're using RHEL in the first place? Are you running Citadel inside an organization that needs their paid support?

[#] Sun Sep 24 2023 05:07:17 EDT from p.agsten

Subject: Re: Citadel Server stopped sending mails out

[Reply] [ReplyQuoted] [Headers] [Print]

Dear All,

eventually found the issue. Somehow Citadel was no longer able to resolve names. Removed systemd-resolved and completely reconfigured. Afterwards resolution was working again resolving the issue.

Now the only remaining question is how to address the error messages related to message #97535.

Any ideas here?

P.

 

Sat Sep 23 2023 07:02:11 EDT from p.agsten Subject: Citadel Server stopped sending mails out

Dear All,

couple of days back server stopped sending mails. Notices because of an error message coming back with SMTP code 412. Receiving is fine, no issues.

In the logs I keep seeing this message:

Sep 23 12:56:17 citserver[5959]: citserver[5959]: msgbase: message #97535 was not found
Sep 23 12:56:17 citserver[5959]: citserver[5959]: smtpclient: 97535 does not exist
Sep 23 12:56:17 citserver[5959]: msgbase: message #97535 was not found
Sep 23 12:56:17 citserver[5959]: smtpclient: 97535 does not exist

Thought maybe database had issues so restored a backup from before last time message was sent successfully. But this did not change anything. No mail goes out and the error also reappears. I therefore guess it is unrelated.

When I login as admin in Webcit and go to outbound SMTP queue it is showing:

As there are mails pending that have not been delivered, I would have expected to see them here.

Any ideas would be much welcome.

Thanks,

P.

         


 



[#] Sun Sep 24 2023 13:36:24 EDT from IGnatius T Foobar

Subject: Re: Citadel Server stopped sending mails out

[Reply] [ReplyQuoted] [Headers] [Print]

Now the only remaining question is how to address the error messages related

to message #97535.

Any ideas here?

There might be a message in the queue that has that number but it isn't there anymore. If that is the case, the mail delivery system will give up after five days and you will stop receiving that message. If you feel like tinkering, the queue is in a hidden room called __CitadelSMTPspoolout__ and you can poke around in there looking for it.

[#] Mon Sep 25 2023 11:19:38 EDT from javier.putterman

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

So...after about the 2nd or 3rd re-Easy Install, I was able to make changes in the db from :8443 without it crashing, and it's been up and just fine ever since.

About RHEL...I inherited it with the project. There's a subscription already in place, and I've never messed with RHEL much, so now's my chance, I guess. 

My only previous linux experience had been with the Ubuntu and Centos flavors.

Thank you for the help. 

Cheers,

JP



[#] Tue Sep 26 2023 09:58:03 EDT from cjonline

Subject: Re: Rebooted my RHEL 8.8 instance and now Citadel crashes upon start...

[Reply] [ReplyQuoted] [Headers] [Print]

Hi, Can you please tell me how you fixed this?  getting similar messages on rasbian.

 

Craig.



[#] Tue Sep 26 2023 10:03:11 EDT from cjonline

Subject: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I've been using citadel for a few months and decided to upgrade to the latest and greatest version with easy install.. I have done this before on previous version with success, however, this time the install ran through fine, but at the point where it stops the services and restarts the install failed to connect.. it bombed to the shell.   I tried to start citadel from command line but it starts then segfaults a few seconds later... please help as this is my main email.

 

thanks

Craig.  (log below) 

 

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: rssclient: using libcurl/7.64.0 OpenSSL/1.1.1n zlib/1.2.11 libidn2/2.2.0 libpsl/0.20.2 (+lib

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: TCP port 0.0.0.0:25: (SMTP-MTA) registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: TCP port 0.0.0.0:465: (SMTPs-MTA) registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: TCP port 0.0.0.0:587: (SMTP-MSA) registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: unix domain socket 'lmtp.socket': registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: unix domain socket 'lmtp-unfiltered.socket': registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: citserver[9846]: Existing database version on disk is 994

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: Existing database version on disk is 994

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: citserver[9846]: extensions: service DICT_TCP has been manually disabled, skipping

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: citserver[9846]: extensions: TCP port 0.0.0.0:5222: (XMPP) registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: service DICT_TCP has been manually disabled, skipping

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: citserver[9846]: main: changing uid to 112

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: extensions: TCP port 0.0.0.0:5222: (XMPP) registered.

Sep 26 14:51:16 victor.cajsoft.co.uk citserver[9846]: main: changing uid to 112

Sep 26 14:51:17 victor.cajsoft.co.uk citserver[9846]: citserver[9846]: context: session (SMTP-MSA) started from 77.90.185.59 (77.90.185.59) uid=-1

Sep 26 14:51:17 victor.cajsoft.co.uk citserver[9846]: context: session (SMTP-MSA) started from 77.90.185.59 (77.90.185.59) uid=-1

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: citadel.service: Main process exited, code=killed, status=11/SEGV

-- Subject: Unit process exited

-- Defined-By: systemd

-- Support: https://www.debian.org/support

--

-- An ExecStart= process belonging to unit citadel.service has exited.

--

-- The process' exit code is 'killed' and its exit status is 11.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: citadel.service: Failed with result 'signal'.

-- Subject: Unit failed

-- Defined-By: systemd

-- Support: https://www.debian.org/support

--

-- The unit citadel.service has entered the 'failed' state with result 'signal'.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: citadel.service: Service RestartSec=100ms expired, scheduling restart.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: citadel.service: Scheduled restart job, restart counter is at 5.

-- Subject: Automatic restarting of a unit has been scheduled

-- Defined-By: systemd

-- Support: https://www.debian.org/support

--

-- the configured Restart= setting for the unit.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: Stopped Citadel Server.

-- Subject: A stop job for unit citadel.service has finished

-- Defined-By: systemd

-- Support: https://www.debian.org/support

--

-- A stop job for unit citadel.service has finished.

--

-- The job identifier is 24163 and the job result is done.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: citadel.service: Start request repeated too quickly.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: citadel.service: Failed with result 'signal'.

-- Subject: Unit failed

-- Defined-By: systemd

-- Support: https://www.debian.org/support

--

-- The unit citadel.service has entered the 'failed' state with result 'signal'.

Sep 26 14:51:18 victor.cajsoft.co.uk systemd[1]: Failed to start Citadel Server.

-- Subject: A start job for unit citadel.service has failed

-- Defined-By: systemd

-- Support: https://www.debian.org/support

--

-- A start job for unit citadel.service has finished with a failure.

--

-- The job identifier is 24163 and the job result is failed.

-- Automatic restarting of the unit citadel.service has been scheduled, as the result for

 


[#] Tue Sep 26 2023 10:11:16 EDT from Nurb432

Subject: Re: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

[Reply] [ReplyQuoted] [Headers] [Print]

Cant help with the crash, but you did make a backup right? Could always roll back and do some testing with coming suggestions.  

Tue Sep 26 2023 10:03:11 EDT from cjonline Subject: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

 please help as this is my main email.

 



[#] Tue Sep 26 2023 10:38:56 EDT from cjonline

Subject: Re: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

[Reply] [ReplyQuoted] [Headers] [Print]

Would you believe it.. NO I didnt as the previous upgrade I did I made a backup but it went smoothly so thought it wouldnt be needed :(

how I was wrong !

 

Craig.

 

Tue Sep 26 2023 10:11:16 EDT from Nurb432 Subject: Re: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

Cant help with the crash, but you did make a backup right? Could always roll back and do some testing with coming suggestions.  

Tue Sep 26 2023 10:03:11 EDT from cjonline Subject: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

 please help as this is my main email.

 



 



[#] Tue Sep 26 2023 10:52:42 EDT from Nurb432

Subject: Re: Citadel wont start after EASY INSTALL upgrade to 944 (rasbian)

[Reply] [ReplyQuoted] [Headers] [Print]

Darn. i always do that even if i have tested it. you never know. power fail, OS freak out = corrupted files = ack!

Once the others see this i'm sure you will be getting suggestions.  



Go to page: 1 2 3 [4] 5 6 7 8 ... Last