Language:
switch to room list switch to menu My folders
Go to page: First ... 9 10 11 12 [13] 14 15 16 17 ... Last
[#] Sat Mar 05 2022 14:33:03 EST from publicaccessDOTclub

Subject: Webcit headaches

[Reply] [ReplyQuoted] [Headers] [Print]

Hello everyone,

 

I operate a very small invite-only/application membership Pub*nix server over at publicaccess.club.

We Have recently installed a docker install of Citadel and I used apt to install Citadel-webcit since it appeared absent or needed to be installed separately.

I set webcit to run on internal alongside my Apache2 server. It’s currently set to run on ports 2000 and 2002 for http/https respectively.

I also added a virtualhost for the bbs which is directed to look at bbs.publicaccess.club.

so, it appears atleast the text message server is running, which is perfect cause thats what I was hoping for, however it doesn’t appear when in head over to bbs.publicacces.club that webcit is running at all.

Can someone kindly help me?

 

Thanks!



[#] Mon Mar 07 2022 00:07:18 EST from ParanoidDelusions

Subject: Re: Webcit headaches

[Reply] [ReplyQuoted] [Headers] [Print]

Are you putting "https:/bbs.publicaccess.club:2002" in the URL? 

Sat Mar 05 2022 14:33:03 EST from publicaccessDOTclub Subject: Webcit headaches

Hello everyone,

 

I operate a very small invite-only/application membership Pub*nix server over at publicaccess.club.

We Have recently installed a docker install of Citadel and I used apt to install Citadel-webcit since it appeared absent or needed to be installed separately.

I set webcit to run on internal alongside my Apache2 server. It’s currently set to run on ports 2000 and 2002 for http/https respectively.

I also added a virtualhost for the bbs which is directed to look at bbs.publicaccess.club.

so, it appears atleast the text message server is running, which is perfect cause thats what I was hoping for, however it doesn’t appear when in head over to bbs.publicacces.club that webcit is running at all.

Can someone kindly help me?

 

Thanks!



 



[#] Mon Mar 07 2022 08:13:28 EST from lleandrobs

Subject: suddenly no mail delivery anymore

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I've got a strange problem.. I'm running Citadel since a few years now and suddenly the sending of mails stopped to work (since last Wednesday I guess).
I do receive mails but when I send a mail I receive a "Delivery Status Notification (Failure)" after a few hours telling me that

A message you sent has not been delivered to some or all of its recipients.
Citadel will continue attempting delivery for five days.
The following addresses were undeliverable:

xxx@protonmail.com: 421 ()


A netcat on port 25 is working, so the port isn't blocked by my ISP and the last time I changed a firewall rule is long ago.

I run citadel on a Raspberry Pi 4 (Buster).
citserver: Version 949 (build fbd0e65f9) ***

Did anyone experience this?


[#] Mon Mar 07 2022 11:10:32 EST from JeepNWilly

Subject: Re: Citadel Database Files

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Feb 22 2022 18:18:38 EST from IGnatius T Foobar Subject: Re: Citadel Database Files
Your data files are in /usr/local/citadel/data

You can shut down the Citadel service, move that directory somewhere else, and make /usr/local/citadel/data a symbolic link to the new location. It'll do the right thing.

If you want to do it the "fancy" way, you can look at [ https://www.citadel.org/how_may_i_improve.html ] to learn how to explicitly configure a separate location.

Thank you for your help



[#] Mon Mar 07 2022 14:51:01 EST from lleandrobs

Subject: Re: suddenly no mail delivery anymore

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Mar 07 2022 08:13:28 EST from lleandrobs Subject: suddenly no mail delivery anymore

Hello,

I've got a strange problem.. I'm running Citadel since a few years now and suddenly the sending of mails stopped to work (since last Wednesday I guess).
I do receive mails but when I send a mail I receive a "Delivery Status Notification (Failure)" after a few hours telling me that

A message you sent has not been delivered to some or all of its recipients.
Citadel will continue attempting delivery for five days.
The following addresses were undeliverable:

xxx@protonmail.com: 421 ()


A netcat on port 25 is working, so the port isn't blocked by my ISP and the last time I changed a firewall rule is long ago.

I run citadel on a Raspberry Pi 4 (Buster).
citserver: Version 949 (build fbd0e65f9) ***

Did anyone experience this?


 

 

I want to try a different smart host but I can't figure out the correct syntax. In the documentation is this:

https://www.citadel.org/relay.html

 [smtp[s]://][username:password@]host[:port]


But my problem is the username is "username@xxx.com". How to write it correctly?
I tried this:
smtps://username@xxx.com:password@mail.xxx.com:465

But it doesn't seem to work. Does someone know how to write it correctly?

 



[#] Mon Mar 07 2022 15:51:10 EST from s3cr3to to lleandrobs <lleandrobs@uncensored.citadel.org>, Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: suddenly no mail delivery anymore

[Reply] [ReplyQuoted] [Headers] [Print]

From another post with the suject "Re: SMTP Relay as Smarthost" I found this:

According to [ https://unix.stackexchange.com/questions/609888/how-to-escape-in-curl-command-password-field
] the libcurl library allows you to use URL escapes, so if your username has
a @ in it you might try changing that to %40 , something like this: 
  
 smtp://user%40example.com:password@example.smtp.com:587 
  
 Citadel uses libcurl to send mail, so whatever is valid for libcurl will
be valid for Citadel. 

Thank you AJC for the answer


On 3/7/22 12:51, lleandrobs wrote:

 

Mon Mar 07 2022 08:13:28 EST from lleandrobs Subject: suddenly no mail delivery anymore

Hello,

I've got a strange problem.. I'm running Citadel since a few years now and suddenly the sending of mails stopped to work (since last Wednesday I guess).
I do receive mails but when I send a mail I receive a "Delivery Status Notification (Failure)" after a few hours telling me that

A message you sent has not been delivered to some or all of its recipients.
Citadel will continue attempting delivery for five days.
The following addresses were undeliverable:

xxx@protonmail.com: 421 ()


A netcat on port 25 is working, so the port isn't blocked by my ISP and the last time I changed a firewall rule is long ago.

I run citadel on a Raspberry Pi 4 (Buster).
citserver: Version 949 (build fbd0e65f9) ***

Did anyone experience this?


 

 

I want to try a different smart host but I can't figure out the correct syntax. In the documentation is this:

https://www.citadel.org/relay.html

 [smtp[s]://][username:password@]host[:port]


But my problem is the username is "username@xxx.com". How to write it correctly?
I tried this:
smtps://username@xxx.com:password@mail.xxx.com:465

But it doesn't seem to work. Does someone know how to write it correctly?

 




[#] Mon Mar 07 2022 16:00:18 EST from lleandrobs

Subject: Re: suddenly no mail delivery anymore

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Mar 07 2022 15:51:10 EST from s3cr3to Subject: Re: suddenly no mail delivery anymore
From another post with the suject "Re: SMTP Relay as Smarthost" I found this:

According to [ https://unix.stackexchange.com/questions/609888/how-to-escape-in-curl-command-password-field
] the libcurl library allows you to use URL escapes, so if your username has
a @ in it you might try changing that to 
%40
 , something like this: 
  
 smtp://user%40example.com:password@example.smtp.com:587 
  
 Citadel uses libcurl to send mail, so whatever is valid for libcurl will
be valid for Citadel. 

 




 

Thank you, that worked!



[#] Mon Mar 07 2022 16:56:18 EST from IGnatius T Foobar

Subject: Re: suddenly no mail delivery anymore

[Reply] [ReplyQuoted] [Headers] [Print]

But my problem is the username is "username@xxx.com". How to write it
correctly?
I tried this:
smtps://username@xxx.com:password@mail.xxx.com:465

But it doesn't seem to work. Does someone know how to write it
correctly?

Try escaping the first '@' character. Some systems will accept %40 instead.

smtps://username%40xxx.com:password@mail.xxx.com:465

[#] Tue Mar 08 2022 15:15:43 EST from erol.kahraman

Subject: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

During installation progress i selected option two to set up a LDAP server for my users. My LDAP server is FreeIPA. I can get users with binded admin account or any other account by using ldapsearch.

 # ldapsearch -x -b "cn=users,cn=accounts,dc=test,dc=io" -h ldap.test.io -D "uid=admin,cn=users,cn=accounts,dc=test,dc=io" -W

 

However i am not able to get users and I get an errors like this;

 

# ./citserver

...

citserver[50491]: extensions: unix domain socket 'lmtp-unfiltered.socket': registered.
citserver[50491]: Existing database version on disk is 949
citserver[50491]: extensions: service DICT_TCP has been manually disabled, skipping
citserver[50491]: extensions: TCP port *:5222: (XMPP) registered.
citserver[50491]: main: changing uid to 1001
citserver[50491]: ldap: synchronizing Citadel user database from LDAP
Segmentation fault (core dumped)

The error repeats continuously and it is impossible to start server again.

 

What could be the problem? How can i get more informative output to solve the problem?



[#] Tue Mar 08 2022 15:17:31 EST from IGnatius T Foobar

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]

What could be the problem? How can i get more informative output to
solve the problem?

Run it in the debugger and get a backtrace.

gdb ./citserver
run -x9

[ wait for it to crash... ]

bt

[ post the output ]

[#] Tue Mar 08 2022 15:26:29 EST from erol.kahraman

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]

...

citserver[50602]: ldap: synchronizing Citadel user database from LDAP
citserver[50602]: sysdep: new client socket 36
citserver[50602]: context: session (citadel-UDS) started from  () uid=0
citserver[50602]: [(not logged in)(0)] MSGP application/x-citadel-delivery-list|text/calendar|application/ics|text/vnote|text/x-vcard|text/vcard|text/html|text/plain|text/x-citadel-variformat|text/x-markdown
citserver[50602]: [(not logged in)(0)] USER admin
citserver[50602]: user_ops: cmd_user(admin)
citserver[50602]: user_ops: CtdlLoginExistingUser(admin)
citserver[50602]: ldap: search: (&(objectclass=posixAccount)(cn=admin))
citserver[50602]: ldap: search: (objectClass=inetOrgPerson)
citserver[50602]: ldap: No such user was found.
citserver[50602]: [(not logged in)(0)] MESG hello
citserver[50602]: ldap: 1 entries returned
citserver[50602]: ldap: found uid=erol.kahraman,cn=users,cn=accounts,dc=test,dc=io

Thread 2 "citserver" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff46be700 (LWP 50607)]
0x00005555555e328f in derive_fullname_from_ldap_result (fullname=0x7ffff46bd440 "", fullname_size=256, ldserver=0x7ffff0005400,
    search_result=0x7ffff0005eb0) at ldap.c:52
52      ldap.c: No such file or directory.

Tue Mar 08 2022 15:17:31 EST from IGnatius T Foobar Subject: Re: LDAP Users
What could be the problem? How can i get more informative output to
solve the problem?

Run it in the debugger and get a backtrace.

gdb ./citserver
run -x9

[ wait for it to crash... ]

bt

[ post the output ]

 



[#] Tue Mar 08 2022 15:30:58 EST from erol.kahraman

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]

After bt command;

 

#0  0x00005555555e328f in derive_fullname_from_ldap_result (fullname=0x7ffff46bd440 "", fullname_size=256, ldserver=0x7ffff0005400,
    search_result=0x7ffff0005f20) at ldap.c:52
#1  0x00005555555e504a in CtdlSynchronizeUsersFromLDAP () at ldap.c:595
#2  0x000055555558af55 in do_housekeeping () at housekeeping.c:152
#3  0x0000555555575bca in worker_thread (blah=0x0) at sysdep.c:1059
#4  0x000055555559322e in CTC_backend (supplied_start_routine=0x555555575296 <worker_thread>) at threads.c:117
#5  0x00007ffff7bf1609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007ffff776f163 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Tue Mar 08 2022 15:26:29 EST from erol.kahraman Subject: Re: LDAP Users

...

citserver[50602]: ldap: synchronizing Citadel user database from LDAP
citserver[50602]: sysdep: new client socket 36
citserver[50602]: context: session (citadel-UDS) started from  () uid=0
citserver[50602]: [(not logged in)(0)] MSGP application/x-citadel-delivery-list|text/calendar|application/ics|text/vnote|text/x-vcard|text/vcard|text/html|text/plain|text/x-citadel-variformat|text/x-markdown
citserver[50602]: [(not logged in)(0)] USER admin
citserver[50602]: user_ops: cmd_user(admin)
citserver[50602]: user_ops: CtdlLoginExistingUser(admin)
citserver[50602]: ldap: search: (&(objectclass=posixAccount)(cn=admin))
citserver[50602]: ldap: search: (objectClass=inetOrgPerson)
citserver[50602]: ldap: No such user was found.
citserver[50602]: [(not logged in)(0)] MESG hello
citserver[50602]: ldap: 1 entries returned
citserver[50602]: ldap: found uid=erol.kahraman,cn=users,cn=accounts,dc=test,dc=io

Thread 2 "citserver" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff46be700 (LWP 50607)]
0x00005555555e328f in derive_fullname_from_ldap_result (fullname=0x7ffff46bd440 "", fullname_size=256, ldserver=0x7ffff0005400,
    search_result=0x7ffff0005eb0) at ldap.c:52
52      ldap.c: No such file or directory.

Tue Mar 08 2022 15:17:31 EST from IGnatius T Foobar Subject: Re: LDAP Users
What could be the problem? How can i get more informative output to
solve the problem?

Run it in the debugger and get a backtrace.

gdb ./citserver
run -x9

[ wait for it to crash... ]

bt

[ post the output ]

 



 



[#] Wed Mar 09 2022 09:11:12 EST from IGnatius T Foobar

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]


Ok, that's absolutely perfect. Give me some time to check what's happening there.

[#] Thu Mar 10 2022 12:49:28 EST from IGnatius T Foobar

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]


This error shouldn't happen, because the code at line 52 of ldap.c is actually checking to make sure it isn't trying to work with a NULL value. It's kind of weird.

Can you tell me what version of Citadel you're using, and give us a brief idea of what your LDAP schema looks like? In particular, I am interested in knowing what attribute holds the "display name" of the user. I suspect "cn" isn't the right one, but that's what we're using.

[#] Thu Mar 10 2022 14:11:20 EST from erol.kahraman

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I reinstalled my citadel server and LDAP server (FreeIPA) with different domain name. The result didn't change.

I used easy install to install citeadel server. From "About this server" i see that information: "You are connected to Citadel Server, running Citadel 949 with WebCit 949, server build 949 and located in (null). Your system administrator is ."

When i run ldapsearch command i got the following output:

root@mail:/usr/local/citadel# ldapsearch -x -b "cn=users,cn=accounts,dc=kovan,dc=io" -h ldap.kovan.io -D "uid=admin,cn=users,cn=accounts,dc=kovan,dc=io" -W uid=erol.kahraman
Enter LDAP Password:
# extended LDIF
#
# LDAPv3
# base <cn=users,cn=accounts,dc=kovan,dc=io> with scope subtree
# filter: uid=erol.kahraman
# requesting: ALL
#

# erol.kahraman, users, accounts, kovan.io
dn: uid=erol.kahraman,cn=users,cn=accounts,dc=kovan,dc=io
givenName: Erol
sn: Kahraman
uid: erol.kahraman
cn: Erol Kahraman
displayName: Erol Kahraman
initials: EK
gecos: Erol Kahraman
krbPrincipalName: erol.kahraman@KOVAN.IO
objectClass: top
objectClass: person
objectClass: organizationalperson
objectClass: inetorgperson
objectClass: inetuser
objectClass: posixaccount
objectClass: krbprincipalaux
objectClass: krbticketpolicyaux
objectClass: ipaobject
objectClass: ipasshuser
objectClass: ipaSshGroupOfPubKeys
objectClass: mepOriginEntry
objectClass: ipantuserattrs
loginShell: /bin/sh
homeDirectory: /home/erol.kahraman
mail: erol.kahraman@kovan.io
krbCanonicalName: erol.kahraman@KOVAN.IO
ipaUniqueID: 49295cfa-9f12-11ec-a5bd-000c29753a2b
uidNumber: 986400003
gidNumber: 986400003
krbPasswordExpiration: 20220308190221Z
krbLastPwdChange: 20220308190221Z
krbExtraData:: AAI9qCdicm9vdC9hZG1pbkBLT1ZBTi5JTwA=
mepManagedEntry: cn=erol.kahraman,cn=groups,cn=accounts,dc=kovan,dc=io
ipaNTSecurityIdentifier: S-1-5-21-2385968081-1163531236-3748134971-1003
memberOf: cn=admins,cn=groups,cn=accounts,dc=kovan,dc=io
memberOf: cn=Replication Administrators,cn=privileges,cn=pbac,dc=kovan,dc=io
memberOf: cn=Add Replication Agreements,cn=permissions,cn=pbac,dc=kovan,dc=io
memberOf: cn=Modify Replication Agreements,cn=permissions,cn=pbac,dc=kovan,dc=
 io
memberOf: cn=Read Replication Agreements,cn=permissions,cn=pbac,dc=kovan,dc=io
memberOf: cn=Remove Replication Agreements,cn=permissions,cn=pbac,dc=kovan,dc=
 io
memberOf: cn=Modify DNA Range,cn=permissions,cn=pbac,dc=kovan,dc=io
memberOf: cn=Read PassSync Managers Configuration,cn=permissions,cn=pbac,dc=ko
 van,dc=io
memberOf: cn=Read Replication Changelog Configuration,cn=permissions,cn=pbac,d
 c=kovan,dc=io
memberOf: cn=Write Replication Changelog Configuration,cn=permissions,cn=pbac,
 dc=kovan,dc=io
memberOf: cn=Modify PassSync Managers Configuration,cn=permissions,cn=pbac,dc=
 kovan,dc=io
memberOf: cn=Read LDBM Database Configuration,cn=permissions,cn=pbac,dc=kovan,
 dc=io
memberOf: cn=Add Configuration Sub-Entries,cn=permissions,cn=pbac,dc=kovan,dc=
 io
memberOf: cn=Read DNA Range,cn=permissions,cn=pbac,dc=kovan,dc=io
memberOf: cn=Host Enrollment,cn=privileges,cn=pbac,dc=kovan,dc=io
memberOf: cn=System: Add krbPrincipalName to a Host,cn=permissions,cn=pbac,dc=
 kovan,dc=io
memberOf: cn=System: Enroll a Host,cn=permissions,cn=pbac,dc=kovan,dc=io
memberOf: cn=System: Manage Host Certificates,cn=permissions,cn=pbac,dc=kovan,
 dc=io
memberOf: cn=System: Manage Host Enrollment Password,cn=permissions,cn=pbac,dc
 =kovan,dc=io
memberOf: cn=System: Manage Host Keytab,cn=permissions,cn=pbac,dc=kovan,dc=io
memberOf: cn=System: Manage Host Principals,cn=permissions,cn=pbac,dc=kovan,dc
 =io
memberOf: cn=ipausers,cn=groups,cn=accounts,dc=kovan,dc=io

# search result
search: 2
result: 0 Success

# numResponses: 2
# numEntries: 1

I think this output will give you an information about LDAP schema.



[#] Thu Mar 10 2022 18:38:49 EST from bsdrob

Subject: Timestamps are wrong

[Reply] [ReplyQuoted] [Headers] [Print]

I'm sure it's been answered before, but I've found no way to search yet. New Citadel set-up on new Debian install. Both have time zones correctly set (CST), yet every post and calendar event displays in UTC. For example, I post at 5pm and the post is stamped 22:00, or a calendar entry set for 10am displays at 15:00. 



[#] Fri Mar 11 2022 05:35:02 EST from s3cr3to

Subject: can't reach port 25 from outside & where are the logs?

[Reply] [ReplyQuoted] [Headers] [Print]

LTDR;

How can I see if there is SMTP activity from outside to the server in this version with Docker?

A couple of days ago my citadel server crash.
Now I have a LXC debian+Turnkey/Docker + Citadel container.
I managed to send mails to the outside (gmail).
Even from a Linux terminal from home.
Turnkey had postfix enabled and prevented Citadel from using port 25, I disabled the postfix service and locally I can telnet to port 25.

From home I can telnet to the secure ports to send mail abroad from Citadel.

Two problems:
1) From outside I can't telnet to port 25 (Linux terminal).
2) From gmail I cannot send mails to this Citadel.

Note: I have another Citadel server (old) which can send mail to this new server. Of course, both are on the same NETWORK segment.
Note2: From Citadel itself I can send between internal accounts without any problem and abroad.

Note: I added a self-signed certificate without any problem.
Does it sound like this is a problem with my Firewall?

I have already 3 days trying to configure (several mail servers) and definitely Citadel is the simplest to implement. But this problem just stopped me.


Regards



[#] Fri Mar 11 2022 22:16:19 EST from s3cr3to

Subject: Re: can't reach port 25 from outside & where are the logs?

[Reply] [ReplyQuoted] [Headers] [Print]

Solved, the problem was our firewall.

Regards

Fri Mar 11 2022 05:35:02 AM EST from s3cr3to Subject: can't reach port 25 from outside & where are the logs?

LTDR;

How can I see if there is SMTP activity from outside to the server in this version with Docker?

...

Regards



 



[#] Sat Mar 12 2022 00:30:08 EST from smashbot64

Subject: PORTS!

[Reply] [ReplyQuoted] [Headers] [Print]

maybe not the point, but I am in the grouping that has repurposed their commodore dialup bbs systems to ones that communicate via telnet.

 

Speaking of which... can anyone suggest the easiest way to do something? i dont want to mess up my citadel install.

 

I run a website on apache2, it answers 80 and 443 via vhosts. DNS sends everything to an endpoint IP. I want to redirect everything that comes to port 1000 on mysite.com to port 1000 on an ip:1000 somewhere else (an external ip).

 

Most painless way?

 



[#] Sat Mar 12 2022 10:02:18 EST from IGnatius T Foobar

Subject: Re: LDAP Users

[Reply] [ReplyQuoted] [Headers] [Print]

I may have to set up FreeIPA to figure this out.

Go to page: First ... 9 10 11 12 [13] 14 15 16 17 ... Last