Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last
[#] Wed Feb 02 2022 12:00:03 EST from JFCM

Subject: I am new and lost about Doc and specially Wiki

[Reply] [ReplyQuoted] [Headers] [Print]

I am condiering to install Citadel on an Unbuntu test/home machine. My main interest lies in mediawiki farm and mails. I do not find where to have documentation about installing and running them under citadel?

Thx!



[#] Fri Feb 04 2022 14:33:49 EST from billpowell

Subject: new install problem

[Reply] [ReplyQuoted] [Headers] [Print]

I have just installed Citadel on Mint Linux 19.3 using the Software manager.  I used all the defaults.  I am unable to log in.  When I get to the login screen, there is a banner that says "You must be logged in to access this page."  Attempting to login using admin user name and password gets me back to the same page.  Using a different password bring up a Wrong Password message as one would expect.



[#] Fri Feb 04 2022 18:11:55 EST from IGnatius T Foobar

Subject: Re: new install problem

[Reply] [ReplyQuoted] [Headers] [Print]

Please advise what is "the software manager"? And what version of Citadel have you installed? To the best of my knowledge, Citadel is not available in any known Mint repository.

[#] Fri Feb 04 2022 18:19:47 EST from billpowell

Subject: Re: new install problem

[Reply] [ReplyQuoted] [Headers] [Print]

Never Mind. Installed using Easy Install and everything seems to be working.



[#] Fri Feb 04 2022 23:13:00 EST from IGnatius T Foobar

Subject: Re: new install problem

[Reply] [ReplyQuoted] [Headers] [Print]

Cool. I was thinking that if you found something in a repo, it was probably derived from the Debian one, which is very old and has probably been removed by now. Enjoy your new installation!

[#] Wed Feb 09 2022 19:42:24 EST from paulb

Subject: Mail attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Hey everyone,

 

I'm still struggling with this problem. I'm out of ideas of what to try. Everything else works perfectly.

 

Mail attachments wont receive correctly. I managed to send a text document attached, but ended up with text like the following; 

ensure that when the wor����2F��R��R�fR6��f�FV�6P��F�R&�6W72�B�W"��O�egrity.

 

There was no formatting in the original document.

I'm assuming this is why no other files are working correctly, the information is corrupted.

Citadel 939 with WebCit 939, server build 939

Running on raspberry pi 3b, raspbian.

Changed the max message length to more then enough aswell. No change.


Thanks,



[#] Fri Feb 11 2022 14:21:51 EST from s3cr3to to Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: Mail attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

There is an answer from ParanoidDelusions, maybe it is the answer to your problem.



On 2/9/22 17:42, paulb wrote:

Hey everyone,

 

I'm still struggling with this problem. I'm out of ideas of what to try. Everything else works perfectly.

 

Mail attachments wont receive correctly. I managed to send a text document attached, but ended up with text like the following; 

ensure that when the wor����2F��R��R�fR6��f�FV�6P��F�R&�6W72�B�W"��O�egrity.

 

There was no formatting in the original document.

I'm assuming this is why no other files are working correctly, the information is corrupted.

Citadel 939 with WebCit 939, server build 939

Running on raspberry pi 3b, raspbian.

Changed the max message length to more then enough aswell. No change.


Thanks,




[#] Sat Feb 12 2022 04:43:16 EST from agornik

Subject: Delete account

[Reply] [ReplyQuoted] [Headers] [Print]

Hey,

How can I delete my account on this forum ?

 



[#] Sat Feb 12 2022 10:54:48 EST from IGnatius T Foobar

Subject: Re: Delete account

[Reply] [ReplyQuoted] [Headers] [Print]

Are you looking to get off the mailing list? Go to https://uncensored.citadel.org/listsub and select the list and enter your email address.

[#] Sat Feb 12 2022 12:07:41 EST from blonk

Subject: New deployment: Outgoing email issues

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all, 

I have deployed an instance of Citadel in an Azure VM and configured how I think is all correct. 

Incoming email seems to be working; I can email my first new Citadel contact from an outside account and it arrives to the mailbox and opens ok.

I've got a problem with outgoing emails though. 

If I reply to the incoming test email, the outbound SMTP queue show the message, but it doesn't show the sender as what I would expect to see. 

It shows the sender as name@NODENAME rather than name@domain.co.uk

It sits in the processing queue for while, then disappears. My external email account never receives it (checked spam!)

I have updated the contact email address in the Primary Internet e-mail address correctly. I've done a number of restarts. 

Also, if I compose a brand new email from WebCit, as soon as I hit Send, WebCit fails with:

"This page isn't working at the moment. mail.domainname.co.uk didn’t send any data.

ERR_EMPTY_RESPONSE"

Any help is much appreciated



[#] Sat Feb 12 2022 14:59:03 EST from blonk

Subject: Re: New deployment: Outgoing email issues

[Reply] [ReplyQuoted] [Headers] [Print]

I've actually figured this out, I've added a SMTP smart host provider. Sorry for the noob question!

Can anyone recommend an android mail app that includes calendar functionality for mail accounts from Citadel?



[#] Sat Feb 12 2022 18:31:51 EST from blonk2

Subject: WebCit webmail emails

[Reply] [ReplyQuoted] [Headers] [Print]

OK, I had to create a new account as I must have had fat fingers when making my first account!

So my Citadel deployment is pretty much there. I can send / receive emails through IMAP / SMTP on multiple devices and apps which is all good, so I think port forwarding / DNS / SMTP relaying is all correct. 

The one issue which is driving me potty which I cant get my head around is that emails within WebCit webmail fail when composing new emails. 

If I go to compose a new email from with the webcit portal, and hit send, my browser returns:

"This page isn't working at the moment. mail.domain.co.uk didn’t send any data.

ERR_EMPTY_RESPONSE"

I can however respond to emails from the web portal. But they do not appear in the inbox.

Is this still a DNS related issues? Or port forwarding? Any help would be great. I couldnt find anything similar anywhere in the docs.

 

Many thanks

 



[#] Sun Feb 13 2022 16:25:59 EST from dxmann

Subject: Fresh install... citadel.socket not found

[Reply] [ReplyQuoted] [Headers] [Print]

Hello everyone!

I'm at the first use of citadel on a Unbuntu 20.04 server instance running on a RPi 3B+; Citadel is installed from the system repository.

After installed I can't load any page: webcit says to me:

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.

So I tried to use the command citadel but... 

Attaching to server...

[/var/run/citadel/citadel.socket]

Can't connect: No such file or directory

What ca I do? where is the problem?



[#] Tue Feb 15 2022 19:04:49 EST from IGnatius T Foobar

Subject: Re: Fresh install... citadel.socket not found

[Reply] [ReplyQuoted] [Headers] [Print]

Don't use the .deb packages. They are hopelessly outdated.

[#] Wed Feb 16 2022 00:54:27 EST from ParanoidDelusions

Subject: Re: Fresh install... citadel.socket not found

[Reply] [ReplyQuoted] [Headers] [Print]

Absolutely this. If you read back... I describe installing Citadel on a 3B using the Easy Install. It is the way to go - but it doesn't work quite the same on Raspberry OS as a true Debian. 

There might be a walkthrough in the files section here, with screenshots. I think I uploaded it here. See up above where it says 6 files below "Citadel Support" on the room header. That is where you get into the file section. 

I have documentation on file transfer in Citadel on my BBS at wallofhate.com too. 


Tue Feb 15 2022 19:04:49 EST from IGnatius T Foobar Subject: Re: Fresh install... citadel.socket not found
Don't use the .deb packages. They are hopelessly outdated.

 



[#] Wed Feb 16 2022 00:56:02 EST from ParanoidDelusions

[Reply] [ReplyQuoted] [Headers] [Print]

Somewhere I did a screen-by-screen screenshot of installing Citadel on Rpi 3B+ a few years ago, and published/uploaded it. Not sure where it is now. I think it was here on Uncensored. 

I may have a copy of it around somewhere still, too. 

 



[#] Wed Feb 16 2022 19:55:25 EST from IGnatius T Foobar

Subject: Re: Fresh install... citadel.socket not found

[Reply] [ReplyQuoted] [Headers] [Print]

I do believe the Citadel packages have been removed from the latest Debian.
Major kudos to the maintainer who kept it going for a very long time. It isn't really feasible anymore though, since we have dropped support for the LFSH, and I don't think Debian allows /opt or /usr/local style installations in the main repo.

In the future I would like the text client to return to the main repo after we make it a bit more portable.

At the present time, however, the most reliable installation is the Docker container. If you can't or won't run Docker, use Easy Install.

[#] Tue Feb 22 2022 16:56:58 EST from JeepNWilly

Subject: Citadel Database Files

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I just did an easy install into a Raspberry Pi to try and learn the system. I was wondering how would I go about changing the location of the database files so I cam move them to a larger storage device or to my NAS. Planning on using Citadel as my home based email server and did not want to have limited email space on the Pi's MicroSD card

Any help will be greatly appreciated



[#] Tue Feb 22 2022 18:18:38 EST from IGnatius T Foobar

Subject: Re: Citadel Database Files

[Reply] [ReplyQuoted] [Headers] [Print]

Your data files are in /usr/local/citadel/data

You can shut down the Citadel service, move that directory somewhere else, and make /usr/local/citadel/data a symbolic link to the new location. It'll do the right thing.

If you want to do it the "fancy" way, you can look at [ https://www.citadel.org/how_may_i_improve.html ] to learn how to explicitly configure a separate location.

[#] Wed Feb 23 2022 04:07:09 EST from mrlinux2u

Subject: Spamassassin rules

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I've just got Citadel up and running (using the easy install script) and everything's running fine except for one thing - Spamassassin, it's marking e-mails as SPAM in the e-mail headers but it's not modifying the Subject line as [****SPAM****] despite me changing the '/usr/share/spamassassin/local.cf' file accordingly (and running spamassassin --lint shows no errors in the file).

Does Citadel honour the local.cf file at all when checking e-mails for SPAM or does it have it's own internal file that needs changing?

I've tried googling for a solution but I've not found anything relevant so far, could someone point me in the right direction please if there is a solution and any help would be very much appreciated?

Regards

Paul



Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last