Language:
switch to room list switch to menu My folders
Go to page: First ... 25 26 27 28 [29] 30 31 32 33 34
[#] Sat Jun 05 2021 13:46:43 EDT from Nurb432

Subject: Re: AppImage releases of Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Sorry, exact error on the Jetson ->  bash: ./citadel-1622326264-armv7l.appimage: No such file or directory

 
and should this be over in the support room instead? i guess this is getting a bit OT for announcements now. Sorry.


[#] Sat Jun 05 2021 15:28:30 EDT from Nurb432

Subject: New App Images

[Reply] [ReplyQuoted] [Headers] [Print]

Figured its better than over here than in announcements.. 

Findings so far. ( all ARM )

  • In general 32bit images apparently wont run on 64bit Armbian or Ubuntu.  Just as a test i grabbed cura 32 bit for RPI and get the same inaccurate message "No such file or directory" i got with 32bit citadel on 64bit board.
  • 32bit image on 32bit Armbian gives me the same error regardless of cura or citadel:   AppImage: error while loading shared libraries: libz.so: cannot open shared object file: No such file or directory
  • I also tried 64 bit cura on 64bit Armbian, and got the same libZ message as i got on 32/32. So that also must be a Appimage thing. I woudl have expected those libraries to come from inside the image.  I do have libz installed, so i must research.   Once i sort that i suspect matching image to architecture will work.
  • I wonder if this is all due to the builds being built "for" RPI and mine being another OS.  Part of research to be done.


[#] Sat Jun 05 2021 15:53:11 EDT from IGnatius T Foobar

Subject: Re: 500 No such user on AUTH LOGIN

[Reply] [ReplyQuoted] [Headers] [Print]

I encountered this same authentication problem with version 931 built
via easy-install.  I think the problem is with
citadel/modules/smtp/serv_smtp.c where smtp_get_user(5) is called

Thanks again for submitting this fix. It has been tested and the mainline code has been patched.

Easy Install is updated, other distribution methods will follow shortly.

[#] Sat Jun 05 2021 16:25:47 EDT from Zandercraft

Subject: "didn't find Template [login] 5 5" and favicon.ico Not Found.

[Reply] [ReplyQuoted] [Headers] [Print]

Hey guys! I was successfully able to install Citadel a few days ago using the Easy Install process, as outlined in the documentation/installation instructions. It was quite an easy install and worked perfectly. I later deleted the three folders as mentioned in the docs since I wanted to test out some other software. I inevitably came to the conclusion the Citadel would be the best for me to use... I installed it again using the same process, but now I get the following error: "didn't find Template [login] 5 5". The Javascript console also shows that favicon.ico is "net::ERR_EMPTY_RESPONSE". I have tried re-installing about 3 times and it happens each time. I have tried reboots and  it still does not work. I am using a Raspberry Pi 2 Model B+ with Raspberry Pi OS 32-bit Lite. Thanks in advance!



[#] Sat Jun 05 2021 17:48:18 EDT from Nurb432

[Reply] [ReplyQuoted] [Headers] [Print]

Installing zlib1g-dev fixes the lib error when platform matches appimage. odd you have to do that on the host, shouldn't that all be packaged in the image? 



[#] Mon Jun 07 2021 16:07:16 EDT from Nurb432

[Reply] [ReplyQuoted] [Headers] [Print]

Just a warning i have NOT looked into this more yet. It starts, crashes and then repeats tying indefinitely.  I had this same issue with Armbian bullseye on the 32bit BPI but i figured i should put it back to buster and try it again.

This was running from a direct root login via ssh, not sudo/shell. Command line included.  

______________________

 

root@bananapim3:~# ./citadel-1622326264-armv7l.appimage run

ctdlvisor: Welcome to the Citadel System, brought to you using AppImage.

ctdlvisor: LD_LIBRARY_PATH = /tmp/.mount_citadegxy60w/usr/lib

ctdlvisor:            PATH = /tmp/.mount_citadegxy60w/usr/bin

ctdlvisor:          APPDIR = /tmp/.mount_citadegxy60w

ctdlvisor:  data directory = /usr/local/citadel

ctdlvisor:       HTTP port = 80

ctdlvisor:      HTTPS port = 443

ctdlvisor: citserver running on pid=2355

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/citadel/citserver with data directory /usr/local/citadel

ctdlvisor: webcit (HTTP) running on pid=2356

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/webcit/webcit

ctdlvisor: webcit (HTTPS) running on pid=2357

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/webcit/webcit

ctdlvisor: pid=2355 exited, status=139, exitcode=0

ctdlvisor: citserver crashed on signal 11

ctdlvisor: citserver running on pid=2358

ctdlvisor: executing /tmp/.mount_citadegxy60w/usr/local/citadel/citserver with data directory /usr/local/citadel

ctdlvisor: pid=2358 exited, status=139, exitcode=0

ctdlvisor: citserver crashed on signal 11

 

 

after killing it witha control-c:

 

 

^Cctdlvisor: caught signal 2

ctdlvisor: waiting for all child process to exit...

ctdlvisor: 2367 (Citadel Server) ended, status=139

ctdlvisor: waiting for all child process to exit...

ctdlvisor: 2356 (WebCit HTTP) ended, status=15

ctdlvisor: waiting for all child process to exit...

ctdlvisor: 2357 (WebCit HTTPS) ended, status=15

ctdlvisor: waiting for all child process to exit...

ctdlvisor: exit code 0

 
 


[#] Mon Jun 07 2021 21:06:51 EDT from Nurb432

[Reply] [ReplyQuoted] [Headers] [Print]

It must be me. somehow. I forgot i had an old PI 2 in a drawer ( was for BeePI emulator but sort of lost interest and dismissed it out of my head ). 

Current Raspbian 'lite'.. SSH over, sudo to a shell. Create the data folder.  Grab the rile via wget. Change permissions..... 'run'.. It didnt need the extra stuff the BPI needed. But same results, except it eventually died on its own ( perhaps i didnt wait long enough on the BPI ).   It dont like me.    *pout*



[#] Tue Jun 08 2021 15:30:40 EDT from tactyl

Subject: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

Como puedo instalar se servidos. gracias



[#] Tue Jun 08 2021 16:50:24 EDT from IGnatius T Foobar

Subject: Re: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

This is an English language forum.

[#] Tue Jun 08 2021 20:47:24 EDT from ParanoidDelusions

Subject: Re: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

Te quieren usar el "Easy Install" o "AppImage" y por cual OS? Es muy facil, actualamente. Disafortunademente, mi espanol es muy terible - pero yo atemptar ayudar con la asistiencia de Google Translate.  

Tue Jun 08 2021 15:30:40 EDT from tactyl Subject: problemas

Como puedo instalar se servidos. gracias



 



[#] Tue Jun 08 2021 20:47:59 EDT from ParanoidDelusions

[Reply] [ReplyQuoted] [Headers] [Print]

Si se hablan espanol ahora, Ig. ;) 

 



[#] Tue Jun 08 2021 20:50:52 EDT from ParanoidDelusions

[Reply] [ReplyQuoted] [Headers] [Print]

Tactyl - "Easy-Install" es aqui: 

https://citadel.org/download.html

 

Y es un script que instala Citadel automáticamente

Pero el method de instala se preferen en el futuro es "AppImage". 



[#] Wed Jun 09 2021 10:56:27 EDT from s3cr3to to tactyl <tactyl@uncensored.citadel.org>, Citadel_Support <room_Citadel_Support@uncensored.citadel.org>

Subject: Re: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

En esta página encuentras los metodos para instalar.
https://citadel.org/download.html

Actualmente el metodo recomendado es con easy-install, las instrucciones están aquí:
https://citadel.org/easyinstall.html

El metodo más sencillo es con AppImage actualmente en fase beta, pero está funcionando muy bien.

Te recomendaría usar el AppImage para vayas conociendo el servidor Citadel; al final este será el método recomendado.

Solo debes descargar para tu arquitectura de: https://citadel.org/appimage.html
# wget http://easyinstall.citadel.org/citadel-1623018599-x86_64.appimage

hacerlo ejecutable
# chmod +x citadel-1623018599-x86_64.appimage

Si lo corres sin parametros te dice cuales comandos soporta
# ./citadel-1620778956-x86_64.appimage
Unexpected command:
citadel-1620778956-x86_64.appimage: usage: citadel-1620778956-x86_64.appimage [-h data_directory] [-p http_port] [-s https_port] command
command must be one of: run, test, install, database_cleanup, migrate

Primero usar el parametro "test" para saber si tu sistema es compatible.
# ./citadel-1620778956-x86_64.appimage test

Luego puedes hacer pruebas usando "run" para que lo vayas conociendo.
# ./citadel-1620778956-x86_64.appimage run
Ya que lo conozcas bien y estes conforme con el, puedes instalarlo (install) para que se ejecute automaticamente al reiniciar tu servidor, o cuando se libere la AppImage definitiva.

Recomendaciones adicionales:
Instalar y configurar el antivirus (clamav), spamassassin, RBL hosts (zen.spamhaus.org)
Opcionalmente instalar y configurar UFW. Esto con la finalidad de protejerte de los script-kiddies que andan buscando servidores de correo abiertos.

IMPORTANTE:
Activa la siguiente opción, esto evitará que cualquiera que logré accesar tu servidor haga su propia cuenta de correo.




On 6/8/21 1:30 PM, tactyl wrote:

Como puedo instalar se servidos. gracias




[#] Wed Jun 09 2021 12:13:00 EDT from ParanoidDelusions

Subject: Re: problemas

[Reply] [ReplyQuoted] [Headers] [Print]

Gracias por el espanol mas fluente, S3cr3to. ;) 

 

Wed Jun 09 2021 10:56:27 EDT from s3cr3to Subject: Re: problemas
En esta página encuentras los metodos para instalar.
https://citadel.org/download.html

Actualmente el metodo recomendado es con easy-install, las instrucciones están aquí:
https://citadel.org/easyinstall.html

El metodo más sencillo es con AppImage actualmente en fase beta, pero está funcionando muy bien.

Te recomendaría usar el AppImage para vayas conociendo el servidor Citadel; al final este será el método recomendado.

Solo debes descargar para tu arquitectura de: https://citadel.org/appimage.html
# wget http://easyinstall.citadel.org/citadel-1623018599-x86_64.appimage

hacerlo ejecutable
# chmod +x citadel-1623018599-x86_64.appimage

Si lo corres sin parametros te dice cuales comandos soporta
# ./citadel-1620778956-x86_64.appimage
Unexpected command:
citadel-1620778956-x86_64.appimage: usage: citadel-1620778956-x86_64.appimage [-h data_directory] [-p http_port] [-s https_port] command
command must be one of: run, test, install, database_cleanup, migrate

Primero usar el parametro "test" para saber si tu sistema es compatible.
# ./citadel-1620778956-x86_64.appimage test

Luego puedes hacer pruebas usando "run" para que lo vayas conociendo.
# ./citadel-1620778956-x86_64.appimage run
Ya que lo conozcas bien y estes conforme con el, puedes instalarlo (install) para que se ejecute automaticamente al reiniciar tu servidor, o cuando se libere la AppImage definitiva.

Recomendaciones adicionales:
Instalar y configurar el antivirus (clamav), spamassassin, RBL hosts (zen.spamhaus.org)
Opcionalmente instalar y configurar UFW. Esto con la finalidad de protejerte de los script-kiddies que andan buscando servidores de correo abiertos.

IMPORTANTE:
Activa la siguiente opción, esto evitará que cualquiera que logré accesar tu servidor haga su propia cuenta de correo.




On 6/8/21 1:30 PM, tactyl wrote:

Como puedo instalar se servidos. gracias




 



[#] Sat Jun 19 2021 13:34:28 EDT from Nurb432

Subject: Appimages - try 2

[Reply] [ReplyQuoted] [Headers] [Print]

Thought id try the appimages again today.

x86 is working like i expect, from a 'user' view, on a quick install of Devuan 4/alpha. Before i start back with ARM 32 ( since 64 just isn't going to work ), i assume at the least it should work with latest 32bit Raspbian out of the box? right? That is what i had the other day when it kept crashing and restarting.  ( after i tried it on Armbian 10/11 on the BPI with same results once i fixed the missing libraries )

Not really done any troubleshooting with appimages before, i assume its got a log or something i can grab?



[#] Mon Jun 21 2021 13:06:09 EDT from johno

Subject: admin password

[Reply] [ReplyQuoted] [Headers] [Print]

I have installed citadel but during the install process it did not prompt to put in a password for user admin or citadel. Is there a default password or a way to change them ?



[#] Mon Jun 21 2021 14:10:03 EDT from IGnatius T Foobar

Subject: Re: admin password

[Reply] [ReplyQuoted] [Headers] [Print]

Out of the box: username admin, password citadel

[#] Tue Jun 22 2021 16:33:08 EDT from cyberlaw

Subject: Re: IP Based Relaying thru Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Jun 02 2021 13:24:18 EDT from cyberlaw Subject: IP Based Relaying thru Citadel

I've had to abandon my HMAIL server (Windows XP PRO issues activating)

I have installed a Debian system with Citadel. I am looking to do some relaying of email from specific IP addresses from old devices that cannot handle auth.

Is it possible thru Citadel and can it be done via the web manager? Or will it have to be done via CLI?



Time to dump Citadel and move on to something else.... no support here!



[#] Tue Jun 22 2021 16:48:26 EDT from Nurb432

Subject: Re: IP Based Relaying thru Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Or, those of us who were reading didnt have an answer for you.

Far different situation than 'no support here' 

Tue Jun 22 2021 04:33:08 PM EDT from cyberlaw Subject: Re: IP Based Relaying thru Citadel

 

Time to dump Citadel and move on to something else.... no support here!


 



[#] Tue Jun 22 2021 23:08:27 EDT from ParanoidDelusions

Subject: Re: IP Based Relaying thru Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

If I had an answer, I would have given it to him. 

I barely understood the question. 

 

Tue Jun 22 2021 16:48:26 EDT from Nurb432 Subject: Re: IP Based Relaying thru Citadel

Or, those of us who were reading didnt have an answer for you.

Far different situation than 'no support here' 

Tue Jun 22 2021 04:33:08 PM EDT from cyberlaw Subject: Re: IP Based Relaying thru Citadel

 

Time to dump Citadel and move on to something else.... no support here!


 



 



Go to page: First ... 25 26 27 28 [29] 30 31 32 33 34