switch to room list switch to menu My folders
Go to page: First ... 30 31 32 33 [34]
[#] Tue Feb 13 2018 14:50:11 EST from fleeb @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Wait... Python? Seriously? I thought it was R.

[#] Wed Feb 14 2018 12:34:46 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

There are a few high-profile people (esr is one of them) who claim that Rust and Go are now where it's at. But we've heard that song before. Python is still the perennial favorite among open source types.

[#] Wed Feb 14 2018 13:56:16 EST from pandora @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

So, somebody wrote a tool to do exactly what I wanted in Go. (The tool is Vuls.) I got an ansible playbook written to deploy it, [29~and then as part of our DR testing, I blew the server away, and ran the installation playbook again. It wouldn't install, because the new version of go wouldn't work with the whatevert, and it was just a big hassle if I was going to have to update the playbook anytime there was an update.

[#] Wed Feb 14 2018 14:24:25 EST from fleeb @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I've heard this assertion concerning Go, although not Rust.

Although, I haven't had my ear as close to the cacaphony as perhaps I should.

At the end of the day, I don't generally care about the language requirements... I'll work with whatever. Although, I might draw the line at Perl. A line that looks suspiciously like:


[#] Wed Feb 14 2018 14:59:49 EST from LoanShark @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

No ansible here, I guess we've settled on terraform as (what I assume to be) an equivalent

[#] Fri Feb 23 2018 09:28:05 EST from fleeb @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

So, there's this thing.. the 'debian policy' document. You can find it here:


It's supposed to help clarify lots of information related to creating debian packages.

Skip down to 2.2.2., "The contrib archive area", and witness how well they clarify things.

"Every package in /contrib/ must comply with the DFSG."

No link there on the acronym "DFSG".

Imagine someone not skilled in the art of creating debian packages (say... me?) stumbles into a document with this in it. Would they think to look up at 2.2.1. and find that the acronym means "Debian Free Software Guidlines"?
Would they think to click on the [3], jumping to some random area of the document where there's another link to 'REJECT-FAQ' "which details the project's current working interpretatin of the DFSG"? Would they continue through the labyrinth to follow that link to the 90s-esque web page that kinda makes all of this feel more like a legal document and less like a technical one?

Or would they just toss their hands up in the air, quietly scream inside, and just do whatever the fuck they want anyway?

[#] Fri Feb 23 2018 10:28:54 EST from LoanShark @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Developers can't read or write English, particularly the aspies that dominate free software development, so I'm leaning towards "do whatever the fuck."

[#] Sun Feb 25 2018 21:49:22 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I'm still waiting for Stallman to start complaining that I modified the version of the GPL that I use, even though it says "changing it is not allowed." 

Go to page: First ... 30 31 32 33 [34]