Language:
switch to room list switch to menu My folders
Go to page: First ... 5 6 7 8 [9] 10 11 12 13 ... Last
[#] Tue Mar 10 2020 09:14:28 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Please unsub me

[Reply] [ReplyQuoted] [Headers] [Print]

PLEASE UNSUB ME FROM THIS LIST!!!!

Your unsub form on the website doesnt work so an admin will have to do

it. My email is gamept@game-point.net

So just for fun, I went to the unsubscribe page [ http://uncensored.citadel.org/listsub ] and put in your email address, and selected "Unsubscribe". Then I went into the email queue and clicked the confirmation link on the confirmation email that it sent to you.

Do you know what happened? It unsubscribed you. Actually I don't know why I am writing this message as if you're reading it, because it unsubscribed you.

So for everyone else:
1. Be it hereby resolved, that the list subscribe/unsubscribe page works, and works perfectly
2. Be it hereby resolved, that Jeremy Morton is a moron.

I have no patience for people who can't read simple instructions.

[#] Wed Mar 11 2020 17:03:51 EDT from Falco @ Uncensored

Subject: Re: Webcit - File Uploads Corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Feb 14 2020 09:48:35 EST from IGnatius T Foobar @ Uncensored Subject: Re: Webcit - File Uploads Corrupted
Falco: thanks for posting the corrupted version of the upload. We'll have a look at it
!

Found anything yet? As I said it's arm64 (aarch64) on ubuntu (19.10) server (64 bit). It's all running on a raspberry pi 4. if you need any more info please ask.
How about switching to github? It'd make managing issues a lot easier, you get version control and outside people can handle the code easier.
Also how about those tooltips (html title attribute) for those settings and options?



[#] Sun Mar 15 2020 10:11:29 EDT from Knocks @ Uncensored

Subject: Failed ports

[Reply] [ReplyQuoted] [Headers] [Print]

Hello, I installed Citadel using the easyinstall script but now I'm having problems with the ports:
The after installing it the installer gives me this output:

The failed ports and sockets are: extensions: TCP port *:504: (citadel-TCP) ;extensions: TCP port *:143: (IMAP) ;extensions: TCP port *:993: (IMAPS) ;extensions: TCP port *:119: (NNTP) ;extensions: TCP port *:563: (NNTPS) ;extensions: TCP port *:110: (POP3) ;extensions: TCP port *:995: (POP3S) ;extensions: TCP port *:25: (SMTP-MTA) ;extensions: TCP port *:465: (SMTPs-MTA) ;extensions: TCP port *:587: (SMTP-MSA)

but if I try using sudo netstat -lnp | grep <port> I get nothing, so that would mean they aren't used.
Any help?



[#] Mon Mar 16 2020 06:27:55 EDT from IncorrectPassword @ Uncensored

Subject: Re: Not seeing new messages in webcit

[Reply] [ReplyQuoted] [Headers] [Print]

So I tried doing a search for a sender, and in that view the newer messages were showing, Just not if I do an all messages view sorted by date.


Is there some sort of limit (coded or otherwise) with the number of messages the web view will be able to process and show?



[#] Thu Mar 19 2020 05:24:51 EDT from StonedMind @ Uncensored

Subject: Re: Using Let's Encrypt Certificates for TLS based connections

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I would like to come back to this topic as I'm still facing those issues. I would like to make my citadel be able to establish/answer STARTTLS based connections (submission port 587 AND smtp port 25) using certificates provided by my ISP (Let's encrypt)

I followed the instructions on the documentations page (http://www.citadel.org/doku.php?id=faq:systemadmin:how_to_install_a_certificate_signed_by_a_recognized_certificate_authority) and I copied the key pair (public + private key) into /etc/ssl/citadel and I renamed them to citadel.cer and citadel.key.

After that I restarted the citadel service using sudo service citadel restart.

However, I was able to get unix machine and to try to establish an TLS connection using openssl, where I could clearly see, that the wrong certificate is used

openssl s_client -connect my-ip-address:587 -starttls smtp
CONNECTED(00000003)
depth=0 C = ZZ, ST = The World, L = My Location, O = Generic certificate, OU = Citadel server, CN = *
verify error:num=18:self signed certificate
verify return:1
depth=0 C = ZZ, ST = The World, L = My Location, O = Generic certificate, OU = Citadel server, CN = *
verify return:1
---
Certificate chain
 0 s:/C=ZZ/ST=The World/L=My Location/O=Generic certificate/OU=Citadel server/CN=*
   i:/C=ZZ/ST=The World/L=My Location/O=Generic certificate/OU=Citadel server/CN=*
---
Server certificate
-----BEGIN CERTIFICATE-----
MIIDaDCCAlACAQAwDQYJKoZIhvcNAQEEBQAwejELMAkGA1UEBhMCWloxEjAQBgNV
BAgMCVRoZSBXb3JsZDEUMBIGA1UEBwwLTXkgTG9jYXRpb24xHDAaBgNVBAoME0dl
bmVyaWMgY2VydGlmaWNhdGUxFzAVBgNVBAsMDkNpdGFkZWwgc2VydmVyMQowCAYD
VQQDDAEqMB4XDTE5MDgxNTA4MzQ1NloXDTI5MDgxMjA4MzQ1NlowejELMAkGA1UE
BhMCWloxEjAQBgNVBAgMCVRoZSBXb3JsZDEUMBIGA1UEBwwLTXkgTG9jYXRpb24x
HDAaBgNVBAoME0dlbmVyaWMgY2VydGlmaWNhdGUxFzAVBgNVBAsMDkNpdGFkZWwg
c2VydmVyMQowCAYDVQQDDAEqMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKC
AQEAzazFQH4/H/2Oa3p0cuSPuEvU4kbEq3L7lHU3Fl+Ardz+/S4E8QB4GSdWsU0R
rXzS/kSY/R//KSSso+ev0nuDqIzTqY1LPcENt2OGs4vPy2sU/iKADt9wks6+3f3C
LuRYaQQi15ZIAZnFTO9V5Yv3CRQjtRbbJJU9hJ3VJ+zdZpaWanEeVuz3/6BScG2V
TI4SSAuHbamOzlnkf4DnXGH/paMDKWVOkMYijLIJAT2jaOOkQHbeoVrdxv16rUZE
a0J3m/a/HJaXbOLzvA56b+PhT+3WCwS0yWp3NjBSU4e40cHZHXr7CshPMc6+adrD
hBOOvOh4PXAGCss2BzE4voffPwIDAQABMA0GCSqGSIb3DQEBBAUAA4IBAQB6uQNh
tsn3+U/v2eQ/FYQDirf61TI/+pCXwRkE59CVQ73obPziT0hvQMAyrRNgdtwK/VsS
7VBpsV0r3zEyMTz5gIvONrsZbHl1cEnt/mV6EGCq8sRZXVOxH2Zf1SmkmrmFdoFI
z5a98NzW5VQuuEjPd2Ds9FvbiZOap5px+wdbvwd7vjZartM746gE2MywvlsTrlWu
D98aYhqA3BLy+LjJO4Lp6+eFbnLvr3i54/+1GR7qr+w7/KXy44zW3L0BGPogg+bG
lH0kMj6j+roJAvcuq2t1Xc7xitPjUdImy54Ox2F6269iupkLT5VRzKIno+wBhZS6
GOXYXuPGAdZyzrLG
-----END CERTIFICATE-----
subject=/C=ZZ/ST=The World/L=My Location/O=Generic certificate/OU=Citadel server/CN=*
issuer=/C=ZZ/ST=The World/L=My Location/O=Generic certificate/OU=Citadel server/CN=*
---
No client certificate CA names sent
Peer signing digest: SHA512
Server Temp Key: ECDH, P-256, 256 bits
---
SSL handshake has read 1780 bytes and written 463 bytes
---
New, TLSv1/SSLv3, Cipher is ECDHE-RSA-AES256-GCM-SHA384
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : ECDHE-RSA-AES256-GCM-SHA384
    Session-ID: 0F53FA4338C40B28B8755C94B3490D2BF6DE3EEB521C8FDC81F37928D89DA671
    Session-ID-ctx:
    Master-Key: C0B01C57B35CC0DF2A9555D3A53A84E1A1113AECD57B46E7D9CBAD1E7BC1FB0A020B6AF14284ED13FF8BC4F0709FA70A
    Key-Arg   : None
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    TLS session ticket lifetime hint: 7200 (seconds)
    TLS session ticket:
    0000 - ab 7f 18 87 9e f9 04 15-ae 5b 3a 98 7a 46 00 92   .........[:.zF..
    0010 - 36 20 18 df b5 2a d8 c4-23 1c 43 f9 db 34 4b f9   6 ...*..#.C..4K.
    0020 - 5a df 0e 74 40 14 3d d2-25 6d 31 27 7f 40 e9 03   Z..t@.=.%m1'.@..
    0030 - 7b 9c 12 85 89 71 8b a9-62 3b 5e 3a 26 2d f4 7d   {....q..b;^:&-.}
    0040 - 89 22 ef c6 14 3b b7 f4-97 9e 11 e8 84 43 d9 0c   ."...;.......C..
    0050 - 98 a5 85 84 81 8d 4c 39-57 05 c2 73 92 3c 6a 45   ......L9W..s.<jE
    0060 - ae c9 68 48 e2 86 76 66-e8 15 9b 75 94 07 5e 4c   ..hH..vf...u..^L
    0070 - f9 c4 02 da f4 bb 14 58-f1 11 14 f4 77 9e 16 7c   .......X....w..|
    0080 - 3b 57 23 32 f8 15 a3 8c-43 0a 07 70 b6 2f 3e ec   ;W#2....C..p./>.
    0090 - b6 5c 48 5b e2 a2 53 18-64 a3 16 05 61 20 59 d4   .\H[..S.d...a Y.

    Start Time: 1584555723
    Timeout   : 300 (sec)
    Verify return code: 18 (self signed certificate)
---
250 8BITMIME

  • How could this happen? I deleted the old "default" certificates from /etc/ssl/citadel, so where do those certificates come from?
  • What's behind the folder /etc/ssl/certs? Are those the trusted CAs?
  • What's the purpose of /etc/ssl/openssl.cnf file?
Beside that, why does citadel not announce STARTTLS after incoming EHLO on port 25?
 
Any help will be appreciated.





[#] Fri Mar 20 2020 15:22:33 EDT from StonedMind @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sat Feb 15 2020 21:58:03 EST from MAS3 @ Uncensored Subject: Re: Mail aliases limited ?

So i started to do this right away.

Made a test user and copied the alias test1@mydomain.com 50 times (or thought i did).

Then i started to edit the number so that i would end up with aliases test1 to test 50.
But when i was at the number 10, i couldn't add characters anymore.
That field seems limited to 512 characters, and thus limiting the number of aliases after all.
In this test case, it limits the number of aliases to 24.
And they seem to work for this new test user, sent and received an external mail to test23@mydomain.com.

Both users i tried to add aliases to, should have space to add at least 1 alias to the list of 512 characters, but still there's trouble in getting that done.
So there must be something else that's going wrong, and i'm assuming it's me doing something wrong here.

 

 



Hi MAS3,

I'm facing quite the same issues concerning those aliases. I'm not using that many aliases like you do, but nevertheless they disappear totally randomly. As a workaround I'm checking every day whether the aliases have been disappeared or not, which is horrible. Furthermore the documentation seems to be quite poor, just like for other topics in Citadel as well...

Anyway...

Does anybody know in which file should those aliases appear? Sometimes I have the feeling that the Web-GUI of the admin page does not really transmit the changes, only after a service restart of Citadel.

Hope you'll get forward with this. I will try also my very best and as soon as I have a solution I'm going to post this here.

Cheers,

StonedMind

 



[#] Mon Mar 23 2020 17:23:42 EDT from SteinTheRuler @ Uncensored

Subject: Access admin interface from external browser

[Reply] [ReplyQuoted] [Headers] [Print]

How can I access the Citadel admin web interface from an external browser? I've tried to open the port used in the firewall, but without luck.

 

BR,

Stein



[#] Tue Mar 24 2020 16:07:21 EDT from darknetuser @ Uncensored

Subject: Re: Access admin interface from external browser

[Reply] [ReplyQuoted] [Headers] [Print]

2020-03-23 17:23 from SteinTheRuler
Subject: Access admin interface from external browser
How can I access the Citadel admin web interface from an external
browser? I've tried to open the port used in the firewall, but
without luck.

First of all, you have to ensure that Webcit is running. Then you just connect to the ports webcit is using.

[#] Fri Mar 27 2020 23:20:16 EDT from lucagiacometti @ Uncensored

Subject: unexpected answer from Citadel server.

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I've successfully installed citadel, but when i try to connect to the static ip address of my raspberry pi 3, it shows this error message:

Received unexpected answer from Citadel server; bailing out.

Also, when trying to open the citadel-server setup from terminal, the output said that the setup could not connect to a running citadel server: denied acces /var/run/citadel/citadel-admin.socket.

Anyone can help?

Thanks for your patience



[#] Sat Mar 28 2020 02:21:16 EDT from Blizz @ Uncensored

Subject: Forwarding of email with attachment

[Reply] [ReplyQuoted] [Headers] [Print]

If I forward an email with an attachment in Citadel will there be 2 files of the same? Will forwarding an attachment create a copy of the file?

Best regards,

Blizz



[#] Mon Mar 30 2020 15:58:38 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Failed ports

[Reply] [ReplyQuoted] [Headers] [Print]

The after installing it the installer gives me this output:

The failed ports and sockets are: extensions: TCP port *:504:
(citadel-TCP) ;extensions: TCP port *:143: (IMAP) ;extensions: TCP

Hopefully you are running the Citadel Server as root? It needs root to bind those ports.

Otherwise, binding the ports could be stopped by SElinux or some other security agent.

[#] Tue Mar 31 2020 12:29:05 EDT from KimValentine @ Uncensored

Subject: cursor still in progress on cdb 02: attempt to write during r/o cursor

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Guys, I hope you can help.

I am attempting to migrate an old Citadel server that I have had running on a raspberry pi since 2012.

Now I have successfully followed the EasyInstall process and got an empty server running.

But on exporting the data from the running server, and importing on the new server I get the following :

citserver[7422]: room_ops: CtdlCreateRoom(name=Lobby, type=0, view=0)
citserver[7422]: room_ops: cannot create room <Lobby> - already exists
citserver[7422]: room_ops: CtdlCreateRoom(name=Aide, type=3, view=0)
citserver[7422]: room_ops: cannot create room <Aide> - already exists
citserver[7422]: room_ops: CtdlCreateRoom(name=Local System Configuration, type=3, view=0)
citserver[7422]: room_ops: cannot create room <Local System Configuration> - already exists
citserver[7422]: room_ops: CtdlCreateRoom(name=Trashcan, type=0, view=0)
citserver[7422]: room_ops: cannot create room <Trashcan> - already exists
citserver[7422]: Seeding the pseudo-random number generator...
citserver[7422]: master_startup() finished
citserver[7422]: control: sanity checking the recorded highest message and room numbers
citserver[7422]: control: fixing MMnextroom 13 > 0 , found in 0000000009.Calendar
citserver[7422]: db: cursor still in progress on cdb 02: attempt to write during r/o cursor
citserver[7422]: db: citserver is stopping in order to prevent data loss. uid=0 gid=0 euid=0 egid=0

 

running undet gdb I get the following backtrace

#0  bailIfCursor (cursors=0x4be704 <masterTSD+4>, msg=0x475b34 "attempt to write during r/o cursor") at database.c:144
#1  0x00411be3 in cdb_store (cdb=13, ckey=0x475eec, ckeylen=10, cdata=0x5bec30, cdatalen=14) at database.c:469
#2  0x00416749 in CtdlSetConfigStr (key=0x475eec "MMnextroom", value=0xbfffc2e0 "13") at config.c:357
#3  0x004167a4 in CtdlSetConfigLong (key=0x475eec "MMnextroom", value=13) at config.c:369
#4  0x00412f03 in control_find_highest (qrbuf=0xbfffc518, data=0x0) at control.c:64
#5  0x00417fa7 in CtdlForEachRoom (CB=0x412e6b <control_find_highest>, in_data=0x0) at room_ops.c:657
#6  0x0041329d in check_control () at control.c:155
#7  0x0040832d in main (argc=2, argv=0xbffff754) at server_main.c:255

So bailIfCursor is going to cdb_abort() if there are any not null cursors. Since  CtdlForEachRoom is iterating around a cursor this test will always fail.

but cbd_store only calls bailIfCursor if there is no transaction.

So it seems to me the answer to this issue would be to put a transaction around the loop in CtdlForEachRoom.

This is the first time Ive looked at this code, so I could be making a big mistake, but could anyone who knows the code tell me if I am on the right track.

While investigating i found that setting sanity_diag_mode to 2  (-s2 in the command line)

allows the server to start and the log then contains many lines of the form:

citserver[7426]: control: fixing MMhighest 58110 > 0 , found in Aide

citserver[7426]: control: fixing MMhighest 59355 > 0 , found in Aide
citserver[7426]: control: fixing MMhighest 59648 > 0 , found in Aide

So it looks as though import does not set these  high index values.

So I would really like some advice should I

a) just use the -s2 flag and forget about the warnings

b) put in a cdb_begin_transaction /cdb_end_transaction in CtdlForEachRoom

c) Try to work out why  ./sendcommand "MIGR import" doesnt set these counts.

Ive limited time since my original raspberry Pi file system is 97% full

Regards

Kim

 



[#] Wed Apr 01 2020 13:27:45 EDT from KimValentine @ Uncensored

Subject: Re: cursor still in progress on cdb 02: attempt to write during r/o cursor

[Reply] [ReplyQuoted] [Headers] [Print]

Further info :

I put a cdb_begin_transaction() and cdb_end_transaction()  around the call to CtdlForEachRoom in check_control, and the server starts!

I decided that changing CtdlForEachRoom may cause problems because it is called from multiple places, unlike check_control which only seems to be called at startup. My intention is to start the migration again from scratch and attempt to document every step.

Rgds Kim



[#] Tue Apr 07 2020 10:49:01 EDT from davew @ Uncensored

Subject: configuration help needed for raspberry pi rnning buster

[Reply] [ReplyQuoted] [Headers] [Print]

So, here's a brief descriotion of my problem. I followed the instructions here:- https://pimylifeup.com/raspberry-pi-email-server/

Installation seems to go ok, web page is up etc but can't connect via imap, pop3 etc, did some digging, found a nice error message in my console when i restart the service via the webpage saying couldn't bind the required ports, running the setup again fixes the problem but what ever the issue is the fix isn't saved so on the next restart the poblem is back.

I also notice things don't seem to be where they should be, etc/citadel/netconfigs doesn't get created for one and the other thing is usr/lib/citadel-server/setup isn't there, I have usr/local/citadel/setup

Am I following out of date instructions, I found the site i was following for instructions after trying to following the easy setup instrutions on here which for me failed everytime, I've tried installing as root and creating the citadel user name as the site says but it doesn't make any difference.

Any help would be very much appreciated, I'm new to linux so this is a very steep learning curve for me so please be gentle

 

TIA

Dave

 



[#] Tue Apr 07 2020 13:12:11 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

I'm facing quite the same issues concerning those aliases. I'm not
using that many aliases like you do, but nevertheless they disappear

I have confirmed this bug and will look into it immediately. From what I can tell, the list of aliases for a user is only corrupted when you edit it.
More on this shortly.

[#] Tue Apr 07 2020 14:41:54 EDT from davew @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Well I've just done a complete fresh O/S install, all updates etc done wiith root login, then followed this:- http://www.citadel.org/doku.php?id=installation:easyinstall:prereq-debian.html to the letter again as root login, all ports are active until you restart the service then most of them are unavailable - so glad I'm not going mad !!

I look forward to a fix



[#] Wed Apr 08 2020 17:52:38 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

Ok, the fix is complete. If you run Easy Install again you will receive version 929 of Citadel Server, which has been repaired and thoroughly tested to resolve the issue with email aliases disappearing when you try to add/change/remove them.

It was a silly bug, really, and looking back I realize that I've personally been bitten by it recently. When you add an email alias for a user, it feeds back the complete list of addresses to the server, and the server says "no you can't have ajc@example.com because someone else already has that" but the "someone else" is actually you. (Definitely a "brown paper bag over my head" kind of bug.)

Anyway, the fix is now available, share and enjoy.

[#] Wed Apr 08 2020 17:55:26 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Mail aliases limited ?

[Reply] [ReplyQuoted] [Headers] [Print]

By the way, if you need a workaround before you upgrade...

* Rest assured that email aliases will not disappear except when you try to add/change/remove them.

* If you need to make changes and you haven't upgraded to Citadel Server 929 yet:

1. Edit the user once, and remove ALL of their email addresses.
2. Then edit the user a second time, and put in all of the addresses you want.

This will allow all of the addresses to remain configured.

[#] Sun Apr 12 2020 18:33:52 EDT from koelbli @ Uncensored

Subject: smarthosts with smpts ssl/tls/465

[Reply] [ReplyQuoted] [Headers] [Print]

Hi everyone,

 

My ISP will switch off support for STARTTLS on port 587 for Smarthosts.

Only SMTPS SSL/TLS on port 465 will be supported.

What needs to be configured on citadel to make that work?

 


[#] Sun Apr 12 2020 19:42:24 EDT from kamran @ Uncensored

Subject: SMTP not working

[Reply] [ReplyQuoted] [Headers] [Print]

Hi team i am new to this 

i have installed citadel server on raspberry pi 

i can view portal from outside but when i try to send email it gives me below error

 

This page isn’t working


pls help


Regards


KS



Go to page: First ... 5 6 7 8 [9] 10 11 12 13 ... Last