Language:
switch to room list switch to menu My folders
Go to page: First ... 10 11 12 13 [14] 15 16 17 18 19
[#] Fri May 17 2019 03:15:55 EDT from jorge @ Uncensored

Subject: Re: Installing citadel in alpine linux with easy install

[Reply] [ReplyQuoted] [Headers] [Print]

Hi again,

after installation in alpine container, citadel server is running correctly, but webcit segfaults on launch with this message in syslog

webcit[1869]: segfault at 0 ip 00007fa1ea2e85d0 sp 00007ffd6bef4cd0 error 4 in ld-musl-x86_64.so.1[7fa1ea2dc000+45000]

When launched interactively in the command line. When launched demonize it will keep respawining but would never be able to acquire a network port

I will try an ubuntu easyinstall and an alpine git install to try to diagnose the origin. Any pointers would be wellcome.

Regards,

Jorge

 

 



[#] Fri May 17 2019 12:43:48 EDT from loneuser @ Uncensored

Subject: Spam Assasian

[Reply] [ReplyQuoted] [Headers] [Print]

I've just installed spamassassin after using citadel for a number of years. When the spam score exceeds the spam level i set in spamassassin, the mail is just rejected. Is there a way citadel will file it to another folder (or a way to configure spamassassin to do this) rather than just reject? I'm also trying to get the spam score added to the subject / mail headers but haven't been able to do so despite changes to the local.cf file.



[#] Fri May 17 2019 14:50:13 EDT from sami.salehsicpa.com @ Uncensored

Subject: General Questions about Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

I have the following questions about Citadel:

  • Can multi-language support be presented at the login page instead of after?
  • Can we eliminate self-registration?
  • Can we hide some features we don't wish to support - calendar, notes, tasks, view users currently logged in, self-configuration of visible features?
  • Can we have a system-wide address book managed by an "administrator"?

 

Please let me know if any of these are possible.

 

TIA.



[#] Sat May 18 2019 03:26:08 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Got another Pi. Have it set up with Raspian. Learned how to make screenshots. Going to try installing Citadel - hopefully this weekend, and make an install doc. It won't be complete, accurate, or very smart from a Linux expert's view - but it'll be a start and should work. Hopefully someone more experienced than me will take it and make it something really useful. 

 

 



[#] Sat May 18 2019 03:28:41 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Can any of you tell me why attachments don't show inline on my BBS, why I can't upload a picture and make it a link - but I can insert an image posted somewhere else and it shows inline on my BBS? 

 

 



[#] Sat May 18 2019 15:21:46 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a way I can set up the same RSS feeds you have here on my Citadel to increase the content for my callers? Is there a document or howto you can point me towards, and - how do I find out the info for your specific RSS feeds... 



[#] Sun May 19 2019 09:18:58 EDT from jdw @ Uncensored

Subject: Re: Lost all my mail filters

[Reply] [ReplyQuoted] [Headers] [Print]

Happened again this morning. All my mail filters are gonzo this morning.

That's twice so it's not a random thing. Anyone else seeing this?

Tue Apr 23 2019 07:55:39 EDT from jdw @ Uncensored Subject: Lost all my mail filters

I woke up this morning to an insane inbox. Looked at my mail filters and they were all gone. No indication of what could have happened in the logs - system works great otherwise.

Anyone else seen anything like this?



 



[#] Tue May 21 2019 01:29:42 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Or, conversely, can someone point me to where the image files, say - userpic for the user bio... is supposed to be uploaded? Is it stored as a flat file on the file system or is it dumped into some custom relational database when it is uploaded?

[#] Tue May 28 2019 20:03:10 EDT from dlee425 @ Uncensored

Subject: Is there a way to add fidonet to Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

I was wondering if Fidonet or Dovenet can be added.

 

Thanks,

Donnie



[#] Thu May 30 2019 02:00:48 EDT from ParanoidDelusions @ Uncensored

Subject: Re: Is there a way to add fidonet to Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

STFU Donnie! 

;) 

 



[#] Thu May 30 2019 09:50:17 EDT from jay1962 @ Uncensored

Subject: Email attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Citadel installed on a raspberry pi 3+. I use it on a standalone mesh network for classroom training. Email attachments are key to what we are doing. They are corrupted just going from one account to another without leaving the closed network. By corrupted I mean they can’t be read by the original program. I tried text files and libre doc files. This issue must have been addressed but I can’t find any info about remedies. Suggestions welcomed.



[#] Thu May 30 2019 15:42:52 EDT from ParanoidDelusions @ Uncensored

Subject: Re: Email attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

I'm getting similar results with attachments using Citadel as a BBS. Do this... go to "Advanced", "edit your online photo" and upload a picture. That should be broken. Make a room in the web-cit interface. Post a message in the Webcit client in a room, and add a file attachment, it should be broken too. 

Ignatus has acknowledged that there are things that are broken - and this may be one of those things. 

I have found that if I make a room, make it a file directory room, and upload a file to it that way, the file is not corrupted. 

 



[#] Thu May 30 2019 15:43:25 EDT from ParanoidDelusions @ Uncensored

Subject: Re: Email attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Also on a Raspberry Pi, running Rasperian Stretch. 

 



[#] Thu May 30 2019 19:00:55 EDT from jay1962 @ Uncensored

Subject: Re: Email attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Many thanks for the quick reply. Unfortunately I am looking for an easy way to use email with attachments. Citadel seemed like an ideal solution. If there is no straightforward fix, I will have to try another webmail approach or go back to using ClearOS with Thunderbird as a client. That means not using raspberry pi platforms which are very convenient for portable classroom use compared to laptops or small form-factor desktop boxes. I hope someone with the appropriate skills, definitely not me, will eventually resolve the attachment issue. Citadel development began in a different form in 1987 if my understanding is correct. Seems like 30+ years should be enough time to get attachments working. But maybe I am among only a few for whom attachments are a key component. Thank you again. 



[#] Fri May 31 2019 02:18:40 EDT from ParanoidDelusions @ Uncensored

Subject: Re: Email attachments corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Attachments simply weren't a thing when Citadel originated on CP/M - all the way through the first versions of Citadel-UX. 

This is an entirely different beast - with just a historical attachment to the original Citadel code. 

I ran a Cit 86 BBS in 1987. 

Anyhow... I suspect it is a permissions or setup issue - because it works for IG here - and I suspect it has to do with Raspbian defaults. I don't think it is so much a Citadel issue as a Linux issue - and someone who really knows their way around Linux could probably fix it fairly easily. I've had family and friends in town staying over for two weeks now - but I have a Pi all ready to go with Raspbian and I'm going to install and set up Citadel with what I've learned and see if that fixes the problems I've encountered. I intend to make a setup doc. That may solve our problem - but it is about two weeks out at the earliest. 

 

Stay tuned. 

 



[#] Fri May 31 2019 09:04:31 EDT from jay1962 @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I will definitely stay tuned. Citadel has a lot of very useful functionality. Fixing the attachment issue would make it near perfect for the uses I have in mind. Thank you again for putting this on your to-do list forp when you are ready.



[#] Sat Jun 01 2019 15:39:32 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Today I'm having an interesting experience. I'm on a guest network at an AirB&B in Vegas, connected through a VPN. I'm not trying to mask my location so I'm using a local VPN connection - I can read and post - but when I Goto the next room, it returns a page that says simply "not found" in the upper left corner. Then I type in the BBS URL again, and I can go to the next room, but after reading and posting - it does the same thing. Makes going slow. 



[#] Sat Jun 01 2019 15:40:08 EDT from ParanoidDelusions @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I am using Google DNS servers and have IPV6 turned off. 



[#] Sun Jun 02 2019 11:19:35 EDT from macarroni @ Uncensored

Subject: Citadel in Debian Systems

[Reply] [ReplyQuoted] [Headers] [Print]

Citadel in debian systems is seriously screwed up. I had to use easy install in current stable (debian 9.9) , but even easy install does not work for the current testing (debian 10). Any suggestions to install citadel in a debian system, or for that matter, any suggestions on a linux distribution that would work fine for citadel? The intention is to have a bare bones linux, with citadel server and not much more.

Thanks.



[#] Sun Jun 02 2019 23:44:23 EDT from ParanoidDelusions @ Uncensored

Subject: Re: Citadel in Debian Systems

[Reply] [ReplyQuoted] [Headers] [Print]

Are you using the Debian distro packages? 

Try the easy install - using my steps above for Raspbian, if not. 

I don't think it is Citadel - so much as the packages not being well maintained. 

 

Same thing seems to apply to Ubuntu. I gave that a shot, too... 

 



Go to page: First ... 10 11 12 13 [14] 15 16 17 18 19