Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Mon Jul 23 2018 04:00:10 EDT from pop @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Hi guys! 

I install citadel on a ubuntu server ( version 18), i created 5 users and i would like to know how can i share the calendar of the user. 

 

I explain I would like the schedule of a user is visible to others. Is it possible ? thank you in advance





[#] Tue Jul 24 2018 12:24:25 EDT from fishchip @ Uncensored

Subject: Spaces are plusses! Finkle is Einhorn!

[Reply] [ReplyQuoted] [Headers] [Print]

Hey all. Finally going to start using Citadel as a personal workspace a-la Evernote or Keep, seems to be my best compromise between personal writing and Outlook-type calendar and tasklist and stuff..

Compiled from source using easy install and everything seems to be working great, except, in Notes, all spaces are converted to plus signs. What gives? I don't remember this from when I half-assedly gave Citadel a spin a couple years ago. It kind of makes using Notes awkward.

 

Cheers.



[#] Tue Jul 24 2018 15:33:17 EDT from iMav @ Uncensored

Subject: Outbound email issue and webcit shutdown/startup issue...

[Reply] [ReplyQuoted] [Headers] [Print]

First off, I am able to receive email without issue. (new install)  However, whenever I send outbound email (from the web interface) it never attempts (I don't see any outbound connection attempts...nor do I see any entries in either mail.err nor mail.log).  Nothing shows up in the outbound queue when I log in as admin...and eventually, the sending user gets a system email with the subject "Delivery Status Notification (failure)"...with the content "421 (Domain service not available, closing transmission channel)".

Name resolution for the system works fine (/etc/resolv.conf has the correct info and I can look up DNS records from the command line without issue).  I couldn't find any additional DNS configuration within Citadel.  I even installed a local, caching DNS server...just in case Citadel was simply querying DNS from the local host by default...no change.

 

Secondly, whenever I install a package, I get the following errors (and webcit is shut down and not started back up):

insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!

insserv: There is a loop at service webcit if started

insserv:  loop involving service networking at depth 6

insserv:  loop involving service mountdevsubfs at depth 3

insserv:  loop involving service mountkernfs at depth 1

 

I am at a loss as to what is going on with both of these issues.



[#] Wed Jul 25 2018 07:22:17 EDT from kristjan1215 @ Uncensored

Subject: Several questions

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I have several questions about Citadel:

- I am running the suite on my home raspberry pi server and love it. But would love to sync calendar/notes/tasks to Android, is this possible?

- Does Citadel community have any IRC chat rooms? It would be most helpful to find help and to help others in real time. (Maybe Freenode could support it for free?)

- Citadel seems to have problem with images, from images in mails to icons for rooms. They are not shown. Only the "image icon". Any idea why? The default icons/logos are all shown OK.

- Also how do I apply self-signed SSL certificate for (more) secure connection? There are probably instructions somewhere, but did not find them.

Apart from this, I find Citadel superb for my needs. Easy install and use 10/10 ;)

 



[#] Wed Jul 25 2018 17:06:57 EDT from EzPcConcepts @ Uncensored

Subject: Citadel Easy Install Aborts on CentOS 6.10 Compile fails

[Reply] [ReplyQuoted] [Headers] [Print]

Good day and thank you in advance for your time and assistance.


I am trying to install Citadel on CentOS 6.10 using the Easy Installer process. Unfortunately it keeps failing to compile the pages with the following errors

Anyone ever seen this before and have a fix...?

Thanks

 

Running scripts/ge_ical_data.sh

CC ical_maps.c

ical_maps.c:28: error: expected specifier-qualifier-list before 'ical_unknown_token_handling'

ical_maps.c:440: error: expected '}' before 'C'

ical_maps.c:440: error: stray '#' in program

ical_maps.c:440: error: stray '#' in program

ical_maps.c:440: error: stray '#' in program

ical_maps.c:440: error: stray '#' in program

ical_maps.c:440: error: stray '#' in program

ical_maps.c:440: error: stray '#' in program

ical_maps.c:451: error: stray '#' in program

ical_maps.c:451: error: stray '#' in program

ical_maps.c:451: error: stray '#' in program

ical_maps.c:451: error: expected '}' before 'endif'

ical_maps.c:451: error: stray '#' in program

ical_maps.c: In function 'InitModule_ICAL_MAPS':

ical_maps.c:977: error: 'Ical_ical_unknown_token_handling' has no member named 'map'

ical_maps.c:977: warning: passing argument 3 of 'RegisterTokenParamDefine' makes integer from pointer without a cast

subst.h:344: note: expected 'long int' but argument is of type 'struct Ical_ical_unknown_token_handling *'

gmail: *** [ical_maps.o] Error 1

Citadel Easy Install is Aborting

 

 

 

 



IMG_20180723_061008279.jpg (image/jpeg, 3569737 bytes) [ View | Download ]
IMG_20180723_061008279.jpg (image/jpeg, 3569737 bytes) [ View | Download ]
[#] Wed Jul 25 2018 20:25:53 EDT from kristjan1215 @ Uncensored

Subject: Several questions

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I have several questions about Citadel:

- I am running the suite on my home raspberry pi server and love it. But would love to sync calendar/notes/tasks to Android, is this possible?

- Does Citadel community have any IRC chat rooms? It would be most helpful to find help and to help others in real time. (Maybe Freenode could support it for free?)

- Citadel seems to have problem with images, from images in mails to icons for rooms. They are not shown. Only the "image icon". Any idea why? The default icons/logos are all shown OK.

- Also how do I apply self-signed SSL certificate for (more) secure connection? There are probably instructions somewhere, but did not find them.

Apart from this, I find Citadel superb for my needs. Easy install and use 10/10 ;)

 



[#] Thu Jul 26 2018 23:40:48 EDT from "jake" <jake@aCe-Clan.org> to room_Citadel_Support@citadel.org

Subject: Gmail says that E-Mails from my Site are not encrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

Good Morning,
I have recently switched from Postfix+Dovecot to Citadel(because its
easier to use) and I've noticed that E-Mails that are send using Citadel
are shown as not encrypted in Gmail. Even though I have a CA Cert at
Let's Encrypt and it is correctly linked to in the keys folder of Citadel.

I am rather sure I just have to configure Citadel to enforce Encryption
but I don't know where/how I can do that. I haven't found anything
useful in the FAQ, docs, webinterface, or through online searches.

Back when I was using Postfix Gmail just said that the E-Mails were
Encrypted (TLS).

Has someone discovered and solved this issue before? Or has anyone an
Idea or Solution on how to fix that/enforce encryption?

Sincerely,
Jake

[#] Fri Jul 27 2018 02:29:00 EDT from "Dirk Heinrichs" <dirk.heinrichs@altum.de> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Re: [Citadel Support] Gmail says that E-Mails from my Site are notencrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

Citadel Support:

------------------------------------------------------------------------------
From: jake <jake@aCe-Clan.org>

I have recently switched from Postfix+Dovecot to Citadel(because its
easier to use) and I've noticed that E-Mails that are send using Citadel
are shown as not encrypted in Gmail. Even though I have a CA Cert at
Let's Encrypt and it is correctly linked to in the keys folder of Citadel.

You seem to be confusing email encryption (PGP, SMIME) with transport
encryption (TLS, SSL). Neither Postfix nor Citadel encrypts your emails,
they just encrypt the *connection* to other mail hosts or mail clients
(transport encryption). The emails themselves are still unencrypted
unless you do so in the program you use for writing your emails
(Thunderbird, Outlook, ...).

So, can you please clarify which one you're after? I guess it's
transport encryption, just to be sure...

Bye...

Dirk
--
Dirk Heinrichs <dirk.heinrichs@altum.de>
GPG Public Key: D01B367761B0F7CE6E6D81AAD5A2E54246986015
Sichere Internetkommunikation: http://www.retroshare.org
Privacy Handbuch: https://www.privacy-handbuch.de

signature.asc (application/pgp-signature, 849 bytes) [ View | Download ]
[#] Fri Jul 27 2018 02:40:47 EDT from "jake" <jake@aCe-Clan.org> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Gmail says that E-Mails from my Site arenotencrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

Oh sorry, I forgot to add that.
I mean transport encryption.

Thanks,
Jake
On 07/27/2018 08:29 AM, Dirk Heinrichs wrote:
Citadel Support:

------------------------------------------------------------------------------
From: jake <jake@aCe-Clan.org>

I have recently switched from Postfix+Dovecot to Citadel(because its
easier to use) and I've noticed that E-Mails that are send using Citadel
are shown as not encrypted in Gmail. Even though I have a CA Cert at
Let's Encrypt and it is correctly linked to in the keys folder of Citadel.

You seem to be confusing email encryption (PGP, SMIME) with transport
encryption (TLS, SSL). Neither Postfix nor Citadel encrypts your emails,
they just encrypt the *connection* to other mail hosts or mail clients
(transport encryption). The emails themselves are still unencrypted
unless you do so in the program you use for writing your emails
(Thunderbird, Outlook, ...).

So, can you please clarify which one you're after? I guess it's
transport encryption, just to be sure...

Bye...

Dirk

[#] Fri Jul 27 2018 11:25:04 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Gmail says that E-Mails from my Site are not encrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

I am rather sure I just have to configure Citadel to enforce Encryption

but I don't know where/how I can do that. I haven't found anything
useful in the FAQ, docs, webinterface, or through online searches.

As others have pointed out, you have to enable encryption on *outbound* SMTP connections.

Fortunately, there is an undocumented option to enable this. Change to your Citadel Server directory (/usr/local/citadel if using the Easy Install distribution) and enter the following command:

./sendcommand 'conf putval|c_smtpclient_try_starttls|1'

With this option enabled, outbound SMTP connections will use encryption if it is offered by the receiving server.

I'd like to ask you for some help please. Anyone who turns this option on, please provide feedback regarding whether it works well or if there are side effects. I think it's safe to use this everywhere now but I'd like to be 100% sure about it before we make this the default behavior.

[#] Fri Jul 27 2018 12:56:30 EDT from KojimaleR @ Uncensored

Subject: Re: Gmail says that E-Mails from my Site are not encrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

 

I try this, and this setting doesn't do anything.

 

Fri Jul 27 2018 11:25:04 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Gmail says that E-Mails from my Site are not encrypted. Even thoughthey should be.
I am rather sure I just have to configure Citadel to enforce Encryption

but I don't know where/how I can do that. I haven't found anything
useful in the FAQ, docs, webinterface, or through online searches.

As others have pointed out, you have to enable encryption on *outbound* SMTP connections.

Fortunately, there is an undocumented option to enable this. Change to your Citadel Server directory (/usr/local/citadel if using the Easy Install distribution) and enter the following command:

./sendcommand 'conf putval|c_smtpclient_try_starttls|1'

With this option enabled, outbound SMTP connections will use encryption if it is offered by the receiving server.

I'd like to ask you for some help please. Anyone who turns this option on, please provide feedback regarding whether it works well or if there are side effects. I think it's safe to use this everywhere now but I'd like to be 100% sure about it before we make this the default behavior.

 



[#] Fri Jul 27 2018 18:31:26 EDT from jmh @ Uncensored

Subject: Support

[Reply] [ReplyQuoted] [Headers] [Print]

Hey there. Been playing around with Citadel on my Rpi, just seeing if I can set up a nice simple privatebbs.

I've run into a snag I think I resolved, just putting this here in case something might need to be looked into... but it seems that when you do the easy install with only the dependencies listed on the easy install page for a debian like system, it results in an inaccessible, broken webcit. The final page of the setup screen fails to populate the url fields and the webcit page results in nothing but browser errors. Watching console gave me truncated lines of a login issue before giving the useragent.

I previously had tried using the version in the repos, had issues with that too but I made note of what packages were also going to be installed (along with suggested packages)... and installed all of those packages (except the citadel specific ones) before doing the easy install on a fresh Raspbian system. Then it works. Was able to duplicate the necessity of doing this twice.

When I get another Pi board to play with I'll document this fully if I can duplicate how everything went. All in all I ended up having to redo the easy install about 5 times before I found a way to make it stick.

 

Now for the actual support part.

Are doors supported? I see the command for it in the 'h'elp menu but unable to find a way to actually configure a room to be a door. Documentation online doesn't mention doors, either, as far as I've been able to find.

And can that 'h'elp page and non-expert prompt be edited? I notice that upon editing citadel.rc that you change the dot menu, but not the main help menu. I disabled floors and reassigned the < > keys to go prev/next room and would like the 'h'elp page to reflect that.

 

Thanks.



[#] Fri Jul 27 2018 18:39:50 EDT from "jake" <jake@aCe-Clan.org> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Re: Gmail says that E-Mails from my Site arenot encrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

Good Morining,

I have experimented a bit and I found that the servers respond to the
EHLO command does not include 250-STARTTLS on port 25.
Which, if I am not wrong, is correct as far as the standards are
concerned, because port 587 should be used and is correctly used for that.
BUT after doing the same test on smtp.gmail.com port 25, I noticed that
they seem to include STARTTLS encryption on port 25.

EHLO on my Server (port 25):

# netcat 127.0.0.1 25
220 aCe-Clan.org ESMTP Citadel server ready.
EHLO 127.0.0.1
250-Hello 127.0.0.1 (localhost.localdomain [127.0.0.1])
250-HELP
250-SIZE 10485760
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

(Same result when testing from a non localhost pc.)

EHLO on my Server (port 587) (contains 250-STARTTLS):

# netcat 127.0.0.1 587
220 aCe-Clan.org ESMTP Citadel server ready.
EHLO 127.0.0.1
250-Hello 127.0.0.1 (localhost.localdomain [127.0.0.1])
250-HELP
250-SIZE 10485760
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

Here is the same test with smtp.gmail.com (port 25)(Notice the responds
contains 250-STARTTLS):
# netcat smtp.gmail.com 25
220 smtp.gmail.com ESMTP c15-v6sm3622131wmb.2 - gsmtp
EHLO aCe-Clan.org
250-smtp.gmail.com at your service, [84.200.24.47]
250-SIZE 35882577
250-8BITMIME
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-CHUNKING
250 SMTPUTF8


./sendcommand 'conf putval|c_smtpclient_try_starttls|1'

These tests were performed after using this command.

I guess that a fix might be to also enable encryption on port 25. But,
as I am not an expert in SMTP, this is just a wild guess.

After looking into the code a bit I found that this was already
something that was thought about.


modules/smtp/serv_smtp.c:
[...]
#ifdef HAVE_OPENSSL
/*
* Offer TLS, but only if TLS is not already active.
* Furthermore, only offer TLS when running on
* the SMTP-MSA port, not on the SMTP-MTA port, due to
* questionable reliability of TLS in certain sending
MTA's.
*/
if ( (!CCC->redirect_ssl) && (sSMTP->is_msa) ) {
cprintf("250-STARTTLS\r\n");
}
#endif /* HAVE_OPENSSL */
[...]

I would like to know what this "questionable reliability" is, because it
seems like other smtp servers are doing exactly this.
Also with c_smtpclient_try_starttls(CURLUSESSL_TRY) enabled, the
encryption would just be used if the other server supports it, thus
there shouldn't be any "questionable reliability [issues] of TLS in
certain sending MTA's".

If I am correct, one could easily patch this by doing this change in
modules/smtp/serv_smtp.c:
-- if ( (!CCC->redirect_ssl) && (sSMTP->is_msa) ) {
++ if ( (!CCC->redirect_ssl) && ( (sSMTP->is_msa) || ( (sSMTP->is_mta)
&& CtdlGetConfigInt("c_smtp_mta_starttls") != 0 ) ) ) {

This patch would require a new config option c_smtp_mta_starttls to be
applied.

But I didn't look really further into the code thus I am not sure if
there might be some unforeseen consequences or bugs with that.

Maybe some dev can implement and test this.

TL;DR: Maybe fixable by enabling STARTTLS encryption on port 25(MTA).

Sincerely,
Jake

PS.: If you could see it, hope you enjoyed the bloodmoon today.


On 07/27/2018 05:25 PM, IGnatius T Foobar wrote:
I am rather sure I just have to configure Citadel to enforce Encryption

but I don't know where/how I can do that. I haven't found anything
useful in the FAQ, docs, webinterface, or through online searches.

As others have pointed out, you have to enable encryption on *outbound* SMTP
connections.

Fortunately, there is an undocumented option to enable this. Change to your
Citadel Server directory (/usr/local/citadel if using the Easy Install distribution)
and enter the following command:

./sendcommand 'conf putval|c_smtpclient_try_starttls|1'

With this option enabled, outbound SMTP connections will use encryption if
it is offered by the receiving server.

I'd like to ask you for some help please. Anyone who turns this option on,
please provide feedback regarding whether it works well or if there are side
effects. I think it's safe to use this everywhere now but I'd like to be
100% sure about it before we make this the default behavior.

[#] Fri Jul 27 2018 18:55:10 EDT from "s3cr3to" <s3cr3to@uncensored.citadel.org> to undisclosed-recipients: ;

Subject: Re: Gmail says that E-Mails from my Site are not encrypted. Eventhoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

Hi IGnatius/Art

Using Citadel 8.17
Installed using the DEBs; located in /usr/sbin/sendcommand

Some related questions:
* How can I read the current value of that option?
* To rollback the value is with:
sendcommand 'conf putval|c_smtpclient_try_starttls|0'



On 07/27/2018 09:25 AM, IGnatius T Foobar wrote:
I am rather sure I just have to configure Citadel to enforce Encryption

but I don't know where/how I can do that. I haven't found anything
useful in the FAQ, docs, webinterface, or through online searches.

As others have pointed out, you have to enable encryption on *outbound* SMTP
connections.

Fortunately, there is an undocumented option to enable this. Change to your
Citadel Server directory (/usr/local/citadel if using the Easy Install distribution)
and enter the following command:

./sendcommand 'conf putval|c_smtpclient_try_starttls|1'

With this option enabled, outbound SMTP connections will use encryption if
it is offered by the receiving server.

I'd like to ask you for some help please. Anyone who turns this option on,
please provide feedback regarding whether it works well or if there are side
effects. I think it's safe to use this everywhere now but I'd like to be
100% sure about it before we make this the default behavior.

[#] Fri Jul 27 2018 19:05:40 EDT from "jake" <jake@aCe-Clan.org> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Re: Gmail says that E-Mails from my Site arenot encrypted. Eventhoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,


On 07/28/2018 12:55 AM, s3cr3to wrote:
* How can I read the current value of that option?

You can use getval to get the current value of an option.
./sendcommand 'conf getval|c_smtpclient_try_starttls'

Or you can use listval to see the complete config.
./sendcommand 'conf listval'

On 07/28/2018 12:55 AM, s3cr3to wrote:
* To rollback the value is with:
sendcommand 'conf putval|c_smtpclient_try_starttls|0'

Yes.


Further info:
http://www.citadel.org/doku.php?id=documentation:appproto:system_config

Sincerely,
Jake

On 07/28/2018 12:55 AM, s3cr3to wrote:


Hi IGnatius/Art

Using Citadel 8.17
Installed using the DEBs; located in /usr/sbin/sendcommand

Some related questions:
* How can I read the current value of that option?
* To rollback the value is with:
  sendcommand 'conf putval|c_smtpclient_try_starttls|0'



On 07/27/2018 09:25 AM, IGnatius T Foobar wrote:
  >I am rather sure I just have to configure Citadel to enforce
Encryption
  >but I don't know where/how I can do that. I haven't found anything
  >useful in the FAQ, docs, webinterface, or through online searches.
  As others have pointed out, you have to enable encryption on
*outbound* SMTP
connections.
  Fortunately, there is an undocumented option to enable this.  Change
to your
Citadel Server directory (/usr/local/citadel if using the Easy Install
distribution)
and enter the following command:
  ./sendcommand 'conf putval|c_smtpclient_try_starttls|1'
  With this option enabled, outbound SMTP connections will use
encryption if
it is offered by the receiving server.
  I'd like to ask you for some help please.  Anyone who turns this
option on,
please provide feedback regarding whether it works well or if there
are side
effects.  I think it's safe to use this everywhere now but I'd like to be
100% sure about it before we make this the default behavior.

[#] Sat Jul 28 2018 10:29:12 EDT from iMav @ Uncensored

Subject: Re: Outbound email issue and webcit shutdown/startup issue...

[Reply] [ReplyQuoted] [Headers] [Print]

So, no one has a clue???



[#] Mon Jul 30 2018 04:23:06 EDT from anwoke8204 @ Uncensored

Subject: no login page after install

[Reply] [ReplyQuoted] [Headers] [Print]

Hi I am trying to install Citadel on Centos 7.  I ran through the install, but then when it says to browse to my server to get to the login page, nothing comes up.  I have restarted Webcit, as well as tried changing the port it was running on to see if I was conflicting with apache(not installed, this is a fresh centos install) or something.



[#] Mon Jul 30 2018 16:05:25 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Gmail says that E-Mails from my Site are not encrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]


A clarification:

The option to encrypt outbound SMTP appeared in Citadel Server version 912.

If you are running an older version of the server, no amount of tweaking will enable this behavior.

Encrypted outbound SMTP will become the default behavior in version 922.

[#] Mon Jul 30 2018 16:06:48 EDT from Zoaky @ Uncensored

Subject: Citadel on Raspberry Pi

[Reply] [ReplyQuoted] [Headers] [Print]

Hello

Has anybody managed to get a fully working install of Citadel on a Raspberry Pi 3+ running Rasbian Stretch? I can get as far as logging in, setting up accounts etc and adding domains in the Domain names and Internet mail configuration section. but there seems to be no way of selecting a preferred email address. The field is blank.

The install is quite messy:

  1. Update the Pi's OS
  2. sudo apt-get install citadel-suite (which fails due to configuration setting c_default_cal_zone is empty, but must not - check your config! error msg)
  3. Enter sudo sendcommand conf listval
  4. Enter sudo sendcommand "CONF PUTVAL|c_default_cal_zone|Europe/London" (in my case)
  5. Reboot
  6. Login
  7. Tried re-running setup again and it just hangs
  8. Reboot
  9. Login
  10. Enter sudo apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev zlib1g-dev
  11. sudo -i
  12. cd /opt
  13. Then run Easy Install the normal way: curl http://easyinstall.citadel.org/install | bash
  14. Setup will complete and ask you to configure the server settings
  15. Login via the web interface


That's as far as I can get

I know this is far from ideal but its the only way I've found

Anybody got any ideas?

P.S apologies if I've managed to post this twice



[#] Mon Jul 30 2018 16:09:04 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: [Citadel Support] Re: Gmail says that E-Mails from my Site arenot encrypted. Even thoughthey should be.

[Reply] [ReplyQuoted] [Headers] [Print]

But I didn't look really further into the code thus I am not sure if
there might be some unforeseen consequences or bugs with that.

The reason we don't offer STARTTLS on inbound SMTP by default is because the default out-of-the-box deployment creates a self-signed certificate, and there are a lot of SMTP agents out there that will refuse to deliver mail to a server that presents an invalid certificate. Better to just do unencrypted SMTP and let the mail go through.

Yes, it would make sense to have options available to tweak this behavior.
No, I don't have the time to work on this right now. But we would be grateful to accept a patch.

Go to page: [1] 2 3 4 5 ... Last