Language:
switch to room list switch to menu My folders
Go to page: First ... 29 30 31 32 [33] 34 35 36 37
[#] Wed Feb 28 2018 10:33:08 EST from bgerum @ Uncensored

Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Feb 26 2018 16:45:41 EST from bgerum @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

 

Sun Feb 25 2018 21:46:41 EST from IGnatius T Foobar @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

 

checking for libical/ical.h... yes
checking for icaltimezone_set_tzid_prefix in -lical... yes
checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
Operating system: Linux 4.4.104-39-default( 4.4.104-39-default x86_64)

According to that log, it couldn't link to libsieve, even though libsieve had clearly been installed.  That is quite weird.

Can you attach the full log please?  We need to see what happened during the libsieve build.

 

unfortunately the 2nd try has overwritten the original log. I also did some updates overnight... but attached you find the current EasyInstall Log

 

How can I trigger a complete recompilation?

 



(, 0 bytes) [View| Download]

 



citadel-install-log.txt (text/plain, 13387 bytes) [View| Download]
[#] Thu Mar 01 2018 11:15:34 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Unable to connect pidgin to citadel server

[Reply] [ReplyQuoted] [Headers] [Print]

Even if you were to get your SSL sorted out, you'll immediately want
some XMPP feature that Citadel doesn't support, and may not ever..
so, it's easier to write the authentication than waste more time
testing old versions of pidgin.  If a few of us got together, we
could have it done in a few days, if not hours.  All XMPP clients
are junk btw.  

I must admit that XMPP has not been a high priority because the protocol in general seems to be dying. The idea of it being a universal protocol for instant messaging was awesome, and if the adoption rate remained high, it would be worth coping with the fact that the protocol itself is really overengineered.
There was a time when I could fire up Pidgin or Trillian and have it connect simultaneously to AIM, ICQ, Google, Facebook, and Uncensored. That was awesome.

But today? AIM is gone, Google and Facebook want everyone to use proprietary clients to enhance users' level of captivity in their walled gardens, and being able to pass instant messages *between* systems remains a distant dream.

XMPP will remain in Citadel for the foreseeable future, but if you want to run a third party XMPP server, I'd certainly be interested in providing whatever authentication hooks you need to make it happen. Of course, you then have to sacrifice the ability to send messages between XMPP and Citadel clients, which was the original point of having the server inside Citadel in the first place.

What if we implemented IRC protocol? That might be more useful.

[#] Sat Mar 03 2018 00:33:25 EST from julianc @ Uncensored

Subject: ERRORs installing Citadel using "Easy Installer" on ARM64 Machine

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

as stated above I run into ERRORs installing Citadel on my machine (Ubuntu 16.04 LTS with ARM64 processor). When I try to use the precompiled packages I am stuck with an old version with bugs that have been fixed like two years ago. (Citadel runs as root and ...)

 

So I turned to using the "Easy Installer". Sadly it fails and this is the excerpt from the logfile:

 

2018-03-03 05:01:40 (378 KB/s) - 'libical-easyinstall.tar.gz' saved [1173542/1173542]

checking build system type... ./config.guess: unable to guess system type

This script, last modified 2009-11-20, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
and
  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2009-11-20

uname -m = aarch64
uname -r = 4.4.119-mainline-rev1
uname -s = Linux
uname -v = #1 SMP Wed Feb 28 10:44:16 UTC 2018

/usr/bin/uname -p =
/bin/uname -X     =

hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              =
/usr/bin/oslevel       =
/usr/convex/getsysinfo =

UNAME_MACHINE = aarch64
UNAME_RELEASE = 4.4.119-mainline-rev1
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP Wed Feb 28 10:44:16 UTC 2018
configure: error: cannot guess build type; you must specify one
Operating system: Linux Debian stretch/sid ( 4.4.119-mainline-rev1 aarch64)

 

As you can see all that needs to be done is updating the scripts (according to my understanding). Is this correct assessment of the situation?

 



[#] Sun Mar 04 2018 14:07:32 EST from IGnatius T Foobar @ Uncensored

Subject: Re: ERRORs installing Citadel using "Easy Installer" on ARM64 Machine

[Reply] [ReplyQuoted] [Headers] [Print]

As you can see all that needs to be done is updating the scripts
(according to my understanding). Is this correct assessment of the
situation?

Thanks for the heads up! I did a bit of searching and it appears that "config.guess" is bundled with the "automake" package. This probably means that the machine that builds the source packages needs to have its build toolset updated.

We will get to work on that. Thanks again.

[#] Sun Mar 04 2018 16:04:32 EST from "Craig Mcgee" <craig.mcgee@guilt-management.org.uk> to <room_Citadel_Support@citadel.org>

Subject: email server function feature?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello there, I hope this is the wright place and list to post this on?
 
I'm just wondering if the Citadel email server has the below feature, as my old email provider bluebottle had it and I found it extremely useful!
take care
craig.
 
my old provider bluebottle had a great feature. so it would have 2 lists, a allow list and block list. whenever an email arrived at my address, bluebottle would check it and if the address was on the whitelist bang it would arrive in my inbox, if it was on the blocklist it would be deleted automatically. now here comes the nice bit. if the address wasnt on any of the 2 lists, bluebottle would put the email in a pending folder, accessible on the webmail. so i could go in there, each email was a checkbox, check off the emails I want to whitelist, and click allow. addresses added to whitelist, and emails delivered to inbox. i would then check all the boxes next to the emails i didnt want to receive, bang email addresses auto added to blocklist emails deleted, and any more emails from those addresses would be auto deleted without being added to pending. bluebottle shut so now dont have that service any more!


[#] Mon Mar 05 2018 19:07:36 EST from trundle @ Uncensored

Subject: TLS/SSL/ encryption?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Gang,

Been a lurker for quite sometime. Wanted to join in conversations but  I wanted to successfully deploy citadel mainly to use for spice works ticket system.

After going through the docs and googling, I feel like i know nothing about servers/networking/linux, even tho I have been a tech for a couple a years.

I can receive mail only if I open port 25, but curious how to get ssl/tls. I understand(or thought I did) that a tls session is wrapped around the message. 

I have applied a cert via letsencypt.

I would like to verify encryption is happening and not plain auth.

My ultimate goal is to stop gmail/yahoo/office365 to not saying my message was not encrypted or is that beacsue of my free cert from  letsencrypt?

I am sure someone has asked this, but failing to search for those posts. 

Is it possible to get some insight, suggestions, or link to search the support more thoroughly.

Willing to bang head and get through the headaches.

IF I am missing something easy, please slap me.

Thank you

<KnoNothingTech>



[#] Tue Mar 06 2018 03:13:11 EST from bardhi232 @ Uncensored

Subject: Connect via outlook to the Citadel Mail Server

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

 

In our company we have a citadel email server which all the employees use and we would like if possible to make it happen for everyone to connect to their email address using Microsoft Outlook as it is company policy to use that. IMAP port and SMTP port is already open to the server, but outlook is not able to connect to the mail server. If someone has made that possible could you please assist me on how to make that as well?

 

Thank you in advance

Fatbardh Hysa



[#] Wed Mar 07 2018 03:47:24 EST from bgerum @ Uncensored

Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Feb 28 2018 10:33:08 EST from bgerum @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

 

Mon Feb 26 2018 16:45:41 EST from bgerum @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

 

Sun Feb 25 2018 21:46:41 EST from IGnatius T Foobar @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - now with Easyins

 

checking for libical/ical.h... yes
checking for icaltimezone_set_tzid_prefix in -lical... yes
checking sieve2.h usability... yes
checking sieve2.h presence... yes
checking for sieve2.h... yes
checking for sieve2_license in -lsieve... no
configure: error: libsieve was not found and is required.  More info: http://www.citadel.org/doku.php/installation:start
Operating system: Linux 4.4.104-39-default( 4.4.104-39-default x86_64)

According to that log, it couldn't link to libsieve, even though libsieve had clearly been installed.  That is quite weird.

Can you attach the full log please?  We need to see what happened during the libsieve build.

 

unfortunately the 2nd try has overwritten the original log. I also did some updates overnight... but attached you find the current EasyInstall Log

 

How can I trigger a complete recompilation?

 



(, 0 bytes) [View| Download]

 



(, 0 bytes) [View| Download]

 

I just did a fresh install of OpenSuSE 42.3 on a different machine - standard install and then installed citadel-9.01-13.19.x86_64 from

https://download.opensuse.org/repositories/home:/stefjakobs:/citadel-testing

and guess what, I got the same error as before on the other machine:

bdb(): cursor still in progress on cdb 04: can't begin transaction during r/o cursor


see my post from Feb 19th for the other details.

I did not put any data files on that machine so I guess it must be something different, not related to the database files at all.

Maybe there is some dependency missing that is not listed in the rpm? It was already the same error for citadel 8.24 on openSuSE 42.3

 

 

 

 



citadel-install-log.txt (text/plain, 13387 bytes) [View| Download]
[#] Thu Mar 08 2018 13:56:23 EST from Restiphani @ Uncensored

Subject: Trying to make SMTP magic happen

[Reply] [ReplyQuoted] [Headers] [Print]

So let me explain what I am trying to do and then you all can tell me if I am try to fight a losing battle. I have purchased a Raspberry Pi and loaded with linux and the citadel suite. All is up and running however when I try to transmit email through the server from a device it doesn't go anywhere. Let me give you a little history and what I am trying to accomplish.

 

We have equipment that goes out on demos and I was kind of hoping to include a raspberry pi that is pre-configured with citadel and the device pointed at it to send email through ( I have accomplished this with hmail in the past), however nothing I seem to do appears to work. Is there a simple configuration change I am missing. The domain that I was to use doesn't really exist it's just a generic domain like letmescan.com something like that. I hope someone out there can make sense of what I am talking about.

 

Thanks in Advance

Restiphani



[#] Thu Mar 15 2018 18:04:40 EDT from markus @ Uncensored

Subject: How to stop citadel repeating mails?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

My citadel server seems to send one and the same email every month a couple of times. Is there a way to stop citadel doing this again and again?

Thank you in advance,

Markus



[#] Fri Mar 16 2018 15:07:31 EDT from 2oolate @ Uncensored

Subject: Easy Install error on Asterisk server

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I was trying to run Easy Install on the same server I'm running Asterisk 2.6.32-358 which is running Red Hat 6.4 after installing all the Red Hat prerequisites, and I received the following error:

configure: error: OpenLDAP development headers were not found and are required.  More info: http://www.citadel.org/doku.php/installation:start

I then found openLDAP, downloaded it and tried to install it, but it failed as well on a BerkleyDB not installed error.  Have installed version 6.2 of BerkleyDB, but now when I try to install OpenLDAP I'm getting a version error saying the following:

configure: error: BerkeleyDB version incompatible with BDB/HDB backends

 

What version of BerkleyDB do I need to use?

Thanks

Ira



[#] Sun Mar 18 2018 17:02:15 EDT from rafaeltc @ Uncensored

Subject: Need MAIL before RCPT

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

Whenever I try to send a message from a mail client (thunderbird, outlook, etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.



[#] Sun Mar 18 2018 17:09:13 EDT from "fedorowp" <fedorowp@driveforge.org> to Citadel Support <room_Citadel_Support@citadel.org>,room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I received the same error when I did the Easy Install yesterday, then imported my existing data.

The solution I came across was to set the preferred e-mail address for my users in the user edit account screen, (not the Address Book).


On March 18, 2018 5:03:04 PM EDT, Citadel Support <room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: rafaeltc @uncnsrd
Subject: Need MAIL before RCPT

Hello,

Whenever I try to send a message from a mail client (thunderbird,
outlook,
etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

[#] Sun Mar 18 2018 17:09:13 EDT from "fedorowp" <fedorowp@driveforge.org> to Citadel Support <room_Citadel_Support@citadel.org>,room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I received the same error when I did the Easy Install yesterday, then imported my existing data.

The solution I came across was to set the preferred e-mail address for my users in the user edit account screen, (not the Address Book).


On March 18, 2018 5:03:04 PM EDT, Citadel Support <room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: rafaeltc @uncnsrd
Subject: Need MAIL before RCPT

Hello,

Whenever I try to send a message from a mail client (thunderbird,
outlook,
etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

[#] Sun Mar 18 2018 17:34:58 EDT from rafaeltc @ Uncensored

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Thank you fedorowp, this solved the issue.

Rafael.

Sun Mar 18 2018 17:09:13 EDT from "fedorowp" <fedorowp@driveforge.org> Subject: Re: [Citadel Support]
Hi,

I received the same error when I did the Easy Install yesterday, then imported my existing data.

The solution I came across was to set the preferred e-mail address for my users in the user edit account screen, (not the Address Book).


On March 18, 2018 5:03:04 PM EDT, Citadel Support <room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: rafaeltc @uncnsrd
Subject: Need MAIL before RCPT

Hello,

Whenever I try to send a message from a mail client (thunderbird,
outlook,
etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

 



[#] Mon Mar 19 2018 10:04:19 EDT from Freakdog @ Uncensored

Subject: Re: Easy Install error on Asterisk server

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Mar 16 2018 15:07:31 EDT from 2oolate @ Uncensored Subject: Easy Install error on Asterisk server

Hi,

I was trying to run Easy Install on the same server I'm running Asterisk 2.6.32-358 which is running Red Hat 6.4 after installing all the Red Hat prerequisites, and I received the following error:

configure: error: OpenLDAP development headers were not found and are required.  More info: http://www.citadel.org/doku.php/installation:start

I then found openLDAP, downloaded it and tried to install it, but it failed as well on a BerkleyDB not installed error.  Have installed version 6.2 of BerkleyDB, but now when I try to install OpenLDAP I'm getting a version error saying the following:

configure: error: BerkeleyDB version incompatible with BDB/HDB backends

 

What version of BerkleyDB do I need to use?

Thanks

Ira

Ira,

On Red Hat/CentOS/Scientific/<insert your Red Hat derivative distro package name here>, "development headers" are installed via the <package>-devel packages. Have you verified that you have the openldap-devel package(s) installed?

rpm -qa | grep openldap

If you don't see openldap-devel in the package list, run yum install openldap-devel and, voila!



[#] Mon Mar 19 2018 16:23:02 EDT from alex007 @ Uncensored

Subject: migration from 8.22 to 9.17

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all,

I've installed a fresh citadel 9.17 (arm on raspberrypi stretch) with easy install.

I want to migrate my Data from a 8.22 install (LHS).

Is that possible or would you rather shout : no!

I think, there is a

1. config

and

2. data

that have to recover.

Any help would be great

Alex



[#] Mon Mar 19 2018 16:54:26 EDT from "fedorowp" <fedorowp@driveforge.org> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Alex,

See
http://www.citadel.org/doku.php/documentation:system_administration_manual#importingexportingyourcitadeldatabase

The database has the majority of the configuration.

In the event you have customized messages and things like that, you can
probably find them in one of:
/etc/citadel
/var/lib/citadel
/usr/local/citadel

Regards,
Peter


On 2018-03-19 04:23 PM, Citadel Support wrote:

------------------------------------------------------------------------------
From: alex007 <alex007@uncensored.citadel.org>
Subject: migration from 8.22 to 9.17

Hi all,

I've installed a fresh citadel 9.17 (arm on raspberrypi stretch) with easy
install.

I want to migrate my Data from a 8.22 install (LHS).

Is that possible or would you rather shout : no!

I think, there is a

1. config

and

2. data

that have to recover.

Any help would be great

Alex
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

[#] Mon Mar 19 2018 17:36:49 EDT from alex007 @ Uncensored

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Peter,

ah, there is the info, thanks a lot. I will read and try to migrate...

Best regards

Alex

 

Mon Mar 19 2018 16:54:26 EDT from "fedorowp" <fedorowp@driveforge.org> Subject: Re: [Citadel Support]
Hi Alex,

See
http://www.citadel.org/doku.php/documentation:system_administration_manual#importingexportingyourcitadeldatabase

The database has the majority of the configuration.

In the event you have customized messages and things like that, you can
probably find them in one of:
/etc/citadel
/var/lib/citadel
/usr/local/citadel

Regards,
Peter


On 2018-03-19 04:23 PM, Citadel Support wrote:

------------------------------------------------------------------------------
From: alex007 <alex007@uncensored.citadel.org>
Subject: migration from 8.22 to 9.17

Hi all,

I've installed a fresh citadel 9.17 (arm on raspberrypi stretch) with easy
install.

I want to migrate my Data from a 8.22 install (LHS).

Is that possible or would you rather shout : no!

I think, there is a

1. config

and

2. data

that have to recover.

Any help would be great

Alex
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

 



[#] Tue Mar 20 2018 06:52:56 EDT from bennyb @ Uncensored

Subject: Citadel server down

[Reply] [ReplyQuoted] [Headers] [Print]

Hello all,

I've been running a Citadel server as our primary mail server for over a year. As of yesterday morning we were experiencing issues with the availability of the mail server. It came up and went back down irregulary. Since yesterday evening the server has been down completely.

I've rebooted the server repeatedly which normally fixes these kind of issues but this didn't help in this case. If I look at services it indicates the citadel service is up:

 [ + ]  acpid
 [ + ]  apache2
 [ + ]  apparmor
 [ ? ]  apport
 [ + ]  atd
 [ + ]  citadel

but when I go to the websit it gives error 503 which indicates the service is not available.

When I check with ps command what instances are running I get:

root@webserver2:/# ps -eaf |grep cit
root      1464     1  3 11:07 ?        00:01:36 /usr/sbin/citserver -d -x3 -lmail -t/dev/null
root      3527     1  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.81 -p81 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.81.log
nobody    3528  3527  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.81 -p81 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.81.log
root      3530     1  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
nobody    3531  3530  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
root      4149  2021  0 11:48 pts/0    00:00:00 grep --color=auto cit

i've noticed that I've only got the one instance of the citserver in the list and not two as in the faq example.

service citadel restart doesn't give any errors, however service citadel stop doesn't give any errors either but the instance of citserver on the root user seems to keep running.

Can anyone give me some pointers as to what might be causing my issues and how to clear them?

Thanks in advance for the help.

Best regards.

Benny



Go to page: First ... 29 30 31 32 [33] 34 35 36 37