Language:
switch to room list switch to menu My folders
Go to page: First ... 26 27 28 29 [30] 31 32 33 34 ... Last
[#] Mon Feb 19 2018 09:19:49 EST from Yorz @ Uncensored

Subject: Web-interface login stuck at 'please wait'

[Reply] [ReplyQuoted] [Headers] [Print]

Hi there,

Over the last 2 weeks I've been trying to read up on how to install a mailserver on Raspbian. I discovered that citadel was a good way to go. Only I've run into a few problems while installing citadel. Some I've been able to solve and some of them not, i'll list them below:

Do note I've been able to reproduce every error/quirk whatever by installing raspbian fresh and doing it over.

- After installation the first error you usually get is: citserver[1374]: configuration setting c_default_cal_zone is empty, but must not - check your config!

This can be solved by just inputting the timezone manually (even though it's entered through the interface of Raspbian before) by doing: sudo sendcommand "CONF PUTVAL | c_default_cal_zone|Europe/Amsterdam"

So that was out of the way. Then I tried login into the webinterface by going to 192.168.188.36:80 or :443 for https.

I got there fine but when I entered the admin account information: admin/password. It doesn't do anything. It just for a millisecond goes to please wait and then you get the login boxes again. Now if you press login 5/6 times it goes to 'please wait' to infinity.

I've tried adding new users to see if those would work but also no. 

Also I've tried via the sudo /usr/lib/citadel-server/setup to reset it and force it that way but no luck.

 

At this point I can't find through google or whatever means to find the solution so I turn to you. Many thanks in advance and I look forward to fixing this :)

 

Yorick



[#] Mon Feb 19 2018 12:24:08 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel server not starting correctly

[Reply] [ReplyQuoted] [Headers] [Print]

server. After shutting it down and then bringing it up again i was
not able to log on to the mail server again. It showed an error
message "This program was unable to connect or stay connected to the
Citadel server. Please report this problem to your system
administrator."

This message indicates that your browser connected to WebCit, but WebCit was unable to connect to Citadel Server. This generally indicates one of two things:

1. Citadel Server is not running. (Start it up!)

2. If you changed your IP address, then perhaps WebCit was configured to connect to Citadel at the old IP address. Check your WebCit startup script and see if that's the case.

[#] Mon Feb 19 2018 12:26:14 EST from IGnatius T Foobar @ Uncensored

Subject: Re: EasyInstall Failure

[Reply] [ReplyQuoted] [Headers] [Print]

socket. The install says that citadel-admin.socket is missing. How do
I fix this since I have no way of getting a copy of a file the
installer is supposed to have.

citadel-admin.socket is created automatically when Citadel Server starts up.

If your citserver is not running, start it manually if you have to.

[#] Mon Feb 19 2018 12:45:41 EST from zerofire @ Uncensored

Subject: Re: EasyInstall Failure

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Feb 19 2018 12:26:14 EST from IGnatius T Foobar @ Uncensored Subject: Re: EasyInstall Failure
socket. The install says that citadel-admin.socket is missing. How do
I fix this since I have no way of getting a copy of a file the
installer is supposed to have.

citadel-admin.socket is created automatically when Citadel Server starts up.

If your citserver is not running, start it manually if you have to.

Great explanation on how the socket file works. How do I manually start citadel? I cannot find any paperwork on the start commands and sadly this server system is the first one that runs Linux here.



[#] Mon Feb 19 2018 16:05:13 EST from bardhi232 @ Uncensored

Subject: Re: Citadel server not starting correctly

[Reply] [ReplyQuoted] [Headers] [Print]

Hello

 

Thanks for your reply.

As I said the citadel server starts 2 processes under the root user and also if i try systemctl status citadel it shows that the service is up and running. 

I also checked the webcit config file and that has the ip 127.0.0.1 for the citadel-server so that means that it shouldn't cause a problem if i change the IP address of the server.

I also tried restoring the old IP back to the server, but still no luck. It shows the same error again. 

If you need me to provide additional details like logs and other diagnostic messages please tell me and I will do that.

 

Kind Regards

Fatbardh Hysa



[#] Mon Feb 19 2018 16:48:14 EST from bgerum @ Uncensored

Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Feb 04 2018 16:22:10 EST from bgerum @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog

 

Mon Jan 29 2018 18:34:53 EST from bgerum @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog

 

Mon Jan 29 2018 13:35:33 EST from IGnatius T Foobar @ Uncensored Subject: Re: citadel refuses to start after OpenSuSE upgrade - cursor still in prog
thanks for the reply. Unfortunately it seems the last version supplied by
the
homueller SuSE repo which is linked in the citadel.org doku ist 824.


Is there another rpm source?

I'm not aware of another RPM source. You could switch to Easy Install, which works on all distributions, but you'll have to move your data files to another directory first.

I used the Easy Install a long time ago, but the RPM version ist much more integrated in the OpenSuSE environment, not only directory-wise but also regarding startscripts, updating etc.

Do you think you could give Mr. homueller a hint there are new citadel versions out there? 



Ok, I found another OpenSuSE rpm source:

https://download.opensuse.org/repositories/home:/stefjakobs:/citadel-testing

it does provide citadel-9.01-13.19.x86_64, I installed it although it is compiled for the tumbleweed version of OpenSuSE, not leap which is what i use.

however, my database upgrade problem still remains:

citserver[14575]: Checking directory access
citserver[14575]: Opening databases
citserver[14575]: bdb(): open_databases() starting
citserver[14575]: Compiled db: Berkeley DB 4.8.30: (March 31, 2016)
citserver[14575]:   Linked db: Berkeley DB 4.8.30: (October 21, 2013)
citserver[14575]: Calculated dbversion: 4008030
citserver[14575]:   Previous dbversion: 4008030
citserver[14575]: Linked zlib: 1.2.8
citserver[14575]: bdb(): Setting up DB environment
citserver[14575]: dbenv->open(dbenv, /var/lib/citadel/data/, 10899, 0)
citserver[14575]: DB: Finding last valid log LSN: file: 6494 offset 9355549
citserver[14575]: DB: Recovery starting from [6494][9355421]
citserver[14575]: DB: Recovery complete at Sun Feb  4 22:10:24 2018
citserver[14575]: DB: Maximum transaction ID 80000024 Recovery checkpoint [6494][9355549]
citserver[14575]: Starting up DB
citserver[14575]: Checking floor reference counts
citserver[14575]: bdb(): cursor still in progress on cdb 04: can't begin transaction during r/o cursor
citserver[14575]: citserver is stopping in order to prevent data loss. uid=0 gid=0 euid=0 egid=0


 


Hi Ignatius,
 
any help on this? In the meantime I fired up the old server, did a sendcommand "CULL" and retransfered all the data files ... still the same problem!

 



[#] Mon Feb 19 2018 16:55:39 EST from bardhi232 @ Uncensored

Subject: Re: Citadel server not starting correctly

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Feb 19 2018 12:24:08 EST from IGnatius T Foobar @ Uncensored Subject: Re: Citadel server not starting correctly
server. After shutting it down and then bringing it up again i was
not able to log on to the mail server again. It showed an error
message "This program was unable to connect or stay connected to the
Citadel server. Please report this problem to your system
administrator."

This message indicates that your browser connected to WebCit, but WebCit was unable to connect to Citadel Server. This generally indicates one of two things:

1. Citadel Server is not running. (Start it up!)

2. If you changed your IP address, then perhaps WebCit was configured to connect to Citadel at the old IP address. Check your WebCit startup script and see if that's the case.

Hi,

 

My issue is with the port 504 which i read that it is a common problem when you restart the service. 

I try to type in sendcommand 'CONF PUTVAL|c_port_number|504' but the answer that it replies back is:

sendcommand: started (pid=6929) connecting to Citadel server at /var/run/citadel/citadel-admin.socket

200 mail Citadel server ADMIN CONNECTION ready.

CONF PUTVAL|c_port_number|504

512 Illegal option(s) specified.

sendcommand: processing ended.

I find that really weird, because I see that it works for others. If you know a way around this please tell me as I really need this server up and running ASAP

 

Kind Regards and Thank you in advance!

Fatbardh Hysa



[#] Wed Feb 21 2018 09:34:28 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel server not starting correctly

[Reply] [ReplyQuoted] [Headers] [Print]

CONF PUTVAL|c_port_number|504

512 Illegal option(s) specified.

If that command isn't available then you're running an old version of Citadel that doesn't have the new configuration system.

You can probably reset the port number by running the setup program again.

[#] Wed Feb 21 2018 10:31:58 EST from bobdoe @ Uncensored

Subject: Room file directory

[Reply] [ReplyQuoted] [Headers] [Print]

When enabling file directory on a room, upload and download rights can be enabled even if leaving visible folder disabled. If not visible, files cannot be uploaded or downloaded at all in the room! Does it make sense, or only for the case when using text client?



[#] Wed Feb 21 2018 10:32:59 EST from bobdoe @ Uncensored

Subject: Rooms inside rooms

[Reply] [ReplyQuoted] [Headers] [Print]

Subrooms inside rooms don't seem to work; tried creating new room with name "existing room\subroom". Even tried with brackets "[existing room]\subroom". It appears just as a plain additional room at floor level along with the other rooms, instead of a room inside the specified room.



[#] Wed Feb 21 2018 10:36:25 EST from bobdoe @ Uncensored

Subject: URL to uploaded documents

[Reply] [ReplyQuoted] [Headers] [Print]

Can one use urls to link uploaded documents and view them?

I guess this would need the document to be uploaded in a file directory of course...

 



[#] Wed Feb 21 2018 10:36:54 EST from bobdoe @ Uncensored

Subject: IRC channel

[Reply] [ReplyQuoted] [Headers] [Print]

Do you no longer make use of the freenode irc channel?



[#] Wed Feb 21 2018 10:56:44 EST from bardhi232 @ Uncensored

Subject: Re: Citadel server not starting correctly

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Feb 21 2018 09:34:28 EST from IGnatius T Foobar @ Uncensored Subject: Re: Citadel server not starting correctly
CONF PUTVAL|c_port_number|504

512 Illegal option(s) specified.

If that command isn't available then you're running an old version of Citadel that doesn't have the new configuration system.

You can probably reset the port number by running the setup program again.

I was thinking of doing that as well, but I was fearing that it would delete all my emails. 

So if I do that my emails wont be gone or something right?

 

Regards



[#] Wed Feb 21 2018 12:10:41 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel server not starting correctly

[Reply] [ReplyQuoted] [Headers] [Print]

I was thinking of doing that as well, but I was fearing that it would
delete all my emails. 

So if I do that my emails wont be gone or something right?

Running the setup program will *never* erase your data. It's literally impossible for that to happen, because the setup program is not responsible for initializing the database on a new installation. Citadel Server itself is.

That having been said, I do hope you take regular backups.

[#] Wed Feb 21 2018 12:38:53 EST from bobdoe @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Anything regarding previous doubts?



[#] Wed Feb 21 2018 12:51:00 EST from nbewhm4 @ Uncensored

Subject: Installing citadel on raspberry pi running jessie

[Reply] [ReplyQuoted] [Headers] [Print]

The installation seemed to go ok, without any visible errors, but when I try and login as the new admin, I have to click the login button 3 times before anything happens, then I just get the clocking circle icons.

 

I ran the following:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install citadel-suite

 

I am running Raspbian 9.3, codename stretch

Then I also tried changing my sources.list to:

deb http://debian.citadel.org/debian/jessie main 

I get the following error:
E: Malformed entry 4 in list file /etc/apt/sources.list (Component)
E: The list of sources could not be read.
 
 
Any helpful suggestions would be appreciated!
 
Regards,
Andrew.


[#] Wed Feb 21 2018 20:24:13 EST from "Marisa Giancarla" <fstltna@me.com> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Backup script for citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Hi, just made a hot backup script for citadel- would like some feedback. You can get it here: https://synchronetbbs.org/index.php/downloads/category/9-groupware

Let me know 😄
Marisa


[#] Wed Feb 21 2018 22:08:05 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Backup script for citadel

[Reply] [ReplyQuoted] [Headers] [Print]

I like that you're thinking about the problem and coming up with a thoughtful solution, one that takes into consideration the fact that you want to rotate your backups, cull the logs after the backup, etc.

I do have a couple of suggestions:

1. Instead of rotating the backup names, you might consider just including the day of the week in your backup filenames. That way you automatically get seven days of backups, and then they get overwritten without you having to rotate them.

2. If you're using the newest version of Citadel, you might consider only doing backups of /usr/local/citadel/data instead of the whole tree. That will just give you the database. For added safety, have your script back up /usr/local/citadel/data/cdb.* and *then* /usr/local/citadel/data/log.* after that. This is what Berkeley DB recommends.

[#] Thu Feb 22 2018 11:32:53 EST from "Marisa Giancarla" <fstltna@yahoo.com> to room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support] Re: Backup script for citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for the suggestions- I will get started on them right away. The backup of the whole tree was intentional so that you could just extract it and have a complete installation...


On Feb 21, 2018, at 7:08 PM, IGnatius T Foobar <ajc@citadel.org> wrote:

I like that you're thinking about the problem and coming up with a thoughtful
solution, one that takes into consideration the fact that you want to rotate
your backups, cull the logs after the backup, etc.

I do have a couple of suggestions:

1. Instead of rotating the backup names, you might consider just including
the day of the week in your backup filenames.  That way you automatically
get seven days of backups, and then they get overwritten without you having
to rotate them.

2. If you're using the newest version of Citadel, you might consider only
doing backups of /usr/local/citadel/data instead of the whole tree.  That
will just give you the database.  For added safety, have your script back
up /usr/local/citadel/data/cdb.* and *then* /usr/local/citadel/data/log.*
after that.  This is what Berkeley DB recommends.




[#] Thu Feb 22 2018 13:03:41 EST from bobdoe @ Uncensored

Subject: Calendar problems

[Reply] [ReplyQuoted] [Headers] [Print]

Does citadel have shared calendar functions?

I tried adding a new event in calendar for a standard level 4 user, but the attendees button never works! The attendees tab also never displays citadel users to include; only current user's contacts.

Also, when adding events I notice the event appears "delay" shifted in the day view. Meaning, if I set event from 14:00 to 16:00, the hours are saved correctly but in the day view graphic appears like 13:00 to 15:00.

Using citadel 917 and tried with latest firefox browser.

 



Go to page: First ... 26 27 28 29 [30] 31 32 33 34 ... Last