Language:
switch to room list switch to menu My folders
Go to page: First ... 27 28 29 30 [31] 32 33 34 35 ... Last
[#] Fri Dec 22 2017 02:17:31 EST from kinetix @ Uncensored

Subject: Re: Wrong Pwd ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I would suggest having a search for 'stretch' in this room... you'll see that Citadel isn't working Debian 9 yet.  Your best bet is to use the easyinstall setup on Debian 8.

 

Sun Dec 17 2017 08:04:18 PM EST from xavier @ Uncensored Subject: Wrong Pwd ?

Hello, i'm a new "user" of citadel..; well, I try to become, because... I always have "wrong pwd" whatever the pwd...

- raspberry pi3 

- Operating system: Linux Debian 9.1 ( 4.9.59-v7+ armv7l) (new sdcard install)

- apt-get update and upgrade

- I tried 2 install :

a) apt-get install citadel-suite : Install ok, but with webcit access, I always have "wrong pwd"...for all users, 

b) curl http://easyinstall.citadel.org/install | sh : install is "broken" :

/usr/bin/install -c -m 644 ./docs/views.txt /usr/local/citadel/./docs/views.txt
mkdir /usr/local/citadel/techdoc
find: './techdoc': No such file or directory
/usr/bin/install -c -m 644 openldap/./rfc2739.schema /usr/local/citadel/./rfc2739.schema
/usr/bin/install -c -m 644 openldap/./citadel.schema /usr/local/citadel/./citadel.schema
/usr/bin/install -c -m 644 README.txt /usr/local/citadel/README.txt
make[1]: msgfmt: Command not found
Makefile:21: recipe for target '../../locale/ko/LC_MESSAGES/citadel-setup.mo' failed
make[1]: *** [../../locale/ko/LC_MESSAGES/citadel-setup.mo] Error 127
Makefile:185: recipe for target 'install-locale' failed
make: *** [install-locale] Error 2

Could somebody help me please ?

Many thanks in advance !

Xavier

 

 



 



[#] Fri Dec 22 2017 02:37:14 EST from kinetix @ Uncensored

Subject: Re: Configuring SMTP relay for outgoing mail

[Reply] [ReplyQuoted] [Headers] [Print]

Hi there,

Without more detail it's going to be difficult to guess at what the outgoing mail issue would be - I don't know, for example, if you're going to be able to relay through gmail the way you are.  There was a previous discussion here very recently about some sane options for doing mail relay out from a home network.

Citadel maintains it's configuration itself, not in config files.  You may want to have a look at http://citadel.org/doku.php/documentation:system_administration_manual for information on how it's configured.

Tue Dec 19 2017 11:11:57 AM EST from wildphins @ Uncensored Subject: Configuring SMTP relay for outgoing mail

Hi all.  I am playing around with Citadel, hoping to have my own mail server for my email accounts.  I am having trouble configuring SMTP relay.  My ISP requires a login in order to send. I don't think I can use my ISP's server as my email domain is different from the SMTP server (they changed somewhere along the line and my email is basically grandfathered). So I am trying to use a google account. The Webcit configuration looks like this: smtps://username:password@gmail.com:465. It fails to send, and when I check the syslog, I see this: trying smtps://username:password@gmail.com:465/compname, where compname is the name I gave to the server when I installed the OS. That name certainly means nothing outside of my network, and I'm not sure if Citadel is sending the request that way. The other really embarrassing question I have, is where are the Citadel configuration files? I am running Ubuntu 17.10 and Citadel 911. I have done a search and cannot find where they are hiding. I am an experienced IT professional, but a Linux novice for sure, so please forgive my ignorance. Thanks!



 



[#] Sun Dec 24 2017 09:53:35 EST from js32 @ Uncensored

Subject: Citadel login on webpage not possible

[Reply] [ReplyQuoted] [Headers] [Print]

Hello, 

 

I just installed citadel via the apt-get method (apt-get install citadel-suite mailutils citadel-server citadel-client citadel-webcit). 

After configuring everything (it shall run along with apache, admin password,...), I tried to login at the website. But after I clicked on 'Login', nothing happened. I tried some more times, I even created a second user - no success. The password is correct, but the login-screen stays there.

 

Running Apache2 on Debian 9.

 

Could you help me out? I would appreciate your help asap! ;-)



[#] Sun Dec 24 2017 09:58:22 EST from js32 @ Uncensored

Subject: Re: Citadel login on webpage not possible

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Dec 24 2017 09:53:35 EST from js32 @ Uncensored Subject: Citadel login on webpage not possible

Hello, 

 

I just installed citadel via the apt-get method (apt-get install citadel-suite mailutils citadel-server citadel-client citadel-webcit). 

After configuring everything (it shall run along with apache, admin password,...), I tried to login at the website. But after I clicked on 'Login', nothing happened. I tried some more times, I even created a second user - no success. The password is correct, but the login-screen stays there.

 

Running Apache2 on Debian 9.

 

Could you help me out? I would appreciate your help asap! ;-)



Oops, just scrolled a bit up - Debian 9 is not supported yet. That's sad, maybe I'm experiencing the same problem (I also tried to install with EasyInstall, same error was shown to me). Do you have any information about when (or even - whether - ) it will be supported? I don't really know any good alternatives out there. I would like to send mails from my own server (dynamic IP), not via Google etc.

 

Thanks for your help!



[#] Wed Dec 27 2017 06:23:32 EST from steve @ Uncensored

Subject: IMAP/POP3 problems

[Reply] [ReplyQuoted] [Headers] [Print]

Hey guys, have installed Citadel on a machine sitting behind a modem router thats set in DMZ so most ports active on the machine bypass the modem, and are basically controlled by the firewall. The machine runs Linux Mint Cinnamon. I have a STATIC IP on the modem. The lan the machine runs on, is 192.168.20..... a private range.  The machine runs Apache2 web server hosting multiple domains. The DNS is handled by the company i purchased the domains from and they are not locked, WWW services through Apache work and virtual domains function. MX record is set for my domain and resolves.

The problem i have is receiving email. I can send email out through the SMTP just fine, to my hotmail and gmail accounts.

I CAN NOT GET ANY EXTERNAL EMAILS INTO THE MACHINE. The errors i get on the returned emails are "connection refused (10061) just an example from hotmail....

 

Any ideas on whats going on?

SSL works fine on Apache...is there something im missing with SSL on the mail server?

 

 



[#] Wed Dec 27 2017 09:53:56 EST from steve @ Uncensored

Subject: Re: IMAP/POP3 problems

[Reply] [ReplyQuoted] [Headers] [Print]

Hey guys, got a few hours to sort out my email receive problem. Eventually after checking my modem/router for port forwarding and such, i used telnet to connect to my STATIC IP and checked the ports, as it turned out, i have a DVR CCTV system running and had port 25 being directed to it on the LAN, an entry in the NAT table had port 25 being "wrongly" pointed to the device. This is why i kept getting connection refused from the outside, while getting correct operation from the LAN side.......all's well that ends well, and for taking the time to sit down and find the fault .......

 

Regards

Steve



[#] Wed Dec 27 2017 13:15:18 EST from IGnatius T Foobar @ Uncensored

Subject: Citadel version 914 now available, and it runs on Stretch

[Reply] [ReplyQuoted] [Headers] [Print]

Ok folks ... the long-awaited Citadel 914 is now available from www.citadel.org , both as source code tarballs and via Easy Install deployment.

This version has been tested on Debian 9 ("stretch") and has all of the updates required to make it compile and run properly with that platform's updated system libraries (openssl 1.1, etc)

Back up your Citadel installation before running an upgrade.  If version 914 destroys your data and you didn't take a backup, we will point at you and laugh.  This version is cosmetically pretty similar to the previous couple of versions, but it changes a lot of things around under the covers.  In particular, the Internet email addresses for each user are now stored in the user records and indexed directly, rather than being stored in the Global Address Book.  "directory" domains are now identical to "local" domains.  Your database will be automatically updated the first time you start up the server.  Be patient, as this could take a few minutes on a large system.

By the way ... 914 just happened to be the next version number in the sequence.  It doesn't have anything to do with the 914 area code (Westchester county, New York state, USA) whose BBS scene in the 1980's and 1990's brought us to the place where we are today.  It's just a happy coincidence.



[#] Wed Dec 27 2017 23:57:44 EST from larcrom @ Uncensored

Subject: error installing citadel

[Reply] [ReplyQuoted] [Headers] [Print]

I am getting this error when I try to install citadel.

find: './techdoc': No such file or directory

/usr/bin/install -c -m 644 README.txt /usr/local/citadel/README.txt

make[1]: msgfmt: Command not found

Makefile:21: recipe for target '../../locale/ko/LC_MESSAGES/citadel-setup.mo' failed

make[1]: *** [../../locale/ko/LC_MESSAGES/citadel-setup.mo] Error 127

Makefile:185: recipe for target 'install-locale' failed

make: *** [install-locale] Error 2 Post message 

Operating system: Linux Debian 9.1 ( 4.9.59-v7+ armv7l)

 

Any help?

 



[#] Thu Dec 28 2017 18:04:26 EST from markus @ Uncensored

Subject: Pop3 fetcher does not work as it should

[Reply] [ReplyQuoted] [Headers] [Print]

Hello again,

I have six email accounts from which my citadel server should retrieve emails via pop3 fetcher. But it works only for half of them. In former times it works quite well for all of them. But I swichted from debian 7 to 8 and I use system's citadel packages.

I know from former answer in this forum that older citadel versions could get stuck retrieving emails. In case I don't want to switch to a more recent citadel version from your website what can I do in order to make the pop3 fetcher that comes with debian 8 work again for the currently not working accounts? Does the fetcher have all retrieved mails in mind, is it possible to somehow reset it's memory so that it tries to retrieve all massages that it could find again?

It would be very kind of you if you could give me any hint! Thank you in advance.

Markus



[#] Fri Dec 29 2017 17:25:32 EST from markus @ Uncensored

Subject: Re: Pop3 fetcher does not work as it should

[Reply] [ReplyQuoted] [Headers] [Print]

I don't need your help anymore, because I could solve the problem by following these steps:

- For each mail account the pop3 fetcher does not work anymore I have created two accounts within Thunderbird: One account that connects to citadel (account "c") and one that connects to my mail service provider (account "msp2).

- Then I have used Thunderbird to download all available mails from my service provider to the account "msp" via imap protocoll.

- After that I have used Thunderbird to move all mails from the account "msp" to the account "c".

After doing so I recognised that the pop3 fetcher works again for all new arriving mails.

 

Thu Dec 28 2017 18:04:26 EST from markus @ Uncensored Subject: Pop3 fetcher does not work as it should

Hello again,

I have six email accounts from which my citadel server should retrieve emails via pop3 fetcher. But it works only for half of them. In former times it works quite well for all of them. But I swichted from debian 7 to 8 and I use system's citadel packages.

I know from former answer in this forum that older citadel versions could get stuck retrieving emails. In case I don't want to switch to a more recent citadel version from your website what can I do in order to make the pop3 fetcher that comes with debian 8 work again for the currently not working accounts? Does the fetcher have all retrieved mails in mind, is it possible to somehow reset it's memory so that it tries to retrieve all massages that it could find again?

It would be very kind of you if you could give me any hint! Thank you in advance.

Markus



 



[#] Sat Dec 30 2017 07:32:06 EST from nktech1135 @ Uncensored

Subject: citadel development status?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello.

I'm a newby to citadel and am trouble figurring out if it's still in active development?

  If it is, is there a place to see what the current stable version is and release notes?

 

Thanks.

 



[#] Sun Dec 31 2017 02:09:48 EST from Patrick @ Uncensored

Subject: EasyInstall completes all steps, except 'Installing Citadel . . .;

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I have slowly added dependancies as I find they are missing, but just when I thought I was 'there', it fails with

the contents of citadel-install-log.txt:

/usr/local/ctdlsupport/include/libical/ical.h:3183:13: note: expected 'icaltimezone * {aka struct _icaltimezone *}' but argument is of type 'const icaltimezone * {aka const struct _icaltimezone *}'
 const char* icaltimezone_get_tzid   (icaltimezone *zone);
             ^~~~~~~~~~~~~~~~~~~~~
modules/calendar/serv_calendar.c:2160:59: warning: passing argument 1 of 'icaltimezone_get_component' discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
   zc = icalcomponent_new_clone(icaltimezone_get_component(attached_zones[i]));
                                                           ^~~~~~~~~~~~~~
In file included from modules/calendar/serv_calendar.c:21:0:
/usr/local/ctdlsupport/include/libical/ical.h:3201:16: note: expected 'icaltimezone * {aka struct _icaltimezone *}' but argument is of type 'const icaltimezone * {aka const struct _icaltimezone *}'
 icalcomponent* icaltimezone_get_component (icaltimezone *zone);
                ^~~~~~~~~~~~~~~~~~~~~~~~~~
CC modules/checkpoint/serv_checkpoint.c
CC modules/clamav/serv_virus.c
CC modules/crypto/serv_crypto.c
modules/crypto/serv_crypto.c: In function 'init_ssl':
modules/crypto/serv_crypto.c:86:3: warning: implicit declaration of function 'RAND_egd' [-Wimplicit-function-declaration]
   RAND_egd(EGD_POOL);
   ^~~~~~~~
modules/crypto/serv_crypto.c:174:3: warning: 'RSA_generate_key' is deprecated [-Wdeprecated-declarations]
   rsa = RSA_generate_key(1024, /* modulus size */
   ^~~
In file included from /usr/include/openssl/rsa.h:13:0,
                 from /usr/include/openssl/x509.h:31,
                 from /usr/include/openssl/ssl.h:50,
                 from modules/crypto/serv_crypto.c:20:
/usr/include/openssl/rsa.h:193:1: note: declared here
 DEPRECATEDIN_0_9_8(RSA *RSA_generate_key(int bits, unsigned long e, void
 ^
modules/crypto/serv_crypto.c:306:35: error: dereferencing pointer to incomplete type 'X509_REQ {aka struct X509_req_st}'
      X509_set_issuer_name(cer, req->req_info->subject);
                                   ^~
In file included from /usr/include/openssl/ssl.h:48:0,
                 from modules/crypto/serv_crypto.c:20:
modules/crypto/serv_crypto.c: In function 'CtdlStartTLS':
modules/crypto/serv_crypto.c:638:23: error: dereferencing pointer to incomplete type 'SSL {aka struct ssl_st}'
  BIO_set_close(CC->ssl->rbio, BIO_NOCLOSE);
                       ^
At top level:
modules/crypto/serv_crypto.c:61:22: warning: 'id_callback' defined but not used [-Wunused-function]
 static unsigned long id_callback(void)
                      ^~~~~~~~~~~
Makefile:145: recipe for target 'modules/crypto/serv_crypto.o' failed
make: *** [modules/crypto/serv_crypto.o] Error 1
Operating system: Linux Debian 9.3 ( 4.9.59+ armv6l)

 

I can't tell if it's the deprecated RSA generate_key story, or some other reason preventing the installation.  I have the latest EasyInstall, downloaded within the last 48 hours.

PLEASE HELP!



[#] Mon Jan 01 2018 18:53:45 EST from IGnatius T Foobar @ Uncensored

Subject: Re: EasyInstall completes all steps, except 'Installing Citadel . . .;

[Reply] [ReplyQuoted] [Headers] [Print]

I can't tell if it's the deprecated RSA generate_key story, or some
other reason preventing the installation.  I have the latest
EasyInstall, downloaded within the last 48 hours.

PLEASE HELP!

Good news! Citadel has just been updated TODAY to handle OpenSSL 1.1.

All you have to do is run Easy Install again.

Enjoy!

[#] Tue Jan 02 2018 16:19:37 EST from nunction @ Uncensored

Subject: EasyInstall OpenLDAP authentication support

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I installed citadel (Version 916 (build a1ef5b0)) with easy install on Debian 9 and configured LDAP authentication. Which then causes citadel to fail to start after the configuration to LDAP with the message:

"Your system is configured for LDAP authentication, but you are running a server built without OpenLDAP support.".

How do I install citadel with OpenLDAP support?

 

Regards,

 

Philipp



[#] Wed Jan 03 2018 10:12:20 EST from IGnatius T Foobar @ Uncensored

Subject: Re: EasyInstall OpenLDAP authentication support

[Reply] [ReplyQuoted] [Headers] [Print]

How do I install citadel with OpenLDAP support?

apt install libldap2-dev
rm -f /usr/local/ctdlsupport/etc/*.sum
Run the Easy Install again

(removing *.sum tricks Easy Install into thinking it needs to rebuild everything)

[#] Wed Jan 03 2018 10:46:23 EST from Patrick @ Uncensored

Subject: Re: EasyInstall completes all steps, except 'Installing Citadel . . .;

[Reply] [ReplyQuoted] [Headers] [Print]

Thank you Ignatius!

After 10 years of learning Linux and slowly moving away from an MCSE background, I still rely so heavily on people like yourself that are able actually program for Linux. (Something that I haven't learned after beginning with Pastel / Delphi decades ago).

I am envious (and appreciate) your abilities.

Thank you to yourself and all the others who contribute so much to the community!

 



[#] Wed Jan 03 2018 16:33:18 EST from wildphins @ Uncensored

Subject: Configuring SMTP relay for outgoing mail

[Reply] [ReplyQuoted] [Headers] [Print]

Didn't get any response from my first post so I will try again.

Hi all.  I am playing around with Citadel, hoping to have my own mail server for my email accounts.  I am having trouble configuring SMTP relay.  My ISP requires a login in order to send. I don't think I can use my ISP's server as my email domain is different from the SMTP server (they changed somewhere along the line and my email is basically grandfathered). So I am trying to use a google account. The Webcit configuration looks like this: smtps://username:password@gmail.com:465. It fails to send, and when I check the syslog, I see this: trying smtps://username:password@gmail.com:465/compname, where compname is the name I gave to the server when I installed the OS. That name certainly means nothing outside of my network, and I'm not sure if Citadel is sending the request that way. The other really embarrassing question I have, is where are the Citadel configuration files? I am running Ubuntu 17.10 and Citadel 911. I have done a search and cannot find where they are hiding. I am an experienced IT professional, but a Linux novice for sure, so please forgive my ignorance. Thanks!

 


[#] Wed Jan 03 2018 17:01:56 EST from Taegis @ Uncensored

Subject: Mailing/Distribution lists

[Reply] [ReplyQuoted] [Headers] [Print]

Hi, I created a room and I'm trying to set it up to receive emails and then distribute them to a couple of different users. For example I created a room called info, and I set up the Alternative public emailaddresses pointing to this room: to info@example.com and the 'from' address to info@example.com. I also added a test email to the general mailing list, so whenever I create a post, an email is sent to the test address from info@example.com. However, whenever I try to reply to that same address, I get a message back saying that the address doesn't exist: 550 Invalid recipient.



[#] Wed Jan 03 2018 17:07:19 EST from Taegis @ Uncensored

Subject: Re: Mailing/Distribution lists

[Reply] [ReplyQuoted] [Headers] [Print]

Also, I should say that replying to room_info@test.com, DOES work. I was just wondering if I could somehow get emails from info@test.com to make it to the room as well.



[#] Wed Jan 03 2018 21:36:36 EST from nunction @ Uncensored

Subject: Re: EasyInstall OpenLDAP authentication support

[Reply] [ReplyQuoted] [Headers] [Print]

Tried it, but got the same result.

Your system is configured for LDAP authentication,

but you are running a server built without OpenLDAP support.

Apt install:

libldap2-dev is already the newest version (2.4.44+dfsg-5+deb9u1).

Part of citadel-install-log.txt:

checking ldap.h usability... yes

checking ldap.h presence... yes

checking for ldap.h... yes

checking for ldap_initialize in -lldap... yes


Regards,


Philipp



Go to page: First ... 27 28 29 30 [31] 32 33 34 35 ... Last