Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Sun Mar 18 2018 17:02:15 EDT from rafaeltc @ Uncensored

Subject: Need MAIL before RCPT

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

Whenever I try to send a message from a mail client (thunderbird, outlook, etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.



[#] Sun Mar 18 2018 17:09:13 EDT from "fedorowp" <fedorowp@driveforge.org> to Citadel Support <room_Citadel_Support@citadel.org>,room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I received the same error when I did the Easy Install yesterday, then imported my existing data.

The solution I came across was to set the preferred e-mail address for my users in the user edit account screen, (not the Address Book).


On March 18, 2018 5:03:04 PM EDT, Citadel Support <room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: rafaeltc @uncnsrd
Subject: Need MAIL before RCPT

Hello,

Whenever I try to send a message from a mail client (thunderbird,
outlook,
etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

[#] Sun Mar 18 2018 17:09:13 EDT from "fedorowp" <fedorowp@driveforge.org> to Citadel Support <room_Citadel_Support@citadel.org>,room_Citadel_Support@citadel.org

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I received the same error when I did the Easy Install yesterday, then imported my existing data.

The solution I came across was to set the preferred e-mail address for my users in the user edit account screen, (not the Address Book).


On March 18, 2018 5:03:04 PM EDT, Citadel Support <room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: rafaeltc @uncnsrd
Subject: Need MAIL before RCPT

Hello,

Whenever I try to send a message from a mail client (thunderbird,
outlook,
etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

[#] Sun Mar 18 2018 17:34:58 EDT from rafaeltc @ Uncensored

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Thank you fedorowp, this solved the issue.

Rafael.

Sun Mar 18 2018 17:09:13 EDT from "fedorowp" <fedorowp@driveforge.org> Subject: Re: [Citadel Support]
Hi,

I received the same error when I did the Easy Install yesterday, then imported my existing data.

The solution I came across was to set the preferred e-mail address for my users in the user edit account screen, (not the Address Book).


On March 18, 2018 5:03:04 PM EDT, Citadel Support <room_Citadel_Support@citadel.org> wrote:

------------------------------------------------------------------------------
From: rafaeltc @uncnsrd
Subject: Need MAIL before RCPT

Hello,

Whenever I try to send a message from a mail client (thunderbird,
outlook,
etc) I get the error from the mail server:

"Need MAIL before RCPT."

I'm using port 587 to connect to the mail server.

If I send the email through webcit it works.
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

 



[#] Mon Mar 19 2018 10:04:19 EDT from Freakdog @ Uncensored

Subject: Re: Easy Install error on Asterisk server

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Mar 16 2018 15:07:31 EDT from 2oolate @ Uncensored Subject: Easy Install error on Asterisk server

Hi,

I was trying to run Easy Install on the same server I'm running Asterisk 2.6.32-358 which is running Red Hat 6.4 after installing all the Red Hat prerequisites, and I received the following error:

configure: error: OpenLDAP development headers were not found and are required.  More info: http://www.citadel.org/doku.php/installation:start

I then found openLDAP, downloaded it and tried to install it, but it failed as well on a BerkleyDB not installed error.  Have installed version 6.2 of BerkleyDB, but now when I try to install OpenLDAP I'm getting a version error saying the following:

configure: error: BerkeleyDB version incompatible with BDB/HDB backends

 

What version of BerkleyDB do I need to use?

Thanks

Ira

Ira,

On Red Hat/CentOS/Scientific/<insert your Red Hat derivative distro package name here>, "development headers" are installed via the <package>-devel packages. Have you verified that you have the openldap-devel package(s) installed?

rpm -qa | grep openldap

If you don't see openldap-devel in the package list, run yum install openldap-devel and, voila!



[#] Mon Mar 19 2018 16:23:02 EDT from alex007 @ Uncensored

Subject: migration from 8.22 to 9.17

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all,

I've installed a fresh citadel 9.17 (arm on raspberrypi stretch) with easy install.

I want to migrate my Data from a 8.22 install (LHS).

Is that possible or would you rather shout : no!

I think, there is a

1. config

and

2. data

that have to recover.

Any help would be great

Alex



[#] Mon Mar 19 2018 16:54:26 EDT from "fedorowp" <fedorowp@driveforge.org> to Citadel Support <room_Citadel_Support@citadel.org>

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Alex,

See
http://www.citadel.org/doku.php/documentation:system_administration_manual#importingexportingyourcitadeldatabase

The database has the majority of the configuration.

In the event you have customized messages and things like that, you can
probably find them in one of:
/etc/citadel
/var/lib/citadel
/usr/local/citadel

Regards,
Peter


On 2018-03-19 04:23 PM, Citadel Support wrote:

------------------------------------------------------------------------------
From: alex007 <alex007@uncensored.citadel.org>
Subject: migration from 8.22 to 9.17

Hi all,

I've installed a fresh citadel 9.17 (arm on raspberrypi stretch) with easy
install.

I want to migrate my Data from a 8.22 install (LHS).

Is that possible or would you rather shout : no!

I think, there is a

1. config

and

2. data

that have to recover.

Any help would be great

Alex
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

[#] Mon Mar 19 2018 17:36:49 EDT from alex007 @ Uncensored

Subject: Re: [Citadel Support]

[Reply] [ReplyQuoted] [Headers] [Print]

Hi Peter,

ah, there is the info, thanks a lot. I will read and try to migrate...

Best regards

Alex

 

Mon Mar 19 2018 16:54:26 EDT from "fedorowp" <fedorowp@driveforge.org> Subject: Re: [Citadel Support]
Hi Alex,

See
http://www.citadel.org/doku.php/documentation:system_administration_manual#importingexportingyourcitadeldatabase

The database has the majority of the configuration.

In the event you have customized messages and things like that, you can
probably find them in one of:
/etc/citadel
/var/lib/citadel
/usr/local/citadel

Regards,
Peter


On 2018-03-19 04:23 PM, Citadel Support wrote:

------------------------------------------------------------------------------
From: alex007 <alex007@uncensored.citadel.org>
Subject: migration from 8.22 to 9.17

Hi all,

I've installed a fresh citadel 9.17 (arm on raspberrypi stretch) with easy
install.

I want to migrate my Data from a 8.22 install (LHS).

Is that possible or would you rather shout : no!

I think, there is a

1. config

and

2. data

that have to recover.

Any help would be great

Alex
------------------------------------------------------------------------------
You are subscribed to the 'Citadel Support' list.
To post to the list: room_citadel_support@citadel.org

 



[#] Tue Mar 20 2018 06:52:56 EDT from bennyb @ Uncensored

Subject: Citadel server down

[Reply] [ReplyQuoted] [Headers] [Print]

Hello all,

I've been running a Citadel server as our primary mail server for over a year. As of yesterday morning we were experiencing issues with the availability of the mail server. It came up and went back down irregulary. Since yesterday evening the server has been down completely.

I've rebooted the server repeatedly which normally fixes these kind of issues but this didn't help in this case. If I look at services it indicates the citadel service is up:

 [ + ]  acpid
 [ + ]  apache2
 [ + ]  apparmor
 [ ? ]  apport
 [ + ]  atd
 [ + ]  citadel

but when I go to the websit it gives error 503 which indicates the service is not available.

When I check with ps command what instances are running I get:

root@webserver2:/# ps -eaf |grep cit
root      1464     1  3 11:07 ?        00:01:36 /usr/sbin/citserver -d -x3 -lmail -t/dev/null
root      3527     1  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.81 -p81 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.81.log
nobody    3528  3527  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.81 -p81 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.81.log
root      3530     1  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
nobody    3531  3530  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
root      4149  2021  0 11:48 pts/0    00:00:00 grep --color=auto cit

i've noticed that I've only got the one instance of the citserver in the list and not two as in the faq example.

service citadel restart doesn't give any errors, however service citadel stop doesn't give any errors either but the instance of citserver on the root user seems to keep running.

Can anyone give me some pointers as to what might be causing my issues and how to clear them?

Thanks in advance for the help.

Best regards.

Benny



[#] Tue Mar 20 2018 12:44:55 EDT from warbaby @ Uncensored

Subject: Re: Citadel server down

[Reply] [ReplyQuoted] [Headers] [Print]

That 503 is coming from apache not webcit. What is your distribution and version? What port is apache running on? Unless you know you are proxying kill/uninstall apache and restart webcit.  It looks like webcit is running on 81 and 443.  Provide a full ps - aux and netstat -lp  Did some update cause apache to get installed and start at boot?   You shouldn't need it.  If you're going to use it, you have to setup the proxying. 

I've noticed a tendancy for apache or apache-utils to start getting included as a dependency in other seemingly non-related packages (looking at you Debian).   FYI, you have citadel logging to /dev/null - Check your syslog and see if anything is showing up there.

  

Tue Mar 20 2018 06:52:56 AM EDT from bennyb @ Uncensored Subject: Citadel server down

Hello all,

I've been running a Citadel server as our primary mail server for over a year. As of yesterday morning we were experiencing issues with the availability of the mail server. It came up and went back down irregulary. Since yesterday evening the server has been down completely.

I've rebooted the server repeatedly which normally fixes these kind of issues but this didn't help in this case. If I look at services it indicates the citadel service is up:

 [ + ]  acpid
 [ + ]  apache2
 [ + ]  apparmor
 [ ? ]  apport
 [ + ]  atd
 [ + ]  citadel

but when I go to the websit it gives error 503 which indicates the service is not available.

When I check with ps command what instances are running I get:

root@webserver2:/# ps -eaf |grep cit
root      1464     1  3 11:07 ?        00:01:36 /usr/sbin/citserver -d -x3 -lmail -t/dev/null
root      3527     1  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.81 -p81 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.81.log
nobody    3528  3527  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.81 -p81 127.0.0.1 504 -i0.0.0.0 -t/var/log/webcit//access.81.log
root      3530     1  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
nobody    3531  3530  0 11:26 ?        00:00:00 /usr/sbin/webcit -u 65534 -D/var/run/webcit/webcit.pid.443 -p443 127.0.0.1 504 -s -i0.0.0.0 -t/var/log/webcit//access.443.log -s
root      4149  2021  0 11:48 pts/0    00:00:00 grep --color=auto cit

i've noticed that I've only got the one instance of the citserver in the list and not two as in the faq example.

service citadel restart doesn't give any errors, however service citadel stop doesn't give any errors either but the instance of citserver on the root user seems to keep running.

Can anyone give me some pointers as to what might be causing my issues and how to clear them?

Thanks in advance for the help.

Best regards.

Benny



 



[#] Tue Mar 20 2018 20:57:12 EDT from citadel4dje @ Uncensored

Subject: Citadel on Debian Stretch??

[Reply] [ReplyQuoted] [Headers] [Print]

Does it install easily without problems??



[#] Wed Mar 21 2018 06:48:35 EDT from citadel4dje @ Uncensored

Subject: REST API

[Reply] [ReplyQuoted] [Headers] [Print]

Btw...also does it have REST API access?



[#] Wed Mar 21 2018 10:39:48 EDT from 2oolate @ Uncensored

Subject: Re: Easy Install error on Asterisk server

[Reply] [ReplyQuoted] [Headers] [Print]

That worked, thank you!

Ira



[#] Wed Mar 21 2018 11:34:25 EDT from 2oolate @ Uncensored

Subject: Re: Easy Install error on Asterisk server

[Reply] [ReplyQuoted] [Headers] [Print]

That worked, thank you!

Ira



[#] Wed Mar 21 2018 18:06:05 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: REST API

[Reply] [ReplyQuoted] [Headers] [Print]

Btw...also does it have REST API access?

It has an API, which is the protocol that the clients use to talk to the server.

It has a limited set of WebDAV operations which currently work.

You might be interested in the webcit-ng project, which is an effort to completely rewrite the WebCit user interface using modern HTML5 and a "responsive" web design. The entire thing is being built around REST with the user interface implemented as client-side JavaScript. Completion of this is still some time away, but we're definitely moving in that direction.

[#] Thu Mar 22 2018 13:42:47 EDT from moxy @ Uncensored

Subject: Force HTTPS

[Reply] [ReplyQuoted] [Headers] [Print]

I've installed my certs and everything shows secure and green when I point my browser to https://domain.com

Is there a way to make WebCit redirect everything to the secure page?



[#] Thu Mar 22 2018 14:13:38 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Force HTTPS

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a way to make WebCit redirect everything to the secure page?

Nope. Use a regular web server for that.

[#] Thu Mar 22 2018 15:12:08 EDT from warbaby @ Uncensored

Subject: Re: TLS/SSL/ encryption?

[Reply] [ReplyQuoted] [Headers] [Print]

You have 3 seperate tasks:

CERT FOR CITADEL

Copy the files from /etc/letsencrypt/live/<domain> to the citadel keys directory (/usr/local/citadel/keys for ezinstall)  A link won't work because root owns the files in /etc/letsencrypt ..citadel will hang/die.  I wrote a tutorial on this a while ago, posted here, don't see it at the moment.   I believe fullchain.pem -> citadel.csr and privkey.pem -> citadel.key.  But you should look at the content of those files to be sure.  There was some valid reason for using the fullchain, probabily to prevent an error in T-bird when letsencrypt was getting started.   This is for authentication from a mail client for SMTP, not SMTP smarthost setup. 

CERT FOR WEBCIT

If you're using webcit, do something similar in /usr/local/webcit/keys/ (those are ezinstall locations, yours may vary), which is used for the SSl on 443 for webcit.  I don't use it as a daily thing, but it's handy to have it up for configuration changes.  You can run webcit it with ssl on an alternate port (2000), while still running some other mail client (roundcube, whatever) on 443 on the same box. 

CONFIGURE A CLIENT

If you are sending okay on 25, you just have to bang around until you find the SSL settings which work.  After you have setup the cert & key for citadel, open the firewall for anthing like a SMTP port, 587 465 (ufw allow 587/tcp etc)  then use something like Thunderbird to auto configure itself on your email address.  The problem may not be SSL/TLS it could be sending the full email address instead of just the username. Cit wants plaintext auth, username only.  Also, check your mx records.  I'm using mail as a host name but it's not a bad idea to setup CNAMEs for imap. and smtp. some clients look for that.

To see what is going on all the while, tail the log file while you are working 

tail -f /var/log/mail.info

(mail.log, whereever you are logging)

USING A 3rd PARTY SMARTHOST

For auth from citadel to a smarhost, it doesn't require those keys,  it's handled by the open-ssl lib/pkg just make sure it's installed. Get the exact auth string from your provider.

 

Mon Mar 05 2018 07:07:36 PM EST from trundle @ Uncensored Subject: TLS/SSL/ encryption?

Hi Gang,

Been a lurker for quite sometime. Wanted to join in conversations but  I wanted to successfully deploy citadel mainly to use for spice works ticket system.

After going through the docs and googling, I feel like i know nothing about servers/networking/linux, even tho I have been a tech for a couple a years.

I can receive mail only if I open port 25, but curious how to get ssl/tls. I understand(or thought I did) that a tls session is wrapped around the message. 

I have applied a cert via letsencypt.

I would like to verify encryption is happening and not plain auth.

My ultimate goal is to stop gmail/yahoo/office365 to not saying my message was not encrypted or is that beacsue of my free cert from  letsencrypt?

I am sure someone has asked this, but failing to search for those posts. 

Is it possible to get some insight, suggestions, or link to search the support more thoroughly.

Willing to bang head and get through the headaches.

IF I am missing something easy, please slap me.

Thank you

<KnoNothingTech>



 



[#] Thu Mar 22 2018 15:21:03 EDT from warbaby @ Uncensored

Subject: Re: TLS/SSL/ encryption?

[Reply] [ReplyQuoted] [Headers] [Print]

Also, just to be clarify.. what I described is encryption on the connection (data-in-motion), not encrypted email (data-at-rest). That is normally done with your client, and probably GNU PGP, some plugins, jthings like that.   I mention this because you said "saying my message was not encrypted" which may be an idiomatic way of saying they wouldn't like your lack of an encrypted connection (which really only applies in a smarthost situation), but literally meaning encryption of the email message itself. 

Not trying to pick you apart here, just want to make sure we're communicating.

 

Mon Mar 05 2018 07:07:36 PM EST from trundle @ Uncensored Subject: TLS/SSL/ encryption?

Hi Gang,

Been a lurker for quite sometime. Wanted to join in conversations but  I wanted to successfully deploy citadel mainly to use for spice works ticket system.

After going through the docs and googling, I feel like i know nothing about servers/networking/linux, even tho I have been a tech for a couple a years.

I can receive mail only if I open port 25, but curious how to get ssl/tls. I understand(or thought I did) that a tls session is wrapped around the message. 

I have applied a cert via letsencypt.

I would like to verify encryption is happening and not plain auth.

My ultimate goal is to stop gmail/yahoo/office365 to not saying my message was not encrypted or is that beacsue of my free cert from  letsencrypt?

I am sure someone has asked this, but failing to search for those posts. 

Is it possible to get some insight, suggestions, or link to search the support more thoroughly.

Willing to bang head and get through the headaches.

IF I am missing something easy, please slap me.

Thank you

<KnoNothingTech>



 



[#] Thu Mar 22 2018 17:36:39 EDT from warbaby @ Uncensored

Subject: Having fun with Delta Chat & Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

So I've been playing with the DeltaChat "Chat via email" android app through my phone/citadel box and finding it a handy little thing, particularly for friends/family who can't or won't cope with any complexity.  DC is touted as "the ease of chat with the ubiquity of email" and I have to say it it's pretty much that.  It is an GPL 3 licensed pkg available through F-droid.  https://delta.chat/  

It's not a full-featured email client (and won't replace one), it's a chat app running over email (IMAP/SMTP) that accepts inline attachments and looks frighteningly like .. a chat app.   It's pretty neat.  Anybody running a citadel box should try it for work/home/play.  It works with any incoming mail, provided you "accept the request" (whitelist) the account to chat with you.

There are two minor rubs with Citadel: the auto config requires intervention, and DeltaChat occasionally complains about not being able to change to <main_floor>.  I did some renaming of floors, trying 'All' and a few other standard IMAP names, but there was no change, logs reveal no issues. Not really deal-breakers, but it would be nice to have things working seamlessly.

I'm going to speak with the Delta Chat developers about handling multiple root level folders (eg, floors) and  mailing list folders (public rooms) and work with them to get Citadel's folder/floor layout supported.  Also the auto config.  It will be good for both projects to have DeltaChat auto-configure any Citadel box based on email address and password with a proper MX record for the domain.  

If we can accomplish those things it will keep Citadel solidly in the "private chat server" space regardless of the future of XMPP.  This is my rational for enlisting the support of the community here. 

Take a look at it.  Try the client. https://delta.chat/en/download  Look at the code..  https://github.com/deltachat/deltachat-android  Also, F-droid (https://f-droid.org/) is a nice repository of FOSS apps for your android device. Also available on Google Play.

 

 

 

 

 



Go to page: [1] 2 3 4 5 ... Last