Language:
switch to room list switch to menu My folders
Go to page: First ... 20 21 22 23 [24] 25 26 27 28 ... Last
[#] Mon Dec 11 2017 02:14:46 EST from markus @ Uncensored

Subject: Re: Problem with retrieving messages from other mail server

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

thank you for your answer me.

I do have citadel 8.24-1 which comes with Debian 8. What can I do to overcome the problem with the pop3 fetcher in this version? By the way, I cannot seitch to Debian 9.

Regards

Markus

 

Sun Dec 10 2017 22:24:10 EST from IGnatius T Foobar @ Uncensored Subject: Re: Problem with retrieving messages from other mail server

markus: unless I missed it, you have not indicated what version of Citadel Server you are using? The POP3 fetcher was completely rewritten in version 910. Older versions might have had a habit of getting stuck, I'm not quite sure about it, but in 910 we switched to having libcurl do all of the protocol handling so it's more likely to run smoothly.

 



[#] Mon Dec 11 2017 09:38:47 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Problem with retrieving messages from other mail server

[Reply] [ReplyQuoted] [Headers] [Print]

Generally we are recommending that everyone should use the Easy Install build, because it is always up to date with the latest code and we can get you any needed fixes faster than in operating system packages. However, to switch from the packages to Easy Install you will need to follow this process:

1. Take a backup of your system.
2. Seriously, take a backup. You can mess things up here.
3. Look at http://www.citadel.org/doku.php/documentation:file_layout and move your data files to /usr/local/citadel as indicated.
4. Uninstall the .deb packages
5. Run the Easy Install process.

This will bring you up to a modern 9XX version of the Citadel system with the updated POP3 fetcher.

(Also follow the advice above and take a backup.)

[#] Tue Dec 12 2017 00:01:39 EST from JEJJ @ Uncensored

Subject: How do I turn Citadel ON?

[Reply] [ReplyQuoted] [Headers] [Print]

Would someone please tell me how to get Citadel up and running?  I have a linux box, run Debian latest, and the last thing I saw in my EasyInstall was that Citidel had installed but couldn't connect to " a server."  Which server, it never said and why it couldn't , it never said and error messages like why it couldn't connect, it never posted.  It just dropped me back to the command line and left me staring at a blinking cursor.   The one think I can think of was that I am running Apache2 on localhost:80 and if Citadel tried to connect on that port, it was busy adn couldn't get to me there. But I don't know for sure that was the problem.  The documentation is awful.  It doesn't answer even the most basic of basic questions, like "how do I turn this damned thing on?" or "even "how do I fire this thing up?"

 



[#] Tue Dec 12 2017 00:37:42 EST from JEJJ @ Uncensored

Subject: how to connect & configure?

[Reply] [ReplyQuoted] [Headers] [Print]

Would someone please tell me how to get Citadel running?  I have a linux box, run Debian latest, and the last thing I saw in my EasyInstall was that Citidel had installed but couldn't connect to " a server."  Which server, it never said, and why it couldn't , it never said, and error messages, it never posted.   It also never asked me for an admin username or password.  It just dropped me back to the command line and left me staring at a blinking cursor.   The one think I can think of was that I have Apache2 living on localhost:80 and if Citadel tried to connect to me there, it would fail since the port is in use.   But  I don't know for sure that was the problem.  The documentation is terrible.  It doesn't answer even the most basic of questions, like "how do I turn this damned thing on?" or "how do I fire this thing up?"

 



[#] Tue Dec 12 2017 16:14:55 EST from IGnatius T Foobar @ Uncensored

Subject: Re: how to connect & configure?

[Reply] [ReplyQuoted] [Headers] [Print]

During installation you were asked what port to run WebCit on. The default is usually port 2000. You can try pointing a web browser at that port. 80 is *not* the default for precisely the reason you specified: many sites already have some other web server running on port 80.




However, do keep in mind that there are a lot of reports of Citadel not working correctly with the very latest Debian. We are working on this and will have some fixes published soon.

[#] Tue Dec 12 2017 20:11:18 EST from solrosin @ Uncensored

Subject: Citadel isn't using SSL anywhere

[Reply] [ReplyQuoted] [Headers] [Print]

I installed Citadel using the easy install.  I see places in the configuration for SSL in IMAP and POP3, but nowhere to turn it on for webcit.  Also, I've placed citadel.key and citadel.crt in the keys directory, but even then, no SSL happens.  Port 993 never responds.  I'm at a total loss here as to why.  I've seen documentation that suggests that the setup was supposed to ask about SSL, but mine never did.  I really don't want to use insecure IMAP, SMTP, and web access if I can help it.  That was why I switched away from it the first time, only to find even more frustration with postfix/saslauthd/courier IMAP when it randomly decides to stop letting me send emails because the authentication breaks for no reason.  I really could use some insight into why Citadel isn't using SSL like it should be.

 



[#] Tue Dec 12 2017 23:07:15 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel isn't using SSL anywhere

[Reply] [ReplyQuoted] [Headers] [Print]

Do you have the OpenSSL development libraries installed on your system? If the library is not present, Citadel will be built without SSL support.

[#] Wed Dec 13 2017 05:20:59 EST from monodrones @ Uncensored

Subject: Can't remove alt. public email addr. from a rooms mailinglist service

[Reply] [ReplyQuoted] [Headers] [Print]

I hope this is the right place an time to drop my support request / bug report.

I currently installed citadel on my server and am very new to citadel. I set up an Mailinglist Service in a newly created room and I set up a alternative public email address pointing to this room (option at the bottom)

My Problem:

I cannot remove the email address I set up at this option. I click on the remove link after the email adress, but it does not get removed. I removed the mailinglist and created it again but the mail was still there.

How can I remove this entry?

The Problem with my Problem:

The email I set up, was a email of a useraccount of mine (robert@<mydomain.xyz>). Now emails sent to this email address will bounce and not arrive my mail folder.

Bounce Message:

 

This is the mail system at host mout01.posteo.de.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<robert@<mydomain>>: host mail.<mydomain>[88.80.192.145] said: 550 Invalid
    recipient: room_mailinglist (in reply to RCPT TO command)
Reporting-MTA: dns; mout01.posteo.de
X-Postfix-Queue-ID: 32C0720F99
X-Postfix-Sender: rfc822; <name>@posteo.de
Arrival-Date: Wed, 13 Dec 2017 11:16:14 +0100 (CET)

Final-Recipient: rfc822; robert@<mydomain>
Original-Recipient: rfc822;robert@y<mydomain>
Action: failed
Status: 5.0.0
Remote-MTA: dns; mail.<mydoamin>
Diagnostic-Code: smtp; 550 Invalid recipient: room_mailinglist
Return-Path: <<name>@posteo.de>
Received: from mout01.posteo.de (unknown [10.0.0.65])
	by mout01.posteo.de (Postfix) with ESMTPS id 32C0720F99
	for <robert@<mydomain>>; Wed, 13 Dec 2017 11:16:14 +0100 (CET)
Received: from submission-encrypt01.posteo.de (unknown [10.0.0.76])
	by mout01.posteo.de (Postfix) with ESMTPS id EE04620F6F
	for <robert@<mydomain>>; Wed, 13 Dec 2017 11:16:13 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=posteo.de; s=2017;
	t=1513160174; bh=SnPojxEgLBke1q6sXVxxo6kjisO8eoqeq0d48EPvkqA=;
	h=Date:From:To:Subject:From;
	b=BvX+6WSPUqIfg1ftl6RysNfM/dm5YXkySErDoKZBoWhBwP0g4UYi50I4MzJHZD+uS
	 dPffNsHfs95510cW2X3XxyEdy0wiXlfl72vXDtplhgo5OBOiM+GwLvOnjt1HCoAYGU
	 Rh5XMBlEg57OVyzqg/H2Luc+Efgmoga4tHqkwKFLmihA4K92flZkM6T8P/4FMw0F4h
	 CVAVeynn8ZWkz+vP4Uy85CczioYEZ2tE6KUz7w3c5rBCI03FMiUE1FHN2ArHbBweYv
	 aRSvWcBitYeiV7Uzn+UM3vheoUYKt3miV7D0VgKZ3ATrSFaRDlmVf+robpDZB7MJ4c
	 xfTx9Y8QyoCwQ==
Received: from customer (localhost [127.0.0.1])
	by submission (posteo.de) with ESMTPSA id 3yxXf52gh0z9rxH
	for <robert@<mydomain>>; Wed, 13 Dec 2017 11:16:13 +0100 (CET)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8;
 format=flowed
Content-Transfer-Encoding: quoted-printable
Date: Wed, 13 Dec 2017 11:16:13 +0100
From: Robert <<name>@posteo.de>
To: Robert <robert@<mydomain>>
Subject: Test
Message-ID: <ddc0a8359044fe9cbd861762f2c4da72@posteo.de>
X-Sender: <name>@posteo.de
User-Agent: Posteo Webmail
Posteo-User: <name>@posteo.de
Posteo-DKIM: ok


[#] Wed Dec 13 2017 09:57:22 EST from solrosin @ Uncensored

Subject: Re: Citadel isn't using SSL anywhere

[Reply] [ReplyQuoted] [Headers] [Print]

They really ought to add that bit to the install guide.  The "easy install" insinuates that it downloads and installs everything it requires.  I deleted it and reinstalled it with that library in place, and now it seems to use SSL.  



[#] Wed Dec 13 2017 18:45:30 EST from markus @ Uncensored

Subject: Re: Problem with retrieving messages from other mail server

[Reply] [ReplyQuoted] [Headers] [Print]

Whenever possible I don't want change my current verion of citadel. Is it possible to somehow reset the pop3 fetcher? As far as I understand the provider of the mailbox which citadel fetches, citadel simply touches the mails so that they aren't new anymore and so they aren't retieved. This behavour starts suddenly and only for a single mailbox. For all the other mailboxes that are fetched the pop3 fetcher works well.

Sun Dec 10 2017 22:24:10 EST from IGnatius T Foobar @ Uncensored Subject: Re: Problem with retrieving messages from other mail server

markus: unless I missed it, you have not indicated what version of Citadel Server you are using? The POP3 fetcher was completely rewritten in version 910. Older versions might have had a habit of getting stuck, I'm not quite sure about it, but in 910 we switched to having libcurl do all of the protocol handling so it's more likely to run smoothly.

 



[#] Wed Dec 13 2017 19:22:13 EST from JEJJ @ Uncensored

Subject: Re: how to connect & configure?

[Reply] [ReplyQuoted] [Headers] [Print]

 

 

Actually, no, I was never asked which port Webcit should run on.  Here's the final page of the log, note that I also found in it "no such file as /usr/local/citadel/citadel-admin.socket":

------------------------------------------------------------------------
Character set conversion support: yes

Note: if you are not using Linux, make sure you are using GNU make
(gmake) to compile Citadel.


Dependencies: gcc -M -I/usr/local/ctdlsupport/include  -g -I/usr/local/ctdlsupport/include  -g -I. -I ./src/include/  | sed -e 's!.o!.o /.o buildinfo!' > buildinfo
Complie: gcc -I/usr/local/citadel  -I/usr/local/ctdlsupport/include  -g -I/usr/local/ctdlsupport/include  -g -Wall -Wcast-qual -Wcast-align -Wstrict-prototypes -Wno-strict-aliasing -D_REENTRANT -pthread  -I ./include/ -I/usr/local/ctdlsupport/include  -g -I/usr/local/ctdlsupport/include  -g -I. -I ./src/include/ -DHAVE_CONFIG_H -DDIFF="/usr/bin/diff" -DPATCH="/usr/bin/patch" -c  -o buildinfo
LDFLAGS: -L/usr/local/citadel -L/usr/local/ctdlsupport/lib -Wl,--rpath -Wl,/usr/local/ctdlsupport/lib

CC src/citadel.c
CC src/client_chat.c
CC src/client_passwords.c
CC src/commands.c
CC src/md5.c
src/md5.c: In function 'MD5Final':
src/md5.c:153:26: warning: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Wsizeof-pointer-memaccess]
     memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
                          ^
CC src/messages.c
CC src/rooms.c
CC src/routines.c
CC src/routines2.c
src/routines2.c: In function 'upload':
src/routines2.c:370:8: warning: implicit declaration of function 'ka_wait' [-Wimplicit-function-declaration]
    b = ka_wait(&a);
        ^~~~~~~
CC src/tuiconfig.c
CC src/screen.c
CC src/ecrash.c
CC src/citadel_ipc.c
src/citadel_ipc.c:3033:22: warning: 'id_callback' defined but not used [-Wunused-function]
 static unsigned long id_callback(void) {
                      ^~~~~~~~~~~
src/citadel_ipc.c:2938:13: warning: 'ssl_lock' defined but not used [-Wunused-function]
 static void ssl_lock(int mode, int n, const char *file, int line)
             ^~~~~~~~
CC src/ipc_c_tcp.c

Dependencies: gcc -M -I/usr/local/ctdlsupport/include  -g -I/usr/local/ctdlsupport/include  -g -I. -I ./src/include/  | sed -e 's!.o!.o /.o buildinfo!' > buildinfo
Complie: gcc -I/usr/local/citadel  -I/usr/local/ctdlsupport/include  -g -I/usr/local/ctdlsupport/include  -g -Wall -Wcast-qual -Wcast-align -Wstrict-prototypes -Wno-strict-aliasing -D_REENTRANT -pthread  -I ./include/ -I/usr/local/ctdlsupport/include  -g -I/usr/local/ctdlsupport/include  -g -I. -I ./src/include/ -DHAVE_CONFIG_H -DDIFF="/usr/bin/diff" -DPATCH="/usr/bin/patch" -c  -o buildinfo
LDFLAGS: -L/usr/local/citadel -L/usr/local/ctdlsupport/lib -Wl,--rpath -Wl,/usr/local/ctdlsupport/lib

/usr/bin/install -c citadel /usr/local/citadel/citadel
find: './help': No such file or directory
find: './messages': No such file or directory
find: './network': No such file or directory
/usr/bin/install -c -m 644 citadel.rc /usr/local/citadel/citadel.rc

Installation is complete.

--2017-12-11 20:22:55--  http://easyinstall.citadel.org/citadel-init-scripts.tar
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10240 (10K) [application/x-tar]
Saving to: 'citadel-init-scripts.tar'

     0K ..........                                            100% 51.0K=0.2s

2017-12-11 20:23:00 (51.0 KB/s) - 'citadel-init-scripts.tar' saved [10240/10240]

Operating system: Linux Debian 9.3 ( 4.9.0-4-686-pae i686)



[#] Wed Dec 13 2017 21:22:39 EST from solrosin @ Uncensored

Subject: One more little glitch - email aliases

[Reply] [ReplyQuoted] [Headers] [Print]

I can't seem to get email aliases to take.  I change it, but it's not there when I go back to the contact preferences.  I need my admin account to be able to receive emails for "root@" my domain.



[#] Fri Dec 15 2017 12:09:14 EST from kinetix @ Uncensored

Subject: Re: Citadel isn't using SSL anywhere

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

Which install guide did you use?  The path to the documentation may not be clear, as going to "Documentation" on citadel.org doesn't seem to get you to the install info as easily as going to "Download".  However, if you go to Download and hit the Easy Install instructions, there's a whole section there on prerequisites for various distros, which does mention installing the openssl devel packages.

 

Wed Dec 13 2017 09:57:22 AM EST from solrosin @ Uncensored Subject: Re: Citadel isn't using SSL anywhere

They really ought to add that bit to the install guide.  The "easy install" insinuates that it downloads and installs everything it requires.  I deleted it and reinstalled it with that library in place, and now it seems to use SSL.  



 



[#] Sat Dec 16 2017 13:07:31 EST from jsco427 @ Uncensored

Subject: Re: Login Screen

[Reply] [ReplyQuoted] [Headers] [Print]

I am having the same problem. When I try to log in, I get a brief flash of "please wait" and then back to user and password. If I put in an incorrect password, I get a "wrong password" The correct password just does nothing. I have no access to the dashboard.



[#] Sun Dec 17 2017 20:04:18 EST from xavier @ Uncensored

Subject: Wrong Pwd ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello, i'm a new "user" of citadel..; well, I try to become, because... I always have "wrong pwd" whatever the pwd...

- raspberry pi3 

- Operating system: Linux Debian 9.1 ( 4.9.59-v7+ armv7l) (new sdcard install)

- apt-get update and upgrade

- I tried 2 install :

a) apt-get install citadel-suite : Install ok, but with webcit access, I always have "wrong pwd"...for all users, 

b) curl http://easyinstall.citadel.org/install | sh : install is "broken" :

/usr/bin/install -c -m 644 ./docs/views.txt /usr/local/citadel/./docs/views.txt
mkdir /usr/local/citadel/techdoc
find: './techdoc': No such file or directory
/usr/bin/install -c -m 644 openldap/./rfc2739.schema /usr/local/citadel/./rfc2739.schema
/usr/bin/install -c -m 644 openldap/./citadel.schema /usr/local/citadel/./citadel.schema
/usr/bin/install -c -m 644 README.txt /usr/local/citadel/README.txt
make[1]: msgfmt: Command not found
Makefile:21: recipe for target '../../locale/ko/LC_MESSAGES/citadel-setup.mo' failed
make[1]: *** [../../locale/ko/LC_MESSAGES/citadel-setup.mo] Error 127
Makefile:185: recipe for target 'install-locale' failed
make: *** [install-locale] Error 2

Could somebody help me please ?

Many thanks in advance !

Xavier

 

 



[#] Mon Dec 18 2017 08:07:56 EST from xavier @ Uncensored

Subject: Wrong Pwd ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

Is this the proper "official"  site of citadel support ?

Anyone to give a little help, please... ?

Tks in advance !

Xavier



[#] Mon Dec 18 2017 10:34:48 EST from Freakdog @ Dog Pound BBS II

Subject: Re: Wrong Pwd ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

Is this the proper "official"  site of citadel support ?

Anyone to give a little help, please... ?

Tks in advance !

Yes, it is. Welcome.

Please note that you're posting at 8AM EST in the US and the volunteers who might be able to help you are also working full time jobs.

Someone will reply to your actual issue when they have a free moment.

[#] Tue Dec 19 2017 04:47:12 EST from xavier @ Uncensored

Subject: Re: Wrong Pwd ?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

oh ! Yes, I'm sorry with the "French Time" :)

and I'm dying to start this new system :)

Tks for your answer

Waiting for a solution, maybe ? :)

Tks in advance,

Xavier



[#] Tue Dec 19 2017 06:54:12 EST from Oliverg @ Uncensored

Subject: Smart Hosts

[Reply] [ReplyQuoted] [Headers] [Print]

Hello Citadel Support, 

 

I have a problem with the relay of the Citadel Server.

I can't send Mails via my relay because- and so I guess- of the syntax of my User Data.

My user Data for my Relay/Smart Host is in this syntax: postmaster@xxxx:xxxx@mail.domain.com

 

So "postmaster@xxxx" is the Username after the "xxxx" the pw and the address after the @.

I guess, Citadel thinks after the first @ the rest is the address but this is wrong.

With an earlier version of Citadel this has work, but after an update not longer.

 

Do you have a solution for this problem? 

 

greetings Oliver G.



[#] Tue Dec 19 2017 11:11:57 EST from wildphins @ Uncensored

Subject: Configuring SMTP relay for outgoing mail

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all.  I am playing around with Citadel, hoping to have my own mail server for my email accounts.  I am having trouble configuring SMTP relay.  My ISP requires a login in order to send. I don't think I can use my ISP's server as my email domain is different from the SMTP server (they changed somewhere along the line and my email is basically grandfathered). So I am trying to use a google account. The Webcit configuration looks like this: smtps://username:password@gmail.com:465. It fails to send, and when I check the syslog, I see this: trying smtps://username:password@gmail.com:465/compname, where compname is the name I gave to the server when I installed the OS. That name certainly means nothing outside of my network, and I'm not sure if Citadel is sending the request that way. The other really embarrassing question I have, is where are the Citadel configuration files? I am running Ubuntu 17.10 and Citadel 911. I have done a search and cannot find where they are hiding. I am an experienced IT professional, but a Linux novice for sure, so please forgive my ignorance. Thanks!



Go to page: First ... 20 21 22 23 [24] 25 26 27 28 ... Last