Language:
switch to room list switch to menu My folders
Go to page: First ... 14 15 16 17 [18] 19 20 21 22 ... Last
[#] Wed Oct 04 2017 01:53:27 EDT from madpoet @ Uncensored

Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

[Reply] [ReplyQuoted] [Headers] [Print]

Yes, agreed. My google-fu is failing on this as well though. I am getting no where troubleshooting it. Do you have any suggestions?

Tue Oct 03 2017 17:13:15 EDT from bennabiy @ Uncensored Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

This might have something to do with it...

In file included from /usr/include/openssl/ssl.h:48:0,
                 from modules/crypto/serv_crypto.c:20:
modules/crypto/serv_crypto.c: In function 'CtdlStartTLS':
modules/crypto/serv_crypto.c:637:23: error: dereferencing pointer to incomplete type 'SSL {aka struct ssl_st}'
  BIO_set_close(CC->ssl->rbio, BIO_NOCLOSE);
                       ^



 



[#] Wed Oct 04 2017 07:43:01 EDT from Aleksas @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Hello, how do I check how many exactly emails have bounced in the smtp outbound quene, I need raw numbers, how do I do that ? And how do I extract those numbers in python script ?



[#] Thu Oct 05 2017 11:48:39 EDT from bennabiy @ Uncensored

Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

[Reply] [ReplyQuoted] [Headers] [Print]

Is it possible that the RPi repos you are using might not have the full versions of the dependencies? I know it compiles fine on a standard system, and have not tried it on a pi yet. I would check to make sure you have the correct openssl dev packages and that might mean compiling openssl for your pi.

Wed Oct 04 2017 01:53:27 AM EDT from madpoet @ Uncensored Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

Yes, agreed. My google-fu is failing on this as well though. I am getting no where troubleshooting it. Do you have any suggestions?

Tue Oct 03 2017 17:13:15 EDT from bennabiy @ Uncensored Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

This might have something to do with it...

In file included from /usr/include/openssl/ssl.h:48:0,
                 from modules/crypto/serv_crypto.c:20:
modules/crypto/serv_crypto.c: In function 'CtdlStartTLS':
modules/crypto/serv_crypto.c:637:23: error: dereferencing pointer to incomplete type 'SSL {aka struct ssl_st}'
  BIO_set_close(CC->ssl->rbio, BIO_NOCLOSE);
                       ^



 



 



[#] Thu Oct 05 2017 11:49:47 EDT from bennabiy @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Log parsing perhaps? (If you need it to be python friendly) 

Wed Oct 04 2017 07:43:01 AM EDT from Aleksas @ Uncensored

Hello, how do I check how many exactly emails have bounced in the smtp outbound quene, I need raw numbers, how do I do that ? And how do I extract those numbers in python script ?



 



[#] Sun Oct 08 2017 08:36:46 EDT from jiten @ Uncensored

Subject: how to setup GAJIM as XMPP client

[Reply] [ReplyQuoted] [Headers] [Print]



[#] Sun Oct 08 2017 08:37:21 EDT from jiten @ Uncensored

Subject: XMPP CLIENT GAJIM

[Reply] [ReplyQuoted] [Headers] [Print]

 

I am not able to connect to XMPP server through GAJIM client



[#] Sun Oct 08 2017 12:44:23 EDT from bennabiy @ Uncensored

Subject: Re: how to setup GAJIM as XMPP client

[Reply] [ReplyQuoted] [Headers] [Print]

Well, I would recommend looking at GAJIM's site and seeing if they have instructions. XMPP is typically on port 5222 by default, but you will have to make sure you have the firewall open for that (be wise, don't blindly open the firewall if you are not ready)...

 

The only part citadel plays is providing the service you are connecting to, so make sure your ports are configured, and you should be able to follow the directions GAJIM provides.

Sun Oct 08 2017 08:36:46 AM EDT from jiten @ Uncensored Subject: how to setup GAJIM as XMPP client


 



[#] Sun Oct 08 2017 16:42:18 EDT from mjkerpan @ Uncensored

Subject: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

When attempting to install Citadel on a VPS running Debian 9 (stretch), the process fails while trying to build libcitadel. I've attached the last 100 lines of the log. What's going on here and how may I fix it.



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Sun Oct 08 2017 17:20:20 EDT from bennabiy @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

Did you install all required dependencies as per the "Fine Manual"?

Sun Oct 08 2017 04:42:18 PM EDT from mjkerpan @ Uncensored Subject: Citadel build fails

When attempting to install Citadel on a VPS running Debian 9 (stretch), the process fails while trying to build libcitadel. I've attached the last 100 lines of the log. What's going on here and how may I fix it.



(, 0 bytes) [View| Download]

 



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Sun Oct 08 2017 17:56:28 EDT from mjkerpan @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Oct 08 2017 17:20:20 EDTfrom bennabiy @ Uncensored Subject: Re: Citadel build fails

Did you install all required dependencies as per the "Fine Manual"?

I followed the directions at http://citadel.org/doku.php/installation:easyinstall:prereq-debian.html. Going back through the logs, it appears that zlib and its development packages weeded to be installed before libcitadel would compile. However, after filling that dependecy, Citadel still won't build: now I'm having problems with serv_crypto.c I have libssl and its headers installed, so it SHOULD be working, but it doesn't. What gives.



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Mon Oct 09 2017 05:12:26 EDT from madpoet @ Uncensored

Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

[Reply] [ReplyQuoted] [Headers] [Print]

I suppose that could be the case. In previous updates to this thread, I include the versions/package info for all the packages noted as needed on the install site. I tried to compile it without easy install and I get the same results. If you would like me to manually compile anything, please let me know what.

 

Thu Oct 05 2017 11:48:39 EDT from bennabiy @ Uncensored Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

Is it possible that the RPi repos you are using might not have the full versions of the dependencies? I know it compiles fine on a standard system, and have not tried it on a pi yet. I would check to make sure you have the correct openssl dev packages and that might mean compiling openssl for your pi.

Wed Oct 04 2017 01:53:27 AM EDT from madpoet @ Uncensored Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

Yes, agreed. My google-fu is failing on this as well though. I am getting no where troubleshooting it. Do you have any suggestions?

Tue Oct 03 2017 17:13:15 EDT from bennabiy @ Uncensored Subject: Re: RPi2 Debian Stretch: Easy Install failing at serv_crypto.o

This might have something to do with it...

In file included from /usr/include/openssl/ssl.h:48:0,
                 from modules/crypto/serv_crypto.c:20:
modules/crypto/serv_crypto.c: In function 'CtdlStartTLS':
modules/crypto/serv_crypto.c:637:23: error: dereferencing pointer to incomplete type 'SSL {aka struct ssl_st}'
  BIO_set_close(CC->ssl->rbio, BIO_NOCLOSE);
                       ^



 



 



 



[#] Mon Oct 09 2017 05:14:26 EDT from madpoet @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

This appears to be the same issue I am experiencing with a raspberry pi 2 on Debian (raspbian) stretch.

Sun Oct 08 2017 17:56:28 EDT from mjkerpan @ Uncensored Subject: Re: Citadel build fails

 

Sun Oct 08 2017 17:20:20 EDTfrom bennabiy @ Uncensored Subject: Re: Citadel build fails

Did you install all required dependencies as per the "Fine Manual"?

I followed the directions at http://citadel.org/doku.php/installation:easyinstall:prereq-debian.html. Going back through the logs, it appears that zlib and its development packages weeded to be installed before libcitadel would compile. However, after filling that dependecy, Citadel still won't build: now I'm having problems with serv_crypto.c I have libssl and its headers installed, so it SHOULD be working, but it doesn't. What gives.



(, 0 bytes) [View| Download]

 



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Mon Oct 09 2017 11:33:21 EDT from mjkerpan @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Oct 09 2017 05:14:26 EDTfrom madpoet @ Uncensored Subject: Re: Citadel build fails

This appears to be the same issue I am experiencing with a raspberry pi 2 on Debian (raspbian) stretch.

So it seems that this is a generic problem with the libraries included with Debian Stretch, then since it's happening on both AMD64 and ARM...


citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Mon Oct 09 2017 13:35:33 EDT from bennabiy @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

I think that is a safe assumption. 

Mon Oct 09 2017 11:33:21 AM EDT from mjkerpan @ Uncensored Subject: Re: Citadel build fails

 

Mon Oct 09 2017 05:14:26 EDTfrom madpoet @ Uncensored Subject: Re: Citadel build fails

This appears to be the same issue I am experiencing with a raspberry pi 2 on Debian (raspbian) stretch.

So it seems that this is a generic problem with the libraries included with Debian Stretch, then since it's happening on both AMD64 and ARM...


(, 0 bytes) [View| Download]

 



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Mon Oct 09 2017 21:30:37 EDT from Pytry @ Uncensored

Subject: admin login on raspbian

[Reply] [ReplyQuoted] [Headers] [Print]

After I first isntall citadel-suite, and when I try to login to the webcit gui with default admin and settings, I get logged out automatically (no errors).

I'm unable to create new users.

When I go through the setup, I will change the user to run as to "citadel", but the next time I run it, it still thinks it is root.

I'm new ro all of this.

 



[#] Tue Oct 10 2017 02:10:53 EDT from madpoet @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

I can confirm no issues with debian Jesse on ARM.

Mon Oct 09 2017 13:35:33 EDT from bennabiy @ Uncensored Subject: Re: Citadel build fails

I think that is a safe assumption. 

Mon Oct 09 2017 11:33:21 AM EDT from mjkerpan @ Uncensored Subject: Re: Citadel build fails

 

Mon Oct 09 2017 05:14:26 EDTfrom madpoet @ Uncensored Subject: Re: Citadel build fails

This appears to be the same issue I am experiencing with a raspberry pi 2 on Debian (raspbian) stretch.

So it seems that this is a generic problem with the libraries included with Debian Stretch, then since it's happening on both AMD64 and ARM...


(, 0 bytes) [View| Download]

 



(, 0 bytes) [View| Download]

 



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Tue Oct 10 2017 10:43:50 EDT from bennabiy @ Uncensored

Subject: Re: admin login on raspbian

[Reply] [ReplyQuoted] [Headers] [Print]

I would highly recommend installing citadel through the easy installer, rather than the repositories. Much more current version, much better supported.

Mon Oct 09 2017 09:30:37 PM EDT from Pytry @ Uncensored Subject: admin login on raspbian

After I first isntall citadel-suite, and when I try to login to the webcit gui with default admin and settings, I get logged out automatically (no errors).

I'm unable to create new users.

When I go through the setup, I will change the user to run as to "citadel", but the next time I run it, it still thinks it is root.

I'm new ro all of this.

 



 



[#] Tue Oct 10 2017 14:12:23 EDT from bennabiy @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]

This is being looked into. Hold tight :)

Mon Oct 09 2017 11:33:21 AM EDT from mjkerpan @ Uncensored Subject: Re: Citadel build fails

 

Mon Oct 09 2017 05:14:26 EDTfrom madpoet @ Uncensored Subject: Re: Citadel build fails

This appears to be the same issue I am experiencing with a raspberry pi 2 on Debian (raspbian) stretch.

So it seems that this is a generic problem with the libraries included with Debian Stretch, then since it's happening on both AMD64 and ARM...


(, 0 bytes) [View| Download]

 



citadelbuildfail.txt (text/plain, 7961 bytes) [View| Download]
[#] Mon Oct 16 2017 15:36:25 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: getcontenttype in PROPFIND

[Reply] [ReplyQuoted] [Headers] [Print]

The difference in the location of D:getcontenttype tag causes Inverse
SOGo Connector's Contacts support to fail. It will be great if we can
have this fixed in Citadel.

Thanks for reporting this. It will be fixed.

[#] Mon Oct 16 2017 15:37:40 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel build fails

[Reply] [ReplyQuoted] [Headers] [Print]


Attention: everyone who was having trouble building Citadel using the Easy Install method in Debian "stretch" (and possibly elsewhere)

You must install the development library for ZLIB. On Debian that would be "apt-get install zlib1g-dev". This will fix the problem.

Go to page: First ... 14 15 16 17 [18] 19 20 21 22 ... Last