Language:
switch to room list switch to menu My folders
Go to page: First ... 13 14 15 16 [17] 18 19 20 21 ... Last
[#] Mon May 22 2017 20:16:43 EDT from Freejack @ Uncensored

Subject: Re: Citadel replication

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon May 22 2017 15:33:26 EDT from IGnatius T Foobar @ Uncensored Subject: Re: Citadel replication
901 and 911 should speak to each other without any problem. Do make sure that the systems have each other set up in their network configurations and are using the same host names, shared secret, etc.

Also be sure that the room sharing is configured identically on both systems.

Finally, I do hope that you're attempting to share a normal room and not a private mailbox. If the room only exists in one user's namespace, it won't behave as you expect when you try to share it.

Are you meaning Host name for node name? shared secret was a no brainer. This is a regualr bulletin board room on both ends with same name.



[#] Mon May 22 2017 21:25:34 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

And what about connecting with mobile devices? Does it work? I read this article http://www.citadel.org/doku.php/faq:generalquestions:mobile#how.do.i.support.mobile.devices.and.push.e-mail.with.the.citadel.system  but it says that : As of 2012, the Citadel email connector is unsupported due to lack of client and server support for newer smartphones and Funambol releases. 



[#] Mon May 22 2017 23:17:05 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I have multiple citadel instances running with users in the 250-300s each... works fine as long as you set it up right. Timeouts need to be tuned, etc.

Mon May 22 2017 05:18:14 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

Thank you for your help :) Also I guess Citadel runs smoothly even with a lot of users for example 100 or more?



 



[#] Tue May 23 2017 17:33:37 EDT from omega12 @ Uncensored

Subject: EasyInstall on Arch giving compilation errors about incomplete types

[Reply] [ReplyQuoted] [Headers] [Print]

I'm using easy install on Linux 4.9.11-1-ARCH( 4.9.11-1-ARCH x86_64) but it cannot compile due to errors with incomplete types.

Here is the log:

CC modules/checkpoint/serv_checkpoint.c

CC modules/clamav/serv_virus.c

CC modules/crypto/serv_crypto.c

modules/crypto/serv_crypto.c: In function 'init_ssl':

modules/crypto/serv_crypto.c:87:3: warning: implicit declaration of function 'RAND_egd' [-Wimplicit-function-declaration]

   RAND_egd(EGD_POOL);

   ^~~~~~~~

modules/crypto/serv_crypto.c:147:22: error: dereferencing pointer to incomplete type 'DH {aka struct dh_st}'

  if (!(BN_hex2bn(&(dh->p), DH_P))) {

                      ^~

modules/crypto/serv_crypto.c:173:3: warning: 'RSA_generate_key' is deprecated [-Wdeprecated-declarations]

   rsa = RSA_generate_key(1024, /* modulus size */

   ^~~

In file included from /usr/include/openssl/rsa.h:13:0,

                 from /usr/include/openssl/x509.h:31,

                 from /usr/include/openssl/ssl.h:50,

                 from modules/crypto/serv_crypto.c:20:

/usr/include/openssl/rsa.h:193:1: note: declared here

 DEPRECATEDIN_0_9_8(RSA *RSA_generate_key(int bits, unsigned long e, void

 ^

modules/crypto/serv_crypto.c:305:35: error: dereferencing pointer to incomplete type 'X509_REQ {aka struct X509_req_st}'

      X509_set_issuer_name(cer, req->req_info->subject);

                                   ^~

In file included from /usr/include/openssl/ssl.h:48:0,

                 from modules/crypto/serv_crypto.c:20:

modules/crypto/serv_crypto.c: In function 'CtdlStartTLS':

modules/crypto/serv_crypto.c:637:23: error: dereferencing pointer to incomplete type 'SSL {aka struct ssl_st}'

  BIO_set_close(CC->ssl->rbio, BIO_NOCLOSE);

                       ^

At top level:

modules/crypto/serv_crypto.c:61:22: warning: 'id_callback' defined but not used [-Wunused-function]

 static unsigned long id_callback(void)

                      ^~~~~~~~~~~

make: *** [Makefile:146: modules/crypto/serv_crypto.o] Error 1

Operating system: Linux 4.9.11-1-ARCH( 4.9.11-1-ARCH x86_64)

 


[#] Tue May 23 2017 18:50:24 EDT from kinetix @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Just out of curiosity... what kind of setups are those with that many users?  Corporate mail setups?

When you mention you needed to tweak timeouts and the like... what specifically did you find you had to tune?

 



[#] Thu May 25 2017 09:35:51 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon May 22 2017 09:25:34 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

And what about connecting with mobile devices? Does it work? I read this article http://www.citadel.org/doku.php/faq:generalquestions:mobile#how.do.i.support.mobile.devices.and.push.e-mail.with.the.citadel.system  but it says that : As of 2012, the Citadel email connector is unsupported due to lack of client and server support for newer smartphones and Funambol releases. 

And as of 2017, the Funambol connector has been removed completely  :)

Today's mobile devices work just fine with Citadel using IMAP.  You should have no trouble with it.  Also, you can use iCalendar and vCard data formats to access your calendar and contacts.



[#] Thu May 25 2017 10:25:57 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I wouldn't call us corporate, but yes, organization email servers. 

 

As to the settings which need to be tweaked, I found the biggest one was Server connection idle timeout (in seconds) (default is quite high)... I moved it to 180 and it seems pretty stable for the amount of concurrent connections I have at once. I might even drop it lower if need be. 

Tue May 23 2017 06:50:24 PM EDT from kinetix @ Uncensored Subject: Re: installing on Ubuntu 16.04

Just out of curiosity... what kind of setups are those with that many users?  Corporate mail setups?

When you mention you needed to tweak timeouts and the like... what specifically did you find you had to tune?

 



 



[#] Thu May 25 2017 13:04:29 EDT from Freejack @ Uncensored

Subject: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



[#] Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



[#] Thu May 25 2017 21:44:36 EDT from Freejack @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

Nope fresh login different browser same result. Click Mail and get NOT FOUND. I wouldn't say anything had I not tried several different ways.

Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



 



[#] Thu May 25 2017 22:09:53 EDT from bennabiy @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

try a different browser? I am getting it just fine...

Thu May 25 2017 09:44:36 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

Nope fresh login different browser same result. Click Mail and get NOT FOUND. I wouldn't say anything had I not tried several different ways.

Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



 



 



[#] Thu May 25 2017 22:19:57 EDT from Freejack @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

I guess using 2 different browsers now 3 and getting same result. NOT FOUND when you click Mail, Calendar, Contacts, Notes, or Tasks. Even for jokes I tried it from safari on an iphone 7 got the same result. Want me to try more? I can, I have a full testing suite if you need. Oh wait I am not getting paid to do this. I was just making a notification while waiting on an answer about replication that is not working between 2 nodes. Oh well.

Thu May 25 2017 22:09:53 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

try a different browser? I am getting it just fine...

Thu May 25 2017 09:44:36 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

Nope fresh login different browser same result. Click Mail and get NOT FOUND. I wouldn't say anything had I not tried several different ways.

Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



 



 



 



[#] Fri May 26 2017 08:41:21 EDT from bennabiy @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

No one is getting paid to do this... It might be connected to your account. Can you try creating a new uncensored account, and see if the issue remains?

Thu May 25 2017 10:19:57 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

I guess using 2 different browsers now 3 and getting same result. NOT FOUND when you click Mail, Calendar, Contacts, Notes, or Tasks. Even for jokes I tried it from safari on an iphone 7 got the same result. Want me to try more? I can, I have a full testing suite if you need. Oh wait I am not getting paid to do this. I was just making a notification while waiting on an answer about replication that is not working between 2 nodes. Oh well.

Thu May 25 2017 22:09:53 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

try a different browser? I am getting it just fine...

Thu May 25 2017 09:44:36 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

Nope fresh login different browser same result. Click Mail and get NOT FOUND. I wouldn't say anything had I not tried several different ways.

Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



 



 



 



 



[#] Fri May 26 2017 09:22:39 EDT from Freejack @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

I know that. That is why I mentioned it. Nothing else nothing more and that I tested it thoroughly before I mentioned it. If it is an account thing no biggy just heads up if someone else mentions it.

Fri May 26 2017 08:41:21 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

No one is getting paid to do this... It might be connected to your account. Can you try creating a new uncensored account, and see if the issue remains?

Thu May 25 2017 10:19:57 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

I guess using 2 different browsers now 3 and getting same result. NOT FOUND when you click Mail, Calendar, Contacts, Notes, or Tasks. Even for jokes I tried it from safari on an iphone 7 got the same result. Want me to try more? I can, I have a full testing suite if you need. Oh wait I am not getting paid to do this. I was just making a notification while waiting on an answer about replication that is not working between 2 nodes. Oh well.

Thu May 25 2017 22:09:53 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

try a different browser? I am getting it just fine...

Thu May 25 2017 09:44:36 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

Nope fresh login different browser same result. Click Mail and get NOT FOUND. I wouldn't say anything had I not tried several different ways.

Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



 



 



 



 



 



[#] Fri May 26 2017 12:54:10 EDT from Freejack @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

A note on top of this I can get to mail by going to the Welcome room and then goto next room I get Mail. If I click the Mail Icon in the list I still get NOT FOUND. Just a note.

Fri May 26 2017 09:22:39 EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

I know that. That is why I mentioned it. Nothing else nothing more and that I tested it thoroughly before I mentioned it. If it is an account thing no biggy just heads up if someone else mentions it.

Fri May 26 2017 08:41:21 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

No one is getting paid to do this... It might be connected to your account. Can you try creating a new uncensored account, and see if the issue remains?

Thu May 25 2017 10:19:57 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

I guess using 2 different browsers now 3 and getting same result. NOT FOUND when you click Mail, Calendar, Contacts, Notes, or Tasks. Even for jokes I tried it from safari on an iphone 7 got the same result. Want me to try more? I can, I have a full testing suite if you need. Oh wait I am not getting paid to do this. I was just making a notification while waiting on an answer about replication that is not working between 2 nodes. Oh well.

Thu May 25 2017 22:09:53 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

try a different browser? I am getting it just fine...

Thu May 25 2017 09:44:36 PM EDT from Freejack @ Uncensored Subject: Re: Uncensored appears to be broken

Nope fresh login different browser same result. Click Mail and get NOT FOUND. I wouldn't say anything had I not tried several different ways.

Thu May 25 2017 21:12:42 EDT from bennabiy @ Uncensored Subject: Re: Uncensored appears to be broken

Are you sure you are not logged out and just viewing a cached version?

Thu May 25 2017 01:04:29 PM EDT from Freejack @ Uncensored Subject: Uncensored appears to be broken

Click Mail and says appears to be not found. Click any of the Calendar, Contacts, Notes, Tasks says same thing. Yet Mail shows 1 message.



 



 



 



 



 



 



 



[#] Fri May 26 2017 15:27:53 EDT from s3cr3to @ Uncensored to room_Citadel_Support@uncensored.citadel.org

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

Maybe you have some plugin/addon that blocks something?
enable javascript and allow pop-up in uncensored.
disable or lower your security in your browsers just for test.

Are you using wind0ws?

[#] Sat May 27 2017 11:17:11 EDT from Freejack @ Uncensored

Subject: Re: Uncensored appears to be broken

[Reply] [ReplyQuoted] [Headers] [Print]

Linux, and I use this on 3 other citadel sites and no issues there. All in enabled, just no mail box unless I go room to room to get to mail.

Fri May 26 2017 15:27:53 EDT from s3cr3to @ Uncensored Subject: Re: Uncensored appears to be broken
Maybe you have some plugin/addon that blocks something?
enable javascript and allow pop-up in uncensored.
disable or lower your security in your browsers just for test.

Are you using wind0ws?

 



[#] Sun May 28 2017 12:47:06 EDT from Freejack @ Uncensored

Subject: Ubuntu 16.04 LTS .deb package install

[Reply] [ReplyQuoted] [Headers] [Print]

I tried the easy installer and it would not run so I did the .deb package install and it loaded. Now I am noticing some abnormalities on reboot or restart of the service. It forgets that we set citadel as the user to run citadel and drops port 504 to 0. Every service restart I have to run setup to fix this. I can not find a citadel config file hoding any of that information. Anyone know where it should reside and possibly what it should look like since this is a .deb install?

 

Would love to build a config that has the information and restarts go without issue.



[#] Mon May 29 2017 09:08:22 EDT from bennabiy @ Uncensored

Subject: Re: Ubuntu 16.04 LTS .deb package install

[Reply] [ReplyQuoted] [Headers] [Print]

When you say the easy installer would not run, can you post a screenshot, or pastebin of the terminal output?

Sun May 28 2017 12:47:06 PM EDT from Freejack @ Uncensored Subject: Ubuntu 16.04 LTS .deb package install

I tried the easy installer and it would not run so I did the .deb package install and it loaded. Now I am noticing some abnormalities on reboot or restart of the service. It forgets that we set citadel as the user to run citadel and drops port 504 to 0. Every service restart I have to run setup to fix this. I can not find a citadel config file hoding any of that information. Anyone know where it should reside and possibly what it should look like since this is a .deb install?

 

Would love to build a config that has the information and restarts go without issue.



 



[#] Mon May 29 2017 11:07:56 EDT from Freejack @ Uncensored

Subject: Re: Ubuntu 16.04 LTS .deb package install

[Reply] [ReplyQuoted] [Headers] [Print]

I will run it again and get you the information. I am just a bit confused on the restarts and it forgetting the user and port.

Mon May 29 2017 09:08:22 EDT from bennabiy @ Uncensored Subject: Re: Ubuntu 16.04 LTS .deb package install

When you say the easy installer would not run, can you post a screenshot, or pastebin of the terminal output?

Sun May 28 2017 12:47:06 PM EDT from Freejack @ Uncensored Subject: Ubuntu 16.04 LTS .deb package install

I tried the easy installer and it would not run so I did the .deb package install and it loaded. Now I am noticing some abnormalities on reboot or restart of the service. It forgets that we set citadel as the user to run citadel and drops port 504 to 0. Every service restart I have to run setup to fix this. I can not find a citadel config file hoding any of that information. Anyone know where it should reside and possibly what it should look like since this is a .deb install?

 

Would love to build a config that has the information and restarts go without issue.



 



 



Go to page: First ... 13 14 15 16 [17] 18 19 20 21 ... Last