Language:
switch to room list switch to menu My folders
Go to page: First ... 16 17 18 19 [20] 21 22 23 24 ... Last
[#] Wed May 10 2017 14:49:47 EDT from s3cr3to @ Uncensored to room_Citadel_Support@uncensored.citadel.org

Subject: Questions related to auto-purge

[Reply] [ReplyQuoted] [Headers] [Print]

Regards
A few weeks ago, I see than my Citadel/db is using ~60GB of HDD

Because my lack of understanding, I try to solve using the autopurge
with this method #1: changing *individually* for each user/room the
[Message expire policy] with:
1.1) Grant aide access to the user
1.2) Enter to each room needed (Mail,Trash, etc) and change the expire
policy accordly to my needs.
1.3) Return the level acces for the user

This task take a lot of time, and I wonder if is working.

But maybe I need to do this method #2 instead, for the *important*
mailboxes/users:
2.1) Grant aide access to the user
2.2) Enter to each room needed (Mail,Trash, etc) and change the expire
policy to [Never automatically expire messages]
2.3) Return the level acces for the user
Then
2.4) (*as Admin Edit site-wide configuration*) Change the Auto-purger
for private mailboxes: Expire by message age

Questions:
a) I wonder if step #2.4 will *respect* the policy of the important
users in step #2.2.

b) This tasks can be managed from the terminal/text client? (Can I have
a cookbook-recipe to do this steps)

c) Exists some command to know the *free/remain/used* space in the
database? The size of the db file is the used hard disk space. I know
that auto-purge *don't shrink* the database. But with this information
we can know if the auto-purge is working and if free space is filling up
or reused then know when to delete or migrate to a bigger HDD.

(Edited point 2.4)

[#] Thu May 11 2017 11:31:38 EDT from Christian.Commarmond @ Uncensored

Subject: Import mails (and export?) and other question...

[Reply] [ReplyQuoted] [Headers] [Print]

Hello to all,

 

I am not yet user of citadel, but, before I install it, I would like to know :

- is there a way to import messages from other mail servers (eg:gmail, outlook...). And by the way, maybe also to export them?

- can it be multi domain? I am requested to manages mails @joe.com and @jim.com... Is it possible, or do I need to set up two servers?

- and, I would like to have a 'auto-create' users function... in the kind:

  Having my user_name='joe', my address being joe@joe.com. When I create my amazon_account, I would give email address amazon_joe@joe.com. To gitub, I would say github_joe@joe.com...

  And Citadel would create an email account amazon_joe with same password than joe, and another user github_joe with same password than joe... So joe can have as many adresses he wants, without having to manually come to create the account. What do you think? 

  I am aware of th joe+amazon@joe.com, but a lot of websites do not manage the '+'...

 

If these things are possible, can you point me to a good and simple explanation?

 

Thank you for reading,

 

Best regards,

Christian COMMARMOND (From Paris, France).

christian.commarmond '@' gmail.com

 

BTW, I was, ages ago, a 'C' developper. I appreciate that the code is in 'C' and that I understand it. It look very well written to me. 

I may be interested, if I can import all my mails (12Gb from gmail) to propose some improvements.

 

 

 

 



[#] Thu May 11 2017 21:37:50 EDT from zooer @ Uncensored

Subject: Re: Import mails (and export?) and other question...

[Reply] [ReplyQuoted] [Headers] [Print]

Perhaps the Citadel Support room would be a better place to ask for support.



[#] Fri May 12 2017 15:12:07 EDT from bennabiy @ Uncensored

Subject: Re: Import mails (and export?) and other question...

[Reply] [ReplyQuoted] [Headers] [Print]

You mean here?

Thu May 11 2017 09:37:50 PM EDT from zooer @ Uncensored Subject: Re: Import mails (and export?) and other question...

Perhaps the Citadel Support room would be a better place to ask for support.



 



[#] Fri May 12 2017 16:39:45 EDT from Fluffy @ Uncensored

Subject: attachments not working

[Reply] [ReplyQuoted] [Headers] [Print]

I installed Citadel (easy install) on a clean Ubuntu 16  and cannot send attachments. There are also connection problems, I guess the TLS is attempting to use a weak encryption. Note that I disabled (-1) all the unencrypted protocols. Please help.



[#] Thu May 18 2017 02:09:50 EDT from graylion @ Uncensored

Subject: installing with the intellgigent installer in Ubunutu 16

[Reply] [ReplyQuoted] [Headers] [Print]



[#] Thu May 18 2017 03:11:33 EDT from graylion @ Uncensored

Subject: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

when installing spamassassing and amavis

 

> apt install amavisd-new spamassassin


insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package spamassassin (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of sa-compile:
 sa-compile depends on spamassassin; however:
  Package spamassassin is not configured yet.

dpkg: error processing package sa-compile (--configure):
 dependency problems - leaving unconfigured
Setting up spamc (3.4.1-3) ...
Setting up amavisd-new (1:2.10.1-2ubuntu1) ...
Creating/updating amavis user account...
insserv: warning: script 'K15webcit' missing LSB tags and overrides
insserv: warning: script 'webcit' missing LSB tags and overrides
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service webcit and rc.local if started
insserv:  loop involving service rc.local at depth 12
insserv:  loop involving service webcit at depth 1
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package amavisd-new (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up libauthen-sasl-perl (2.1600-1) ...
Processing triggers for systemd (229-4ubuntu17) ...
Processing triggers for ureadahead (0.100.0-19) ...
Errors were encountered while processing:
 spamassassin
 sa-compile
 amavisd-new
E: Sub-process /usr/bin/dpkg returned an error code (1)

fix:

> nano /etc/init.de/webcit

add

### BEGIN INIT INFO
# Provides:          webcit
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start daemon at boot time
# Description:       Enable service provided by daemon.
### END INIT INFO
 
could this be incorporated into the product please?


[#] Thu May 18 2017 04:35:21 EDT from ola @ Uncensored

Subject: Citadel on Ubuntu Server 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Hello!

I am new to Citadel, I've installed it successfully on Ubuntu Server 16.04 and configured it to send and receive mails and till now works fine. But  every time I do a change as an admin at Edit side-wide configuration panel, for example I specify my fully qualified domain name as the domain I want to use or even I changed the default timezone to the one that I want not the default UTC, after I restart citadel I get an error:

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.  Without a working Citadel server, , WebCit is unable to provide you with any more content than this error page. The reason for this might be that citserver is not running; another might be that you configured it to listen to another IP address or port, or if your Citadel server is running on another host, it might not be able to reach it.

I am not sure how to fix this, I have tried some things that I found in the internet, but nothing seems to work. Can you please help me?



[#] Thu May 18 2017 11:19:23 EDT from bennabiy @ Uncensored

Subject: Re: Citadel on Ubuntu Server 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

You can start with the easy things, like making sure you did not accidentally install something which would have a port conflict, etc. 

 

Have you turned on logging as well? what is the result from service citadel status when it appears crashed? 

Thu May 18 2017 04:35:21 AM EDT from ola @ Uncensored Subject: Citadel on Ubuntu Server 16.04

Hello!

I am new to Citadel, I've installed it successfully on Ubuntu Server 16.04 and configured it to send and receive mails and till now works fine. But  every time I do a change as an admin at Edit side-wide configuration panel, for example I specify my fully qualified domain name as the domain I want to use or even I changed the default timezone to the one that I want not the default UTC, after I restart citadel I get an error:

This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.  Without a working Citadel server, , WebCit is unable to provide you with any more content than this error page. The reason for this might be that citserver is not running; another might be that you configured it to listen to another IP address or port, or if your Citadel server is running on another host, it might not be able to reach it.

I am not sure how to fix this, I have tried some things that I found in the internet, but nothing seems to work. Can you please help me?



 



[#] Thu May 18 2017 11:51:50 EDT from ola @ Uncensored

Subject: Re: Citadel on Ubuntu Server 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I have nothing installed in my server rather than Citadel. You can find attached what I get when I run: service citadel status



cit-error.PNG (image/png, 36921 bytes) [ View | Download ]
[#] Thu May 18 2017 12:21:56 EDT from heini @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu May 18 2017 03:11:33 EDT from graylion @ Uncensored Subject: installing on Ubuntu 16.04

> nano /etc/init.de/webcit


add

### BEGIN INIT INFO
# Provides:          webcit
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start daemon at boot time
# Description:       Enable service provided by daemon.
### END INIT INFO
 
could this be incorporated into the product please?

Err, since Ubuntu16.04 uses systemd, it'd be better to provide proper unit files.

 

Bye...

 

    Heini



[#] Fri May 19 2017 03:07:52 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I tried to add this in the webcit file, nothing changed, I'm getting the same error. I don't understand how just changing the timezone causes this error, isn't this a bug? 



[#] Sat May 20 2017 15:25:34 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Can somebody help me with this error please? Looks like everything that I edit in the Edit Site Wide Configuration breaks the communication of webcit with the citadel server and I get the error:  This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.  I've installed Citadel in Ubuntu Server 16.04, I'm running Citadel 9.01, Webcit 9.01. I would really appreciate your help!!! 



[#] Sat May 20 2017 20:07:34 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Did you install with packages from the repository, or from Easy Install?

Sat May 20 2017 03:25:34 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

Can somebody help me with this error please? Looks like everything that I edit in the Edit Site Wide Configuration breaks the communication of webcit with the citadel server and I get the error:  This program was unable to connect or stay connected to the Citadel server. Please report this problem to your system administrator.  I've installed Citadel in Ubuntu Server 16.04, I'm running Citadel 9.01, Webcit 9.01. I would really appreciate your help!!! 



 



[#] Sat May 20 2017 20:15:44 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I installed it running: sudo apt-get install citadel-webcit citadel-server citadel-mta, also tried sudo apt-get install citadel-suite, but not with Easy Install



[#] Sat May 20 2017 21:51:08 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I did a test installing Citadel with Easy Install locally and it is not giving me the error. But how can I do now to fix my real server's installation, I don't want to install it from the beginning, I have data that I don't want to lose. 

In my real server I have not installed : apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev     . Can the error be caused by the absence of this installation?


 

 



[#] Sat May 20 2017 23:22:29 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

I did a test installing Citadel with Easy Install locally and it is not giving me the error. But how can I do now to fix my real server's installation, I don't want to install it from the beginning, I have data that I don't want to lose. 

In my real server I have not installed : apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev     . Can the error be caused by the absence of this installation?


 

 



[#] Sat May 20 2017 23:38:58 EDT from ola @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Looks like installing Citadel from the repository with sudo apt-get install citadel-suite on Ubunutu 16.04 amd64 has some kind of bug, maybe something is missing. I'm not getting the error with the installation from Easy Install. How can I fix this?



[#] Sun May 21 2017 09:29:19 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

It is hard to say what the original cause is, except that there is something different being done by the packages in the repository vs easy install actually checking to make sure it has what it needs on your system to work well. Plus easy install is kept all in one location (relatively) and is a little easier to debug because of that.

Sat May 20 2017 09:51:08 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

I did a test installing Citadel with Easy Install locally and it is not giving me the error. But how can I do now to fix my real server's installation, I don't want to install it from the beginning, I have data that I don't want to lose. 

In my real server I have not installed : apt-get install build-essential curl g++ gettext shared-mime-info libssl-dev     . Can the error be caused by the absence of this installation?


 

 



 



[#] Sun May 21 2017 09:30:08 EDT from bennabiy @ Uncensored

Subject: Re: installing on Ubuntu 16.04

[Reply] [ReplyQuoted] [Headers] [Print]

Use easy install and migrate your information from one install to the other (look in the documentation online, there is info on it.)

Sat May 20 2017 11:38:58 PM EDT from ola @ Uncensored Subject: Re: installing on Ubuntu 16.04

Looks like installing Citadel from the repository with sudo apt-get install citadel-suite on Ubunutu 16.04 amd64 has some kind of bug, maybe something is missing. I'm not getting the error with the installation from Easy Install. How can I fix this?



 



Go to page: First ... 16 17 18 19 [20] 21 22 23 24 ... Last