Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last
[#] Fri Mar 31 2017 10:07:52 EDT from graylion @ Uncensored

Subject: LDAP issues

[Reply] [ReplyQuoted] [Headers] [Print]


Hi - further to the above, I still have issues with LDAP after installing libldap2-dev (Ubuntu 16.04.2)

1) easy install:

Reconfiguring Citadel server

Restarting Citadel server to apply changes
**************************************************************************....

and in another terminal:

root@mail  Fri Mar 31 14:58:21  /tmp
#tail -f citadel-install-log.txt


root@mail  Fri Mar 31 15:00:38  /tmp
#

after selecting option 2 and giving the base DN. I also had a TCPdump running and there are no packets on port 389

2) if I go into the WebUI and try to enter a directory server, click save and go back to the Directory page it remains empty and the port 0

Clearly something is missing. Help?

Thanks!



[#] Fri Mar 31 2017 10:54:03 EDT from graylion @ Uncensored

Subject: MySQL on the same box

[Reply] [ReplyQuoted] [Headers] [Print]

Setting up mysql-server-5.7 (5.7.17-0ubuntu0.16.04.1) ...
Renaming removed key_buffer and myisam-recover options (if present)
insserv: warning: script 'K15webcit' missing LSB tags and overrides
insserv: warning: script 'webcit' missing LSB tags and overrides
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service webcit and rc.local if started
insserv:  loop involving service rc.local at depth 11
insserv:  loop involving service webcit at depth 1
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package mysql-server-5.7 (--configure):

now, presumably if I installed from reporitories this would work, but the version in the repo has been built without LDAP support :(

Help?



[#] Fri Mar 31 2017 11:07:04 EDT from graylion @ Uncensored

Subject: Re: MySQL on the same box

[Reply] [ReplyQuoted] [Headers] [Print]

sorted. LSB comments missing - added



[#] Sat Apr 01 2017 18:41:20 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

whenever I try to telnet to anything it just says "trying (ip address)" forever.



[#] Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



[#] Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



[#] Mon Apr 03 2017 03:39:48 EDT from graylion @ Uncensored

Subject: Re: LDAP issues

[Reply] [ReplyQuoted] [Headers] [Print]

Hi guys - anybody?

Fri Mar 31 2017 10:07:52 EDT from graylion @ Uncensored Subject: LDAP issues


Hi - further to the above, I still have issues with LDAP after installing libldap2-dev (Ubuntu 16.04.2)

1) easy install:

Reconfiguring Citadel server

Restarting Citadel server to apply changes
**************************************************************************....

and in another terminal:

root@mail  Fri Mar 31 14:58:21  /tmp
#tail -f citadel-install-log.txt


root@mail  Fri Mar 31 15:00:38  /tmp
#

after selecting option 2 and giving the base DN. I also had a TCPdump running and there are no packets on port 389

2) if I go into the WebUI and try to enter a directory server, click save and go back to the Directory page it remains empty and the port 0

Clearly something is missing. Help?

Thanks!



 



[#] Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



[#] Mon Apr 03 2017 09:15:43 EDT from vnaster @ Uncensored

Subject: Configuring Citadel as Microsoft Exchange Public folders alternative

[Reply] [ReplyQuoted] [Headers] [Print]

Is it possible to configure Citadel as a Microsoft Exchange Public folders alternative and make it connect to an existing pop3 server?

We are thinking to use this system for collaboration/management/storage/ of our emails on a LAN

Wouldn't like to fully replace our current email provider as it seems a rather Herculean task.

Thank you,

Evangelos



[#] Wed Apr 05 2017 12:18:31 EDT from heini @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Empty message



[#] Wed Apr 05 2017 12:45:13 EDT from heini @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Empty message



[#] Wed Apr 05 2017 13:44:46 EDT from "Dirk Heinrichs" <dirk.heinrichs@altum.de> to room_citadel_support@uncensored.citadel.org

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

On 28.03.2017 19:11, heini wrote:

Tue Mar 28 2017 11:41:18 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

Did you install the dependencies and follow the directions for debian?

Yes, I did.


Tried easyinstall again and found out that compiling libcitadel requires package zlib1g-dev, which isn't listed as dependency. But...

 I currently have about 5 citadel installs all happily running on debian (from wheezy to Jessie) all using LDAP.

 This is a Stretch system, ...


... which leads to another compilation problem later, in the citadel package. The problem here is that Stretch already ships OpenSSL 1.1, which introduces API incompatible changes. So, in order to compile Citadel on Stretch, it has to be adapted to OpenSSL 1.1 first.

Bye...

    Dirk

-- 
Dirk Heinrichs <dirk.heinrichs@altum.de>
GPG Public Key: D01B367761B0F7CE6E6D81AAD5A2E54246986015
Sichere Internetkommunikation: http://www.retroshare.org
Privacy Handbuch: https://www.privacy-handbuch.de


[#] Wed Apr 05 2017 17:05:40 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



[#] Thu Apr 06 2017 03:10:10 EDT from graylion @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

Your ISP is lying :)

Wed Apr 05 2017 17:05:40 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



 



[#] Thu Apr 06 2017 04:11:51 EDT from graylion @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

$telnet mail.port25.com 25
Trying 173.203.187.1...
Connected to mail.port25.com.
Escape character is '^]'.
220 mx1.emailsrvr.com ESMTP - VA Code Section 18.2-152.3:1 forbids sending spam through this system

Your ISP has closed port 25 - very obviously

 

Thu Apr 06 2017 03:10:10 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

Your ISP is lying :)

Wed Apr 05 2017 17:05:40 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



 



 



[#] Thu Apr 06 2017 10:22:58 EDT from "Dirk Heinrichs" <dirk.heinrichs@altum.de> to room_citadel_support@uncensored.citadel.org

Subject: [WebCit] Compose message broken?

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

while I could post here using the web UI last week, it doesn't work
anymore. Tried with Konqueror and Chromium. See attached screenshot.

Bye...

Dirk

--
Dirk Heinrichs <dirk.heinrichs@altum.de>
GPG Public Key: D01B367761B0F7CE6E6D81AAD5A2E54246986015
Sichere Internetkommunikation: http://www.retroshare.org
Privacy Handbuch: https://www.privacy-handbuch.de

webcit.png (image/png, 105416 bytes) [ View | Download ]
[#] Thu Apr 06 2017 16:20:54 EDT from warbaby @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

With some of these VPS providers you have to hard restart the instance after they remove the block.  use their admin panel to restart rather than 'shutdown -r now' or 'reboot'

 

Wed Apr 05 2017 05:05:40 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



 



[#] Thu Apr 06 2017 21:08:13 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

  I just tried that and I still have the same problem...

Thu Apr 06 2017 16:20:54 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

With some of these VPS providers you have to hard restart the instance after they remove the block.  use their admin panel to restart rather than 'shutdown -r now' or 'reboot'

 

Wed Apr 05 2017 05:05:40 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



 



 



[#] Fri Apr 07 2017 14:50:09 EDT from tank100 @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

Should I try to reconfigure it to use port 26? 

Thu Apr 06 2017 21:08:13 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

  I just tried that and I still have the same problem...

Thu Apr 06 2017 16:20:54 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

With some of these VPS providers you have to hard restart the instance after they remove the block.  use their admin panel to restart rather than 'shutdown -r now' or 'reboot'

 

Wed Apr 05 2017 05:05:40 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

 

pi@raspberrypi:~ $ telnet mail.port25.com 25

This is the command I am using.  I have port forwarded port 25 and my isp claims they have unblocked it. Yet I still get the same error and my citadel server can't receive or send mail to external sources. 
Mon Apr 03 2017 03:40:57 EDT from graylion @ Uncensored Subject: Re: Sending and receiving

from where are you testing and can you give us the telnet comman you are using? Please understand that we are using telnet and a universal TCP client here, not for the telnet protocol. Hency need to specify port 25

Sun Apr 02 2017 18:47:02 EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

I have done all that but I still get the same error. 

Sat Apr 01 2017 22:20:05 EDT from warbaby @ Uncensored Subject: Re: Sending and receiving

The port is blocked.  Double check with your provider & 

ufw allow smtp
ufw allow imap

or whatever is appropriate for your  distribution 

 

Sat Apr 01 2017 06:41:20 PM EDT from tank100 @ Uncensored Subject: Re: Sending and receiving

whenever I try to telnet to anything it just says "trying (ip address)" forever.



 



 



 



 



 



 



 



[#] Fri Apr 07 2017 15:17:23 EDT from markdmac @ Uncensored

Subject: New to Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Hi there.  I am looking for a viable replacement for Microsoft's Small Business Server for a client that has a very small office of counselors and psychotherapists.  Their needs are very simple.  They barely send any emails, they just use shared calendars to book appointment rooms.  I discovered Citadel today and it looks like it may offer all that they need.  My only concern is the web site doesn't show any activity.  Is this project still alive?  I am totally new to the Linux world so I am starting at ground zero here and the installs for Citadel seem straight forward which is great.  I just don't want to take my client off of one old product and move them to another that will be considered obsolete as soon as I implement it.  I would appreciate learning if this project is still alive.  Thank you.



Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last