Language:
switch to room list switch to menu My folders
Go to page: First ... 13 14 15 16 [17] 18 19 20 21 ... Last
[#] Tue Mar 28 2017 11:20:33 EDT from heini @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

Tue Mar 28 2017 11:00:06 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

You may want to try the easy install as there have been some changes made between versions (and the debian packages are not the most current stable).

Tried that already, but it failed to compile.

Bye...

 

    Heini



[#] Tue Mar 28 2017 11:41:18 EDT from bennabiy @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

Did you install the dependencies and follow the directions for debian? I currently have about 5 citadel installs all happily running on debian (from wheezy to Jessie) all using LDAP.

Tue Mar 28 2017 11:20:33 AM EDT from heini @ Uncensored Subject: Re: Can't resolve admin account from AD

Hi,

Tue Mar 28 2017 11:00:06 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

You may want to try the easy install as there have been some changes made between versions (and the debian packages are not the most current stable).

Tried that already, but it failed to compile.

Bye...

 

    Heini



 



[#] Tue Mar 28 2017 13:11:58 EDT from heini @ Uncensored

Subject: Re: Can't resolve admin account from AD

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Mar 28 2017 11:41:18 EDT from bennabiy @ Uncensored Subject: Re: Can't resolve admin account from AD

Did you install the dependencies and follow the directions for debian?

Yes, I did.

 I currently have about 5 citadel installs all happily running on debian (from wheezy to Jessie) all using LDAP.

 This is a Stretch system, and it's AD, not standard LDAP.

 

Bye...

 

    Heini



[#] Tue Mar 28 2017 17:11:18 EDT from bennabiy @ Uncensored

Subject: Error with IMAP implementation

[Reply] [ReplyQuoted] [Headers] [Print]

IMAP FETCH command is being divided causing issues on some mail clients. Posted below is the debug output from one (emphasis added).

 

[imapx:A] I/O: '* 1 FETCH (UID 145342 RFC822.SIZE 3918 ^M

RFC822.HEADER {247}^M

Return-Path: userb@example.net^M

Date: Sun, 29 Jan 2017 11:35:31 -0500^M

To: usera@example.net^M

Subject: Test^M

Message-ID: <da4845f637bf1b3494037561af73468f@example.net>^M

From: "User B" <userb@example.net>^M

 FLAGS (\Seen))^M

 

 



[#] Tue Mar 28 2017 17:46:32 EDT from Freakdog @ Dog Pound BBS II

[Reply] [ReplyQuoted] [Headers] [Print]

Just a note...I updated to 907 using Easy Install...the process replaced my hello and goodbye files with the stock files.

This is the first time that this has happened in quite a long time.



[#] Wed Mar 29 2017 09:32:07 EDT from bennabiy @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I noted the same thing. 

Tue Mar 28 2017 05:46:32 PM EDT from Freakdog @ Dog Pound BBS II

Just a note...I updated to 907 using Easy Install...the process replaced my hello and goodbye files with the stock files.

This is the first time that this has happened in quite a long time.



 



[#] Wed Mar 29 2017 19:10:54 EDT from tank100 @ Uncensored

Subject: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

I can't seem to send or receive mail from external sources.  I have port forwarded port 25 and my isp claims that they have unblocked it; so any suggestions?



[#] Thu Mar 30 2017 03:31:15 EDT from jsebean @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

Well they didn't unblock it then. ;)

Wed Mar 29 2017 19:10:54 EDT from tank100 @ Uncensored Subject: Sending and receiving

I can't seem to send or receive mail from external sources.  I have port forwarded port 25 and my isp claims that they have unblocked it; so any suggestions?



 



[#] Thu Mar 30 2017 06:27:49 EDT from graylion @ Uncensored

Subject: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

Hi guys

I am following http://www.citadel.org/doku.php/installation:easyinstall:prereq-debian.html and the download works and I get through the options and no problems. But then it tries to restart the server and hangs at 95%. I have sufficient disk space.

The end of /tmp/citadel-install-log.txt reads:

 

2017-03-30 03:16:34 (9.15 MB/s) - 'webcit-easyinstall.sum' saved [41/41]

--2017-03-30 03:16:34--  http://easyinstall.citadel.org/textclient-easyinstall.sum
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 41 [text/plain]
Saving to: 'textclient-easyinstall.sum'

     0K                                                       100% 11.2M=0s

2017-03-30 03:16:34 (11.2 MB/s) - 'textclient-easyinstall.sum' saved [41/41]

--2017-03-30 03:16:34--  http://easyinstall.citadel.org/citadel-init-scripts.tar
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10240 (10K) [application/x-tar]
Saving to: 'citadel-init-scripts.tar'

     0K ..........                                            100% 22.6K=0.4s

2017-03-30 03:16:35 (22.6 KB/s) - 'citadel-init-scripts.tar' saved [10240/10240]

Operating system: Linux Debian stretch/sid ( 4.4.0-66-generic x86_64)

Any ideas? And many thanks in advance!

 



[#] Thu Mar 30 2017 07:03:06 EDT from graylion @ Uncensored

Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

sorted - it did not like LDAP as authentication :(



[#] Thu Mar 30 2017 09:21:16 EDT from warbaby @ Uncensored

Subject: Re: Sending and receiving

[Reply] [ReplyQuoted] [Headers] [Print]

telnet to port 25 on your box and see what happens

Wed Mar 29 2017 07:10:54 PM EDT from tank100 @ Uncensored Subject: Sending and receiving

I can't seem to send or receive mail from external sources.  I have port forwarded port 25 and my isp claims that they have unblocked it; so any suggestions?



 



[#] Thu Mar 30 2017 12:11:10 EDT from graylion @ Uncensored

Subject: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



[#] Thu Mar 30 2017 12:29:04 EDT from bennabiy @ Uncensored

Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

[Reply] [ReplyQuoted] [Headers] [Print]

For LDAP authentication to work, you need to have libldap2-dev installed on a debian or ubuntu system (not sure package on others)...

 

That needs to be installed before you run the easy install scripts. 

Thu Mar 30 2017 07:03:06 AM EDT from graylion @ Uncensored Subject: Re: citadel install with easy installation script on Ubuntu 16.04 - hangs

sorted - it did not like LDAP as authentication :(



 



[#] Thu Mar 30 2017 12:31:07 EDT from bennabiy @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

This is a known issue (although not entirely known WHY it happens ) but to fix it with an easy install:

sudo ~citadel/setup

will rerun through the setup of citserver and one of the entries is the port.

Thu Mar 30 2017 12:11:10 PM EDT from graylion @ Uncensored Subject: c_port_number

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



 



[#] Thu Mar 30 2017 23:22:33 EDT from kc5tja @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I've been kicking around the idea of setting up a Citadel instance for myself and my friends to use (Twitter just makes more and more and more stupid ideas reality, pushing me and my group that much closer to wanting our own local forum). The last time I set up a Citadel instance on a cloud server, it ended up forwarding spam every which way, and I had to shut it down.
Any one have a collection of howto's or other resources on how to secure a Citadel instance? (Point of reference; package in Ubuntu is 9.01; I know it's not the latest, but it's the easiest for me to configure for hopefully obvious reasons.)

Thanks.

[#] Fri Mar 31 2017 04:29:03 EDT from graylion @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks, that worked



[#] Fri Mar 31 2017 06:31:45 EDT from graylion @ Uncensored

Subject: Re: c_port_number

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Mar 30 2017 12:31:07 EDT from bennabiy @ Uncensored Subject: Re: c_port_number

This is a known issue (although not entirely known WHY it happens ) but to fix it with an easy install:

sudo ~citadel/setup

will rerun through the setup of citserver and one of the entries is the port.

Thu Mar 30 2017 12:11:10 PM EDT from graylion @ Uncensored Subject: c_port_number

On restarting the citadel server I get a message:

citserver[86730]: configuration setting c_port_number is not -1 (disabled) or a valid TCP-Port - check your config! Default setting is: 504

I have added the service to /etc/services and I have no idea where to edit this?



 



Thanks! That alone was not sufficient though, ~citadel/setup still hangs on restart.

 

--2017-03-30 03:46:35--  http://easyinstall.citadel.org/citadel-init-scripts.tar
Resolving easyinstall.citadel.org (easyinstall.citadel.org)... 216.150.130.115
Connecting to easyinstall.citadel.org (easyinstall.citadel.org)|216.150.130.115|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 10240 (10K) [application/x-tar]
Saving to: 'citadel-init-scripts.tar'

     0K ..........                                            100% 44.5K=0.2s

2017-03-30 03:46:35 (44.5 KB/s) - 'citadel-init-scripts.tar' saved [10240/10240]



[#] Fri Mar 31 2017 10:07:52 EDT from graylion @ Uncensored

Subject: LDAP issues

[Reply] [ReplyQuoted] [Headers] [Print]


Hi - further to the above, I still have issues with LDAP after installing libldap2-dev (Ubuntu 16.04.2)

1) easy install:

Reconfiguring Citadel server

Restarting Citadel server to apply changes
**************************************************************************....

and in another terminal:

root@mail  Fri Mar 31 14:58:21  /tmp
#tail -f citadel-install-log.txt


root@mail  Fri Mar 31 15:00:38  /tmp
#

after selecting option 2 and giving the base DN. I also had a TCPdump running and there are no packets on port 389

2) if I go into the WebUI and try to enter a directory server, click save and go back to the Directory page it remains empty and the port 0

Clearly something is missing. Help?

Thanks!



[#] Fri Mar 31 2017 10:54:03 EDT from graylion @ Uncensored

Subject: MySQL on the same box

[Reply] [ReplyQuoted] [Headers] [Print]

Setting up mysql-server-5.7 (5.7.17-0ubuntu0.16.04.1) ...
Renaming removed key_buffer and myisam-recover options (if present)
insserv: warning: script 'K15webcit' missing LSB tags and overrides
insserv: warning: script 'webcit' missing LSB tags and overrides
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service webcit and rc.local if started
insserv:  loop involving service rc.local at depth 11
insserv:  loop involving service webcit at depth 1
insserv: Starting webcit depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package mysql-server-5.7 (--configure):

now, presumably if I installed from reporitories this would work, but the version in the repo has been built without LDAP support :(

Help?



[#] Fri Mar 31 2017 11:07:04 EDT from graylion @ Uncensored

Subject: Re: MySQL on the same box

[Reply] [ReplyQuoted] [Headers] [Print]

sorted. LSB comments missing - added



Go to page: First ... 13 14 15 16 [17] 18 19 20 21 ... Last