Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Sat Dec 17 2016 11:48:08 EST from jcigala @ Uncensored

Subject: FQDN in 220 SMTP response.-

[Reply] [ReplyQuoted] [Headers] [Print]

In a previous post, IGnatius explain about if you want to rebuilt a server and, if the new server is similar to the old one, you can copy the whole /citadel directory and the new server must be work. That's right, in my case ;-)

OK, I make this but I have an issue looking for correct it. My new server has the name "svr03" and the old one named "svr01". Then, the answer

220 svr01.xxxxxxx.net ESMTP Citadel server ready. [719 ms]

must be svr03.xxxxxxx.net

It seems like Citadel don't take this name asking the server their FQDN. ¿Where can I modify this? Thank you!



[#] Tue Dec 20 2016 08:19:06 EST from IGnatius T Foobar @ Uncensored

Subject: Re: FQDN in 220 SMTP response.-

[Reply] [ReplyQuoted] [Headers] [Print]

Citadel does not get the FQDN from the operating system, except when it is first set up.

Edit your system configuration.  There is a place for it there.



[#] Tue Dec 27 2016 20:48:44 EST from magotar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Part 1: (text/x-markdown) (203 bytes)

(text/x-markdown, 219 bytes) [ View | Download ]
[#] Tue Dec 27 2016 20:51:43 EST from magotar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Part 1: (text/x-markdown) (16 bytes)

(text/x-markdown, 16 bytes) [ View | Download ]
[#] Fri Jan 06 2017 16:27:24 EST from wizard of aahz @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

If I want to enter a spam filter on uncensored that will only keep email from uncensored users and reject everything else, what would be the correct setup?

[#] Fri Jan 06 2017 18:09:30 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

If you're sure that your incoming non-local email is absolutely 100.0% spam, I can slap a blacklist_to directive on your address, which would block every email coming in to that address and also train the filters. Intra-site mail would be unaffected.

[#] Mon Jan 09 2017 10:26:18 EST from wizard of aahz @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

OH PLEASE! OH PLEASE! OH PLEASE!

So yes. Do exactly that. I would like email from Citadel peoples only. I received over 200 pieces of spam the last 3 days.

[#] Mon Jan 09 2017 11:05:31 EST from fleeb @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]


Gadzooks, but that's too many.

Actually, that's about how much spam my @fleeb.com account gets.

[#] Mon Jan 09 2017 15:51:35 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

It's getting really difficult to run an effective spam filter. This leads me to conclude that 99% of spam is sent by people working for Google and Yahoo, who are doing so to sabotage all email servers that they do not control.

[#] Wed Jan 11 2017 10:16:25 EST from bennabiy @ Uncensored

Subject: LDAP support for Citadel Easy Install

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a way to tell what the dependencies are for ldap support?

 

I have compiled in LDAP support before, but that was a few years back and I cannot remember all the steps I needed to do to make it work. I do remember I modified the easy install and placed a copy in the development room, but I do not have access to that any more.

 

Can anyone help me out?



[#] Wed Jan 11 2017 10:24:58 EST from IGnatius T Foobar @ Uncensored

Subject: Re: LDAP support for Citadel Easy Install

[Reply] [ReplyQuoted] [Headers] [Print]

All you need is the development library for OpenLDAP. On a debian-type system it's "apt-get install libldap2-dev" , on a redhat-type system it's "yum install openldap-devel" . Then run Easy Install (delete the file /usr/local/citadel/citadel-easyinstall.sum first if necessary, to force an upgrade) and it will build with LDAP authentication support.

[#] Thu Jan 12 2017 10:39:59 EST from wsHovius @ Uncensored

Subject: BOSH support?

[Reply] [ReplyQuoted] [Headers] [Print]

the XMPP client i try to configure needs a BOSH url. does Citadel support this? and if so, where do i find it?



[#] Thu Jan 12 2017 11:53:33 EST from IGnatius T Foobar @ Uncensored

Subject: Re: BOSH support?

[Reply] [ReplyQuoted] [Headers] [Print]

Nope ... we don't support BOSH, only regular XMPP.

[#] Thu Jan 12 2017 12:45:55 EST from Texaskilt @ Uncensored

Subject: Calendar configuration and questions

[Reply] [ReplyQuoted] [Headers] [Print]

Y'all,

 

Can the Calendar be configured in such a way that user can create an event, see all events, but only edit/delete the events that they own (create)?

 

Also, can multiple floors/rooms have their own individual calendar?

 

Thanks,

TK



[#] Thu Jan 12 2017 16:08:54 EST from Texaskilt @ Uncensored

Subject: Calendar configuration and questions

[Reply] [ReplyQuoted] [Headers] [Print]

Y'all,

 

Can the Calendar be configured in such a way that user can create an event, see all events, but only edit/delete the events that they own (create)?

 

Also, can multiple floors/rooms have their own individual calendar?

 

Thanks,

TK



[#] Fri Jan 13 2017 11:48:27 EST from IGnatius T Foobar @ Uncensored

Subject: Re: Calendar configuration and questions

[Reply] [ReplyQuoted] [Headers] [Print]

You can have as many calendars as you want, wherever you want, accessible by whoever you want. Just create calendar rooms.

[#] Fri Jan 13 2017 13:23:33 EST from data635 @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I've installed Citadel on my test server (Fedora 25 x86_64) through the easy install and can't seem to get it to use its own system account.  I've run the setup script from /usr/local/citadel several times specifying citadel when asked for the user ID but this always goes back to root.  I've also tried specifying the numeric UID but it still goes back to root.  Other changes I make when running the script, like changing the port, stick.  The messages log records the following error:

<hostname>.citserver[4461]: Cannot create /usr/local/citadel/netconfigs/7: No such file or directory

I tried creating the netconfigs directory and running the script again.  The username went back to root and running the setup script again deleted the netconfigs directory.

Is there a config file I can edit to manually set the correct system user?  I think this is what is causing me to be unable to send attachments since the files directory is owned by the citadel account.  When I try to send the attachment, Firefox gives the "Connection has been reset" error.  The messages goes through but there is no attachment.

 



[#] Sun Jan 15 2017 18:19:15 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a config file I can edit to manually set the correct system
user?  I think this is what is causing me to be unable to send

Citadel has no config files. What little system configuration cannot be performed from within Citadel itself, is configured from the setup program.

The netconfigs error is from an old piece of code that should have been removed when we migrated netconfigs from a separate set of files into the database.
Thanks for reporting that; I have removed it.

I am, however, able to reproduce your problem where it gets the wrong system user. Stand by for a fix!

[#] Sun Jan 15 2017 18:27:12 EST from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

All right, I've fixed the problem. It turns out your system user *was* being set properly, but it wasn't being detected on subsequent runs of the setup program. If you run Easy Install again you'll get the new version.

Once that's in working order, we'll look at your attachments problem again if you still have it.

Thanks for using Citadel!

[#] Mon Jan 16 2017 10:47:49 EST from s3cr3to @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Jan 13 2017 01:23:33 PM EST from data635 @ Uncensored
... unable to send attachments since the files directory is owned by the citadel account.  When I try to send the attachment, Firefox gives the "Connection has been reset" error.  The messages goes through but there is no attachment.

Are you using some kind of adblock+noscript+ublock?

Some strange issues occurs when popups windows or javascript is blocked on citadel+webcit.

I need to whitelist my citadel server for each computer that I use.



Go to page: [1] 2 3 4 5 ... Last