Language:
switch to room list switch to menu My folders
Go to page: First ... 12 13 14 15 [16] 17 18 19 20 ... Last
[#] Thu Jun 16 2016 01:15:32 EDT from pansophy @ Uncensored

Subject: Re: Task List in 'Summary' View

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Jun 14 2016 20:21:38 EDT from pansophy @ Uncensored Subject: Task List in 'Summary' View
 
Also, does the new build support CalDAV ?


To answer one of my own questions: Even the older 8.x Version supports CalDAV in a way. Under Mozilla Thunderbird with Lightning extension, all works well. It is important to add the trailing '/' to the Room names, though. And add them as 'iCal' File.

Rainlendar does a good job as well.


e.g.:

https://your.citadel.server/groupdav/Calendar/

https://your.citadel.server/groupdav/Tasks/

https://your.citadel.server/groupdav/Roomxyz/

 

Hope that helps somebody in the future. ;)



[#] Thu Jun 16 2016 11:32:26 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Task List in 'Summary' View

[Reply] [ReplyQuoted] [Headers] [Print]

That's correct; it supports a standard "icalendar" format (which basically syncs the whole calendar at once, rather than one item at a time). It works fine with Thunderbird/Lightning. We are in the process of a major overhaul of WebCit which is fundamentally built on a DAV/REST design and will support the full CalDAV/CardDAV protocols, but a finished release is some time away.

[#] Thu Jun 16 2016 20:19:03 EDT from pansophy @ Uncensored

Subject: Re: Task List in 'Summary' View

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Jun 14 2016 20:21:38 EDT from pansophy @ Uncensored Subject: Task List in 'Summary' View

Hello Citadel & Folks! I'm new to Citadel but like what I see and can do with it. I have two questions, though:

1) the Summary view does not show my tasks I created, even if I assign them a due date

2) my created Notes under Citadel 8.24 with WebCit 8.24, server build 8.24 show '+' instead of 'SPACE'

What do I do wrong?

Thanks!



Any update to these two questions?

Also, if I create a hidden passworded room, others cannot connect to it as WebCit does not ask for a password. It works on the CLI, though.



[#] Tue Jun 21 2016 18:23:34 EDT from sirtcp @ Uncensored

Subject: User name instead of Full Name

[Reply] [ReplyQuoted] [Headers] [Print]

Dear All,

I am very new to citadel and i really love the product. can you guys please share. why it happens when i send email through imap or webcit my login ID is displayed instead of full name on recipient end. i even change contact information in webcit. however still same issue. login name displays instead of my complete name. need your help.
 


Thanks,

Yousuf



[#] Wed Jun 22 2016 06:48:05 EDT from zooer @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I see a visit to the Citadel Support room in your future.



[#] Wed Jun 22 2016 21:50:34 EDT from pansophy @ Uncensored

Subject: Re: User name instead of Full Name

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Jun 21 2016 18:23:34 EDT from sirtcp @ Uncensored Subject: User name instead of Full Name
Dear All,

I am very new to citadel and i really love the product. can you guys please share. why it happens when i send email through imap or webcit my login ID is displayed instead of full name on recipient end. i even change contact information in webcit. however still same issue. login name displays instead of my complete name. need your help.
 


Thanks,

Yousuf



1) Edit contact information: (Update your contact information)
change 'Display name' to your Full Name

2) Preferences and settings: (Change your preferences and settings)
change 'Preferred display name for email messages' to your Full Name

Works at least my place ...

Cheers,

Pansophy



[#] Sun Jun 26 2016 17:03:07 EDT from Freejack @ Uncensored

Subject: Re: Which rpm?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue May 31 2016 14:26:54 EDT from Freakdog @ Dog Pound BBS II Subject: Re: Which rpm?
Greetings. Just a quick question: which rpm do I download for Leap
42.1?

You can try the packages for openSUSE, but they may not work, as support is currently listed for the 12.x series, while Leap is based on 13.x.

It does not work and I figured out why, the file locations are not in the right place. The package version for 42.1 is 8.24 and in stead of being in /usr/local they are in /usr/share. So everytime you start it fails and the permissions are root:root not citadel:citadel on Opensuse.



[#] Sun Jun 26 2016 17:07:30 EDT from Freejack @ Uncensored

Subject: Re: Which rpm?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun Jun 26 2016 17:03:07 EDT from Freejack @ Uncensored Subject: Re: Which rpm?

 

Tue May 31 2016 14:26:54 EDT from Freakdog @ Dog Pound BBS II Subject: Re: Which rpm?
Greetings. Just a quick question: which rpm do I download for Leap
42.1?

You can try the packages for openSUSE, but they may not work, as support is currently listed for the 12.x series, while Leap is based on 13.x.

It does not work and I figured out why, the file locations are not in the right place. The package version for 42.1 is 8.24 and in stead of being in /usr/local they are in /usr/share. So everytime you start it fails and the permissions are root:root not citadel:citadel on Opensuse.



Also the easy install fails on Opensuse 42.1 I think due  to setup with 42.1 using systemd. Not sure yet there will follow it out.



[#] Sat Jul 02 2016 09:17:24 EDT from 0x378 @ Uncensored

Subject: Automatically create eMail Alias

[Reply] [ReplyQuoted] [Headers] [Print]

Hy Folks,

I have thoroughly searched the web, all citadel files on my server and of course the citadel FAQ but have not found a solution to my problem yet.

I have already managed to set up a citadel server with webcit. Sending and receiving mails works perfectly fine but there is one last thing I would like to use citadel for.

I have set up a mail account ontimers@domain.com for one-time mail addresses for web shops registrations etc. This mail account is supposed to have a number of aliases each of which clearly identifies the place where I left the eMail address ( untrustworthywebshop1@domain.com, funnyonetimeregistration@domain.com etc. all to be collected in the mailbox of onetimers@domain.com)

Adding aliases manually in the vCard works perfectly fine. But I would like to automate this process so I can easily add a new alias using a shell script or using a secured html form hosted on my mail server which then again triggers the shell script which then again adds (or maybe removes) an alias address.

So far the only idea on how to fix this is to send an HTTP request to webcit pretending to be the web frontend which then adds the alias. But there has to be an easier solution to this.

Can anybody help me with this problem?

 

Thanks in advance :)

 

0x378 



[#] Tue Jul 05 2016 05:36:53 EDT from lodger @ Uncensored

Subject: Enabling LDAP Authentication

[Reply] [ReplyQuoted] [Headers] [Print]

Hello everyone,

I've set up and configured my Citadel server to do LDAP authentication. Logging in with regular users works pretty fine but somehow, the LDAP account I want to use as Citadel aide (administrator) will not show the Administration menu. I have set the CN and SN and GECOS attributes according to this statement in the Citadel documentation:

  • If Full Name of the user is set to Edward Xavier Ample, use that Full Name as System Admnistrator name.
  • If First Name is Edward and Last Name is Ample, use both, as in “Edward Ample”.
  • If and only if you did not set the above fields for any reason, then and only then use User Logon Name, such as example for the System Administrator name!

but still no cigar. Can someone help me sort this out?



[#] Wed Jul 06 2016 07:28:45 EDT from billy @ Uncensored

Subject: why after i installed citadel, it listens to tcp6 port, not tcp port

[Reply] [ReplyQuoted] [Headers] [Print]

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      2093/perl
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2058/webcit
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      2069/sshd
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      2057/webcit
tcp6       0      0 :::5222                 :::*                    LISTEN      2046/citserver
tcp6       0      0 :::587                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::110                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::143                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::465                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::22                   :::*                    LISTEN      2069/sshd
tcp6       0      0 :::504                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::25                   :::*                    LISTEN      2046/citserver
tcp6       0      0 :::993                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::995                  :::*                    LISTEN      2046/citserver
tcp6       0      0 :::2020                 :::*                    LISTEN      2046/citserver

so it doesn't work, right?

how to fix this problem?

Thank you!

 

 



[#] Thu Jul 07 2016 10:24:15 EDT from linuxfan724 @ Uncensored

Subject: Cant send emails

[Reply] [ReplyQuoted] [Headers] [Print]



[#] Thu Jul 07 2016 10:26:17 EDT from linuxfan724 @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Hey guys
I cant seem to figure out how to send and receive messages via email from other providers

if you need any information just contact me and ill be glad to give it (i have no idea what do give)

Running on Raspberry Pi 2 B
lubuntu 16.10 



[#] Fri Jul 15 2016 00:18:35 EDT from mellertson @ Uncensored

Subject: Broadcast message from systemd-journald

[Reply] [ReplyQuoted] [Headers] [Print]

Hi everyone!

 

I installed citadel-suite using apt-get on Ubuntu 15.10.  I then uninstalled it using 'apt-get remove citadel-suite', manually deleted the directory '/etc/citadel/', and then re-installed it again using apt-get.  I thought it would re-run the easy install, but alas no.  After reading the FAQs and the Citadel docs, I ran Citadel's 'setup' executable.  Now it's totally borked.  It's spitting out messages like the following as fast as it can go:

 

Broadcast message from systemd-journald@hostname (Thu 2016-07-14 21:09:52 PDT):

citserver[12510]: failed to create directory /etc/citadel/messages/: No such file or directory

Broadcast message from systemd-journald@hostname (Thu 2016-07-14 21:09:52 PDT):

citserver[12510]: failed to access & create directories

Broadcast message from systemd-journald@hostname (Thu 2016-07-14 21:09:52 PDT):

citserver[12511]: configuration setting c_default_cal_zone is empty, but must not - check your config!

Broadcast message from systemd-journald@hostname (Thu 2016-07-14 21:09:52 PDT):

citserver[12511]: failed to create directory /etc/citadel/messages/: No such file or directory

Broadcast message from systemd-journald@hostname (Thu 2016-07-14 21:09:52 PDT):

citserver[12511]: failed to access & create directories

 
I just rebooted the server, but it's still spitting out the same messages from systemd-journald.  Anyone have any ideas on how to fix it and get Citadel re-installed?


[#] Sat Jul 16 2016 08:58:08 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Broadcast message from systemd-journald

[Reply] [ReplyQuoted] [Headers] [Print]

It sounds like you've got several copies of Citadel on the system, maybe even running simultaneously. You definitely can't mix the Ubuntu packages with the Easy Install; they go into two different directory hierarchies.

If it's a new system, remove the packages, remove all the Citadel stuff under /usr/local, make sure nothing's running, and start again.

[#] Sat Jul 16 2016 13:44:49 EDT from stejey @ Uncensored

Subject: Citadel not sending encrypted emails (Gmail says)

[Reply] [ReplyQuoted] [Headers] [Print]

Hi there,
I'm trying to set up a mailserver on my new Ubuntu 14.04 VPS. I've chosen Citadel. The purpose is to have Citadel both handle incoming and outgoing emails. I've kind of achieved what I needed, but the problem I'm facing now is that Gmail tells emails sent from the VPS are unencrypted, and displays a red open padlock.

I'm quite new to setting this up so feel free to ask any questions, since I don't really know what details to provide. I will say that even though all Citadel ports should be open, the firewall is disabled right now, as to clear any possible issues coming from it.

Hope someone has a clue and can help, huge thanks! :)



[#] Mon Jul 18 2016 09:45:59 EDT from IGnatius T Foobar @ Uncensored

Subject: Re: Citadel not sending encrypted emails (Gmail says)

[Reply] [ReplyQuoted] [Headers] [Print]


*grml*

I wasn't aware that Google is now red-flagging any emails that don't arrive via encrypted SMTP. That sucks. Citadel doesn't send out SMTP connections with TLS encryption in the current version, sorry to say. Since the mighty Google overlords now seem to be shaming everyone for doing that, I suppose we should put it on the short list.

In the mean time, the only way to get outbound encrypted SMTP would be to put another MTA in front of Citadel. You could, for example, install Postfix on your server, and don't make it listen on port 25, just use it as an outbound smart-host.

[#] Wed Jul 20 2016 10:31:44 EDT from Freakdog @ Dog Pound BBS II

[Reply] [ReplyQuoted] [Headers] [Print]

Subject: RSS Aggregation run failure
Error while RSS-Aggregation Run of
https://ineverbooedsanta.wordpress.com/feed/
need a 200, got a 301 !
Curl Error message: Citadel RSS Client /
Redirect header points to:
https://ineverbooedsanta.wordpress.com/feed/
Response text was:

<html> <head><title>301 Moved Permanently</title></head> <body
bgcolor="white"> <center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center> </body> </html>


Good morning.

The above message is appearing in my Aide room, regarding an RSS feed for a room that no longer exists on my system.

Since I'm running version 902, now, there are no longer any netconfigs files for me to update/remove in order to remove this entry.

How do I go about doing so, now, for a room that no longer exists for me to edit?

[#] Wed Jul 20 2016 11:33:27 EDT from 0x378 @ Uncensored

Subject: Re: Automatically create eMail Alias

[Reply] [ReplyQuoted] [Headers] [Print]

No ideas?



[#] Wed Jul 20 2016 15:04:49 EDT from IGnatius T Foobar @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

Since I'm running version 902, now, there are no longer any netconfigs

files for me to update/remove in order to remove this entry.

Editing netconfig files was never the correct way to modify a room's RSS feeds.

In the web interface you edit the room and click the tab to modify the feeds.

Go to page: First ... 12 13 14 15 [16] 17 18 19 20 ... Last