Language:
switch to room list switch to menu My folders
Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last
[#] Tue Mar 01 2016 00:00:56 EST from Bobau @ Uncensored

Subject: webcit[5148]: SSL_accept failed: errval=5, retval=0 Input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I have installed the system, internally everything is working correctly, but I am now having issues sending email from an external source using imap.

Can someone please advise on what I need to look at.

Regards

Bob



[#] Tue Mar 01 2016 00:45:35 EST from Bobau @ Uncensored

Subject: webcit[5148]: SSL_accept failed: errval=5, retval=0 Input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I have installed the system, internally everything is working correctly, but I am now having issues sending email from an external source using imap.

Can someone please advise on what I need to look at.

Regards

Bob



[#] Wed Mar 02 2016 08:51:41 EST from gerrit @ Uncensored

Subject: SMTP Retries

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

Is it possible to set citadel to only try sending an email 3 times if it doesn't succeed, remove the mail from the smtp queue

 

Thanks 

 

Gerrit



[#] Wed Mar 02 2016 12:58:20 EST from pechter @ Uncensored

Subject: SSL disable v3 v2 etc

[Reply] [ReplyQuoted] [Headers] [Print]

Is it possible (or easy) to change citadel to disable certain ssl versions to avoid things like poodle, drown etc.

I could put it behind the apache on the box -- but I wanted to demo it as a standalone as well.

I want to tweak it to pass the SSL Labs test with an A or better if possible.  Would this require code changes or is there a config for me to tweak?

 

Bill



[#] Thu Mar 03 2016 03:44:47 EST from harrijer @ Uncensored

Subject: Search through web interface

[Reply] [ReplyQuoted] [Headers] [Print]

Morning all (if appropriate in your time zone),

New here and have a question: is it possible to do a 'search' in a room or wider?

I wanted to search for caldav/android/sync etc but couldn't work out how to do it - am I missing something obvious ? Please be kind in your replies if I have ;)

Jeremy



[#] Fri Mar 04 2016 17:32:49 EST from mne130 @ Uncensored

Subject: Installing Citadel on FreeBSD

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I'm following the installation this installation guide: http://www.citadel.org/doku.php/faq:installation:installing_citadel_on_a_freebsd_5.4_or_6.0_os

Yes, it is outdated.

 

One problem with libcitadel I hacked away with line

 

  typedef long long loff_t;

 

in libcitadel.h, (loff_t was not defined in FreeBSD header hell) but later this one raised: (last lines of /tmp/citadel-install-log.txt)

....

CC database.c
database.c: In function 'cdb_store':
database.c:526: warning: assignment discards qualifiers from pointer target type
database.c: In function 'cdb_fetch':
database.c:674: warning: assignment discards qualifiers from pointer target type
CC domain.c
In file included from domain.c:23:
/usr/include/resolv.h:157: error: array type has incomplete element type
/usr/include/resolv.h:171: error: field 'addr' has incomplete type
/usr/include/resolv.h:196: error: field 'sin' has incomplete type
Makefile:145: recipe for target 'domain.o' failed
gmake: *** [domain.o] Error 1
Operating system:

....

(Operating system is ...FreeBSD 9.3-STABLE #1 r296323...)

 

when calling "sh install".

"sh install" itself ended this way:

.....

Citadel Easy Install is aborting.

A log file has been written to /tmp/citadel-install-log.txt
Reading this file may tell you what went wrong. If you
need to ask for help on the support forum, please post the
last screenful of text from this log.

Operating system:

....

Any ideas?

 

Best regards

Erik Weber.

 

 

 



[#] Fri Mar 04 2016 22:46:34 EST from hamishthaggis @ Uncensored

Subject: Fighting with Install on Ubuntu - Crash or successful without LDAP

[Reply] [ReplyQuoted] [Headers] [Print]

Good evening/morning/day.

 

I'm trying to install Citadel on 14.04 LTS with support for LDAP integration - both for user authentication and address book/directory.  I am having two different issues depending on how I try to install:

 

If I use "apt-get install citadel-suite" the installation completes successfully, but when logging in, the LDAP authentication and address book are not functional - only the admin account created in install works.  The setting page "Admin-EditSiteWideConfig-Directory" shows "This Citadel server has been built without LDAP support, these settings will have no effect." I have tried both Compliant LDAP and Non-Compliant LDAP modes in installation with the same affect.

Alternately, if I use the "EasyInstallation" method (including installing the Debian/Ubuntu prerequisites) the process fails - after responding to config settings the installer begins the "Applying, restarting" cycle and fails each time.  Specifically in what I think is the final step, showing "Restarting to apply settings" it stalls at 95% and never moves again - even if left for hours.

 

I've tried both methods repeatedly with completely clean minimal OS builds and with more complete/standard builds.  The failures are consistent and reliable.

Would really like to get this installed and running but I'm approaching the "FU" point and considering jumping ship to another solution.

 

Any suggestions/assistance is welcome.

 

Thanks.

 



[#] Mon Mar 07 2016 13:28:42 EST from warbaby @ Uncensored

Subject: Re: Fighting with Install on Ubuntu - Crash or successful without LDAP

[Reply] [ReplyQuoted] [Headers] [Print]

Post a tail of /tmp/citadel-install-log.txt (or post the whole thing as an attachment).  I was working on this a while ago, will try to find my notes.

 

Fri Mar 04 2016 10:46:34 PM EST from hamishthaggis @ Uncensored Subject: Fighting with Install on Ubuntu - Crash or successful without LDAP

Good evening/morning/day.

 

I'm trying to install Citadel on 14.04 LTS with support for LDAP integration - both for user authentication and address book/directory.  I am having two different issues depending on how I try to install:

 

If I use "apt-get install citadel-suite" the installation completes successfully, but when logging in, the LDAP authentication and address book are not functional - only the admin account created in install works.  The setting page "Admin-EditSiteWideConfig-Directory" shows "This Citadel server has been built without LDAP support, these settings will have no effect." I have tried both Compliant LDAP and Non-Compliant LDAP modes in installation with the same affect.

Alternately, if I use the "EasyInstallation" method (including installing the Debian/Ubuntu prerequisites) the process fails - after responding to config settings the installer begins the "Applying, restarting" cycle and fails each time.  Specifically in what I think is the final step, showing "Restarting to apply settings" it stalls at 95% and never moves again - even if left for hours.

 

I've tried both methods repeatedly with completely clean minimal OS builds and with more complete/standard builds.  The failures are consistent and reliable.

Would really like to get this installed and running but I'm approaching the "FU" point and considering jumping ship to another solution.

 

Any suggestions/assistance is welcome.

 

Thanks.

 



 



[#] Mon Mar 07 2016 13:30:22 EST from warbaby @ Uncensored

Subject: Re: SSL disable v3 v2 etc

[Reply] [ReplyQuoted] [Headers] [Print]

Use nginx or apache to configure the ssl ciphers and proxy it to webcit.  

Wed Mar 02 2016 12:58:20 PM EST from pechter @ Uncensored Subject: SSL disable v3 v2 etc

Is it possible (or easy) to change citadel to disable certain ssl versions to avoid things like poodle, drown etc.

I could put it behind the apache on the box -- but I wanted to demo it as a standalone as well.

I want to tweak it to pass the SSL Labs test with an A or better if possible.  Would this require code changes or is there a config for me to tweak?

 

Bill



 



[#] Mon Mar 07 2016 13:32:18 EST from warbaby @ Uncensored

Subject: Re: webcit[5148]: SSL_accept failed: errval=5, retval=0 Input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Don't you mean SMTP?  You don't send with IMAP bro. What do you mean by external source, a client?  Post the exact text of your error message. 

Tue Mar 01 2016 12:45:35 AM EST from Bobau @ Uncensored Subject: webcit[5148]: SSL_accept failed: errval=5, retval=0 Input/output error

Hi,

I have installed the system, internally everything is working correctly, but I am now having issues sending email from an external source using imap.

Can someone please advise on what I need to look at.

Regards

Bob



 



[#] Fri Mar 11 2016 15:05:32 EST from Davixxa @ Uncensored

[Reply] [ReplyQuoted] [Headers] [Print]

I'm having trouble with setting up multiple domains for my mail server. I need @davixxa.net and @moe-desu.com to work on the server. I have already added it under alias, as well as having atleast @davixxa.net set up as a MX record at my domain CP (though, moe-desu works with recieving mails, so I'd presume that a MX record is set up there), however I only get the option to use the domain set in the FQDN.



[#] Sat Mar 12 2016 11:45:49 EST from mne130 @ Uncensored

Subject: Re: Installing Citadel on FreeBSD

[Reply] [ReplyQuoted] [Headers] [Print]

Solved.

changed from "easyinstall" to source code tarballs.

Configure problem went away via setting of environment variables:

setenv CFLAGS "-I/usr/local/include -I/usr/local/include/db5"
setenv LDFLAGS "-L/usr/local/lib -L/usr/local/lib/db5/"
setenv CPPFLAGS "-I/usr/local/include -I/usr/local/include/db5"

Compiling problems via source three minor-minor code fixes:

a) in libcitadel, file lib/libcitadel.h

a.1) on line 19


typedef long long loff_t;


a.2) on line 449: #ifndef-frame added

#ifndef IsEmptyStr
#define IsEmptyStr(a) ((a)[0] == '\0')
#endif

b) in webcit, file gettext.c

b.1)on line 333 :

changed

from "sprintf(buf, "%s.UTF8", AvailLang[i]);"

to  "sprintf(buf, "%s.UTF-8", AvailLang[i]);"

(minus-sign added)

 

c) in citadel, file domain.c

c.1) on line 23: "#include <netinet/in.h>" inserted:

...
#endif
#include <netinet/in.h>
#include <resolv.h>
#endif
...

Now its ready for configuration.

Best regards

Erik Weber.

 

Fri Mar 04 2016 17:32:49 EST from mne130 @ Uncensored Subject: Installing Citadel on FreeBSD

Hello,

I'm following the installation this installation guide: http://www.citadel.org/doku.php/faq:installation:installing_citadel_on_a_freebsd_5.4_or_6.0_os

Yes, it is outdated.

 

One problem with libcitadel I hacked away with line

 

  typedef long long loff_t;

 

in libcitadel.h, (loff_t was not defined in FreeBSD header hell) but later this one raised: (last lines of /tmp/citadel-install-log.txt)

....

CC database.c
database.c: In function 'cdb_store':
database.c:526: warning: assignment discards qualifiers from pointer target type
database.c: In function 'cdb_fetch':
database.c:674: warning: assignment discards qualifiers from pointer target type
CC domain.c
In file included from domain.c:23:
/usr/include/resolv.h:157: error: array type has incomplete element type
/usr/include/resolv.h:171: error: field 'addr' has incomplete type
/usr/include/resolv.h:196: error: field 'sin' has incomplete type
Makefile:145: recipe for target 'domain.o' failed
gmake: *** [domain.o] Error 1
Operating system:

....

(Operating system is ...FreeBSD 9.3-STABLE #1 r296323...)

 

when calling "sh install".

"sh install" itself ended this way:

.....

Citadel Easy Install is aborting.

A log file has been written to /tmp/citadel-install-log.txt
Reading this file may tell you what went wrong. If you
need to ask for help on the support forum, please post the
last screenful of text from this log.

Operating system:

....

Any ideas?

 

Best regards

Erik Weber.

 

 

 



 



[#] Sun Mar 13 2016 17:38:53 EDT from joeway15 @ Uncensored

Subject: cant receive emails

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I am using a godaddy domain name which allowed me to send emails but not receive them.

Any ideas?

Thanks

Joe



[#] Sun Mar 13 2016 17:40:54 EDT from "Marisa Giancarla" <fstltna@me.com> to citadel_support@citadel.org

Subject: Re: [Citadel Support] cant receive emails

[Reply] [ReplyQuoted] [Headers] [Print]

Perhaps there is a DNS MX record pointing to a different server?

Marisa

[#] Sun Mar 13 2016 17:45:05 EDT from joeway15 @ Uncensored

Subject: Re: [Citadel Support] cant receive emails

[Reply] [ReplyQuoted] [Headers] [Print]

How could i go about fixing this?

 

If you send an email to admin@jtests.co.uk you can see the error.

Dont know if this helps...

 



[#] Sun Mar 13 2016 17:48:15 EDT from "Marisa Giancarla" <fstltna@me.com> to citadel_support@citadel.org

Subject: Re: [Citadel Support] cant receive emails

[Reply] [ReplyQuoted] [Headers] [Print]

It says that address is not found. Make sure there is a account with admin@ in that domain and that your citadel is set to accept mail for that domain...


On Mar 13, 2016, at 2:45 PM, joeway15 <joeway15@uncensored.citadel.org> wrote:

How could i go about fixing this?

 

If you send an email to admin@jtests.co.uk you can see the error.

Dont know if this helps...

 



[#] Sun Mar 13 2016 17:57:44 EDT from joeway15 @ Uncensored

Subject: My setup if this helps

[Reply] [ReplyQuoted] [Headers] [Print]

http://imgur.com/uiOwGh5

http://imgur.com/wMTjoKz

This is my server setup, i think that it is all correct

btw thanks for the quick replys :D



[#] Sun Mar 13 2016 18:11:47 EDT from "Marisa Giancarla" <fstltna@me.com> to citadel_support@citadel.org

Subject: Re: [Citadel Support] My setup if this helps

[Reply] [ReplyQuoted] [Headers] [Print]

those look ok, what about the users info?


On Mar 13, 2016, at 2:57 PM, joeway15 <joeway15@uncensored.citadel.org> wrote:

http://imgur.com/uiOwGh5

http://imgur.com/wMTjoKz

This is my server setup, i think that it is all correct

btw thanks for the quick replys :D




[#] Sun Mar 13 2016 18:18:27 EDT from joeway15 @ Uncensored

Subject: Re: [Citadel Support] My setup if this helps

[Reply] [ReplyQuoted] [Headers] [Print]

http://imgur.com/jC9nsUj

http://imgur.com/zQpi1ff

If this does not help i can show you my domain setup on godaddy if you think that will help?



[#] Sun Mar 13 2016 18:22:09 EDT from "Marisa Giancarla" <fstltna@me.com> to citadel_support@citadel.org

Subject: Re: [Citadel Support] My setup if this helps

[Reply] [ReplyQuoted] [Headers] [Print]

Those look good too. Im not sure you can set a MX entry in go daddy, but the error you are getting indicates it IS connecting to your citadel server, but the server doesn’t like the admin address. I saw this happen on a 0.8x version of citadel, but not the 0.9x version. What version are you running and how did you install it?

Marisa
On Mar 13, 2016, at 3:18 PM, joeway15 <joeway15@uncensored.citadel.org> wrote:

http://imgur.com/jC9nsUj

http://imgur.com/zQpi1ff

If this does not help i can show you my domain setup on godaddy if you think that will help?




Go to page: 1 2 3 4 [5] 6 7 8 9 ... Last