Language:
switch to room list switch to menu My folders
Go to page: First ... 4 5 6 7 [8] 9 10 11 12 ... Last
[#] Mon Feb 08 2016 06:46:52 EST from mhiller @ Uncensored

Subject: Attachments from POP3 accounts frequently corrupted

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I've been trying lots of things in order to determine what actually is the problem with corrupted attachments in Citadel running om my Raspberry PI set-up with Wheezy.

I have tried the official installation, I have recompiled the newest source on right on the PI (and with Jessie), I have installed the OS on ext2 instead of the official ext4 file system. All combos shows the same problem with attachments. I think I've located the culprit; when fetching POP3 account messages sometimes a small part of the last part of the last attached multipart document is not stored. At least this is what I think is happening. As I display the message source, I can see, the last part (the boundary and some lines before it) is missing. The POP3 client shows the full source - and displays the attachment perfectly.

Sending messages from my Citadel installation with attachements works fine and the receivers never complain about corruption. However, sending a message with attachments to one of my POP3 accounts (which Citadel later fetches), the last of the attachments is corrupted (ie. some lines are missing and therefore it cannot be re-assembled).

The above indicates to me, that it is the Citadel motor that is flawed and more specifically I suspect the POP3 fetch mecanism. To be certain I need some help. Is there any way I can verify what is actually stored in the Citadel message store?

Sincerely,

Michael



[#] Mon Feb 08 2016 12:21:44 EST from marsmars @ Uncensored

Subject: change the email address format or / and the LDAP mail attribut

[Reply] [ReplyQuoted] [Headers] [Print]

Hello! I am looking for an option to change the email adresses of my users. I have got the External LDAP - nonstandard MS Active Directory Authentfication (AD with samba4 with RFC_2307 , works fine), but citadel does not use the mail attribut of the LDAP-User ...

How could I change the email address format, e.g. givenname@example.com instead of givenname_surname@example.com

  • for one user?
  • for all users with a schema?

Is their any change after switch to External LDAP - RFC 2307 compliant directory if I fill the postfix attribut?

Thanks for help.



[#] Mon Feb 08 2016 16:21:33 EST from marsmars @ Uncensored

Subject: Re: change the email address format or / and the LDAP mail attribut

[Reply] [ReplyQuoted] [Headers] [Print]

I edit the users vcards manually for my 10 users; THX for the workaround I got at irc from dothebart!

But it would be nice, if the users vcard is sync to LDAP.



[#] Mon Feb 08 2016 21:43:46 EST from CurtisCC @ Uncensored

Subject: Question about syntax for AuthN from an Ajax CAll

[Reply] [ReplyQuoted] [Headers] [Print]

Hello. I am new to the Citadel world and am looking at it to replace some existing functionality. 

With current functionality I am running a script to preform a basic Auth from a separate Application. 

Does Citadel allow me to make an authenticated ajax call to the server to be logged in? IF so could anyone please provide some syntax help? 

 

THank you

Curtis 



[#] Mon Feb 08 2016 22:56:51 EST from nristen @ Uncensored

Subject: Re: fetchmail status 7 error

[Reply] [ReplyQuoted] [Headers] [Print]

Just a follow up... I was able to use offlineimap successfully to download my spam for use with spamassassin.

Sat Feb 06 2016 12:20:00 AM EST from nristen @ Uncensored Subject: fetchmail status 7 error

I am trying to use fetchmail to pull mail from a "spam" folder to send to spamassassin however fetchmail always exits with following output:

 

fetchmail -a -v --bad-header accept --folder spam -m "/usr/bin/sa-learn -D --spam"

fetchmail: IMAP< * 100 FETCH (RFC822.SIZE 5476)
fetchmail: IMAP< A0007 OK FETCH completed
fetchmail: IMAP> A0008 FETCH 1 RFC822.HEADER
fetchmail: IMAP< * 1 FETCH (
fetchmail: IMAP< RFC822.HEADER {375}
fetchmail: IMAP< Return-Path: bounce-md_30540405.554cdde0.v1-913269d54d874502a6b1bd5017ee0e69@mandrillapp.com
fetchmail: IMAP< Date: Fri, 08 May 2015 12:01:36 -0400
fetchmail: IMAP< To: hh <heather@blablabla.com>
fetchmail: IMAP< Subject: Last Chance: 40% off at APLC
fetchmail: IMAP< Message-ID: <30540405.20150508160136.554cdde0405ab0.68493906@mail128-132.atl41.mandrillapp.com>
fetchmail: IMAP< From: "Alice Seba & The DIYplr.com Team" <theteam@diyplr.com>
fetchmail: IMAP< )
fetchmail: IMAP< A0008 OK FETCH completed
fetchmail: Incorrect FETCH response: * 1 FETCH (.
fetchmail: IMAP> A0009 LOGOUT
fetchmail: IMAP< * BYE news.blablabla.com logging out
fetchmail: IMAP< A0009 OK Citadel IMAP session ended.
fetchmail: client/server synchronization error while fetching from heather@news.thehomesteadinghippy.com
fetchmail: 6.3.22 querying news.blablabla.com (protocol IMAP) at Fri 05 Feb 2016 11:49:01 PM EST: poll completed
fetchmail: Query status=7 (ERROR)
fetchmail: normal termination, status 7

 

I have tried several folder combinations always with the same results.  I even tried pointing to the folder inbox which shows a different email header but I get the same result.  I also tried deleting that one message which of course then it shows the next message in the fetchmail output.  I hope that it is some mistake I am making with the fetchmail syntax but I haven't been able to figure anything out.

I enabled imap_srv debugging and see the following citadel logs when I run the fetchmail command:

Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.83444 seconds
Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] A0005 SELECT "spam"
Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] ---- Looking up [SELECT] -----
Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] Found.
Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] (That translates to "spam")
Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] imap_do_expunge() called
Feb  6 00:12:09 news citserver[12639]: CC[379]MSG<0000000010.spam> 8 new of 111 total messages, oldest=89378, newest=265049
Feb  6 00:12:09 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.322 seconds
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] A0006 EXPUNGE
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] ---- Looking up [EXPUNGE] -----
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Found.
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] imap_do_expunge() called
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Expunged 0 messages from <0000000010.spam>
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.96 seconds
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] A0007 SEARCH UNSEEN
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] ---- Looking up [SEARCH] -----
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Found.
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.165 seconds
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] A0008 FETCH 100:111 RFC822.SIZE
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] ---- Looking up [FETCH] -----
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Found.
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.490 seconds
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] A0009 FETCH 100 RFC822.HEADER
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] ---- Looking up [FETCH] -----
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Found.
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] RFC822: headers=320, text=0, total=320
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.270 seconds
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] A0010 LOGOUT
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] ---- Looking up [LOGOUT] -----
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Found.
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] imap_do_expunge() called
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Expunged 0 messages from <0000000010.spam>
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] IMAP command completed in 0.130 seconds
Feb  6 00:12:10 news citserver[12639]: xmpp_queue_event(1, heather@blablabla.com)
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] imap_do_expunge() called
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Expunged 0 messages from <0000000010.spam>
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Performing IMAP cleanup hook
Feb  6 00:12:10 news citserver[12639]: IMAP W CC[379] Finished IMAP cleanup hook

 

from citadel I don't see a problem but maybe I don't know what to look for?



 



[#] Wed Feb 10 2016 06:10:13 EST from "Martin" <martin@swetech.se> to citadel_support@citadel.org

Subject: Force all incoming email into one shared inbox

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,
Got a few questions

I need to force all incoming email into one shared inbox regardless if the users of the system replies with their own emails from within the system - the reply on their email should go to the one and only shared inbox.
Is this possible in citadel?
--
Best Regards Martin



[#] Thu Feb 11 2016 11:27:51 EST from CurtisCC @ Uncensored

Subject: sendcommand second arguement

[Reply] [ReplyQuoted] [Headers] [Print]

Hello everyone,

I am currently trying to automate user creation using sendcommand CREU

I am trying to pass a second argument and I am not getting anywhere. The documentation says the first argument for CREU is the username and the 2nd(optional) is the password. Can anyone please me me an email with an example with how to include the second arguement? or an example of a sendcommand CREU with the username and password?

 

Thank you

Curtis



[#] Thu Feb 11 2016 13:21:17 EST from lol @ Uncensored

Subject: Citael resetting Options

[Reply] [ReplyQuoted] [Headers] [Print]

I had following problem:
When I restarted citadel using "sudo service citadel restart" the citadel uid changed to root, and the tcp port changed to 0.
Here is how I fixed this:

I replaced /etc/init.d/citadel with this script:

#!/bin/bash

### BEGIN INIT INFO
# Provides:          citadel
# Required-Start:
# Required-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start daemon at boot time
# Description:       Enable service provided by daemon.
### END INIT INFO

CITADEL_DIR=/usr/local/citadel
USER=citadel
case "$1" in

start)          echo -n "Starting Citadel... "
                if $CITADEL_DIR/citserver -d -h$CITADEL_DIR
                then
                        sleep 3
                        chown $USER:root $CITADEL_DIR/citadel-admin.socket
                        echo "ok"
                else
                        echo "failed"
                        exit 1
                fi
                ;;
stop)           echo -n "Stopping Citadel... "
                if su $USER -c "$CITADEL_DIR/sendcommand DOWN >/dev/null 2>&1" ; then
                        echo "ok"
                else
                        echo "failed"
                        exit 1
                fi
                ;;
restart)        stop
                sleep 2
                start
                ;;
*)              echo "Usage: $0 {start|stop|restart}"
                exit 1
                ;;
esac
exit 0



[#] Thu Feb 11 2016 16:17:04 EST from warbaby @ Uncensored

Subject: Comments in mail.aliases

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a format for comments in mail.aliases? Mine is starting to get quite complex..  

 

Also, can I comma separate two forwarding addresses?  

 

eg 

foo,bar,baz /* alias foo to both bar and baz..  */

 

Sorry, don't have time to check the source right now.. Lemme go try to break something... 

 

 



[#] Fri Feb 12 2016 10:06:36 EST from jarome @ Uncensored

Subject: Re: Fresh Citadel Install on OpenSuse 13.2 using repo homueller

[Reply] [ReplyQuoted] [Headers] [Print]

I have a similar problem and do not understand the answer. On OpenSUDSE Leap 42.1, and Citadel 9, If I start the server, I get:

jarfx:/etc/citadel #
Message from syslogd@jarfx at Feb 12 10:04:21 ...
 citserver[5354]: configuration setting c_default_cal_zone is empty, but must not - check your config!

Message from syslogd@jarfx at Feb 12 10:04:21 ...
 citserver[5354]: bdb(): cursor still in progress on cdb 04: can't begin transaction during r/o cursor

and then

jarfx:/etc/citadel # systemctl status citadel -l
citadel.service - Citadel Groupware Server
   Loaded: loaded (/usr/lib/systemd/system/citadel.service; disabled)
   Active: failed (Result: exit-code) since Fri 2016-02-12 10:04:21 EST; 50s ago
  Process: 5352 ExecStart=/usr/sbin/citserver -d -l${CITADEL_LOG_FACILITY} ${CITADEL_DEBUG_AREA} ${CITADEL_HOME_DIR} (code=exited, status=0/SUCCESS)
 Main PID: 5353 (code=exited, status=105)

Feb 12 10:04:21 jarfx citserver[5354]: bdb(): Setting up DB environment
Feb 12 10:04:21 jarfx citserver[5354]: dbenv->open(dbenv, /var/lib/citadel/data/, 10899, 0)
Feb 12 10:04:21 jarfx citserver[5354]: DB: Finding last valid log LSN: file: 1 offset 114169
Feb 12 10:04:21 jarfx citserver[5354]: DB: Recovery starting from [1][112954]
Feb 12 10:04:21 jarfx citserver[5354]: DB: Recovery complete at Fri Feb 12 10:04:21 2016
Feb 12 10:04:21 jarfx citserver[5354]: DB: Maximum transaction ID 80000019 Recovery checkpoint [1][114169]
Feb 12 10:04:21 jarfx citserver[5354]: Starting up DB
Feb 12 10:04:21 jarfx citserver[5354]: Checking floor reference counts
Feb 12 10:04:21 jarfx citserver[5354]: bdb(): cursor still in progress on cdb 04: can't begin transaction during r/o cursor
Feb 12 10:04:21 jarfx citserver[5354]: citserver is stopping in order to prevent data loss. uid=0 gid=0 euid=0 egid=0
jarfx:/etc/citadel #

I did the one-click install. The servers are not running. How do I get Citadel to work?



[#] Sun Feb 14 2016 09:03:28 EST from rlah @ Uncensored

Subject: Forwarding email received in citadel to a remote email address

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

I was trying to view this link, http://www.citadel.org/doku.php/faq:everydayuse:how_do_i_automatically_forward_all_mail_to_a_remote_email_address_somewhere

Am unable to view images on the page.

 

Regards,

Rupa



[#] Tue Feb 16 2016 16:57:05 EST from nellson @ Uncensored

Subject: Citadel Virtual Appliance? (2012 version not found)

[Reply] [ReplyQuoted] [Headers] [Print]

I found this searching for a multi-domain capable e-mail server in a virtual appliance, but the link for downloading the virtual appliance does not work. Is this still an option?

Nick

 



[#] Wed Feb 17 2016 15:41:43 EST from warbaby @ Uncensored

Subject: Re: Citadel Virtual Appliance? (2012 version not found)

[Reply] [ReplyQuoted] [Headers] [Print]

Just grab the packages with your package manager or use easyinstall.  Configuring SpamAssassin and ClamAV is not necessary to evaluate Citadel.   That Appliance info is ancient and should be removed or somebody should automate building the snapshots. 

http://www.citadel.org/doku.php/doku.php?id=installation:start

http://www.citadel.org/doku.php/installation:easyinstall:easyinstall

Citadel is a good mail server.  It is for men.  And will most likely work for you.  Take a few minutes to do the basic install so you understand what is going on. 

 

Tue Feb 16 2016 04:57:05 PM EST from nellson @ Uncensored Subject: Citadel Virtual Appliance? (2012 version not found)

I found this searching for a multi-domain capable e-mail server in a virtual appliance, but the link for downloading the virtual appliance does not work. Is this still an option?

Nick

 



 



[#] Fri Feb 19 2016 16:33:32 EST from jbb0906 @ Uncensored

Subject: Error configuring citadel suite.

[Reply] [ReplyQuoted] [Headers] [Print]

I installed the suite on Ubuntu server 15.10 using apt-get. During the configuration set up, I had one error

Broadcast message from systemd-journald@ednet (Fri 2016-02-19 21:17:28 WET):
citserver[8844]: configuration setting c_default_cal_zone is empty, but must not - check your config!

I´m not sure where the file is or what to put in it.

Also, I am running Nginx web server on the same system, and when I ran the initial configuration, I forgot to change the plain http port from 80 to something else.

That resulted in this error:

Broadcast message from systemd-journald@ednet (Fri 2016-02-19 21:15:29 WET):
webcit[8350]: Can't bind: Address already in use

So I ran

dpkg-reconfigure citadel-server

It took me through creating the admin user, but not back to reconfigure the port. Is there a way that I can correct that?

Thanks

 



[#] Tue Feb 23 2016 12:58:32 EST from dabeegmon @ Uncensored

Subject: installation failure

[Reply] [ReplyQuoted] [Headers] [Print]

Trying to setup Citadel on a VM (VirtualBox 5.0.14 if that helps).

System is a Debian stretch.

 

Would love to copy the last page here (or attach it) as requested but I have not ever been able to figure out how to pass documents from a guest to the host. (If anyone cares to point me to a method that works I would be all ears!

 

 

Error message ends:

 

:  undefined reference to `SSLv3_client_method'

collect2: error: ld returned 1 exit status

Makefile:531: recipe for target 'curl' failed

make[2]: *** [curl] Error 1

make[2]: Leaving directory 'tmp/citadel-build.11481/curl-7.26.0/src'

Makefile:469: recipe for target 'all' failed

make[1]: *** [all] Error 2

make[1]: Leaving directory 'tmp/citadel/build.11481/curl-7.26.0/src'

Makefile:437: recipe for target 'all-recursive' failed

make: *** [all-recursive] Error 1

Operating system: Linux Debian stretch/sid (4.2.0-1-amd64 x86_64)

(END)

 

Is there a way to 'fix' the installation?

What needs to be done?

TIA



[#] Tue Feb 23 2016 23:23:26 EST from dabeegmon @ Uncensored

Subject: Re: installation failure

[Reply] [ReplyQuoted] [Headers] [Print]

Turns out Citadel WAS installed - - - just needed to figure out how to get to it.

 



[#] Thu Feb 25 2016 23:40:47 EST from warbaby @ Uncensored

Subject: Re: Question about syntax for AuthN from an Ajax CAll

[Reply] [ReplyQuoted] [Headers] [Print]

You've got an entire API here chief.  You can use the built-in sendcommand utility, or write something to talk to port 504.    

Citserver returns a pipe-delimited string with a response code.  eg 200 80|24|260    Just tokenize the string to json and send it back to your battle station.  

This kind of thing has been done a few times over.  https://bitbucket.org/robotamer/citadelphp

see also:

http://www.citadel.org/doku.php/documentation:cmdman:sendcommand#examples

http://www.citadel.org/doku.php/documentation:appproto:app_proto#connecting.to.a.server

http://www.citadel.org/doku.php/documentation:appproto:app_proto#connecting.to.a.server

 

 

Mon Feb 08 2016 09:43:46 PM EST from CurtisCC @ Uncensored Subject: Question about syntax for AuthN from an Ajax CAll

Hello. I am new to the Citadel world and am looking at it to replace some existing functionality. 

With current functionality I am running a script to preform a basic Auth from a separate Application. 

Does Citadel allow me to make an authenticated ajax call to the server to be logged in? IF so could anyone please provide some syntax help? 

 

THank you

Curtis 



 



[#] Sat Feb 27 2016 14:28:28 EST from madpoet @ Uncensored

Subject: easy-install on RPi2 w/ Arch

[Reply] [ReplyQuoted] [Headers] [Print]

In file included from src/ipc_c_tcp.c:25:0:

./src/include/citadel_ipc.h:481:13: warning: inline function 'CtdlIPC_unlock' declared but never defined

 INLINE void CtdlIPC_unlock(CtdlIPC *ipc);

             ^

./src/include/citadel_ipc.h:479:13: warning: inline function 'CtdlIPC_lock' declared but never defined

 INLINE void CtdlIPC_lock(CtdlIPC *ipc);

             ^

src/citadel_ipc.o: In function `CtdlIPCQuit':

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:267: undefined reference to `CtdlIPC_lock'

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:281: undefined reference to `CtdlIPC_unlock'

src/citadel_ipc.o: In function `CtdlIPCLogout':

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:295: undefined reference to `CtdlIPC_lock'

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:299: undefined reference to `CtdlIPC_unlock'

src/citadel_ipc.o: In function `CtdlIPCPartialRead':

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:2365: undefined reference to `CtdlIPC_lock'

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:2383: undefined reference to `CtdlIPC_unlock'

src/citadel_ipc.o: In function `CtdlIPCHighSpeedReadDownload':

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:2467: undefined reference to `CtdlIPC_lock'

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:2494: undefined reference to `CtdlIPC_unlock'

src/citadel_ipc.o: In function `CtdlIPCGenericCommand':

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:2611: undefined reference to `CtdlIPC_lock'

/tmp/citadel-build.228/textclient/src/citadel_ipc.c:2717: undefined reference to `CtdlIPC_unlock'

collect2: error: ld returned 1 exit status

Makefile:102: recipe for target 'citadel' failed

make: *** [citadel] Error 1

Operating system: Linux 4.1.18-2-ARCH( 4.1.18-2-ARCH armv7l)



[#] Mon Feb 29 2016 22:09:04 EST from Bobau @ Uncensored

Subject: webcit[5148]: SSL_accept failed: errval=5, retval=0 (Input/output erro

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

I have installed the system, internally everything is working correctly, but I am now having issues sending email from an external source using imap.

 

Can someone please advise on what I need to look at.

 

Regards

Bob

Australia



[#] Mon Feb 29 2016 22:15:49 EST from Bobau @ Uncensored

Subject: webcit[5148]: SSL_accept failed: errval=5, retval=0 Input/output error

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I have installed the system, internally everything is working correctly, but I am now having issues sending email from an external source using imap.

Can someone please advise on what I need to look at.

Regards

Bob



Go to page: First ... 4 5 6 7 [8] 9 10 11 12 ... Last