Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



[#] Thu Oct 24 2013 16:35:21 EDT from Seth Galitzer @ Uncensored

Subject: admin user with LDAP?

[Reply] [ReplyQuoted] [Headers] [Print]

I was able to successfully install using the easy installer and LDAP works great OOTB, so thanks for that.  Unfortunately, the LDP acct I specified as the site admin doesn't seem to have any admin privileges.  At least I don't see any admin type tasks available to me.  Any suggestions to get me going?

Thanks.

Seth



[#] Thu Oct 24 2013 20:46:02 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



i will try it, thanks!



[#] Thu Oct 24 2013 23:44:09 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



hi, i build stable_82x. The install seemed to work fine, but the setup program fails with the following error.  "Setup could not connect to a running Citadel server.: No such file or directory /home/citadel/local/citadel/citadel-admin.socket"

what should i do?

thans!



[#] Fri Oct 25 2013 02:18:29 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 23:44:09 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



hi, i build stable_82x. The install seemed to work fine, but the setup program fails with the following error.  "Setup could not connect to a running Citadel server.: No such file or directory /home/citadel/local/citadel/citadel-admin.socket"

what should i do?

thans!



i solve it, it works now , thanks very much!



[#] Fri Oct 25 2013 12:25:28 EDT from bennabiy @ Uncensored

Subject: SSL availabe for xmpp? Also, OTR?

[Reply] [ReplyQuoted] [Headers] [Print]

I am trying to include a little more security with the xmpp portion of citadel. I do not mind doing the work, but need a little direction.

 

I grabbed the source and have located the xmpp module, but am not sure if someone who is already familiar with the way xmpp works in citadel could contact me and I could pick their brain about a few things.

 

We really appreciate all the work that has gone into Citadel, and look forward to seeing it increase more and more.

 

Please message me if you are able to talk about this topic.



[#] Fri Oct 25 2013 16:13:24 EDT from Gilles Pérez @ Uncensored

Subject: Problem with citmail in version 8.20

[Reply] [ReplyQuoted] [Headers] [Print]

Hello,

I just installed Citadel (first the Ubuntu-12.04 version, then I did the easy install to get the last version). It is the first time I don't bang my head against the wall when installing a mail server. And I do get much, much more than a mail server...

Little problem with Citadel 8.20 and citmail: it doesn’t work. It seems to want a mail address between <>:

# sendmail -d -t toto@example.com
> 220 xxx.xxx ESMTP Citadel server ready.
Subject: Essai

Corps
< LHLO xxx.xxx
> 250-Greetings and joyous salutations.
> 250-HELP
> 250-SIZE 10485760
> 250-AUTH LOGIN PLAIN
> 250-AUTH=LOGIN PLAIN
> 250 8BITMIME
< MAIL From: root@xxx.xxx
> 250 Sender ok
< RCPT To: toto@example.com
> 550 No recipients specified.
< DATA
> 503 Need RCPT command first.
citmail: DATA command failed
citmail: error #6 occurred while sending mail.
Please check your Citadel configuration.
< QUIT
> 221 Goodbye...

The same command just with the <> added: sendmail -d -t \<toto@example.com\> works perfectly...

Thank you,

Gilles.

 



[#] Sat Oct 26 2013 04:22:46 EDT from dothebart @ Uncensored

Subject: Re: Problem with citmail in version 8.20

[Reply] [ReplyQuoted] [Headers] [Print]

yes, thats a known issue which is going to be fixed with the next version.

there are two workarounds; use msmtp instead of citmail, or compile the latest stable-82x git

Fri Oct 25 2013 16:13:24 EDT from Gilles Pérez @ Uncensored Subject: Problem with citmail in version 8.20

Hello,

I just installed Citadel (first the Ubuntu-12.04 version, then I did the easy install to get the last version). It is the first time I don't bang my head against the wall when installing a mail server. And I do get much, much more than a mail server...

Little problem with Citadel 8.20 and citmail: it doesn’t work. It seems to want a mail address between <>:

# sendmail -d -t toto@example.com
> 220 xxx.xxx ESMTP Citadel server ready.
Subject: Essai

Corps
< LHLO xxx.xxx
> 250-Greetings and joyous salutations.
> 250-HELP
> 250-SIZE 10485760
> 250-AUTH LOGIN PLAIN
> 250-AUTH=LOGIN PLAIN
> 250 8BITMIME
< MAIL From: root@xxx.xxx
> 250 Sender ok
< RCPT To: toto@example.com
> 550 No recipients specified.
< DATA
> 503 Need RCPT command first.
citmail: DATA command failed
citmail: error #6 occurred while sending mail.
Please check your Citadel configuration.
< QUIT
> 221 Goodbye...

The same command just with the <> added: sendmail -d -t \<toto@example.com\> works perfectly...

Thank you,

Gilles.

 



 



[#] Sat Oct 26 2013 04:28:44 EDT from dothebart @ Uncensored

Subject: Re: SSL availabe for xmpp? Also, OTR?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Oct 25 2013 12:25:28 EDT from bennabiy @ Uncensored Subject: SSL availabe for xmpp? Also, OTR?

I am trying to include a little more security with the xmpp portion of citadel. I do not mind doing the work, but need a little direction.

 

I grabbed the source and have located the xmpp module, but am not sure if someone who is already familiar with the way xmpp works in citadel could contact me and I could pick their brain about a few things.

 

We really appreciate all the work that has gone into Citadel, and look forward to seeing it increase more and more.

 

Please message me if you are able to talk about this topic.



 

in CTDL_MODULE_INIT(xmpp) the listener is registered with citserver. hm, I thought we had some ssl support registered there too - but can't find it. maybe this patch was lost somewhen in the past.

for more interactive chatting, i'd sugest #citadel on freenode.

 

if I get that correctly, OTR is what two clients speak to each other - so its probably not making any sense to have this in the webcit chat?



[#] Sat Oct 26 2013 06:21:46 EDT from platonov @ Uncensored

Subject: citadel server crash on ubuntu 12.04 32 bit

[Reply] [ReplyQuoted] [Headers] [Print]

Is there a fix for bug:

https://bugs.launchpad.net/ubuntu/+source/citadel/+bug/911732

in the 32 bit version of citadel?

Citadel ran fine before I went from ubuntu 9.xxx to 12.04 32 bit environment.

I have spend days on it and can not find any resolution to this bug anywhere on the net.

It is strange such a serious bug as coredumping is not taken care of and totally ignored as it seems.

/var/log/syslog says:

Jul 30 22:58:01 preciseinfo citadel: DB: not a restored transaction
Jul 30 22:58:01 preciseinfo citadel: DB: PANIC: Invalid argument
Jul 30 22:58:01 preciseinfo citadel: bdb(): PANIC: Invalid argument
Jul 30 22:58:01 preciseinfo citadel: bdb(): txn_commit: DB_RUNRECOVERY: Fatal error, run database recovery

But this can not be true since the database does not even exist after a clean install.

So it never actually runs even once.

There may be 32/64 bit compatibility issue with the database.

Unfortunately, for me to go to 64 bit environment involves weeks of work as system is very complex besides citadel.

 

 



[#] Sat Oct 26 2013 07:09:58 EDT from dothebart @ Uncensored

Subject: Re: citadel server crash on ubuntu 12.04 32 bit

[Reply] [ReplyQuoted] [Headers] [Print]

please try with more recent versions of citadel.



[#] Sat Oct 26 2013 11:19:41 EDT from Bouke J. Henstra @ Uncensored

Subject: Next version

[Reply] [ReplyQuoted] [Headers] [Print]

Hi all,

At this moment we use version 8.20. This version has an issue with Bynari Outlook Connector.

My question is: when could I expect the next version with the bugfix? I really would like to get my hands on the patched version =P~

Thanks :-)

Bouke



[#] Sat Oct 26 2013 11:29:23 EDT from platonov @ Uncensored

Subject: Re: citadel server crash on ubuntu 12.04 32 bit

[Reply] [ReplyQuoted] [Headers] [Print]

>please try with more recent versions of citadel.

Do you have any idea which version and where do i get it and do I have to build it from a source tree.

It looks like more recent versions have library dependencies problem.

I downloaded the recent tree via git by:

sudo git clone git://git.citadel.org/appl/gitroot/citadel.git

But there is no detailed instructions on how to build it and virtually no documentation on building process.

It is something like: "and then do the normal thing". But what is "normal" in THEIR mind only God knows.

 



[#] Sat Oct 26 2013 15:45:40 EDT from Muhammad Bashir Al-Noimi @ Uncensored

Subject: Re: IM delaying issue

[Reply] [ReplyQuoted] [Headers] [Print]

You mean it's impossible to use web chat in Citadel in Similar way or GMail web interface?!

Mon Oct 14 2013 04:51:17 EDT from dothebart @ Uncensored Subject: Re: IM delaying issue

in general, citadel _is_ completeley UTF-8, and XMPP _is_ UTF-8 by definition;

I didn't experience any troublems with german umlauts so far;

If somethings broken, we need to find out.

 

On the frequency for the initial chat to start - this is done by polling; so the frequency of polling (and thus the idle load of the system) has set this limit of a minute.



 



[#] Sat Oct 26 2013 15:46:48 EDT from Muhammad Bashir Al-Noimi @ Uncensored

Subject: Re: IM encoding

[Reply] [ReplyQuoted] [Headers] [Print]

But do you posted the new binaries to Ubuntu repositories?!

Mon Oct 21 2013 14:49:46 EDT from bennabiy @ Uncensored Subject: Re: IM encoding

Nm... Self Answered Question.

 

For anyone else's benefit - Shut down citadel and web cit and then do the easy install again.

Mon Oct 21 2013 12:32:13 EDT from bennabiy @ Uncensored Subject: Re: IM encoding

So how do I update if I did an Easy install?

Sun Oct 20 2013 18:33:19 EDT from dothebart @ Uncensored Subject: Re: IM encoding

hm, yes you're right. multibyte characters are not treated the right way.

 fixed with 292aaf708967cb105ab014d1b4e5fe4ab0b342d8

Sun Oct 20 2013 12:18:15 EDT from bennabiy @ Uncensored Subject: Re: IM encoding

I also am having this issue when connecting to xmpp through external client. German characters are not coming through.

 

 

Wed Oct 02 2013 19:55:06 EDT from Muhammad Bashir Al-Noimi @ Uncensored Subject: IM encoding

Howdy,

 

How can I change the encode of IM text? it doesn't support UTF-8 (I'm using Arabic) although my system locale supports it!

mbnoimi-pc mbnoimi # locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
mbnoimi-pc mbnoimi # 

How can I fix this issue?



 



 



 



 



 



[#] Sat Oct 26 2013 15:49:29 EDT from Muhammad Bashir Al-Noimi @ Uncensored

Subject: Recover password

[Reply] [ReplyQuoted] [Headers] [Print]

Hallo,

 

I already have an account in citadel.org (mbnoimi) but I forgot my password. How can I recover my account?



[#] Sat Oct 26 2013 15:54:22 EDT from Muhammad Bashir Al-Noimi @ Uncensored

Subject: Subscribe to specified room

[Reply] [ReplyQuoted] [Headers] [Print]

Hallo,

 

How can I subscribe to specified room?



[#] Sat Oct 26 2013 17:48:50 EDT from dothebart @ Uncensored

Subject: Re: IM delaying issue

[Reply] [ReplyQuoted] [Headers] [Print]

  - we found a bug in the xmpp encoding

 - https://uncensored.citadel.org/listsub

  - http://ubuntu.citadel.org  - see http://www.citadel.org/doku.php/installation:debian  for details.

Sat Oct 26 2013 15:45:40 EDT from Muhammad Bashir Al-Noimi @ Uncensored Subject: Re: IM delaying issue

You mean it's impossible to use web chat in Citadel in Similar way or GMail web interface?!

Mon Oct 14 2013 04:51:17 EDT from dothebart @ Uncensored Subject: Re: IM delaying issue

in general, citadel _is_ completeley UTF-8, and XMPP _is_ UTF-8 by definition;

I didn't experience any troublems with german umlauts so far;

If somethings broken, we need to find out.

 

On the frequency for the initial chat to start - this is done by polling; so the frequency of polling (and thus the idle load of the system) has set this limit of a minute.



 



 



[#] Sat Oct 26 2013 19:12:02 EDT from Muhammad Bashir Al-Noimi @ Uncensored

Subject: Re: IM delaying issue

[Reply] [ReplyQuoted] [Headers] [Print]

You mean you still working on fixing it? If you finished how can I get recent ubuntu binaries?

BTW,

  • your links below are invalid!
  • Why you don't reply each topic in its thread?!
Sat Oct 26 2013 17:48:50 EDT from dothebart @ Uncensored Subject: Re: IM delaying issue

  - we found a bug in the xmpp encoding

  - http://ubuntu.citadel.org  - see http://www.citadel.org/doku.php/installation:debian  for details.



[#] Sat Oct 26 2013 19:16:54 EDT from Muhammad Bashir Al-Noimi @ Uncensored

Subject: Re: IM delaying issue

[Reply] [ReplyQuoted] [Headers] [Print]

sorry my mistake, the links work fine but I coudn't find my Ubuntu distro option?!

I'm using Ubuntu 13.04 (Raring).

Sat Oct 26 2013 19:12:02 EDT from Muhammad Bashir Al-Noimi @ Uncensored Subject: Re: IM delaying issue

You mean you still working on fixing it? If you finished how can I get recent ubuntu binaries?

BTW,

  • your links below are invalid!
  • Why you don't reply each topic in its thread?!
Sat Oct 26 2013 17:48:50 EDT from dothebart @ Uncensored Subject: Re: IM delaying issue

  - we found a bug in the xmpp encoding

  - http://ubuntu.citadel.org  - see http://www.citadel.org/doku.php/installation:debian  for details.



 



Go to page: [1] 2 3 4 5 ... Last