Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Mon Oct 21 2013 12:32:13 EDT from bennabiy @ Uncensored

Subject: Re: IM encoding

[Reply] [ReplyQuoted] [Headers] [Print]

So how do I update if I did an Easy install?

Sun Oct 20 2013 18:33:19 EDT from dothebart @ Uncensored Subject: Re: IM encoding

hm, yes you're right. multibyte characters are not treated the right way.

 fixed with 292aaf708967cb105ab014d1b4e5fe4ab0b342d8

Sun Oct 20 2013 12:18:15 EDT from bennabiy @ Uncensored Subject: Re: IM encoding

I also am having this issue when connecting to xmpp through external client. German characters are not coming through.

 

 

Wed Oct 02 2013 19:55:06 EDT from Muhammad Bashir Al-Noimi @ Uncensored Subject: IM encoding

Howdy,

 

How can I change the encode of IM text? it doesn't support UTF-8 (I'm using Arabic) although my system locale supports it!

mbnoimi-pc mbnoimi # locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
mbnoimi-pc mbnoimi # 

How can I fix this issue?



 



 



 



[#] Mon Oct 21 2013 14:49:46 EDT from bennabiy @ Uncensored

Subject: Re: IM encoding

[Reply] [ReplyQuoted] [Headers] [Print]

Nm... Self Answered Question.

 

For anyone else's benefit - Shut down citadel and web cit and then do the easy install again.

Mon Oct 21 2013 12:32:13 EDT from bennabiy @ Uncensored Subject: Re: IM encoding

So how do I update if I did an Easy install?

Sun Oct 20 2013 18:33:19 EDT from dothebart @ Uncensored Subject: Re: IM encoding

hm, yes you're right. multibyte characters are not treated the right way.

 fixed with 292aaf708967cb105ab014d1b4e5fe4ab0b342d8

Sun Oct 20 2013 12:18:15 EDT from bennabiy @ Uncensored Subject: Re: IM encoding

I also am having this issue when connecting to xmpp through external client. German characters are not coming through.

 

 

Wed Oct 02 2013 19:55:06 EDT from Muhammad Bashir Al-Noimi @ Uncensored Subject: IM encoding

Howdy,

 

How can I change the encode of IM text? it doesn't support UTF-8 (I'm using Arabic) although my system locale supports it!

mbnoimi-pc mbnoimi # locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
mbnoimi-pc mbnoimi # 

How can I fix this issue?



 



 



 



 



[#] Mon Oct 21 2013 15:12:47 EDT from bennabiy @ Uncensored

Subject: XMPP question

[Reply] [ReplyQuoted] [Headers] [Print]

I am running XMPP on citadel, but would like to include more security for the conversations, either SSL wrapping the connection, or using OTR2 or such. Can anyone help me in this direction? Also, I noticed that when I connect to the uncensored.citadel.org network for xmpp, I get the full options for file transfer, video, etc, but when I do it over my own server, I only have text chat. What do I need to change to enable the extra services?



[#] Mon Oct 21 2013 21:05:30 EDT from Devdom @ Uncensored

Subject: Re: Webcit / Citadel SSL issue

[Reply] [ReplyQuoted] [Headers] [Print]

lets bump my issue again after 14 days of waiting

 

Tue Oct 08 2013 14:30:41 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

 

Thanks for your support, but it didn’t work,

 

 

First I changed the ownership to root and the chmod to 644 as you instructed and tested the connection after a server restart.

 

 

After that I appended the intermediate certificate to citadel.cer but this had no effect either. 

Every time I try to open the https page the result in the browser is:

 

Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap)

 

When I remove the certificates and keys and restart the system the self signed cert is created and the system works...

any other suggestion is appreciated,

Thanks in advance,

Marcel

 

Wed Oct 02 2013 06:08:20 EDT from schaap23 @ Uncensored Subject: Re: Webcit / Citadel SSL issue

When you move the certificates to /etc/ssl/webcit and /etc/ssl/citadel/,
make sure citadel cannot overwrite the new ssl certificate.
So change the file permissions (chmod) so that the file can only be read by citadel.
Otherwise citadel might try to overwrite your new certificates with self-signed certificates.
So login as root:
Su

Change the ownership of the keys to root
Chown root citadel.cer; chown root citadel.key

change the modifiers to 6 (owner read,write) 4 (group read) 4 (everyone read)
chmod 644 citadel.cer; chmod 644 citadel.key


It might also be necessary to append the intermediate certificate (intermediate.cer) to your own certificate (citadel.cer / webcit.cer).
For me, this was necessary to get my godaddy certificate working. I had to append the gd_bundle.cert (godaddy intermediate.cer) of godaddy to my citadel.cer:

Open the intermediate.cer with a text editor and copy it's contents.

Open the citadel.cer file with a text editor and go to the last line. On the last line paste the contents of the intermediate.cer.

Remember, since you have changed the ownership of the citadel.cer file to root, you must open the file as root, otherwise you cannot edit it off course.

Now you can login to webcit and restart the citadel server. You should now be able to use https (ssl).

 

Tue Oct 01 2013 09:14:39 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

 

Mon Sep 30 2013 18:31:58 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

 

Fri Sep 27 2013 11:17:27 EDT from Devdom @ Uncensored Subject: Webcit / Citadel SSL issue

good day to you all....

I think I need some help setting up my citadel/webcit with ssl/tls,
when I remove all keys and certificates then restart, it generates a self-signed key /certificate, all this works, next I remove all the files in /etc/ssl/webcit and /etc/ssl/citadel
then I run openssl genrsa -out citadel-key 2048
this generates the key
Start openssl req -new -key citadel.key -out citadel.crt
This generates the request form for Geotrust
I use this crt code to request a certificate using server Apache+OpenSSL
I get 2 codes back, an intermediate certificate code and the certificate code for the server; I rename those in citadel.cer and intermediate.cer
Then move those two files to the server in webcit and citadel
Restart the server, and the certificates are not recognized...
Am i missing a step here? Something obvious perhaps? I tried this sequence 4 times now....
help would be appreciated.

Thanks in advance,

Marcel



bump;



well, so much for support,

Thanks all, signing off



 



 



 



[#] Mon Oct 21 2013 21:44:32 EDT from davekimble @ Uncensored

Subject: Re: citadel mail server setup - newbie questions

[Reply] [ReplyQuoted] [Headers] [Print]

I just did a software update of Ubuntu which updated the kernel, and so needed a restart. On rebooting, webcit grabbed port 80 before apache2, so apache2 could not start ( !!! ) - this is despite me having told webcit to use 443.  The surest way to get apache2 going was to uninstall citadel-suite, so I did.

I still like the idea of a single mail server package that handles MTA, SMTPS, POP3S, non-MySQL database, non-LDAP authentication, web admin front end. But I have no need for anything additional to that - chat, rooms, calendar, contacts, notes, tasks, etc. And it must behave itself and NOT do things like the above, and the earlier problems. 

It seems like Citadel has grown out of being a BBS server and into something else entirely. Nothing wrong with that, but has there been a fork of Citadel that meets my requirements?  Or would such a fork be easy to implement?



[#] Mon Oct 21 2013 23:44:04 EDT from ax25 @ Uncensored

Subject: Re: citadel mail server setup - newbie questions

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Oct 21 2013 09:44:32 PM EDT from davekimble @ Uncensored Subject: Re: citadel mail server setup - newbie questions

I just did a software update of Ubuntu which updated the kernel, and so needed a restart. On rebooting, webcit grabbed port 80 before apache2, so apache2 could not start ( !!! ) - this is despite me having told webcit to use 443.  The surest way to get apache2 going was to uninstall citadel-suite, so I did.

I still like the idea of a single mail server package that handles MTA, SMTPS, POP3S, non-MySQL database, non-LDAP authentication, web admin front end. But I have no need for anything additional to that - chat, rooms, calendar, contacts, notes, tasks, etc. And it must behave itself and NOT do things like the above, and the earlier problems. 

It seems like Citadel has grown out of being a BBS server and into something else entirely. Nothing wrong with that, but has there been a fork of Citadel that meets my requirements?  Or would such a fork be easy to implement?



I have had:

HTTP_PORT=2000

at the top of my /etc/init.d/webcit file for years and that has stopped Webcit from fighting with my Apache server.

The other variable in that start / stop file is:

HTTPS_PORT=443

for HTTP(S) - note, not HTTP.

 



[#] Tue Oct 22 2013 11:35:34 EDT from dothebart @ Uncensored

Subject: Re: Webcit / Citadel SSL issue

[Reply] [ReplyQuoted] [Headers] [Print]

ssl certificates are basicaly text files, some with base64 formats in them.

so, if you're handy with an editor, you should be able to see what you got from your CA, and what citadel did with the self signed certificates.

most probably using that information you can google the formats.

openssl has some support to convert some formats, it also should be able to inspect certificates, and give you informations about them.

openssl.org should probably be one of the sources for information; your browser also should give you information on the type of encryption.

so if you manage to use your certificate with apache, maybe that could also sched more light on this.

Citadel basicaly uses openssl for all this, but we're no experts on what any CA on the world may provide you as certificates and so on.

Mon Oct 21 2013 21:05:30 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

lets bump my issue again after 14 days of waiting

 

Tue Oct 08 2013 14:30:41 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

 

Thanks for your support, but it didn’t work,

 

 

First I changed the ownership to root and the chmod to 644 as you instructed and tested the connection after a server restart.

 

 

After that I appended the intermediate certificate to citadel.cer but this had no effect either. 

Every time I try to open the https page the result in the browser is:

 

Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap)

 

When I remove the certificates and keys and restart the system the self signed cert is created and the system works...

any other suggestion is appreciated,

Thanks in advance,

Marcel

 

Wed Oct 02 2013 06:08:20 EDT from schaap23 @ Uncensored Subject: Re: Webcit / Citadel SSL issue

When you move the certificates to /etc/ssl/webcit and /etc/ssl/citadel/,
make sure citadel cannot overwrite the new ssl certificate.
So change the file permissions (chmod) so that the file can only be read by citadel.
Otherwise citadel might try to overwrite your new certificates with self-signed certificates.
So login as root:
Su

Change the ownership of the keys to root
Chown root citadel.cer; chown root citadel.key

change the modifiers to 6 (owner read,write) 4 (group read) 4 (everyone read)
chmod 644 citadel.cer; chmod 644 citadel.key


It might also be necessary to append the intermediate certificate (intermediate.cer) to your own certificate (citadel.cer / webcit.cer).
For me, this was necessary to get my godaddy certificate working. I had to append the gd_bundle.cert (godaddy intermediate.cer) of godaddy to my citadel.cer:

Open the intermediate.cer with a text editor and copy it's contents.

Open the citadel.cer file with a text editor and go to the last line. On the last line paste the contents of the intermediate.cer.

Remember, since you have changed the ownership of the citadel.cer file to root, you must open the file as root, otherwise you cannot edit it off course.

Now you can login to webcit and restart the citadel server. You should now be able to use https (ssl).

 

Tue Oct 01 2013 09:14:39 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

 

Mon Sep 30 2013 18:31:58 EDT from Devdom @ Uncensored Subject: Re: Webcit / Citadel SSL issue

 

Fri Sep 27 2013 11:17:27 EDT from Devdom @ Uncensored Subject: Webcit / Citadel SSL issue

good day to you all....

I think I need some help setting up my citadel/webcit with ssl/tls,
when I remove all keys and certificates then restart, it generates a self-signed key /certificate, all this works, next I remove all the files in /etc/ssl/webcit and /etc/ssl/citadel
then I run openssl genrsa -out citadel-key 2048
this generates the key
Start openssl req -new -key citadel.key -out citadel.crt
This generates the request form for Geotrust
I use this crt code to request a certificate using server Apache+OpenSSL
I get 2 codes back, an intermediate certificate code and the certificate code for the server; I rename those in citadel.cer and intermediate.cer
Then move those two files to the server in webcit and citadel
Restart the server, and the certificates are not recognized...
Am i missing a step here? Something obvious perhaps? I tried this sequence 4 times now....
help would be appreciated.

Thanks in advance,

Marcel



bump;



well, so much for support,

Thanks all, signing off



 



 



 



 



[#] Tue Oct 22 2013 11:40:39 EDT from dothebart @ Uncensored

Subject: Re: citadel mail server setup - newbie questions

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon Oct 21 2013 23:44:04 EDT from ax25 @ Uncensored Subject: Re: citadel mail server setup - newbie questions

 

Mon Oct 21 2013 09:44:32 PM EDT from davekimble @ Uncensored Subject: Re: citadel mail server setup - newbie questions

I just did a software update of Ubuntu which updated the kernel, and so needed a restart. On rebooting, webcit grabbed port 80 before apache2, so apache2 could not start ( !!! ) - this is despite me having told webcit to use 443.  The surest way to get apache2 going was to uninstall citadel-suite, so I did.

I still like the idea of a single mail server package that handles MTA, SMTPS, POP3S, non-MySQL database, non-LDAP authentication, web admin front end. But I have no need for anything additional to that - chat, rooms, calendar, contacts, notes, tasks, etc. And it must behave itself and NOT do things like the above, and the earlier problems. 

It seems like Citadel has grown out of being a BBS server and into something else entirely. Nothing wrong with that, but has there been a fork of Citadel that meets my requirements?  Or would such a fork be easy to implement?

I have had:

HTTP_PORT=2000

at the top of my /etc/init.d/webcit file for years and that has stopped Webcit from fighting with my Apache server.

The other variable in that start / stop file is:

HTTPS_PORT=443

for HTTP(S) - note, not HTTP.

you can disable any service citadel provides by putting -1 in the config and restarting citserver.

however citadel aims to offer access to all of its facilities via all of the protocols (pop3 only can give you your inbox, but thats not citadels fault)

the hardware footprint is also rather low in comparison with similar solutions; its even known to work on smaller hardware as i.e. the pi.

if that doesn't suit your needs, git is your friend. Its all open source.



[#] Tue Oct 22 2013 20:54:14 EDT from davekimble @ Uncensored

Subject: Re: citadel mail server setup - newbie questions

[Reply] [ReplyQuoted] [Headers] [Print]

I just did a software update of Ubuntu which updated the kernel, and so needed a restart. On rebooting, webcit grabbed port 80 before apache2, so apache2 could not start ( !!! ) - this is despite me having told webcit to use 443.  The surest way to get apache2 going was to uninstall citadel-suite, so I did.

I still like the idea of a single mail server package that handles MTA, SMTPS, POP3S, non-MySQL database, non-LDAP authentication, web admin front end. But I have no need for anything additional to that - chat, rooms, calendar, contacts, notes, tasks, etc. And it must behave itself and NOT do things like the above, and the earlier problems. 

It seems like Citadel has grown out of being a BBS server and into something else entirely. Nothing wrong with that, but has there been a fork of Citadel that meets my requirements?  Or would such a fork be easy to implement?



[#] Tue Oct 22 2013 23:44:36 EDT from ax25 @ Uncensored

Subject: Re: citadel mail server setup - newbie questions

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Oct 22 2013 08:54:14 PM EDT from davekimble @ Uncensored Subject: Re: citadel mail server setup - newbie questions

I just did a software update of Ubuntu which updated the kernel, and so needed a restart. On rebooting, webcit grabbed port 80 before apache2, so apache2 could not start ( !!! ) - this is despite me having told webcit to use 443.  The surest way to get apache2 going was to uninstall citadel-suite, so I did.

I still like the idea of a single mail server package that handles MTA, SMTPS, POP3S, non-MySQL database, non-LDAP authentication, web admin front end. But I have no need for anything additional to that - chat, rooms, calendar, contacts, notes, tasks, etc. And it must behave itself and NOT do things like the above, and the earlier problems. 

It seems like Citadel has grown out of being a BBS server and into something else entirely. Nothing wrong with that, but has there been a fork of Citadel that meets my requirements?  Or would such a fork be easy to implement?



Sure, the code is available.  Just download it and trim to fit your situation.  If you are looking for a mail server with a web interface for administration (warning: it uses the dreaded MySQL), you could give Vexim a go:

https://github.com/avleen/vexim2



[#] Wed Oct 23 2013 06:27:54 EDT from ichrispa @ Uncensored

Subject: Citadel GroupDAV Ressource inaccessable

[Reply] [ReplyQuoted] [Headers] [Print]

Hello everyone,

recently a problem emerged on my Citadel installation (server version 8.14-2 on debian on wheezy from official stable repo), which has worked fine for over 2 years. I can't seem to be able of accessing my Calendar room using GroupDAV anymore - this is limited to my user account and the specific room. I can access other private rooms of mine using GroupDAV without errors and when using webcit, I can view my Calendar room normally. Some other users have reported this problem as well, notably those using GroupDAV to sync their calendars with various clients.

The error manifests itself when retrieving the contents of the Calendar folder. I have tried using both Calendar (KDE) and cadaver; the former complains about a network timeout, the later gives the following error message:

dav:/groupdav/> ls Calendar
Listing collection `/groupdav/Calendar/': failed:
Could not read status line: connection was closed by server

Running citserver with a tracefile, I get the following messages just before the connection is terminated:

citserver[16882]: [2][<username removed>(11)] MSG0 31872|3
citserver[16882]: Citadel client disconnected: ending session.
citserver[16882]: Context: [  2]SRV[citadel-TCP] Session ended.

Other than that I can't note any other apparent problem and I'm running out of clues as to how to debug this. Any help would be much appreciated.

Kind regards,

Chris



[#] Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored

Subject: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!



[#] Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



[#] Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



[#] Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



[#] Thu Oct 24 2013 16:35:21 EDT from Seth Galitzer @ Uncensored

Subject: admin user with LDAP?

[Reply] [ReplyQuoted] [Headers] [Print]

I was able to successfully install using the easy installer and LDAP works great OOTB, so thanks for that.  Unfortunately, the LDP acct I specified as the site admin doesn't seem to have any admin privileges.  At least I don't see any admin type tasks available to me.  Any suggestions to get me going?

Thanks.

Seth



[#] Thu Oct 24 2013 20:46:02 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



i will try it, thanks!



[#] Thu Oct 24 2013 23:44:09 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



hi, i build stable_82x. The install seemed to work fine, but the setup program fails with the following error.  "Setup could not connect to a running Citadel server.: No such file or directory /home/citadel/local/citadel/citadel-admin.socket"

what should i do?

thans!



[#] Fri Oct 25 2013 02:18:29 EDT from wanghuok @ Uncensored

Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Oct 24 2013 23:44:09 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 10:25:11 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:29:39 EDT from wanghuok @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 03:15:27 EDT from dothebart @ Uncensored Subject: Re: hello,everybody,when i send some message in chinese ,it didn't display

 

Thu Oct 24 2013 02:45:32 EDT from wanghuok @ Uncensored Subject: hello,everybody,when i send some message in chinese ,it didn't display

hello,everybody,when i send some message in chinese ,it didn't display correctly in client, whether should i change my codec of the server?

thanks!

hi, which client do you mean?

webcit?

the commandline client is probably not good at i18n and encodings at all.



hi, i use Pidgin ,i config it follow this link:

http://www.citadel.org/doku.php/faq:everydayuse:jabber#configuring.a.jabber.client.to.access.citadel

my Server envirent is:

CentOS 6.4 chinese version, i install citadel server from easy install

thanks.



ok, you're lucky to be the third person to report this in the last 3 weeks,

http://code.citadel.org/?p=citadel.git;a=commit;h=b564b4f31c59b75d3bdc7d7cf7a4a48218e345c9

is the fix for it, its going to be part of the next release.

If you can't wait till the next release, please clone the 8.2x branch and compile the latest unreleased stability patches:

http://citadel.org/doku.php/installation:sourcecode



hi, i build stable_82x. The install seemed to work fine, but the setup program fails with the following error.  "Setup could not connect to a running Citadel server.: No such file or directory /home/citadel/local/citadel/citadel-admin.socket"

what should i do?

thans!



i solve it, it works now , thanks very much!



[#] Fri Oct 25 2013 12:25:28 EDT from bennabiy @ Uncensored

Subject: SSL availabe for xmpp? Also, OTR?

[Reply] [ReplyQuoted] [Headers] [Print]

I am trying to include a little more security with the xmpp portion of citadel. I do not mind doing the work, but need a little direction.

 

I grabbed the source and have located the xmpp module, but am not sure if someone who is already familiar with the way xmpp works in citadel could contact me and I could pick their brain about a few things.

 

We really appreciate all the work that has gone into Citadel, and look forward to seeing it increase more and more.

 

Please message me if you are able to talk about this topic.



Go to page: [1] 2 3 4 5 ... Last