Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Tue Dec 17 2013 13:16:44 EST from s3cr3to @ Uncensored

Subject: Re: VM Appliances available to test Citadel?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Dec 17 2013 12:02:02 AM EST from rattlesnakeshake @ Uncensored Subject: VM Appliances available to test Citadel?

Hi there

I tried to download<http://easyinstall.citadel.org/citadel-vmware-appliance-2012.zip>, which results in a 404 Not Found webserver error...

I managed to download <http://easyinstall.citadel.org/citadel-kvm-appliance-2011.zip>, but the ZIP archive seems to be broken. At least this is what I get on MacOS 10.7.5:

charlieBrown:~ mike$ unzip -tq /Users/mike/Desktop/citadel-kvm-appliance-2011.zip
[/Users/mike/Desktop/citadel-kvm-appliance-2011.zip]
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of /Users/mike/Desktop/citadel-kvm-appliance-2011.zip or
        /Users/mike/Desktop/citadel-kvm-appliance-2011.zip.zip, and cannot find /Users/mike/Desktop/citadel-kvm-appliance-2011.zip.ZIP, period.

So if anybody has any helpful ideas on how I could try a Citadel VM appliance, I'd appreciate feedback.

Thanks a lot!

Mike (aka rattlesnakeshake)



Well, I use VirtualBox and a debian vm, then I get the .debs and I install without (well, yes one) issues.

The benefits of this is that you can take a snapshot each time you want to try something, I do this some time ago:

  1. In VBox I create and install Debian 6 (you can use wheezy 7.x)
  2. configure the host name of this vm (something simple like "vmmail")
  3. once I have my networks configured (I use two NICS one internal one external (for smtp, update, etc)
  4. update everything. Here I install nginx, ufw, fail2ban, ssh (hardened with a ssh key and other port than 22)
  5. download the .debs (but not install yet) for citadel of the version that you want - I only once use the easy install with some issues but when works, works good.
  6. Test and retest all your vm, try to access this vm from your real computer or another one (pings, etc) from outside. if all works take a snapshot
  7. Here we go, if you have the .debs, run from where the debs are located: sudo dpkg -i *.deb
  8. If the install complains about some dependencies, check and get or install those. and try again step 7.
  9. I need to edit the file in: /etc/default/webcit because I use nginx so this is what I got:

# Original:

export WEBCIT_APACHEFLAG=' '
export WEBCIT_CITADEL_IP='127.0.0.1'
export WEBCIT_CITADEL_PORT='504'
export WEBCIT_HTTPS_PORT='443'
export WEBCIT_HTTP_PORT='80'
export WEBCIT_LANG='UNLIMITED'
export WEBCIT_LISTEN_IP='0.0.0.0'

.......................................................

# Edited by me, currently in use

export WEBCIT_APACHEFLAG=" -f "
export WEBCIT_LISTEN_IP=127.0.0.1
export WEBCIT_HTTP_PORT=80 <<-- I change this port to "12380" by example
export WEBCIT_HTTPS_PORT=443
export WEBCIT_LANG=UNLIMITED
export WEBCIT_CITADEL_PORT=504
export WEBCIT_CITADEL_IP=127.0.0.1

See that I use 127.0.0.1 so nginx "serve" and communicate with webcit using the localhost. BUT, if you don't use nginx just, check the default of webcit, because by default it listens an all the interfaces

If all goes OK, in /etc/init.d must exists two files:

  • citadel
  • webcit

I barely recall that with easy install or some version, this files were missing. But If after installing this you ended without this files, I can post this in other message.


Finally, If you got all working:

  • You can Export the appliance so you can take to another computer etc.
  • I recommend to take a snapshot to your vm. So you can play and break it to learn more :) and if something goes wrong just restore the snapshot.

Sorry for any mistake/error ... I wrote this from memory but, you know human RAM is not so good like before.

Regards



[#] Tue Dec 17 2013 14:29:26 EST from rattlesnakeshake @ Uncensored

Subject: Re: VM Appliances available to test Citadel?

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Dec 17 2013 13:16:44 EST from s3cr3to @ Uncensored Subject: Re: VM Appliances available to test Citadel?

 

Tue Dec 17 2013 12:02:02 AM EST from rattlesnakeshake @ Uncensored Subject: VM Appliances available to test Citadel?

Hi there

I tried to download<http://easyinstall.citadel.org/citadel-vmware-appliance-2012.zip>, which results in a 404 Not Found webserver error...

I managed to download <http://easyinstall.citadel.org/citadel-kvm-appliance-2011.zip>, but the ZIP archive seems to be broken. At least this is what I get on MacOS 10.7.5:

charlieBrown:~ mike$ unzip -tq /Users/mike/Desktop/citadel-kvm-appliance-2011.zip
[/Users/mike/Desktop/citadel-kvm-appliance-2011.zip]
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of /Users/mike/Desktop/citadel-kvm-appliance-2011.zip or
        /Users/mike/Desktop/citadel-kvm-appliance-2011.zip.zip, and cannot find /Users/mike/Desktop/citadel-kvm-appliance-2011.zip.ZIP, period.

So if anybody has any helpful ideas on how I could try a Citadel VM appliance, I'd appreciate feedback.

Thanks a lot!

Mike (aka rattlesnakeshake)



Well, I use VirtualBox and a debian vm, then I get the .debs and I install without (well, yes one) issues.

The benefits of this is that you can take a snapshot each time you want to try something, I do this some time ago:

  1. In VBox I create and install Debian 6 (you can use wheezy 7.x)
  2. configure the host name of this vm (something simple like "vmmail")
  3. once I have my networks configured (I use two NICS one internal one external (for smtp, update, etc)
  4. update everything. Here I install nginx, ufw, fail2ban, ssh (hardened with a ssh key and other port than 22)
  5. download the .debs (but not install yet) for citadel of the version that you want - I only once use the easy install with some issues but when works, works good.
  6. Test and retest all your vm, try to access this vm from your real computer or another one (pings, etc) from outside. if all works take a snapshot
  7. Here we go, if you have the .debs, run from where the debs are located: sudo dpkg -i *.deb
  8. If the install complains about some dependencies, check and get or install those. and try again step 7.
  9. I need to edit the file in: /etc/default/webcit because I use nginx so this is what I got:

# Original:

export WEBCIT_APACHEFLAG=' '
export WEBCIT_CITADEL_IP='127.0.0.1'
export WEBCIT_CITADEL_PORT='504'
export WEBCIT_HTTPS_PORT='443'
export WEBCIT_HTTP_PORT='80'
export WEBCIT_LANG='UNLIMITED'
export WEBCIT_LISTEN_IP='0.0.0.0'

.......................................................

# Edited by me, currently in use

export WEBCIT_APACHEFLAG=" -f "
export WEBCIT_LISTEN_IP=127.0.0.1
export WEBCIT_HTTP_PORT=80 <<-- I change this port to "12380" by example
export WEBCIT_HTTPS_PORT=443
export WEBCIT_LANG=UNLIMITED
export WEBCIT_CITADEL_PORT=504
export WEBCIT_CITADEL_IP=127.0.0.1

See that I use 127.0.0.1 so nginx "serve" and communicate with webcit using the localhost. BUT, if you don't use nginx just, check the default of webcit, because by default it listens an all the interfaces

If all goes OK, in /etc/init.d must exists two files:

  • citadel
  • webcit

I barely recall that with easy install or some version, this files were missing. But If after installing this you ended without this files, I can post this in other message.


Finally, If you got all working:

  • You can Export the appliance so you can take to another computer etc.
  • I recommend to take a snapshot to your vm. So you can play and break it to learn more :) and if something goes wrong just restore the snapshot.

Sorry for any mistake/error ... I wrote this from memory but, you know human RAM is not so good like before.

Regards



Hi s3cr3to

thanks a lot for the detailed description. I will try and give it a shot this weekend. It deviates considerably from my preferred workflow, so I guess it will take me some time. I'll report back...

Thanks!

Mike



[#] Sun Dec 22 2013 18:44:36 EST from IGnatius T Foobar @ Uncensored

Subject: Re: VM Appliances available to test Citadel?

[Reply] [ReplyQuoted] [Headers] [Print]

The virtual appliances got way too out of date so we pulled them. They will return someday soon.

[#] Mon Dec 23 2013 21:42:47 EST from hansi2323 @ Uncensored

Subject: webcit displays folders for folders that via imap are not empty

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

I installed citadel on my raspberry as it looks like a program that does exactly what I want. Now I'm facing the problem that webcit only shows empty folders, although they do contain data.
What I did:
-installing and configuring
-synced some mails via imap -> worked and mails also are shown in webcit and other clients
So mail is working as expected for now. Imap-folders I create are also synced correctly.

-synced contacts, tasks, etc. with Outlook using bynari connector -> looked good, but then
-opened webcit webfrontend -> no contacts, tasks, etc. are shown (folders are empty)
-synced with thunderbird (with empty profile) -> contacts, tasks, etc. are there!
-logged in via citadel command line -> Contacts, tasks, etc. are there (as imap mails with xml attachment)
-I can create contacts, tasks, etc. in webcit and they are displayed then also in outlook in the same folder the other items are in, which are not shown
-set all folders to public, played around with different settings, read faq and so on...

So now there still is the problem that webcit displays that contacts-, tasks- etc.-folders are empty. Looks like webcit accesses another database than imap does, or imap syncs to a hidden room - but even with aide rights (guess thats root?) I cannot see any rooms that might contain my data in webcit. Does anybody have an idea what I could try to fix this? I'm new to citadel and it would be great to get it running. I'm also willing to learn more about  citadel so pointing me to a readme would be ok, too.
Thanks in advence,
hansi



[#] Tue Dec 24 2013 02:50:01 EST from dothebart @ Uncensored

Subject: Re: webcit displays folders for folders that via imap are not empty

[Reply] [ReplyQuoted] [Headers] [Print]

hm, that sounds strange.

if you go to your contacts room in webcit, and alter the URL by adding &view=1 (or replacing) do you see messages in there (which should contain vcards)?

can you create a contact with outlook / bynari, use thunderbird Imap to open the contact room, search the contact, press CTRL+U and paste what pops up here?



[#] Tue Dec 24 2013 08:08:54 EST from hansi2323 @ Uncensored

Subject: Re: webcit displays folders for folders that via imap are not empty

[Reply] [ReplyQuoted] [Headers] [Print]

dothebart,
thanks for your reply! If I open https://[server]/webcit/dotgoto?room=_CONTACTS_&view=1, the contacts are displayed indeed, but as e-mails with subjects like 00000000D11BD5EB576A7549ADFB1DA285FE1FD20100BA7D3940D65BAE45B360E4B64B8FD45D000000000A680000, sender is me (although "View as Address Book" is selected). Bodies of these mails contain the text added as note to a contact, and there's an attachment "Kolab.xml" containing all the rest of contact details.
If I press in thunderbird (without lighning + sync kolab) ctrl-u on a contact synced with outlook (it comes from ActiveSync, I'm syncing my old Windows Mobile 2003 device, if someone knows a better way than outlook+bynari...), it displays the source like this (tried to remove some private data):

Return-Path: hansi2323
Date: Thu, 19 Dec 2013 20:30:13 +0100
Subject: 00000000D11BD5EB576A7549ADFB1DA285FE1FD20100BA7D3940D65BAE45B360E4B64B8FD38D000000000A620000
Message-ID: <000c05db53.0001cefcf1.00018b4608.0000003a61@provider.com>
From: "Jan Schmitt" <hansi2323@provider.com>
Sender: Jan Schmitt <hansi2323@provider.com>
X-Priority: 3
X-Mailer: Outlook Connector 4.1.19-16010
X-Kolab-Type: application/x-vnd.kolab.contact
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary=000000025615783-000000000008909-000001387481545-000000000000000

--000000025615783-000000000008909-000001387481545-000000000000000
Content-Type: text/plain; charset=Windows-1252
Content-Transfer-Encoding: quoted-printable

test note

--000000025615783-000000000008909-000001387481545-000000000000000
Content-Type: application/x-vnd.kolab.contact; name="Kolab.xml"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; FILENAME="Kolab.xml"

PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPGNvbnRh
Y3QgdmVyc2lvbj0iMS4wIj4KCTx1aWQ+MDAwMDAwMDBEMTFCRDVFQjU3NkE3
NTQ5QURGQjFEQTI4NUZFMUZEMjAxMDBCQTdEMzk0MEQ2NUJBRTQ1QjM2MEU0
QjY0QjhGRDM4.... etc....==

--000000025615783-000000000008909-000001387481545-000000000000000--

So webcit does use the right folders, I guess something went wrong when pushing to the server so that contacts are in a wrong format. Or looks this like a server issue to you? I'll re-setup my outlook stuff and play around with it.
Thanks,
hansi



[#] Tue Dec 24 2013 11:40:43 EST from friday @ Uncensored

Subject: Any way to block zip attachments, or scan for exe within zip.

[Reply] [ReplyQuoted] [Headers] [Print]

I don't believe there is a way, but heck, can't hurt to ask.

We get a ton of those DHL, UPS, etc scam emails with zip attachments. A few unlucky users haven't realized they are viruses, and thus, infect themselves. I'd just love to remove zip attachments all together and be done with the issue.



[#] Wed Dec 25 2013 07:40:02 EST from mingodad @ Uncensored

Subject: About translations !

[Reply] [ReplyQuoted] [Headers] [Print]

Hello !

I recently started testing citadel and noticed that the en_GB translation seems to be out of sync with launchpad.

When we select en_GB on the left menu we get "Contents" instead of "Contacts", when I search the launchpad I can see that there the translation is correct but using easyintall or even checking out the source code using git we have there "Contents" for "Contacts".

Is it too hard to fix that ?

I already fixed it on my own installation !

 

Thanks in advance for your time and help !



[#] Wed Dec 25 2013 07:56:01 EST from mingodad @ Uncensored

Subject: Google openid with firefox do not work

[Reply] [ReplyQuoted] [Headers] [Print]

Hello !

When I try to login here using Firefox 26 firefox ask to open/save it. Using Chromiun it works.

Thanks in advance for your time and help !



[#] Thu Dec 26 2013 17:17:18 EST from TaMeR @ Uncensored

Subject: Re: Google openid with firefox do not work

[Reply] [ReplyQuoted] [Headers] [Print]

 

Wed Dec 25 2013 07:56:01 EST from mingodad @ Uncensored Subject: Google openid with firefox do not work

Hello !

When I try to login here using Firefox 26 firefox ask to open/save it. Using Chromiun it works.

Thanks in advance for your time and help !



I can't even get that far with Firefox, when I try to visit http://uncensored.citadel.org with Firefox I get an http login prompt. 

 



[#] Thu Dec 26 2013 21:11:55 EST from hansi2323 @ Uncensored

Subject: Re: webcit displays folders for folders that via imap are not empty

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

after trying around with bynari and outlook I still didn't get it to work. In folder permissions I re-set the types and tried other things, no success. Calendar, Contacts, Tasks and Notes are synced only from webcit to outlook, items created in outlook will in webcit only show up using &view=1 (in a list view then). Can anybody tell me the right settings in Account settings -> More settings -> Format? Or could it be I have to reconfigure something on server side to make it work?
Thats what verbose log says when creating a task in outlook with bynari connected:
2013-12-27 02:08:05.854  0x000001B4  BE_IMAP: CBackEnd::GetAccessFlags: Folder: Tasks Access: 0x0000003f AccessLevel: 0x00000001
2013-12-27 02:08:13.565  0x000001B4  BE_IMAP: CBackEnd::GetAccessFlags: Folder: Tasks Access: 0x0000003f AccessLevel: 0x00000001
2013-12-27 02:08:13.587  0x000001B4  CONPST32: Enter CMessage::SaveChanges
2013-12-27 02:08:13.587  0x000000A4  BE_IMAP: CBackEnd::OpenImap: Opening folder ""
2013-12-27 02:08:13.598  0x000001B4  CONPST32: Leaving CMessage::SaveChanges
2013-12-27 02:08:13.742  0x000001B4  BE_IMAP: CBackEnd::GetAccessFlags: Folder: Tasks Access: 0x0000003f AccessLevel: 0x00000001
2013-12-27 02:08:13.753  0x000001B4  BE_IMAP: CBackEnd::GetAccessFlags: Folder: Tasks Access: 0x0000003f AccessLevel: 0x00000001
2013-12-27 02:08:13.775  0x000001B4  BE_IMAP: CBackEnd::GetAccessFlags: Folder: Tasks Access: 0x0000003f AccessLevel: 0x00000001
2013-12-27 02:08:13.786  0x000001B4  BE_IMAP: CBackEnd::GetAccessFlags: Folder: Tasks Access: 0x0000003f AccessLevel: 0x00000001
2013-12-27 02:08:18.159  0x000000A4  BE_IMAP: CImport::GetHTMLFromRTF: OpenProperty failed for PR_RTF_COMPRESSED, 0x8004010f - MAPI_E_NOT_FOUND

2013-12-27 02:08:18.170  0x000000A4  BE_IMAP: CImport::GetTextFromRTF: OpenProperty failed for PR_RTF_COMPRESSED, 0x8004010f - MAPI_E_NOT_FOUND

2013-12-27 02:08:18.181  0x000000A4  BE_IMAP: CBackEnd::OpenImap: Opening folder "INBOX/Tasks"
2013-12-27 02:08:18.798  0x000000A4  BE_IMAP: CBackEnd::UploadMessage: Have a Kolab subject, looking for subject 040000008200E00074C5B7101A82E008000000000000000000000000000000000000000000000000E01EE4422D4F6845B6773473287CCCE00100FDF53BEC3805D648B7879F40CED231B300000000100A0000 - ulMessageUID: 0
2013-12-27 02:08:19.092  0x000000A4  BE_IMAP: CBackEnd::UploadMessage: Uploading message to INBOX/Tasks folder - replace UID: 0 last known UID: 0
2013-12-27 02:08:19.667  0x000000A4  BE_IMAP: CBackEnd::UploadMessage: Folder: INBOX/Tasks New UID: 4401 Old UID: 0
Another issue is thunderbird with lightning and sync kolab, had to install sync kolab nightly to show up configuration, then calendar-sync worked, tasks-sync didn't work at all. Do I have to select kolab1, kolab2 or kolab3 in sync kolab?
Thanks in advance,
hansi



[#] Fri Dec 27 2013 03:50:14 EST from dothebart @ Uncensored

Subject: Re: webcit displays folders for folders that via imap are not empty

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue Dec 24 2013 08:08:54 EST from hansi2323 @ Uncensored Subject: Re: webcit displays folders for folders that via imap are not empty

dothebart,
thanks for your reply! If I open https://[server]/webcit/dotgoto?room=_CONTACTS_&view=1, the contacts are displayed indeed, but as e-mails with subjects like 00000000D11BD5EB576A7549ADFB1DA285FE1FD20100BA7D3940D65BAE45B360E4B64B8FD45D000000000A680000, sender is me (although "View as Address Book" is selected). Bodies of these mails contain the text added as note to a contact, and there's an attachment "Kolab.xml" containing all the rest of contact details.
If I press in thunderbird (without lighning + sync kolab) ctrl-u on a contact synced with outlook (it comes from ActiveSync, I'm syncing my old Windows Mobile 2003 device, if someone knows a better way than outlook+bynari...), it displays the source like this (tried to remove some private data):

Return-Path: hansi2323
Date: Thu, 19 Dec 2013 20:30:13 +0100
Subject: 00000000D11BD5EB576A7549ADFB1DA285FE1FD20100BA7D3940D65BAE45B360E4B64B8FD38D000000000A620000
Message-ID: <000c05db53.0001cefcf1.00018b4608.0000003a61@provider.com>
From: "Jan Schmitt" <hansi2323@provider.com>
Sender: Jan Schmitt <hansi2323@provider.com>
X-Priority: 3
X-Mailer: Outlook Connector 4.1.19-16010
X-Kolab-Type: application/x-vnd.kolab.contact
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary=000000025615783-000000000008909-000001387481545-000000000000000

--000000025615783-000000000008909-000001387481545-000000000000000
Content-Type: text/plain; charset=Windows-1252
Content-Transfer-Encoding: quoted-printable

test note

--000000025615783-000000000008909-000001387481545-000000000000000
Content-Type: application/x-vnd.kolab.contact; name="Kolab.xml"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; FILENAME="Kolab.xml"

PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPGNvbnRh
Y3QgdmVyc2lvbj0iMS4wIj4KCTx1aWQ+MDAwMDAwMDBEMTFCRDVFQjU3NkE3
NTQ5QURGQjFEQTI4NUZFMUZEMjAxMDBCQTdEMzk0MEQ2NUJBRTQ1QjM2MEU0
QjY0QjhGRDM4.... etc....==

--000000025615783-000000000008909-000001387481545-000000000000000--

So webcit does use the right folders, I guess something went wrong when pushing to the server so that contacts are in a wrong format. Or looks this like a server issue to you? I'll re-setup my outlook stuff and play around with it.
Thanks,
hansi



Ah, XML. thats Kolab2 mode - citadel only speaks kolab 1



[#] Fri Dec 27 2013 04:11:49 EST from dothebart @ Uncensored

Subject: Re: Any way to block zip attachments, or scan for exe within zip.

[Reply] [ReplyQuoted] [Headers] [Print]

Tue Dec 24 2013 11:40:43 EST from friday @ Uncensored Subject: Any way to block zip attachments, or scan for exe within zip.

I don't believe there is a way, but heck, can't hurt to ask.

We get a ton of those DHL, UPS, etc scam emails with zip attachments. A few unlucky users haven't realized they are viruses, and thus, infect themselves. I'd just love to remove zip attachments all together and be done with the issue.

afaik you can configure blacklist extensions in spamassassin.



[#] Fri Dec 27 2013 04:20:15 EST from dothebart @ Uncensored

Subject: Re: About translations !

[Reply] [ReplyQuoted] [Headers] [Print]

Wed Dec 25 2013 07:40:02 EST from mingodad @ Uncensored Subject: About translations !

Hello !

I recently started testing citadel and noticed that the en_GB translation seems to be out of sync with launchpad.

When we select en_GB on the left menu we get "Contents" instead of "Contacts", when I search the launchpad I can see that there the translation is correct but using easyintall or even checking out the source code using git we have there "Contents" for "Contacts".

Is it too hard to fix that ?

I already fixed it on my own installation !

 

Thanks in advance for your time and help !

hm, fancy. it won't output this to the bzr export

i've fixed it by hand, tnx for reporting.



[#] Fri Dec 27 2013 07:11:06 EST from nunnakirankumar @ Uncensored

Subject: Unable to perform easyInstall

[Reply] [ReplyQuoted] [Headers] [Print]

 

All,

I am trying to install Citadel in my Mac system using EasyInstall. But seeing following error while installing it. And the error as follows:

[Data from citadel-install-log.txt file]

config.status: creating db_config.h

config.status: executing libtool commands

./libtool --mode=compile cc -c -I. -I../src  -O3  ../src/mutex/mut_tas.c

libtool: compile:  cc -c -I. -I../src -O3 ../src/mutex/mut_tas.c  -fno-common -DPIC -o .libs/mut_tas.o

In file included from ../src/mutex/mut_tas.c:11:

In file included from ./db_int.h:999:

In file included from ../src/dbinc/mutex.h:15:

In file included from ../src/dbinc/mutex_int.h:12:

../src/dbinc/atomic.h:179:19: error: definition of builtin function '__atomic_compare_exchange'

static inline int __atomic_compare_exchange(

                  ^

1 error generated.

make: *** [mut_tas.lo] Error 1

Operating system:

 

FYI,

Command I am using to install is "curl http://easyinstall.citadel.org/install | sh"

I am using Mac with version 10.8.5.

Much appreciated for the help. 

-Kiran

 

 



[#] Fri Dec 27 2013 19:24:14 EST from TaMeR @ Uncensored

Subject: Citadel Sync needs your help/input

[Reply] [ReplyQuoted] [Headers] [Print]

 

I am working on version 2 of CitadelSync and need some user input.

In order to keep in sync version 1 of CitadelSync deletes all contacts, in the given room on your citadel server, then uploads the vCards from your local folder to the room.

This only works if you maintain your address book locally

I like to make Version 2 of CitadelSync a bid smarter.

Options:

  1. Download all contacts from Citadel compare them to the local contacts, and process only the modified once. Either upload to the server or save the one from the serve locally, which ever is newer.
  2. Create a second application to run on the server. Basically have a client, server application pair. The Application pair then can send to each other the revision information and only the modifieds get processed.

 The first choice is easier to do, but uses more bandwidth and server resources if you have a lot of users that can make a difference. 

Second one has some nice benefits. vCards could also be stored in a folder, in addition to Citadel. This folder could be made available via ftp, webdav etc opening up a lot more possibilities to access your vCards. However you will have to install two application to use thi, server and client application. If the owner of the server does install the server application then the user can't use CitadelSync. The owner of the server will have an additional application running as a daemon, continuously on his server 

 

By the way, I moved CitadelSync in to it's own repository, which makes it easier to access.

The new link is http://bitbucket.org/gotamer/citadelsync  

Any comments, suggestions, bug reports etc are very welcome, however I don't hang out here much, therefore bug reports should be reported to

https://bitbucket.org/gotamer/citadelsync/issues

The executable is still available here:

https://bitbucket.org/gotamer/citadel/downloads 



[#] Fri Dec 27 2013 21:22:14 EST from hansi2323 @ Uncensored

Subject: Re: webcit displays folders for folders that via imap are not empty

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri Dec 27 2013 03:50:14 EST from dothebart @ Uncensored Subject: Re: webcit displays folders for folders that via imap are not empty
 
 
Ah, XML. thats Kolab2 mode - citadel only speaks kolab 1

thanks for for your reply again. With this info, today I set the focus on syncing tasks. Now I'm so far that Outlook writes tasks in VCALENDAR format like webcit does. But unfortunately webcit has the content inline in the email while outlook attaches VCALENDAR file to email, so that webcit again cannot display it. Tried every option I could find and setup my outlook vm several times from scratch. Any ideas?
Is there anybody who is really syncing outlook with citadel successfully in both directions? Or is there a better way for syncing mobile devices via ActiveSync with citadel? How do you guys out there accomplish this?
Thanks again,
hansi



[#] Fri Dec 27 2013 22:58:43 EST from TaMeR @ Uncensored

Subject: Need help with port 504

[Reply] [ReplyQuoted] [Headers] [Print]

 

I have got this working fine receiving CODE_LISTING_FOLLOWS
"MSG0 1301|2"

Now I need to convert it to this
"MSG4 1301|2"

I understand that it needs an additional command

So I got this:
"MSGP text/x-vcard; charset=UTF-8|text/x-vcard"

But I can't figure out how those are supposed to work together

It doesn't work in either sequence

"MSG4 1301|2"
"MSGP text/x-vcard; charset=UTF-8|text/x-vcard"

 

"MSGP text/x-vcard; charset=UTF-8|text/x-vcard"
"MSG4 1301|2"

Any tips?

--

TaMeR


Citadel Sync:
https://bitbucket.org/gotamer/citadelsync



[#] Fri Dec 27 2013 23:01:50 EST from TaMeR @

[Reply] [ReplyQuoted] [Headers] [Print]

NEW UPLOAD: 'citadelsync-v1-Linux-AMD64'
For vCards => https://bitbucket.org/gotamer/citade application/x-executable

[#] Fri Dec 27 2013 23:10:58 EST from TaMeR @ Uncensored

Subject: Re: Need help with port 504

[Reply] [ReplyQuoted] [Headers] [Print]

 

Strike this, got it!

msg 1301 has no part 2

-- 
TaMeR

Citadel Sync:
https://bitbucket.org/gotamer/citadelsync



Go to page: [1] 2 3 4 5 ... Last