Language:
switch to room list switch to menu My folders
Go to page: [1] 2 3 4 5 ... Last
↑↑↑ Old messages ↑↑↑            ↓↓↓ New messages ↓↓↓
[#] Thu Apr 30 2015 09:29:50 EDT from dothebart @ Uncensored

Subject: Re: Server keeps stopping after crash from hours of excess cpu usage

[Reply] [ReplyQuoted] [Headers] [Print]

hm, the utilities should be available with your distribution.

Be carefull, they need to be the same bdb version as your lib.

if you deleted that user, try whats happening with

sendcommand TDAP

eventually you need to go back to a previous backup after that - if it also doesn't like the way the db behaves.



[#] Thu Apr 30 2015 16:51:03 EDT from TaMeR @ Uncensored to citadel_support@citadel.org

Subject: citadel.org hangs on fonts

[Reply] [ReplyQuoted] [Headers] [Print]

citadel.org hangs trying to download fonts from http://fonts.googleapis.com

I could do without those fonts!

On that note, is there any access to the raw wiki text files?

I looked at code.citadel.org but didn't see anything there.

[#] Fri May 01 2015 20:31:28 EDT from TaMeR @ Uncensored to citadel_support@citadel.org

Subject: Return-Path ???

[Reply] [ReplyQuoted] [Headers] [Print]

I have been wondering about this for quite some time. However, as I
mentioned before I am coding something for citadel again and it effects
my code now. So, I am a bid confused about how mailing lists work in
citadel.

Any post submitted in to a mailing list enabled room, I would think
should have some kind of mechanism that insures that replies are sent to
the room rather then the original posters personal email.

At first I thought that Return-Path does this job. But it appears not to
be. If someone posts a message not with Webcit then his/her email
address ends up in the Return-Path.
And even if the message is send via webcit and the Return-Path is set to
the list name, a reply from an email client is set to be the original
posters email address not the list room. And Return-Path wouldn't be
useful to the email client anyway since it has only the room name at
best not the rooms email address.

Shouldn't every post have a header like Reply-To at leased set so that
if one receives a message with an email client, reply will direct the
message to the list rather then the personal email of the person we are
replying to.

Some research on this shows, that Reply-To might not be the right
solution either. However the posters points don't make sense in Citadels
case because Reply To All/Group doesn't work in Citadel either.
http://www.unicom.com/pw/reply-to-harmful.html

So what is Citadels solution to this? Having to type in the mailing
lists email address on every reply doesn't seam to be a very good solution.

Am I totally of track here? Is there something I don't get?

[#] Sat May 02 2015 09:30:38 EDT from TaMeR @ Uncensored to citadel_support@citadel.org

Subject: Disable Login

[Reply] [ReplyQuoted] [Headers] [Print]

I am wondering if there is a way to disable login in http mode, or
forward logins to https.

At the moment I have nginx forward all requests to https but that does
not make sense for plain reading of public pages, rss feeds etc.
Specifically because I use a self signed certificate, but also in general.

So turning of login at http level or forwarding login requests to https
would be great for security.

[#] Sun May 03 2015 08:01:17 EDT from dothebart @ Uncensored

Subject: Re: Disable Login

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sat May 02 2015 09:30:38 EDT from TaMeR @ Uncensored Subject: Disable Login
I am wondering if there is a way to disable login in http mode, or
forward logins to https.

At the moment I have nginx forward all requests to https but that does
not make sense for plain reading of public pages, rss feeds etc.
Specifically because I use a self signed certificate, but also in general.

So turning of login at http level or forwarding login requests to https
would be great for security.

you probably could alter the login mask target action to contain https.

the code is here: static/t/get_logged_in.html

On overloading templates see:

http://citadel.org/doku.php/documentation:customize_webcit#customizing.webcit



[#] Sun May 03 2015 08:02:59 EDT from dothebart @ Uncensored

Subject: Re: citadel.org hangs on fonts

[Reply] [ReplyQuoted] [Headers] [Print]

 

Thu Apr 30 2015 16:51:03 EDT from TaMeR @ Uncensored Subject: citadel.org hangs on fonts
citadel.org hangs trying to download fonts from http://fonts.googleapis.com

I could do without those fonts!

On that note, is there any access to the raw wiki text files?

I looked at code.citadel.org but didn't see anything there.

its a dokuwiki, so

http://citadel.org/doku.php/documentation:customize_webcit?do=export_html

will do.

Turning of javascript wil probably also do; I guess the google adds depend on these fonts.

NoScript is your friend ;-)



[#] Sun May 03 2015 08:13:58 EDT from dothebart @ Uncensored

Subject: Re: Return-Path ???

[Reply] [ReplyQuoted] [Headers] [Print]

 

Fri May 01 2015 20:31:28 EDT from TaMeR @ Uncensored Subject: Return-Path ???
I have been wondering about this for quite some time. However, as I
mentioned before I am coding something for citadel again and it effects
my code now. So, I am a bid confused about how mailing lists work in
citadel.

Any post submitted in to a mailing list enabled room, I would think
should have some kind of mechanism that insures that replies are sent to
the room rather then the original posters personal email.

At first I thought that Return-Path does this job. But it appears not to
be. If someone posts a message not with Webcit then his/her email
address ends up in the Return-Path.
And even if the message is send via webcit and the Return-Path is set to
the list name, a reply from an email client is set to be the original
posters email address not the list room. And Return-Path wouldn't be
useful to the email client anyway since it has only the room name at
best not the rooms email address.

Shouldn't every post have a header like Reply-To at leased set so that
if one receives a message with an email client, reply will direct the
message to the list rather then the personal email of the person we are
replying to.

Some research on this shows, that Reply-To might not be the right
solution either. However the posters points don't make sense in Citadels
case because Reply To All/Group doesn't work in Citadel either.
http://www.unicom.com/pw/reply-to-harmful.html

So what is Citadels solution to this? Having to type in the mailing
lists email address on every reply doesn't seam to be a very good solution.

Am I totally of track here? Is there something I don't get?

I've done a bit of research a while back what would be the best things to do... Reply To doesn't always seem to be the prefered solution.

If you want to look deeper into it, The Responsible code to generate the message for mailinglist recipients lives in:

citadel/modules/network/serv_netmail.c network_process_list()

citadel/techdoc/hack.txt describes the internal data structures - especially those of the messages.

citadel/msgbase.c OutputRFC822MsgHeaders() is responsible for generating whats sent via smtp, or imap.

webcit/messages.c display_enter() with replying_mode is the place where the recipinets are fetched and preparend to be put into the recipient lines.



[#] Sun May 03 2015 16:20:00 EDT from TaMeR @ Uncensored to citadel_support@citadel.org

Subject: Re: Disable Login

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks dothebart for pointing me in to the right direction.

Here is what I did, in case anyone else is interested.
I modified only one file, file modal.js

I added the function ishttps()
And I modified toggleModal(b)

This seams to work.

Also fixed a bug in toggleModal(b), a call to a null object was giving errors.
A simple null check did the fix.


function ishttps() {
var ok = true;
if (window.location.protocol != "https:") {
console.log('Not https');
ok = false;
window.location.href = "https:" + window.location.href.substring(window.location.protocol.length);
}
return ok;
}


function toggleModal (b) {

if (modalShowing && b) return;
if (!modalShowing && !b) return;

if(ishttps()){
console.log('ishttps');
}

html.className=modalShowing?'':'modal';

modalShowing = !modalShowing;

if (modalShowing) {
if( dialog != null ){
dialog.focus();
}
} else if (focusedElement) {
try {
focusedElement.focus();
} catch(ex) {}
}
}

[#] Sun May 03 2015 20:53:56 EDT from "Panagiotis Palias" <panagos81@gmail.com> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Re: mail to yahoo not sent

[Reply] [ReplyQuoted] [Headers] [Print]

I created the SPF record and it still won't work. I would swear that
before moving the citadel server from an old server to this one,
everything worked fine, even without SPF record. Could it be something
else? Should I let some time pass for the change in dns to be propagated
maybe?
Thank you!

On 29/04/2015 07:27 μμ, TaMeR wrote:

Yahoo rejects if you don't have an spf record in your dns, google will not.


On 04/29/2015 01:49 PM, Panagiotis Palias wrote:
Hello,

I have issues sending mails to yahoo, while sending to gmail works fine
(same mail, sending to both addresses)

I am attaching the logs (smtpeventclient enabled) I could find with changed
usernames, in case someone might have an idea.

http://pastebin.com/raw.php?i=kLSH9LNJ

Regards,

Panos

signature.asc (application/pgp-signature, 501 bytes) [ View | Download ]
[#] Mon May 04 2015 07:13:52 EDT from dothebart @ Uncensored

Subject: Re: [Citadel Support] Re: mail to yahoo not sent

[Reply] [ReplyQuoted] [Headers] [Print]

 

Sun May 03 2015 20:53:56 EDT from "Panagiotis Palias" <panagos81@gmail.com> Subject: Re: [Citadel Support] Re: mail to yahoo not sent
I created the SPF record and it still won't work. I would swear that
before moving the citadel server from an old server to this one,
everything worked fine, even without SPF record. Could it be something
else? Should I let some time pass for the change in dns to be propagated
maybe?
Thank you!

On 29/04/2015 07:27 μμ, TaMeR wrote:

Yahoo rejects if you don't have an spf record in your dns, google will not.


On 04/29/2015 01:49 PM, Panagiotis Palias wrote:
Hello,

I have issues sending mails to yahoo, while sending to gmail works fine
(same mail, sending to both addresses)

I am attaching the logs (smtpeventclient enabled) I could find with changed
usernames, in case someone might have an idea.

http://pastebin.com/raw.php?i=kLSH9LNJ

Regards,

Panos
Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] SMTP_C_DispatchWriteDone
Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] > MAIL FROM:<giotis@mamias.net.>#015#012

Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] < 501 Syntax error in parameters or arguments
Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] SMTP_C_Terminate

There it is: seems you've configured a dot at the end of your hostname?

 



signature.asc (application/pgp-signature, 681 bytes) [ View | Download ]
[#] Tue May 05 2015 01:47:43 EDT from mendoza @ Uncensored

Subject: Can not send a mail.

[Reply] [ReplyQuoted] [Headers] [Print]

Hi,

 

Installed, configured (hope so) citaled server. Bit it does not work correctly. Problem is that i can send and receive mail only from citadel's admin account. I have added two other users, but when i try send mail to these accouts, lets say from Gmail i am getting an error:

The error that the other server returned was:

550 Invalid recipient: testaccount@myserver.bla

 

Ok, i do not have a rDNS record yet, but then i still should be able to receive emails. Furthemore if the problem would be in that record - i think error message would be different. 



[#] Tue May 05 2015 06:12:39 EDT from "Brian Vind Borgstrøm" <brianvind@borgstrom.cc> to citadel_support@citadel.org

Subject: Delete account from http://uncensored.citadel.org and http://citadel.org

[Reply] [ReplyQuoted] [Headers] [Print]

Hi

Can You please delete the account OX3IO? I can't find anywhere to do this.

Best regards, Brian
P.S. I might have been using the e-mail address ox3io@borgstrom.cc

[#] Tue May 05 2015 06:28:58 EDT from dothebart @ Uncensored

Subject: Re: Can not send a mail.

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue May 05 2015 01:47:43 EDT from mendoza @ Uncensored Subject: Can not send a mail.

Hi,

 

Installed, configured (hope so) citaled server. Bit it does not work correctly. Problem is that i can send and receive mail only from citadel's admin account. I have added two other users, but when i try send mail to these accouts, lets say from Gmail i am getting an error:

The error that the other server returned was:

550 Invalid recipient: testaccount@myserver.bla

 

Ok, i do not have a rDNS record yet, but then i still should be able to receive emails. Furthemore if the problem would be in that record - i think error message would be different. 



please have a look at http://citadel.org/doku.php/faq:troubleshooting:tracking_citadel



[#] Tue May 05 2015 08:25:00 EDT from "Panagiotis Palias" <panagos81@gmail.com> to citadel_support@citadel.org

Subject: Re: [Citadel Support] Re: mail to yahoo not sent

[Reply] [ReplyQuoted] [Headers] [Print]

You are right, that was it. I got confused cause it asked for "Fully qualified domain name" which I interpreted as the domain with a dot at the end.
Thank you!

On Mon, May 4, 2015 at 1:13 PM, dothebart <dothebart@uncensored.citadel.org> wrote:

 

Sun May 03 2015 20:53:56 EDT from "Panagiotis Palias" <panagos81@gmail.com> Subject: Re: [Citadel Support] Re: mail to yahoo not sent
I created the SPF record and it still won't work. I would swear that
before moving the citadel server from an old server to this one,
everything worked fine, even without SPF record. Could it be something
else? Should I let some time pass for the change in dns to be propagated
maybe?
Thank you!

On 29/04/2015 07:27 μμ, TaMeR wrote:

Yahoo rejects if you don't have an spf record in your dns, google will not.


On 04/29/2015 01:49 PM, Panagiotis Palias wrote:
Hello,

I have issues sending mails to yahoo, while sending to gmail works fine
(same mail, sending to both addresses)

I am attaching the logs (smtpeventclient enabled) I could find with changed
usernames, in case someone might have an idea.

http://pastebin..com/raw.php?i=kLSH9LNJ

Regards,

Panos
Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] SMTP_C_DispatchWriteDone
Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] > MAIL FROM:<giotis@mamias.net.>#015#012

Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] < 501 Syntax error in parameters or arguments
Apr 23 16:27:52 localhost citserver[6175]: SMTPC:IO[1420]CC[1420]S[1353][8] SMTP_C_Terminate

There it is: seems you've configured a dot at the end of your hostname?

 




--
-p


[#] Tue May 05 2015 13:27:03 EDT from mendoza @ Uncensored

Subject: Re: Can not send a mail.

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue May 05 2015 06:28:58 EDT from dothebart @ Uncensored Subject: Re: Can not send a mail.

 

Tue May 05 2015 01:47:43 EDT from mendoza @ Uncensored Subject: Can not send a mail.

Hi,

 

Installed, configured (hope so) citaled server. Bit it does not work correctly. Problem is that i can send and receive mail only from citadel's admin account. I have added two other users, but when i try send mail to these accouts, lets say from Gmail i am getting an error:

The error that the other server returned was:

550 Invalid recipient: testaccount@myserver.bla

 

Ok, i do not have a rDNS record yet, but then i still should be able to receive emails. Furthemore if the problem would be in that record - i think error message would be different. 



please have a look at http://citadel.org/doku.php/faq:troubleshooting:tracking_citadel



Hmmm...

myserver:/ # sendcommand "QDIR testuser@myserver.bla"

sendcommand: command not found

 



[#] Tue May 05 2015 13:31:10 EDT from stibby @ Uncensored

Subject: Missing mail

[Reply] [ReplyQuoted] [Headers] [Print]

HELP!!!

I have a server running in a VM and needed to restart citadel.

After doing this emails have been lost (not all) the last 3 -4 months

any idea?

Thanks

Steve



[#] Tue May 05 2015 13:41:18 EDT from mendoza @ Uncensored

Subject: Re: Can not send a mail.

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue May 05 2015 06:28:58 EDT from dothebart @ Uncensored Subject: Re: Can not send a mail.

 

Tue May 05 2015 01:47:43 EDT from mendoza @ Uncensored Subject: Can not send a mail.

Hi,

 

Installed, configured (hope so) citaled server. Bit it does not work correctly. Problem is that i can send and receive mail only from citadel's admin account. I have added two other users, but when i try send mail to these accouts, lets say from Gmail i am getting an error:

The error that the other server returned was:

550 Invalid recipient: testaccount@myserver.bla

 

Ok, i do not have a rDNS record yet, but then i still should be able to receive emails. Furthemore if the problem would be in that record - i think error message would be different. 



please have a look at http://citadel.org/doku.php/faq:troubleshooting:tracking_citadel



Hmmm...

myserver:/ # sendcommand "QDIR testuser@myserver.bla"

sendcommand: command not found

 



[#] Tue May 05 2015 14:47:43 EDT from dothebart @ Uncensored

Subject: Re: Can not send a mail.

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue May 05 2015 13:41:18 EDT from mendoza @ Uncensored Subject: Re: Can not send a mail.

 

Tue May 05 2015 06:28:58 EDT from dothebart @ Uncensored Subject: Re: Can not send a mail.

 

Tue May 05 2015 01:47:43 EDT from mendoza @ Uncensored Subject: Can not send a mail.

Hi,

 

Installed, configured (hope so) citaled server. Bit it does not work correctly. Problem is that i can send and receive mail only from citadel's admin account. I have added two other users, but when i try send mail to these accouts, lets say from Gmail i am getting an error:

The error that the other server returned was:

550 Invalid recipient: testaccount@myserver.bla

 

Ok, i do not have a rDNS record yet, but then i still should be able to receive emails. Furthemore if the problem would be in that record - i think error message would be different. 



please have a look at http://citadel.org/doku.php/faq:troubleshooting:tracking_citadel



Hmmm...

myserver:/ # sendcommand "QDIR testuser@myserver.bla"

sendcommand: command not found

 



sendcommand requires root privileges.

depending on your installation mode, you may need to add it to your path:

http://citadel.org/doku.php/documentation:file_layout#files.and.where.easy.install.and.lhfs.rpm.deb.installs.put.them



[#] Tue May 05 2015 14:48:55 EDT from dothebart @ Uncensored

Subject: Re: Missing mail

[Reply] [ReplyQuoted] [Headers] [Print]

 

Tue May 05 2015 13:31:10 EDT from stibby @ Uncensored Subject: Missing mail

HELP!!!

I have a server running in a VM and needed to restart citadel.

After doing this emails have been lost (not all) the last 3 -4 months

any idea?

Thanks

Steve



The information you're providing is a bit vague.

Maybe you accidently started the vm on an old snapshot of your filesystem?



[#] Tue May 05 2015 16:01:12 EDT from stibby @ Uncensored

Subject: Re: Missing mail

[Reply] [ReplyQuoted] [Headers] [Print]


Sorry new to this app.

Fed 16 Vm

So i ran - "sudo service citadel stop"

Then "sudo service citadel start"

within the data dir one of the cdb files is about 4.8 gb. Is there a limit to this?

 



Go to page: [1] 2 3 4 5 ... Last