Language:
switch to room list switch to menu My folders
Go to page: First ... 24 25 26 27 [28] 29 30 31 32 ... Last
[#] Mon May 17 2021 11:19:17 EDT from ParanoidDelusions

Subject: Re: SMTP authentication problem

[Reply] [ReplyQuoted] [Headers] [Print]

But - have you tried connecting to the SMTP port via Telnet to verify what is happening manually? 

 



[#] Mon May 17 2021 18:40:20 EDT from ParanoidDelusions

Subject: Re:SMTP Authentication Problem

[Reply] [ReplyQuoted] [Headers] [Print]

Interestingly enough - today while searching for SSL errors I get from Citadel - I found the following link:


https://www.linode.com/community/questions/10102/cant-receive-email-with-citadel

Where other people are complaining about the same issue - but also... where people are having trouble with sending/receiving mail.


And the suggestion made by the people trying to help involved connecting to Port 25 via Telnet to see what was happening.


I don't think my error, which is in this guy's logs...

"SSL_accept failed: errval=5, retval=-1 (Input/output error)"

Is related to send errors using SMTP - but it is interesting that it isn't just me getting this error in my logs.

Anyhow - maybe the link above will assist you.

 



[#] Wed May 19 2021 10:59:55 EDT from smashbot64

Subject: Re:SMTP Authentication Problem

[Reply] [ReplyQuoted] [Headers] [Print]

 

Mon May 17 2021 18:40:20 EDT from ParanoidDelusions Subject: Re:SMTP Authentication Problem

Interestingly enough - today while searching for SSL errors I get from Citadel - I found the following link:


https://www.linode.com/community/questions/10102/cant-receive-email-with-citadel

Where other people are complaining about the same issue - but also... where people are having trouble with sending/receiving mail.


And the suggestion made by the people trying to help involved connecting to Port 25 via Telnet to see what was happening.


I don't think my error, which is in this guy's logs...

"SSL_accept failed: errval=5, retval=-1 (Input/output error)"

Is related to send errors using SMTP - but it is interesting that it isn't just me getting this error in my logs.

Anyhow - maybe the link above will assist you.

 



Linodes have 25/tcp blocked by default. If you send them a support ticket and have had the linode for a while they will open it for you. The other thing that worked was enabling deprecated tls 1.0. I had this issue with phpbb also, when I included support for all tls versions including old not recommended ones, it fixed it.



[#] Wed May 19 2021 11:08:59 EDT from ParanoidDelusions

Subject: Re:SMTP Authentication Problem

[Reply] [ReplyQuoted] [Headers] [Print]

Internet Mail is a pain in the ass to configure and requires a very high level of interdisciplinary knowledge about IT to configure successfully - and once you get it up, it is a magnet for attacks and requires constant diligence in management, administration and security - as well as lots of experience navigating the different providers and authorities responsible at all ends for making it work right. Once you get that all right, your running one of the public faced Internet services with the *most* personal liability. Just ask Hillary Clinton how sketchy it can be running your own personal mail server. I wouldn't do it for a SMB, I wouldn't do it for a personal mail server. In each case, a hosted solution is way less headache. I'd only do it for six figures of compensation from a major corporation with a team of IT engineers and lawyers that I was certain wouldn't throw me under the bus if someone from a TLA .gov org came knocking. 

Citadel makes it easy to set up the mail SERVER... but there is no program that can solve the rest of those challenges. 

This is why I have Citadel Internet mail deactivated. 

 

Wed May 19 2021 10:59:55 EDT from smashbot64 Subject: Re:SMTP Authentication Problem

 

Mon May 17 2021 18:40:20 EDT from ParanoidDelusions Subject: Re:SMTP Authentication Problem

Interestingly enough - today while searching for SSL errors I get from Citadel - I found the following link:


https://www.linode.com/community/questions/10102/cant-receive-email-with-citadel

Where other people are complaining about the same issue - but also... where people are having trouble with sending/receiving mail.


And the suggestion made by the people trying to help involved connecting to Port 25 via Telnet to see what was happening.


I don't think my error, which is in this guy's logs...

"SSL_accept failed: errval=5, retval=-1 (Input/output error)"

Is related to send errors using SMTP - but it is interesting that it isn't just me getting this error in my logs.

Anyhow - maybe the link above will assist you.

 



Linodes have 25/tcp blocked by default. If you send them a support ticket and have had the linode for a while they will open it for you. The other thing that worked was enabling deprecated tls 1.0. I had this issue with phpbb also, when I included support for all tls versions including old not recommended ones, it fixed it.



 



[#] Thu May 20 2021 06:21:32 EDT from bartv

Subject: Re:SMTP Authentication Problem

[Reply] [ReplyQuoted] [Headers] [Print]

Thanks for the support !

 

Just to be clear

- My service provider is not blocking any ports

- I can send email using the webclient to an external emailadres (my company email, gmail, etc...)

- i do receive emails from, numerous external sources, webshops, groups.io etc. etc.

But i cannot use an email client using smtp on several ports - pop3 works - login credentials work fine on pop3

 

this is what i get accessing port 25 via putty from a windows pc in my local netwerk :

 

220 bartscorner.nl ESMTP Citadel server ready.
EHLO bartscorner.nl
250-Hello bartscorner.nl (Laborix.bartscorner.local [192.168.1.117])
250-HELP
250-SIZE 10485760
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
AUTH LOGIN
334 VXNlcm5hbWU6
YmFydHYK
334 UGFzc3dvcmQ6
VGhpcyBpcyBub3QgbXkgcmVhbCBwYXNzd29yZA==
535 Authentication failed.

I used https://www.base64encode.org/ to encode my credentials

This is a good webpage describing the procedure : https://www.comparitech.com/net-admin/telnet-smtp-test/

334 VXNlcm5hbWU6 decodes to  Username: in plain text

respons  YmFydHYK is bartv (username)

334 UGFzc3dvcmQ6 decodes to Password:

respons VGhpcyBpcyBub3QgbXkgcmVhbCBwYXNzd29yZA==   is my password (i used the correct one, in this posting i posted a fake one ;-) )

 

regards,

 

Bart

 

 

 

Wed May 19 2021 11:08:59 EDT from ParanoidDelusions Subject: Re:SMTP Authentication Problem

Internet Mail is a pain in the ass to configure and requires a very high level of interdisciplinary knowledge about IT to configure successfully - and once you get it up, it is a magnet for attacks and requires constant diligence in management, administration and security - as well as lots of experience navigating the different providers and authorities responsible at all ends for making it work right. Once you get that all right, your running one of the public faced Internet services with the *most* personal liability. Just ask Hillary Clinton how sketchy it can be running your own personal mail server. I wouldn't do it for a SMB, I wouldn't do it for a personal mail server. In each case, a hosted solution is way less headache. I'd only do it for six figures of compensation from a major corporation with a team of IT engineers and lawyers that I was certain wouldn't throw me under the bus if someone from a TLA .gov org came knocking. 

Citadel makes it easy to set up the mail SERVER... but there is no program that can solve the rest of those challenges. 

This is why I have Citadel Internet mail deactivated. 

 

Wed May 19 2021 10:59:55 EDT from smashbot64 Subject: Re:SMTP Authentication Problem

 

Mon May 17 2021 18:40:20 EDT from ParanoidDelusions Subject: Re:SMTP Authentication Problem

Interestingly enough - today while searching for SSL errors I get from Citadel - I found the following link:


https://www.linode.com/community/questions/10102/cant-receive-email-with-citadel

Where other people are complaining about the same issue - but also... where people are having trouble with sending/receiving mail.


And the suggestion made by the people trying to help involved connecting to Port 25 via Telnet to see what was happening.


I don't think my error, which is in this guy's logs...

"SSL_accept failed: errval=5, retval=-1 (Input/output error)"

Is related to send errors using SMTP - but it is interesting that it isn't just me getting this error in my logs.

Anyhow - maybe the link above will assist you.

 



Linodes have 25/tcp blocked by default. If you send them a support ticket and have had the linode for a while they will open it for you. The other thing that worked was enabling deprecated tls 1.0. I had this issue with phpbb also, when I included support for all tls versions including old not recommended ones, it fixed it.



 



 



[#] Thu May 20 2021 09:37:41 EDT from ParanoidDelusions

Subject: Re:SMTP Authentication Problem

[Reply] [ReplyQuoted] [Headers] [Print]

And you get authentication failed with the correct password - but you can log into the web client, authenticate with the same password and userID, and it works? 

That is bizarre. 

Do you have the Citadel textclient set up for Telnet and SSH? Can you Telnet and SSH into your Citadel or do you get authentication errors there, too? 

Bear with me here - because I've been talking with another Admin who had a problem with authentication failing on the text client - and I'm wondering if this could be related to his issue. 

 

Thu May 20 2021 06:21:32 EDT from bartv Subject: Re:SMTP Authentication Problem

Thanks for the support !

 

Just to be clear

- My service provider is not blocking any ports

- I can send email using the webclient to an external emailadres (my company email, gmail, etc...)

- i do receive emails from, numerous external sources, webshops, groups.io etc. etc.

But i cannot use an email client using smtp on several ports - pop3 works - login credentials work fine on pop3

 

this is what i get accessing port 25 via putty from a windows pc in my local netwerk :

 

220 bartscorner.nl ESMTP Citadel server ready.
EHLO bartscorner.nl
250-Hello bartscorner.nl (Laborix.bartscorner.local [192.168.1.117])
250-HELP
250-SIZE 10485760
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
AUTH LOGIN
334 VXNlcm5hbWU6
YmFydHYK
334 UGFzc3dvcmQ6
VGhpcyBpcyBub3QgbXkgcmVhbCBwYXNzd29yZA==
535 Authentication failed.

I used https://www.base64encode.org/ to encode my credentials

This is a good webpage describing the procedure : https://www.comparitech.com/net-admin/telnet-smtp-test/

334 VXNlcm5hbWU6 decodes to  Username: in plain text

respons  YmFydHYK is bartv (username)

334 UGFzc3dvcmQ6 decodes to Password:

respons VGhpcyBpcyBub3QgbXkgcmVhbCBwYXNzd29yZA==   is my password (i used the correct one, in this posting i posted a fake one ;-) )

 

regards,

 

Bart

 

 

 

Wed May 19 2021 11:08:59 EDT from ParanoidDelusions Subject: Re:SMTP Authentication Problem

Internet Mail is a pain in the ass to configure and requires a very high level of interdisciplinary knowledge about IT to configure successfully - and once you get it up, it is a magnet for attacks and requires constant diligence in management, administration and security - as well as lots of experience navigating the different providers and authorities responsible at all ends for making it work right. Once you get that all right, your running one of the public faced Internet services with the *most* personal liability. Just ask Hillary Clinton how sketchy it can be running your own personal mail server. I wouldn't do it for a SMB, I wouldn't do it for a personal mail server. In each case, a hosted solution is way less headache. I'd only do it for six figures of compensation from a major corporation with a team of IT engineers and lawyers that I was certain wouldn't throw me under the bus if someone from a TLA .gov org came knocking. 

Citadel makes it easy to set up the mail SERVER... but there is no program that can solve the rest of those challenges. 

This is why I have Citadel Internet mail deactivated. 

 

Wed May 19 2021 10:59:55 EDT from smashbot64 Subject: Re:SMTP Authentication Problem

 

Mon May 17 2021 18:40:20 EDT from ParanoidDelusions Subject: Re:SMTP Authentication Problem

Interestingly enough - today while searching for SSL errors I get from Citadel - I found the following link:


https://www.linode.com/community/questions/10102/cant-receive-email-with-citadel

Where other people are complaining about the same issue - but also... where people are having trouble with sending/receiving mail.


And the suggestion made by the people trying to help involved connecting to Port 25 via Telnet to see what was happening.


I don't think my error, which is in this guy's logs...

"SSL_accept failed: errval=5, retval=-1 (Input/output error)"

Is related to send errors using SMTP - but it is interesting that it isn't just me getting this error in my logs.

Anyhow - maybe the link above will assist you.

 



Linodes have 25/tcp blocked by default. If you send them a support ticket and have had the linode for a while they will open it for you. The other thing that worked was enabling deprecated tls 1.0. I had this issue with phpbb also, when I included support for all tls versions including old not recommended ones, it fixed it.



 



 



 



[#] Fri May 21 2021 06:08:22 EDT from pikaboy

Subject: problem with message storing?

[Reply] [ReplyQuoted] [Headers] [Print]

Hello I have since yesterday following problem. When I send or receive email I get error in wincit when I try to open this message. The other side gets this message correctly.



[#] Sun May 23 2021 14:11:13 EDT from IGnatius T Foobar

Subject: Re: Citadel in Docker (prototype repo URL?)

[Reply] [ReplyQuoted] [Headers] [Print]

some (long) time ago I expressed my interest in trying out Citadel within a Docker container and someone here pointed me to some repository where some sort of "prototype" was available. Now, I have lost that particular link and am now asking if anyone here can (once more) provide it to me?

We ended up going in a different direction.  Instead of Docker, we built an AppImage, which just had its first beta release a couple of days ago.

AppImage, as you may know, packages an entire complex application and all of its dependencies into a single executable file that runs on many different Linux versions.  It turns out we had to change a lot of things that were based on outdated assumptions to make this happen.  For example, we ended support for the LFHS-style build and now require everything in a single directory.  These changes ought to make it a lot easier to put Citadel and its dependencies into a container, but as previously noted, we are not currently working on that.

Go ahead and try the AppImage if it can satisfy your requirements.



[#] Sun May 23 2021 14:18:01 EDT from IGnatius T Foobar

Subject: Re:SMTP Authentication Problem

[Reply] [ReplyQuoted] [Headers] [Print]

bart, have you tried using your full email address as the username?

For example, instead of using "bartv" try using "bartv@bartscorner.nl" instead.

And of course, watch your server logs while this is happening, to see if it mapped you to the correct user.

 

this is what i get accessing port 25 via putty from a windows pc in my local netwerk :

220 bartscorner.nl ESMTP Citadel server ready.
EHLO bartscorner.nl
250-Hello bartscorner.nl (Laborix.bartscorner.local [192.168.1.117])
250-HELP
250-SIZE 10485760
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
AUTH LOGIN
334 VXNlcm5hbWU6
YmFydHYK
334 UGFzc3dvcmQ6
VGhpcyBpcyBub3QgbXkgcmVhbCBwYXNzd29yZA==
535 Authentication failed.

I used https://www.base64encode.org/ to encode my credentials

This is a good webpage describing the procedure : https://www.comparitech.com/net-admin/telnet-smtp-test/

334 VXNlcm5hbWU6 decodes to  Username: in plain text

respons  YmFydHYK is bartv (username)

334 UGFzc3dvcmQ6 decodes to Password:

respons VGhpcyBpcyBub3QgbXkgcmVhbCBwYXNzd29yZA==   is my password (i used the correct one, in this posting i posted a fake one ;-) )



[#] Mon May 31 2021 02:48:31 EDT from smashbot64

Subject: Re: Citadel in Docker (prototype repo URL?)

[Reply] [ReplyQuoted] [Headers] [Print]

github was too costly? lol... the source is out there, someone just has to volunteer to maintain

Sun May 23 2021 14:11:13 EDT from IGnatius T Foobar Subject: Re: Citadel in Docker (prototype repo URL?)

some (long) time ago I expressed my interest in trying out Citadel within a Docker container and someone here pointed me to some repository where some sort of "prototype" was available. Now, I have lost that particular link and am now asking if anyone here can (once more) provide it to me?

We ended up going in a different direction.  Instead of Docker, we built an AppImage, which just had its first beta release a couple of days ago.

AppImage, as you may know, packages an entire complex application and all of its dependencies into a single executable file that runs on many different Linux versions.  It turns out we had to change a lot of things that were based on outdated assumptions to make this happen.  For example, we ended support for the LFHS-style build and now require everything in a single directory.  These changes ought to make it a lot easier to put Citadel and its dependencies into a container, but as previously noted, we are not currently working on that.

Go ahead and try the AppImage if it can satisfy your requirements.



 



[#] Mon May 31 2021 02:52:36 EDT from smashbot64

Subject: Re: Citadel in Docker (prototype repo URL?)

[Reply] [ReplyQuoted] [Headers] [Print]

revisited... sourceforge was too complicated? just insult to injury. citadel is a blessing of source code within superb architecture. surely I am not the only one implementing message search and forgot password routines. 

Mon May 31 2021 02:48:31 EDT from smashbot64 Subject: Re: Citadel in Docker (prototype repo URL?)

github was too costly? lol... the source is out there, someone just has to volunteer to maintain

Sun May 23 2021 14:11:13 EDT from IGnatius T Foobar Subject: Re: Citadel in Docker (prototype repo URL?)

some (long) time ago I expressed my interest in trying out Citadel within a Docker container and someone here pointed me to some repository where some sort of "prototype" was available. Now, I have lost that particular link and am now asking if anyone here can (once more) provide it to me?

We ended up going in a different direction.  Instead of Docker, we built an AppImage, which just had its first beta release a couple of days ago.

AppImage, as you may know, packages an entire complex application and all of its dependencies into a single executable file that runs on many different Linux versions.  It turns out we had to change a lot of things that were based on outdated assumptions to make this happen.  For example, we ended support for the LFHS-style build and now require everything in a single directory.  These changes ought to make it a lot easier to put Citadel and its dependencies into a container, but as previously noted, we are not currently working on that.

Go ahead and try the AppImage if it can satisfy your requirements.



 



 



[#] Mon May 31 2021 14:52:01 EDT from IGnatius T Foobar

Subject: Re: Citadel in Docker (prototype repo URL?)

[Reply] [ReplyQuoted] [Headers] [Print]

Search should be pretty easy because there is already a full text indexer built into the message store.

As for the public repositories ... Citadel pre-dates them all, so we've always managed it ourselves.  Our public "forge" is at https://code.citadel.org/

 



[#] Wed Jun 02 2021 03:45:26 EDT from jmb100770

Subject: Re: 500 No such user on AUTH LOGIN

[Reply] [ReplyQuoted] [Headers] [Print]

I encountered this same authentication problem with version 931 built via easy-install.  I think the problem is with citadel/modules/smtp/serv_smtp.c where smtp_get_user(5) is called in smtp_command_loop.  From this context, the offset parameter 5 should be replaced by zero (0).  I modified the easy-install script to work with a patched copy of the tarball and the resulting build seems to work correctly.

 



[#] Wed Jun 02 2021 13:24:18 EDT from cyberlaw

Subject: IP Based Relaying thru Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

I've had to abandon my HMAIL server (Windows XP PRO issues activating)

I have installed a Debian system with Citadel. I am looking to do some relaying of email from specific IP addresses from old devices that cannot handle auth.

Is it possible thru Citadel and can it be done via the web manager? Or will it have to be done via CLI?



[#] Thu Jun 03 2021 09:12:08 EDT from IGnatius T Foobar

Subject: Re: 500 No such user on AUTH LOGIN

[Reply] [ReplyQuoted] [Headers] [Print]

in smtp_command_loop.  From this context, the offset parameter 5
should be replaced by zero (0).  I modified the easy-install script

Thanks for the tip! We will check that out and patch the mainline source.

[#] Sat Jun 05 2021 09:47:54 EDT from compdecon

Subject: Modem Support

[Reply] [ReplyQuoted] [Headers] [Print]

Planning on standing up a Citadel at our makerspace

How much support is still in the current version for dialup modems?

CDL



[#] Sat Jun 05 2021 10:22:21 EDT from compdecon

Subject: Modem Support

[Reply] [ReplyQuoted] [Headers] [Print]

Planning on standing up a Citadel at our makerspace

How much support is still in the current version for dialup modems?

CDL



[#] Sat Jun 05 2021 11:12:36 EDT from IGnatius T Foobar

Subject: Re: Modem Support

[Reply] [ReplyQuoted] [Headers] [Print]

How much support is still in the current version for dialup modems?

You're in luck -- Citadel still works great on dialup.

To make it work, there's not much you have to do with Citadel -- what you really want is to hook up your modem or modem pool to the underlying Linux host. There are tutorials all over the Internet for that. You'll probably end up using a program called "mgetty" which became quite dominant in that space in the final years before broadband Internet replaced dialup in most homes.

Then you just set up an account on your host, for example, one called "bbs" or "citadel" whose shell is /usr/local/citadel/citadel (the text mode client) and put a message in your system's login banner telling users to type that account name to get in.

[#] Sat Jun 05 2021 11:42:45 EDT from Nurb432

Subject: Re: AppImage releases of Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

Sure, ill try both :)

Sat Jun 05 2021 11:07:16 AM EDT from IGnatius T Foobar Subject: Re: AppImage releases of Citadel
You should be able to run the 32 bit image on a 64 bit board. In fact, I would love it if you could try that.

 



[#] Sat Jun 05 2021 13:44:25 EDT from Nurb432

Subject: Re: AppImage releases of Citadel

[Reply] [ReplyQuoted] [Headers] [Print]

On the BPI M3 ->  ./citadel-1622326264-armv7l.appimage: error while loading shared libraries: libz.so: cannot open shared object file: No such file or directory

I'm sure i can fix that, just thought id put that out here before i do. Would have thought that woudl be in the image and not needing to add it myself to the system? 32bit Armbian/Bullseye, updated to current just before i tried.
 
On 64bit Jetson, i get a command not found. Strange, its set to be executable so it should at least try to run. Unless its something IN the appimage its trying to run and its a useless/bogus error.  Jetsons run a hacked up version of Ubuntu, but i have a couple of 64bit machine running Armbian/Bullseye ill try tonight.


Go to page: First ... 24 25 26 27 [28] 29 30 31 32 ... Last